Wifi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
hoofprints
Level 1
Level 1
Posts: 3
Joined: Sun Aug 18, 2019 1:57 pm

Wifi

Post by hoofprints » Sun Aug 18, 2019 2:03 pm

Hi,
Im new to linux and this is my first install, im getting Activation of network failed when i try and connect to my wifi networks and the signal seems pretty weak as well. Thanks in advance!

System:
Host: MC Kernel: 4.15.0-58-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina
base: Ubuntu 18.04 bionic
Machine:
Type: Laptop System: Hewlett-Packard product: HP Notebook
v: Type1ProductConfigId serial: <filter>
Mobo: Hewlett-Packard model: 80CB v: 99.53 serial: <filter> UEFI: Insyde
v: F.28 date: 05/17/2019
CPU:
Topology: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics
bits: 64 type: MCP arch: Puma rev: 1 L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 14372
Speed: 1009 MHz min/max: 1000/1800 MHz Core speeds (MHz): 1: 998 2: 998
3: 998 4: 998
Graphics:
Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Hewlett-Packard
driver: radeon v: kernel bus ID: 00:01.0
Display: x11 server: X.Org 1.19.6 driver: ati,radeon
unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz
OpenGL: renderer: AMD MULLINS (DRM 2.50.0 4.15.0-58-generic LLVM 8.0.0)
v: 4.5 Mesa 19.0.8 direct render: Yes
Audio:
Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus ID: 00:01.1
Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel
v: kernel bus ID: 00:14.2
Sound Server: ALSA v: k4.15.0-58-generic
Network:
Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 3000
bus ID: 02:00.0
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 2000
bus ID: 03:00.0
IF: enp3s0 state: down mac: <filter>
Device-3: Samsung GT-I9070 (network tethering USB debugging enabled)
type: USB driver: rndis_host bus ID: 3-2:3
IF: enp0s16u2 state: unknown speed: N/A duplex: N/A mac: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 14.66 GiB (3.1%)
ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS545050A7E680
size: 465.76 GiB
Partition:
ID-1: / size: 456.04 GiB used: 14.62 GiB (3.2%) fs: ext4 dev: /dev/sda4
Sensors:
System Temperatures: cpu: 41.5 C mobo: 20.0 C gpu: radeon temp: 40 C
Fan Speeds (RPM): N/A
Info:
Processes: 197 Uptime: 26m Memory: 4.78 GiB used: 1.21 GiB (25.3%)
Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
inxi: 3.0.32
--------------------------------------------------------------------------------------------------------------------------------

~$ iwconfig
lo no wireless extensions.

enp3s0 no wireless extensions.

enp0s16u2 no wireless extensions.

wlo1 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Power Management:on


----------------------------------------------------------------------------------------------------

lspci | grep -i wireless
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
steph@MC:~$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

JeremyB
Level 20
Level 20
Posts: 10932
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi

Post by JeremyB » Sun Aug 18, 2019 2:05 pm

In terminal do

Code: Select all

echo "options rtl8723be ips=N ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be
sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*
Reboot

hoofprints
Level 1
Level 1
Posts: 3
Joined: Sun Aug 18, 2019 1:57 pm

Re: Wifi

Post by hoofprints » Sun Aug 18, 2019 2:29 pm

Tried and still same issue

JeremyB
Level 20
Level 20
Posts: 10932
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi

Post by JeremyB » Sun Aug 18, 2019 2:54 pm

Code: Select all

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info && ./wireless-info
cat wireless-info.txt | nc termbin.com 9999
Post termbin URL

hoofprints
Level 1
Level 1
Posts: 3
Joined: Sun Aug 18, 2019 1:57 pm

Re: Wifi

Post by hoofprints » Sun Aug 18, 2019 11:56 pm


JeremyB
Level 20
Level 20
Posts: 10932
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi

Post by JeremyB » Mon Aug 19, 2019 5:12 am

Code: Select all

sudo dkms remove rtlwifi-new/0.6 --all
sudo apt remove broadcom-sta-dkms
echo "options rtl8723be ant_sel=2 ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
Reboot

Post Reply

Return to “Wireless”