Scanning with an EPSON Stylus SX400 printer?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
SilentBlue
Level 1
Level 1
Posts: 24
Joined: Thu May 16, 2019 11:07 am

Scanning with an EPSON Stylus SX400 printer?

Post by SilentBlue » Mon Aug 19, 2019 10:12 am

Hello,

I have an EPSON Stylus SX400 printer which works fine for printing. However, when I want to scan (I tried both Simple Scan and XSane) the application hangs and nothing happens.

I have searched in Synaptic an installed anything that seemed relevant (basically escputil 5.2.13-2).
I went on the website of EPSON but I could not find anything of use.

Any idea about what else I could do to try and make it work?

Thanks.

brian_p
Level 5
Level 5
Posts: 645
Joined: Thu Jan 17, 2019 9:20 am

Re: Scanning with an EPSON Stylus SX400 printer?

Post by brian_p » Mon Aug 19, 2019 2:44 pm

Which version of Mint are you using?
--
Brian.

User avatar
derrick1120
Level 2
Level 2
Posts: 53
Joined: Sun Sep 16, 2018 7:51 am

Re: Scanning with an EPSON Stylus SX400 printer?

Post by derrick1120 » Mon Aug 19, 2019 4:39 pm

Have you tried installing the Epson driver from the Epson website? - https://epson.com/Support/wa00821

Here's a link that may assist re installing - https://tutorialforlinux.com/2018/09/12 ... nt-19-lts/

User avatar
kato181
Level 4
Level 4
Posts: 373
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: Scanning with an EPSON Stylus SX400 printer?

Post by kato181 » Tue Aug 20, 2019 4:06 am

SilentBlue wrote:
Mon Aug 19, 2019 10:12 am
Hello,

I have an EPSON Stylus SX400 printer which works fine for printing. However, when I want to scan (I tried both Simple Scan and XSane) the application hangs and nothing happens.

I have searched in Synaptic an installed anything that seemed relevant (basically escputil 5.2.13-2).
I went on the website of EPSON but I could not find anything of use.

Any idea about what else I could do to try and make it work?

Thanks.
Epson are notorious for slack linux support, but you need to d/l and install imagescan from epson for your scanner to work.
There are two (2) folders in the tar file Core and Plugins. Open plugins folder and install the first two files. (imagescan plugin, then the network scan) then re boot. It comes with a readme file which helps. If it still isn't detected, then post here and i'll tell you what i did to get my ET-4750 scanner working.
Good luck.

SilentBlue
Level 1
Level 1
Posts: 24
Joined: Thu May 16, 2019 11:07 am

Re: Scanning with an EPSON Stylus SX400 printer?

Post by SilentBlue » Tue Aug 20, 2019 8:38 am

@brian_p
I have Linux Mint 19.1

@derrick1120
Thanks a lot. I only went on the website associated with my printer model. I didn't know there was a Linux dedicated support page. I will try your suggestion and post the outcome here.

@kato181
Thank you very much. If Derrick's suggestion fails I will try your alternative path.

brian_p
Level 5
Level 5
Posts: 645
Joined: Thu Jan 17, 2019 9:20 am

Re: Scanning with an EPSON Stylus SX400 printer?

Post by brian_p » Tue Aug 20, 2019 6:11 pm

SilentBlue wrote:
Tue Aug 20, 2019 8:38 am
@brian_p
I have Linux Mint 19.1
There is a workaround on 19.1 but the problem is fixed in 19.2.
--
Brian.

User avatar
kato181
Level 4
Level 4
Posts: 373
Joined: Fri Mar 24, 2017 12:33 am
Location: Frederickton NSW

Re: Scanning with an EPSON Stylus SX400 printer?

Post by kato181 » Tue Aug 20, 2019 11:41 pm

brian_p wrote:
Tue Aug 20, 2019 6:11 pm
SilentBlue wrote:
Tue Aug 20, 2019 8:38 am
@brian_p
I have Linux Mint 19.1
There is a workaround on 19.1 but the problem is fixed in 19.2.
The problem still exists in 19.2 I had to do exactly the same I did in 19.1 to get scanner to work in 19.2. It's not mint that's the problem it's the lousy support from epson. I don't have any problem with my canon, or my hp printer/scanners, they all work perfectly without the work around.

SilentBlue
Level 1
Level 1
Posts: 24
Joined: Thu May 16, 2019 11:07 am

Re: Scanning with an EPSON Stylus SX400 printer?

Post by SilentBlue » Sun Aug 25, 2019 3:54 am

So for now I've tried the first link suggested by derrick1120: https://epson.com/Support/wa00821.
Now I can indeed scan using Image Scan! for Linux. However, I can only make one-page-scans. I cannot ask the scanner to put several scanned pages in a single file. I will try to test the other solutions.

Regarding the latter discussion, I have another EPSON scanner (XP-415) which I managed to make work with a bit of tweaking - I just don't remember exactly what I had to do, I think installing some other drivers or packages.

HAWR
Level 4
Level 4
Posts: 390
Joined: Thu Jun 06, 2019 1:15 pm

Re: Scanning with an EPSON Stylus SX400 printer?

Post by HAWR » Sun Aug 25, 2019 6:00 am

Linuxmint itself refers to a website with solutions for scanners in the release notes. I think that is what BrianP means with the workaround, so just for completeness:

https://bugs.launchpad.net/ubuntu/+sour ... omments/76

Post Reply

Return to “Newbie Questions”