Cannot remove a package.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
waywayka
Level 1
Level 1
Posts: 14
Joined: Sun Mar 03, 2019 9:06 pm

Cannot remove a package.

Post by waywayka » Fri Aug 23, 2019 6:26 am

Hi all,

I hope someone can help me.

I cannot seem to remove a package:

virtualbox-ext-pack 5.2 10-3

Every time I try to download a new package or remove an old package, an error appears telling me that some packages could not be installed or removed. The error is referring to the above 'stuck' package. Something in the error report talked about a 'hash mismatch'. It doesn't affect these other packages from being removed or installed, by the way.

I've tried removing it manually from my package manager, but the damn thing reappeared!

And now the 'mark for complete removal' option is greyed out.

Any information would be greatly appreciated.
Dell XPS 15 9530
i5 4900H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

User avatar
Larry78723
Level 6
Level 6
Posts: 1364
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Cannot remove a package.

Post by Larry78723 » Fri Aug 23, 2019 7:23 am

If you'd post the actual text of the error it would help us to help you.

Larry
Image

User avatar
pbear
Level 8
Level 8
Posts: 2119
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot remove a package.

Post by pbear » Fri Aug 23, 2019 9:42 pm

The repo version of VirtualBox seems to be on version 5.2.23, so looks like you're way out of sync. Can you boot VBox? What version do you have?
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

waywayka
Level 1
Level 1
Posts: 14
Joined: Sun Mar 03, 2019 9:06 pm

Re: Cannot remove a package.

Post by waywayka » Fri Aug 30, 2019 8:36 am

Thank you for your replies.

Have decided to restore my OS from a snapshot in Timeshift.

I will investigate the non-repo version of Virtualbox.

Duly noted - I will provide more textual information next time I have a problem.

Again, thank you.
Dell XPS 15 9530
i5 4900H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

User avatar
pbear
Level 8
Level 8
Posts: 2119
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot remove a package.

Post by pbear » Fri Aug 30, 2019 12:50 pm

waywayka wrote:
Fri Aug 30, 2019 8:36 am
Have decided to restore my OS from a snapshot in Timeshift.
Good plan. The crucial question is whether the system then updates cleanly. If so, you're good to go and this was all just a bad dream. If not, you're gonna have to do the nitty-gritty troubleshooting. BTW, typo, the current repo version of VBox is 5.2.32. If you want to move to direct install of VBox (how-to here), be sure to run apt purge virtualbox* first. Notably, purge leaves your VMs undisturbed, so no need to worry about that.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

User avatar
AndyMH
Level 8
Level 8
Posts: 2499
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Cannot remove a package.

Post by AndyMH » Fri Aug 30, 2019 1:57 pm

Another way to delete the extension pack. In VB File > preferences > extensions, right click on it and select remove package.
Workspace 1_026.png
But if you are running VirtualBox you need the extension pack if you are going the exploit the full functionality of VB.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate

waywayka
Level 1
Level 1
Posts: 14
Joined: Sun Mar 03, 2019 9:06 pm

Re: Cannot remove a package.

Post by waywayka » Sun Sep 01, 2019 12:25 am

You people are first class.

Thanks for your help.
Dell XPS 15 9530
i5 4900H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

Post Reply

Return to “Newbie Questions”