No Wifi in Linux Mint After it Had Been Working

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Sun Sep 01, 2019 1:24 pm

No Wifi in Linux Mint After it Had Been Working

Post by sg0106 » Sun Sep 01, 2019 1:32 pm

Getting the same error attached the output of commands that you provided earlier, suddenly wifi options is not comming, Could you please help in this.

inxi -Fxz

Code: Select all

System:    Host: charu-Lenovo-ideapad-110-15ACL Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: LENOVO product: 80TJ v: Lenovo ideapad 110-15ACL
           Mobo: LENOVO model: Nano 5A8 v: SDK0J40679 WIN
           Bios: Lenovo v: 1QCN32WW date: 08/18/2016
CPU:       Quad core AMD A8-7410 APU with AMD Radeon R5 Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 17566
           clock speeds: max: 2200 MHz 1: 1300 MHz 2: 1300 MHz 3: 1600 MHz
           4: 1300 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics]
           bus-ID: 00:01.0
           Display Server: 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           tty size: 80x24 Advanced Data: N/A for root
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 01:00.0
           IF: enp1s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (5.7% used)
           ID-1: /dev/sda model: WDC_WD10JPCX size: 1000.2GB temp: 36C
Partition: ID-1: / size: 137G used: 50G (39%) fs: ext4 dev: /dev/sda11
           ID-2: swap-1 size: 3.66GB used: 0.00GB (0%) fs: swap dev: /dev/sda12
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.1C mobo: N/A gpu: 44.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 209 Uptime: 28 min Memory: 920.6/3354.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
rfkill list

Code: Select all

0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
Last edited by karlchen on Sun Sep 01, 2019 1:41 pm, edited 3 times in total.
Reason: split off from solved thread, about Mint 18.3

Level 4
Level 4
Posts: 410
Joined: Thu Jun 06, 2019 1:15 pm

Re: No Wifi in Linux Mint After it Had Been Working

Post by HAWR » Sun Sep 01, 2019 4:45 pm

Hello sg0106,

you have the problem, that your wifi card isn't shown in your terminal output. Do you really have the same card in your laptop as in the linked thread? I found here the data of your laptop model with another Realtek card:

So it could be, that you have that card: RTL8821AE 802.11ac PCIe Wireless Network Adapter

Can you show the terminal output of:

Code: Select all


Level 20
Level 20
Posts: 10950
Joined: Fri Feb 21, 2014 8:17 am

Re: No Wifi in Linux Mint After it Had Been Working

Post by JeremyB » Mon Sep 02, 2019 9:15 am

Check UEFI/BIOS settings and see if WLAN is enabled

Post Reply

Return to “Wireless”