Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01) very slow

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
alebal
Level 1
Level 1
Posts: 30
Joined: Fri Aug 08, 2014 5:57 pm

Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01) very slow

Post by alebal » Tue Sep 10, 2019 3:48 pm

Hi everyone,
from some updates, my wireless card (or wireless management) has lost a lot of its performance.
Network controller: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01)
Subsystem: Qualcomm Atheros AR9227 Wireless Network Adapter
Kernel driver in use: ath9k
Kernel modules: ath9k
I have several PCs and laptops with linux mint and for some time in this pc, the downloads have become very slow.
To give you an idea the same file downloaded with another PC at 3Mb/s, with this PC the download at 30Kb/s, yesterday "sudo apt-get update" took 24 minutes and often I lost the connection. Adding a usb wireless key, the situation improves a bit in terms of stability, but not much in download speed.

I searched for new drivers or solutions online, but I couldn't find a solution.

Can you help me figure out how to get my wireless card back to its normal speed?


JeremyB
Level 20
Level 20
Posts: 10931
Joined: Fri Feb 21, 2014 8:17 am

Re: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01) very slow

Post by JeremyB » Wed Sep 11, 2019 5:14 pm

Make sure your router encryption is WPA2 only, no WEP or TKIP enabled

alebal
Level 1
Level 1
Posts: 30
Joined: Fri Aug 08, 2014 5:57 pm

Re: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01) very slow

Post by alebal » Thu Sep 12, 2019 5:38 pm

I tried ... it didn't make much difference, I still download very slowly...

indeed, it seems much slower on upload, ftp is damn slow...

If I wanted to go back, what should I do? this?

Code: Select all

echo "options ath9k nohwcrypt=0" > /etc/modprobe.d/ath9k.conf

sleeper12
Level 6
Level 6
Posts: 1056
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01) very slow

Post by sleeper12 » Thu Sep 12, 2019 9:42 pm

alebal wrote:
Thu Sep 12, 2019 5:38 pm

If I wanted to go back, what should I do?
I'm not sure, but I came across this:

open the “/etc/modprobe.d/ath9k.conf”-file in a text-editor and remove the line containing the following:
options ath9k nohwcrypt=1

Post Reply

Return to “Wireless”