SOLVED: Cannot boot after installing Linux Mint Cinnamon

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
RIH
Level 4
Level 4
Posts: 498
Joined: Sat Aug 22, 2015 3:47 am

Re: Cannot boot after installing Linux Mint Cinnamon

Post by RIH » Wed Sep 18, 2019 1:25 am

Glad that you are at least back to where we started... that is a good thing!! :D


Before we go any farther what I would like to know is whether Windows 7 is loaded under UEFI or legacy - as that will tell us how to install Mint.
This site gives 3 different methods on how to establish how Windows 7 was loaded.
https://www.isumsoft.com/it/if-my-compu ... i-or-bios/

Why 3?? Well the first 2 methods were no help to me at all - the 3rd. method (Disk Management) did.
Can you try them & report back with the answer??

As an aside I have Windows 7 & Mint 19.2 installed on this desktop (howbeit Mint on a SSD & Windows on the hard disk).
Both are in legacy mode, work perfectly & no EFI partition anywhere!!

As far as a user guide is concerned...
As before, I cannot recommend this one enough to you..
https://easylinuxtipsproject.blogspot.c ... -mint.html

Before you install your Mint onto the USB drive, I suggest that you carefully read pbear's (who is helping you in this thread) guide to doing that..
viewtopic.php?t=287353

NOTE Especially:
If Windows 7 tells you that it is installed in Legacy mode then you must install Mint the same way. If you attempt to install it in UEFI mode (which could happen if you have not prepared the USB correctly) then you will get the type of issues that you presented in your first post!!
Aspire-TC-705 Kernel: 4.15.0-72-generic x86_64 bits: 64
compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.2.3
Distro: Linux Mint 19.2

User avatar
pbear
Level 9
Level 9
Posts: 2747
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot boot after installing Linux Mint Cinnamon

Post by pbear » Wed Sep 18, 2019 2:06 am

wannabelinuxguy wrote:
Wed Sep 18, 2019 12:48 am
WHEW! I got Windows 7 back!
Congratulations and well done!

Okay, as RIH says, the next thing is to confirm your boot mode in Win7. Remember I said, one of the reasons it was important to fix Win7 was that I want you to run msinfo32. Notice that's the first method for confirming boot mode mentioned in RIH's link. So, try that first. If it doesn't work (which will surprise me) try one of the others. Doesn't have to be a screenshot, but quote the output exactly. Or post a screenshot (but, please, a system screenshot, not a photo). Anyhoo, I'm pretty sure we're going to find Win7 is booting in BIOS mode, but let's make sure.

No need to delete the old Mint partitions yet. We'll get to that in due course. On the bright side, you're not going to have to go through the shrinking exercise again. The space needed is already cleared. It'll be a simple matter of old partitions out, new partition(s) in.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

wannabelinuxguy
Level 2
Level 2
Posts: 57
Joined: Thu Sep 12, 2019 5:51 pm

Re: Cannot boot after installing Linux Mint Cinnamon

Post by wannabelinuxguy » Wed Sep 18, 2019 9:14 pm

Do i have the weirdest laptop in the world or what?
It seems nothing about it is "normal"...
Okay, so I tried the first 2 methods of finding out my boot info.
Neither of these worked for me.
1) First one, (jpg attached; can't do printscreen unless you want it mounted in a document like Open office, so I did a snip, hopefully that's okay), it does not list the BIOS MODE (if it is on there then I'm legally blind).
2) My Panther folder does not show a setupact folder. (jpg attached)
3) This shows that I have a Healty, Active EFI System Partition (jpg attached). I am wondering about this:
Did I not just create that partition? I am pretty sure I did. Also when I was going into my BIOS on a regular basis to try to choose to boot into Windows I did see that I have a Legacy option and in fact I could choose Legacy or (something else). I wouldn't know how to take a screen shot of my BIOS but if you like I can take a [good] photo of those options.

When I installed Linux it said the problem was I needed to create an EFI partition. So I did, I am sure I did. I chose it from the drop down list in the Mint Installer. However I thought I was choosing 2mb; maybe I chose 2 gb somehow by mistake (which might show as 1.86g, no?)

My feeling (even though I know next to nothing so this is just from what I think I know...) is that my W7 was installed via BIOS.
If it was installed via EFI then why would Linux have told me I needed an EFI partition, causing me to create one?

Okay well maybe this idea is totally wrong on my part so hopefully you know what the truth is or there is a way to find out for sure.

By the way, just so you know, I'm not in any hurry to complete this. I am kinda busy at least tomorrow, so if we have to do it quickly due to your schedule, I can; but otherwise there may be a day or two (like maybe tomorrow) where I don't have the time (although surely I could make it if I needed to).

As usual: Thanks for your help! I appreciate it!
sys info screen.JPG
Panther screen.JPG
snip of disk mgmt W7.JPG
Last edited by Pierre on Wed Sep 18, 2019 10:34 pm, edited 1 time in total.
Reason: That 1st picture says - System Type - - x64-based PC - - so win-7 is an 64 bit system

RIH
Level 4
Level 4
Posts: 498
Joined: Sat Aug 22, 2015 3:47 am

Re: Cannot boot after installing Linux Mint Cinnamon

Post by RIH » Wed Sep 18, 2019 9:53 pm

I had similar results to you using the first 2 methods to establish how Windows 7 was loaded.

My reading of the 3rd. screen shot is this...
Windows 7 was loaded as Legacy & so Mint must be installed in a similar mode.

If it were me then I would probably use GParted from a Mint live disk to erase all the partitions to the right of the Windows 7 partition* & then add that space to the Windows 7 partition. When installing Mint it will then be an easy matter to use the 'Install along side Windows' option.

However, also if I were you :D I would undoubtedly wait until pbear comes back with his 'read' of the situation.
If he offers a path to install then I would certainly follow his advice.
It is best (in my opinion) to follow 1 set of instructions from 1 knowledgeable poster than try to pick the best route from a variety of options!!

* You can keep or dump the last partition (HP Tools) - your choice. It won't offer you anything under Linux, it can under Windows...
Aspire-TC-705 Kernel: 4.15.0-72-generic x86_64 bits: 64
compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.2.3
Distro: Linux Mint 19.2

User avatar
Spearmint2
Level 16
Level 16
Posts: 6883
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Cannot boot after installing Linux Mint Cinnamon

Post by Spearmint2 » Wed Sep 18, 2019 10:08 pm

Code: Select all

gnome-screenshot -i
for making screenshots
It is best (in my opinion) to follow 1 set of instructions from 1 knowledgeable poster than try to pick the best route from a variety of options!!
yes, definitely. Too many confuses the matter.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

User avatar
pbear
Level 9
Level 9
Posts: 2747
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot boot after installing Linux Mint Cinnamon

Post by pbear » Wed Sep 18, 2019 10:54 pm

wannabelinuxguy wrote:
Wed Sep 18, 2019 9:14 pm
Do i have the weirdest laptop in the world or what?
Maybe. :)
3) This shows that I have a Healty, Active EFI System Partition (jpg attached). I am wondering about this:
Right, this means nothing, as you added it recently. Until then, Win7 didn't have an EFI partition, which itself indicates BIOS mode. And there are other indicators, like the fact that it's a DOS partition scheme rather than GPT.
Also when I was going into my BIOS on a regular basis to try to choose to boot into Windows I did see that I have a Legacy option and in fact I could choose Legacy or (something else). I wouldn't know how to take a screen shot of my BIOS but if you like I can take a [good] photo of those options.
Yes, please. Frankly, this may be your last best chance for solving the puzzle. If we can't figure out a way to get Mint to boot in BIOS mode, there's really no way forward on the terms you want. Will have to be either 32 bit dual boot or 64 bit to USB drive (full install, not just a live session). As for 32 bit, please recall I said a couple days ago you might end up there. You have an unusual problem.
My feeling (even though I know next to nothing so this is just from what I think I know...) is that my W7 was installed via BIOS. If it was installed via EFI then why would Linux have told me I needed an EFI partition, causing me to create one?
Apparently the BIOS is UEFI capable (not typical for a Win7 vintage computer), so Mint is booting that way. Whether you can block that is the "last best chance" I mentioned above.
By the way, just so you know, I'm not in any hurry to complete this.
Conversely, I'm about to start my work week, so I'll be checking in once in morning and again in the evening, with long stretches offline.

Okay, so, it seems to me the next four tasks are this.

1. Work through the BIOS settings and see whether you can find something which will force legacy boot. If you find a likely candidate, post a photo.

2. In order to eliminate one source of uncertainty, reburn the ISO to USB drive using Rufus.

3. Boot the USB and check whether it's booting in BIOS or UEFI mode. Use the long form of command. Here it is again:

Code: Select all

[ -d /sys/firmware/efi ] && echo "Currently in UEFI mode" || echo "Currently in Legacy mode"
4. While you're booted to the live session, so ahead and delete the current Mint installation. As I recall (been a while since I had logical partitions), you may have to delete the logical partitions first, then the extended partition. ETA: zcot points out below the swap partition probably will be mounted and can't be deleted in that state; right-click and select swapoff, then you'll be able to delete it; or run the Terminal command he suggests. Anyhoo, when done deleting the Mint partitions, leave the space unallocated.

By the way, it might aid your understanding of the problem to read a few articles about UEFI. Wouldn’t call this light reading, but it’s not rocket science. Of many available, I recommend Chris Hoffman, then Rod Smith and Happy Assasin. Those are in ascending order of complexity, so you learn progressively more as you go along.
Last edited by pbear on Thu Sep 19, 2019 11:29 am, edited 1 time in total.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

User avatar
zcot
Level 5
Level 5
Posts: 596
Joined: Wed Oct 19, 2016 6:08 pm

Re: Cannot boot after installing Linux Mint Cinnamon

Post by zcot » Wed Sep 18, 2019 11:35 pm

pbear wrote:
Wed Sep 18, 2019 10:54 pm
1. Work through the BIOS settings and see whether you can find something which will force legacy boot. If you find a likely candidate, post a photo.

2. In order to eliminate one source of uncertainty, reburn the ISO to USB drive using Rufus.

3. Boot the USB and check whether it's booting in BIOS or UEFI mode. Use the long form of command. Here it is again:

Code: Select all

[ -d /sys/firmware/efi ] && echo "Currently in UEFI mode" || echo "Currently in Legacy mode"
4. While you're booted to the live session, so ahead and delete the current Mint installation. As I recall (been a while since I had logical partitions), you may have to delete the logical partitions first, then the extended partition. When done, leave the space unallocated.
Just trying to help add any useful extra detail.

1. if you do this, then the Mint live session will just boot in BIOS/MBR mode to start with.

2. I had burned a media once using a much newer UEFI system and used "etcher"(it was detecting the environment and set up the usb media accordingly), and I could never get it to boot on an older BIOS-only machine. The only solution was after remaking it with Rufus. Just a point to say, not that the iso or media was bad, but that it was set up in a wrong capable mode for the situation.

3. Interrupt the initial countdown timer when booting. If you are seeing "Boot in UEFI mode" that's an indicator the Mint session is seeing it as available, and so you will not be choosing that selection for sure.

4. The live session will utilize the existing /swap partition for convenience of running the live setting. And you can not work on mounted partitions. So you can throw a terminal command: sudo swapoff -a

User avatar
pbear
Level 9
Level 9
Posts: 2747
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot boot after installing Linux Mint Cinnamon

Post by pbear » Thu Sep 19, 2019 12:16 am

zcot wrote:
Wed Sep 18, 2019 11:35 pm
I had burned a media once using a much newer UEFI system and used "etcher"(it was detecting the environment and set up the usb media accordingly), and I could never get it to boot on an older BIOS-only machine. The only solution was after remaking it with Rufus. Just a point to say, not that the iso or media was bad, but that it was set up in a wrong capable mode for the situation.
Interesting. How long ago was this? I wonder whether it's worth trying to use this trick in reverse, i.e., to have the OP run Etcher on his Win7 system on the hope it will burn the USB in BIOS mode only. That's the objective, to get Mint booted in BIOS mode.

ETA: Tested burning with Etcher on a UEFI machine, then booting in BIOS. Worked fine, so seems that bug has been fixed.
The live session will utilize the existing /swap partition for convenience of running the live setting. And you can not work on mounted partitions. So you can throw a terminal command: sudo swapoff -a
Useful tip. What this means, wannabe, is that after you're run the /sys/firmware command you should run the command zcot gives here. Now you'll be able to delete the swap partition in GParted. (There's another way to do that, but this one is just as good.)
Last edited by pbear on Thu Sep 19, 2019 3:43 am, edited 1 time in total.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

Minux1
Level 3
Level 3
Posts: 128
Joined: Tue Aug 06, 2019 1:49 am

Re: Cannot boot after installing Linux Mint Cinnamon

Post by Minux1 » Thu Sep 19, 2019 2:56 am

Friend of mine who has been into Linux for a year or so told me he installed Linux Mint beside the incumbent Windows 10 on his laptop without creating any special root/swap/home partitions and it worked well. He has a GUI (GRUB) that isn’t the prettiest but on bootup he can choose between Windows 10 or Linux Mint. Linux did it all. All he had to do was choose the size of the Linux partition and answer a few simple questions during the Linux installation.
According to him you always install Windows first and the Linux installer ‘takes charge’ of creating a dual boot system. On the other hand Windows will ‘ignore’ Linux if Windows is installed last and you’ll wind up with an unbootable situation.

RIH
Level 4
Level 4
Posts: 498
Joined: Sat Aug 22, 2015 3:47 am

Re: Cannot boot after installing Linux Mint Cinnamon

Post by RIH » Thu Sep 19, 2019 3:11 am

Yes, Windows always needs to be installed first.
There are differences between dual booting with Mint between Windows 7 & Windows 10.
A major Windows 10 update is also liable to demolish the Mint Grub settings as well.

Personally, I have never had to many issues dual booting Mint with either Windows 7 or 10 in the past.
That is as much down to luck with the way the computer manufacturer has set up BIOS as any great skill on my part though,, :D

I still dual boot my desktop with Windows 7 & Mint 19.2 but that is so I can run a 'clean' version of Windows 7 in order to help friends with Windows 7 issues. Windows 10 has been consigned only to VirtualBox guest visits for quite some time.. :D
Aspire-TC-705 Kernel: 4.15.0-72-generic x86_64 bits: 64
compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.2.3
Distro: Linux Mint 19.2

User avatar
zcot
Level 5
Level 5
Posts: 596
Joined: Wed Oct 19, 2016 6:08 pm

Re: Cannot boot after installing Linux Mint Cinnamon

Post by zcot » Thu Sep 19, 2019 7:39 am

pbear wrote:
Thu Sep 19, 2019 12:16 am
Interesting. How long ago was this?
That was a year and a half ago I'd say, -maybe 2. yea, possible bug situation I suppose.

I'm guessing it won't be hard to get it booting in legacy mode once wannabelinuxguy is trying to do that specifically on purpose.

wannabelinuxguy
Level 2
Level 2
Posts: 57
Joined: Thu Sep 12, 2019 5:51 pm

Re: Cannot boot after installing Linux Mint Cinnamon

Post by wannabelinuxguy » Fri Sep 20, 2019 5:06 pm

Edited by Moderator:
Please stay on Track, with the main Issue.
:D

You think I have a 32 bit system but my system info says otherwise and it also says I am running Windows 7 Home Premium, 64-bit.
sys info screen.JPG
Last edited by Pierre on Sat Sep 21, 2019 12:27 am, edited 1 time in total.
Reason: Removed some un-nessary parts to posting.

wannabelinuxguy
Level 2
Level 2
Posts: 57
Joined: Thu Sep 12, 2019 5:51 pm

Re: Cannot boot after installing Linux Mint Cinnamon

Post by wannabelinuxguy » Fri Sep 20, 2019 5:15 pm

zcot wrote:
Wed Sep 18, 2019 11:35 pm
pbear wrote:
Wed Sep 18, 2019 10:54 pm
1. Work through the BIOS settings and see whether you can find something which will force legacy boot. If you find a likely candidate, post a photo.

2. In order to eliminate one source of uncertainty, reburn the ISO to USB drive using Rufus.

3. Boot the USB and check whether it's booting in BIOS or UEFI mode. Use the long form of command. Here it is again:

Code: Select all

[ -d /sys/firmware/efi ] && echo "Currently in UEFI mode" || echo "Currently in Legacy mode"
4. While you're booted to the live session, so ahead and delete the current Mint installation. As I recall (been a while since I had logical partitions), you may have to delete the logical partitions first, then the extended partition. When done, leave the space unallocated.
Just trying to help add any useful extra detail.

1. if you do this, then the Mint live session will just boot in BIOS/MBR mode to start with.

2. I had burned a media once using a much newer UEFI system and used "etcher"(it was detecting the environment and set up the usb media accordingly), and I could never get it to boot on an older BIOS-only machine. The only solution was after remaking it with Rufus. Just a point to say, not that the iso or media was bad, but that it was set up in a wrong capable mode for the situation.

3. Interrupt the initial countdown timer when booting. If you are seeing "Boot in UEFI mode" that's an indicator the Mint session is seeing it as available, and so you will not be choosing that selection for sure.

4. The live session will utilize the existing /swap partition for convenience of running the live setting. And you can not work on mounted partitions. So you can throw a terminal command: sudo swapoff -a
FYI I believe I did use this Etcher program to create my ISO usb. (the reason I'm not 100% sure is because I downloaded both this and Rufus; but I think Rufus is on my W10 machine and I can check the date to see which I got first. I think I downloaded Rufus after already botching the Linux install and was going to use Rufus to burn the Boot Repair USB):
This is what I used:
balenaEtcher-Setup-1.5.52 .exe

So are you saying this is probably what caused me to get the "you need an EFI partition" error?
And so - I realize we're not there yet , but - so should I use that or not to burn my Linux Mint 64 bit live usb? I ask now because I may as well download it and get it ready. I'll use the same usb drive I had the other one on but Quick Format it first, right?

And can you give me the best link to download a new Mint Cinnamon 64-bit?
I THINK I used this page before: Anyway I am thinking of using it this time:
https://blog.linuxmint.com/?p=3786

I do have also Rufus downloaded on my W10 Lenovo machine to load the iso onto my USB. Just tell me whenever you can, which one to use.

I'll try to run the above commands you request, later today or tomorrow.

athi
Level 6
Level 6
Posts: 1461
Joined: Sun Mar 30, 2014 10:15 am
Location: USA

Re: Cannot boot after installing Linux Mint Cinnamon

Post by athi » Fri Sep 20, 2019 5:56 pm

If you are using Rufus, try setting "Partition scheme" to MBR per below picture, can't hurt. Also, if Mint live USB insist on booting in UEFI mode, try selecting "Compatibility Mode" from GRUB boot menu.
rufus.gif
Mint Mate 19.1. Main rig is HP 800G2 I5 6500 16GB ram, 120GB boot drive, 2x3TB, 1x4TB data drives. Oldest rig is Mate 18.3 on Dell D620 with 32bits core duo.

User avatar
pbear
Level 9
Level 9
Posts: 2747
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot boot after installing Linux Mint Cinnamon

Post by pbear » Fri Sep 20, 2019 8:13 pm

wannabelinuxguy, none of this matters unless you've solved the BIOS/UEFI problem. Did you?

On other points, no need to download the ISO again if you confirmed the checksum last time. Rufus is fine and what I suggested you use all along. By the way, based on further tests, I don't think 32 bit is going to help so long as you're in UEFI mode, as it's unable to boot in UEFI. And if you solve the UEFI boot problem, you don't need 32 bit. Just a little tip, for what may turn out to be my next-to-last post in the thread. Too many cooks, indeed.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

wannabelinuxguy
Level 2
Level 2
Posts: 57
Joined: Thu Sep 12, 2019 5:51 pm

Re: Cannot boot after installing Linux Mint Cinnamon

Post by wannabelinuxguy » Fri Sep 20, 2019 9:02 pm

pbear wrote:
Fri Sep 20, 2019 8:13 pm
wannabelinuxguy, none of this matters unless you've solved the BIOS/UEFI problem. Did you?

On other points, no need to download the ISO again if you confirmed the checksum last time. Rufus is fine and what I suggested you use all along. By the way, based on further tests, I don't think 32 bit is going to help so long as you're in UEFI mode, as it's unable to boot in UEFI. And if you solve the UEFI boot problem, you don't need 32 bit. Just a little tip, for what may turn out to be my next-to-last post in the thread. Too many cooks, indeed.
Thanks, pbear. I'll follow your directions but if you're not available I may ask a question or two and hopefully someone else capable will answer.
Here are the photos of my BIOS. I probably won't try installing Linux until someone is available to help me through any problems I may encounter.
sys info_Medium.jpg
sys config_Medium.jpg
boot menu_Medium.jpg

wannabelinuxguy
Level 2
Level 2
Posts: 57
Joined: Thu Sep 12, 2019 5:51 pm

Re: Cannot boot after installing Linux Mint Cinnamon

Post by wannabelinuxguy » Fri Sep 20, 2019 9:05 pm

Maybe some of these photos will confirm (or deny?) what pbear thought was going on in terms of my bios and what needs to be done?
If anyone else here
knows how to proceed in terms of what pbear has outlined, please confirm or deny. Thanks.
main bios page_Medium.jpg
legacy and boot_Medium.jpg

User avatar
pbear
Level 9
Level 9
Posts: 2747
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot boot after installing Linux Mint Cinnamon

Post by pbear » Fri Sep 20, 2019 9:49 pm

Well, that last screenshot is the problem. To save anyone having to jump back, it says, "When Legacy Support is enabled, UEFI boot order and Legacy boot order are both available and UEFI boot order has higher priority than Legacy boot order." FWIW, I have a more recent HP with Insyde v.45 and it says the same thing on this screen, so I doubt there's anything to be gained by updating the firmware (v.45 is the latest available for mine).

Frankly, I'm stumped. And wonder how anyone ever installed Mint in legacy mode on an HP. Or did they? Throwing the floor open for suggestions.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

RIH
Level 4
Level 4
Posts: 498
Joined: Sat Aug 22, 2015 3:47 am

Re: Cannot boot after installing Linux Mint Cinnamon

Post by RIH » Fri Sep 20, 2019 9:59 pm

Would the answer be to re-install Windows 7 in UEFI & then Mint can be installed the same??

Other than that.... given that Win 7 is EOF in a couple of months - ditch Win 7 all together & install Mint in a single boot system??
Aspire-TC-705 Kernel: 4.15.0-72-generic x86_64 bits: 64
compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.2.3
Distro: Linux Mint 19.2

User avatar
pbear
Level 9
Level 9
Posts: 2747
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cannot boot after installing Linux Mint Cinnamon

Post by pbear » Fri Sep 20, 2019 10:05 pm

There are several options along those lines, including full install to USB drive as you mentioned earlier.* For now, I'd like to focus on whether we're overlooking something in setting the firmware to boot the Mint ISO in BIOS mode.

* By the way, wannabe, I can walk you through that if you like. It's a pretty cool solution, actually, and relatively easy.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

Post Reply

Return to “Installation & Boot”