[SOLVED] No Sound MATE 19.2 Fusion5 Lapbook T50

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
JoeBingo
Level 4
Level 4
Posts: 265
Joined: Fri Jun 24, 2011 4:18 pm

Re: [SOLVED] No Sound MATE 19.2 Fusion5 Lapbook T50

Post by JoeBingo »

I did install pavucontrol. Had it installed before beginning with your suggestions. Wasn't a lot to mess with in there for my default configuration. May be more though since the kernel upgrade. Not going to mess with it now ... too.tired LOL

User avatar
MrEen
Level 17
Level 17
Posts: 7066
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] No Sound MATE 19.2 Fusion5 Lapbook T50

Post by MrEen »

JoeBingo wrote:
Mon Sep 16, 2019 9:42 pm
OH ... and as to when the kernels were being optimized for ATOM powered tablets and lapbooks ... I thought the later 4.15 kernels were, since May or June or so LOL. That's why I didn't pin hope on the 5.0 series. Little did I know HA !!!
Lots of support was already there. It's often/usually just some config issues left to sort out. Those UCM files are just config items, but even that is now getting added to the kernel from what I understood. Stuff like this:

Code: Select all

SectionDefaults [
	cdev "hw:bytcrrt5651"

	# media mixer settings
	#   compress
	cset "name='media0_in Gain 0 Switch' on"
	cset "name='media0_in Gain 0 Volume' 0"
	...

User avatar
MrEen
Level 17
Level 17
Posts: 7066
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] No Sound MATE 19.2 Fusion5 Lapbook T50

Post by MrEen »

JoeBingo wrote:
Mon Sep 16, 2019 9:47 pm
I did install pavucontrol. Had it installed before beginning with your suggestions. Wasn't a lot to mess with in there for my default configuration. May be more though since the kernel upgrade. Not going to mess with it now ... too.tired LOL
HA! Have a good night!

JoeBingo
Level 4
Level 4
Posts: 265
Joined: Fri Jun 24, 2011 4:18 pm

Re: [SOLVED] No Sound MATE 19.2 Fusion5 Lapbook T50

Post by JoeBingo »

You too sir :)

JoeBingo
Level 4
Level 4
Posts: 265
Joined: Fri Jun 24, 2011 4:18 pm

Re: [SOLVED] No Sound MATE 19.2 Fusion5 Lapbook T50

Post by JoeBingo »

FOLLOW UP:

Because I'm retired have tons of time and was curious, I reinstalled 19.2 MATE on the Fusion5 Lapbook T50 this evening.

FIRST THING I did was install the latest 5.0 series kernel. This lapbook needs this series for functionality regardless. However, no sound output. I had also performed all Update Manager updates.

After the kernel change to 5.0 series, I still had to clone UCM and move some files around ...

Code: Select all

cd ~/
apt install git
git clone https://github.com/plbossart/UCM.git
sudo cp -rf ~/UCM/bytcr-rt5651 /usr/share/alsa/ucm
sudo cp ~/UCM/bytcr-rt5651/asound.state /var/lib/alsa
sudo alsa force-reload
Because at this point, I had 2 sound devices listed and the one I needed wasn't default, I chose to blacklist HDMILPE but I'm sure there may be other workarounds. Blacklisting was easy and solved the problem, leaving only the sound device I needed ...

Code: Select all

sudo touch /etc/modprobe.d/blacklist-hdmi-lpe-audio.conf
xed admin:///etc/modprobe.d/blacklist-hdmi-lpe-audio.conf
And added this to the newly created file ...

Code: Select all

blacklist snd_hdmi_lpe_audio
Then also ran the following but aren't sure it was absolutely necessary. No harm anyway ...

Code: Select all

sudo alsa force-reload
pulseaudio --start
Additionally, there were some restarts and shutdowns in there along the way and at one point I deleted the contents of ~/.config/pulse.

The bottom line is that virtually everything MrEen suggested was necessary, AS WELL AS a change of kernel series to 5.0 as Pjotr suggested. No one solution would work without the other.

User avatar
MrEen
Level 17
Level 17
Posts: 7066
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] No Sound MATE 19.2 Fusion5 Lapbook T50

Post by MrEen »

Thank you so much for that update JoeBingo!

This thread will be very useful for future users of the same machine, as well as users of the same sound chip.

Excellent write up of each step as well!

Take care and have fun! :D

Post Reply

Return to “Sound, Multimedia, & Codecs”