[SOLVED] Mint Freezes/Locks Up After Software Update

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 4
Joined: Wed Nov 06, 2019 7:28 pm

[SOLVED] Mint Freezes/Locks Up After Software Update

Post by wolfeman28 »

Hi all, long time Mint user and this is my first issue in the past few years. I have never had a crash or freeze before today and this is a pc that's on about 16 hours a day, so I'm mighty impressed!

I normally do all updates that get pushed through the update manager and haven't had an issue doing that until today. There were four updates available so I installed them-
'apport' 2.20.9-0ubuntu7.9
'chromium-browser' 78.0.3904.70-0ubuntu0.10.04
'cpio' 2.12+dfsg-6ubuntu0.18.04.1
'bind9' 1:9.113+dfsg-1ubuntu1.10

After installing these, my PC has a random freeze that can't be recovered from, I have to hard reset via power button. There is no rhyme or reason as to when the freeze happens- doesn't matter what program is open, computer being used or locked, can freeze after 5min or 1 hour. I repeated the freeze about 10 times so far just to prove to myself I wasn't going nuts, then decided to Timeshift back to before the updates. After reverting, everything is fine again and no crashing so that eliminates hardware going south I suppose.

What would be the proper way to go about fixing the problem or finding exactly what is causing it? I don't have the time to install each one of those updates individually, take a new timeshift for each one, revert to old timeshift after each one, etc. as this PC does work during the 16 hours a day I have it up.


Code: Select all

$ inxi -Fxz
  Host: eric-desktop-home Kernel: 5.3.0-19-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.2.4 
  Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
  Type: Desktop Mobo: ASRock model: Z77 Pro4 serial: <filter> 
  BIOS: American Megatrends v: P2.00 date: 03/13/2018 
  Topology: Quad Core model: Intel Core i5-3570K bits: 64 type: MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27201 
  Speed: 1600 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1600 2: 1600 
  3: 1600 4: 1600 
  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics 
  vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA GK107 [GeForce GTX 650] vendor: Gigabyte driver: nvidia 
  v: 440.26 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: nvidia 
  resolution: 1680x1050~60Hz, 1920x1080~60Hz, 1680x1050~60Hz 
  OpenGL: renderer: GeForce GTX 650/PCIe/SSE2 v: 4.6.0 NVIDIA 440.26 
  direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GK107 HDMI Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 
  Device-3: BEHRINGER type: USB driver: snd-usb-audio bus ID: 2-1.7:5 
  Sound Server: ALSA v: k5.3.0-19-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: d000 bus ID: 05:00.0 
  IF: eth0 state: down mac: <filter> 
  Device-2: Linksys WUSB6300 802.11a/b/g/n/ac Wireless Adapter [Realtek 
  type: USB driver: rtl88xxau bus ID: 3-2:2 
  IF: wlan0 state: up mac: <filter> 
  Local Storage: total: 3.08 TiB used: 379.82 GiB (12.0%) 
  ID-1: /dev/sda vendor: Crucial model: M4-CT128M4SSD1 size: 119.24 GiB 
  ID-2: /dev/sdb vendor: Crucial model: M4-CT256M4SSD2 size: 238.47 GiB 
  ID-3: /dev/sdc vendor: Western Digital model: WD5000AAJS-00YFA0 
  size: 465.76 GiB 
  ID-4: /dev/sdd vendor: Western Digital model: WD5000AAJS-00YFA0 
  size: 465.76 GiB 
  ID-5: /dev/sde vendor: Seagate model: ST2000DL001-9VT156 size: 1.82 TiB 
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 
  bus ID: 00:1f.2 
  ID-1: / size: 915.90 GiB used: 379.82 GiB (41.5%) fs: ext4 dev: /dev/dm-1 
  System Temperatures: cpu: 27.0 C mobo: N/A gpu: nvidia temp: 35 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 48% 
  Processes: 235 Uptime: 44m Memory: 15.53 GiB used: 3.88 GiB (25.0%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 

Level 1
Level 1
Posts: 4
Joined: Wed Nov 06, 2019 7:28 pm

Re: [SOLVED]Mint Freezes/Locks Up After Software Update

Post by wolfeman28 »

Got it fixed. Had something to do with the 'apport' update. Oddly, after installing the python 3 update that populated today, THEN installing the apport update, everything works fine.

Post Reply

Return to “Software & Applications”