[SOLVED] Menus and hints are torn or broken

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
cawx
Level 1
Level 1
Posts: 13
Joined: Fri Jan 17, 2020 3:09 am
Location: Germany

[SOLVED] Menus and hints are torn or broken

Post by cawx »

Hello together
since the update yesterday, some menus and hints are torn or broken. I've attached two screenshots that might better describe what the problem is.
Does anyone else have the problem?

Here is my update history, one of the marked updates must be the problem.
Attachments
update history
update history
right side of task bar
right side of task bar
Auswahl_014.png (4.78 KiB) Viewed 1569 times
shutdown menu
shutdown menu
Last edited by cawx on Sat Jan 18, 2020 4:34 am, edited 1 time in total.
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Menus and hints are torn or broken

Post by gm10 »

The updates you marked are for your display server so they would indeed appear to be the culprit. If you have a Timeshift snapshot you can just revert the system to the previous state. Otherwise for anybody to have any insight on this you should at least share your hardware information by posting the output of this terminal command:

Code: Select all

inxi -Fxz
User avatar
cawx
Level 1
Level 1
Posts: 13
Joined: Fri Jan 17, 2020 3:09 am
Location: Germany

Re: Menus and hints are torn or broken

Post by cawx »

Hi gm10,

thank you for your support, here is the information. Unfortunately I have no timeshift snapshot. I had not set this up yet. :(

I tried a reboot with the following kernels, all with the same uggly errors:
* 5.3.0-26
* 5.0.0-37
* 4.15.0-74

Code: Select all

System:    Host: homestation Kernel: 4.15.0-74-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8 
           Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop Mobo: ASRock model: 880GMH/U3S3 serial: <filter> UEFI: American Megatrends v: P1.80 date: 12/27/2011 
CPU:       Topology: 6-Core model: AMD Phenom II X6 1090T bits: 64 type: MCP arch: K10 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 38401 
           Speed: 800 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 1563 6: 800 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Cypress XT [Radeon HD 5870] vendor: PC Partner Limited driver: radeon 
           v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: ati,radeon unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD CYPRESS (DRM 2.50.0 / 4.15.0-74-generic LLVM 9.0.0) v: 4.3 Mesa 19.2.1 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Device-2: AMD Cypress HDMI Audio [Radeon HD 5830/5850/5870 / 6850/6870 Rebrand] vendor: PC Partner Limited 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.15.0-74-generic 
Network:   Device-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: ASRock driver: atl1c v: 1.0.1.1-NAPI port: c000 
           bus ID: 04:00.0 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 223.58 GiB used: 20.22 GiB (9.0%) 
           ID-1: /dev/sda vendor: SanDisk model: SSD PLUS 240 GB size: 223.58 GiB 
Partition: ID-1: / size: 218.57 GiB used: 20.21 GiB (9.2%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 19.0 C mobo: N/A gpu: radeon temp: 38 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 217 Uptime: 7m Memory: 7.78 GiB used: 1.01 GiB (13.0%) Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 
           Shell: bash v: 4.4.20 inxi: 3.0.32 
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Menus and hints are torn or broken

Post by gm10 »

With that hardware you wouldn't need the HWE stack, anyway, so I suggest you go back to the LTS version (don't worry if you don't know what I'm talking about ;)). Run this in a terminal window, then reboot:

Code: Select all

apt install xserver-xorg xserver-xorg-video-all
User avatar
nakednorman
Level 2
Level 2
Posts: 90
Joined: Mon Jan 02, 2017 9:05 am

Re: Menus and hints are torn or broken

Post by nakednorman »

@gm10
This looks similar to another post today:

viewtopic.php?f=208&t=309789

If it is, then you will be knowledgeable enough to know how to address it - I haven't a clue :(
User avatar
cawx
Level 1
Level 1
Posts: 13
Joined: Fri Jan 17, 2020 3:09 am
Location: Germany

Re: Menus and hints are torn or broken

Post by cawx »

@gm10
It's working again, thank you. :D :D :D

Yes, I opened two tickets, in the afternoon I saw that there is also a German forum.

I apologize, I didn't think I would get answers or even a solution so quickly.
I will close both tickets as "solved".
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Menus and hints are torn or broken

Post by gm10 »

You are welcome, even though differences in your statements in both threads (no Timeshift here, yes Timeshift in the other one) as well as the timing (you made the German one hours after I had already responded here) make me raise an eye brow in wonder. ;)

The thread nakednorman linked was yet another one though, none of yours. You weren't the only one with the problem it seems.
SatanLovesJello
Level 1
Level 1
Posts: 2
Joined: Sat Jan 18, 2020 1:05 pm

Re: Menus and hints are torn or broken

Post by SatanLovesJello »

gm10 wrote:
Fri Jan 17, 2020 1:11 pm
With that hardware you wouldn't need the HWE stack, anyway, so I suggest you go back to the LTS version (don't worry if you don't know what I'm talking about ;)). Run this in a terminal window, then reboot:

Code: Select all

apt install xserver-xorg xserver-xorg-video-all
First visit, first post. I made the full switch from Windows to Linux this month after 25 years of loyalty to Microsoft. This problem was the first I encountered, and I must say that this support community is damned impressive.

I found your answer to resolving this problem rather quickly. I certainly appreciate it. On an interesting side note, I had recently ordered a USB bluetooth dongle from wish.com for $2.00, and it would it not work with Windows. After hours spent trying to locate the proper drivers and software (the dongle turned out to be made by a now defunct company, Cambridge Radio LTD) I finally gave up and tossed it in my junk drawer. Once I switched my laptop to Linux, I though it wouldn't hurt to try that USB dongle again. It worked perfectly. I wish I'd switched sooner.

I appreciate people like you that take the time to address community questions, and to provide your support via time and knowledge so freely. People like yourself make the world as a whole a better place.

Thank you!
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Menus and hints are torn or broken

Post by gm10 »

SatanLovesJello wrote:
Sat Jan 18, 2020 1:28 pm
I appreciate people like you that take the time to address community questions, and to provide your support via time and knowledge so freely. People like yourself make the world as a whole a better place.
Thank you for your kind words from all of us that help out here. Who knows, maybe one day in the future it will be you, too!
MintUser19
Level 2
Level 2
Posts: 55
Joined: Fri Dec 27, 2019 7:23 pm

Re: Menus and hints are torn or broken

Post by MintUser19 »

gm10 wrote:
Fri Jan 17, 2020 1:11 pm
With that hardware you wouldn't need the HWE stack, anyway, so I suggest you go back to the LTS version (don't worry if you don't know what I'm talking about ;)). Run this in a terminal window, then reboot:

Code: Select all

apt install xserver-xorg xserver-xorg-video-all
Thank you, this helped me in this post: viewtopic.php?f=47&t=310332

Thanks gm10 :)
Mikey Likey
Level 1
Level 1
Posts: 11
Joined: Tue Jan 21, 2020 2:06 am

Re: [SOLVED] Menus and hints are torn or broken

Post by Mikey Likey »

Thanks everyone for your helpful input. As far as timeshift goes, I have had this problem for a week and have installed many packages. Ha!I wrongly thought I could fix this problem. So I am not sure that timeshift would work. Have just run "apt install xserver-xorg xserver-xorg-video-all" from terminal. So now I have the LTE version? Are you saying that my hardware is obsolete? Anyway, problem persists. The screen caps showed the same kind of problem by appearance, but this problem is confined to the smaller area I have outlined above. Thank you all very much.
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: [SOLVED] Menus and hints are torn or broken

Post by gm10 »

Mikey Likey wrote:
Fri Jan 24, 2020 10:13 pm
Thanks everyone for your helpful input. As far as timeshift goes, I have had this problem for a week and have installed many packages. Ha!I wrongly thought I could fix this problem. So I am not sure that timeshift would work. Have just run "apt install xserver-xorg xserver-xorg-video-all" from terminal. So now I have the LTE version? Are you saying that my hardware is obsolete? Anyway, problem persists. The screen caps showed the same kind of problem by appearance, but this problem is confined to the smaller area I have outlined above. Thank you all very much.
Timeshift can bring you back to the point before you installed the problematic update (assuming you have a snapshot from before that), so it would work, that's what it's there for. Otherwise: Did you reboot yet? If you did and it's still broken, please make a new thread of your own so we can help you there.
User avatar
MrEen
Level 22
Level 22
Posts: 15008
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Menus and hints are torn or broken

Post by MrEen »

gm10 wrote:
Sat Jan 25, 2020 8:58 am
Timeshift can bring you back to the point before you installed the problematic update (assuming you have a snapshot from before that), so it would work, that's what it's there for. Otherwise: Did you reboot yet? If you did and it's still broken, please make a new thread of your own so we can help you there.
Already solved. I believe Mikey Likey meant for that post to go to his thread after I pointed him to this one for the fix.
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: [SOLVED] Menus and hints are torn or broken

Post by gm10 »

MrEen wrote:
Sat Jan 25, 2020 2:06 pm
I believe Mikey Likey meant for that post to go to his thread after I pointed him to this one for the fix.
It would seem that way. ;)
Post Reply

Return to “Software & Applications”