change boot sequence

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

change boot sequence

Post by dorothy39 »

Is it possible to change boot sequence from Linux to Windows? so Windows automatically boots instead of Linux?

User avatar
pbear
Level 14
Level 14
Posts: 5078
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: change boot sequence

Post by pbear »

I think this is what you're looking for: Make Windows the default option in the Grub boot menu.

The author if that site is Forum member Pjotr.
Time flies like an arrow. Fruit flies like a banana.
Before you post, please read how to get help.

dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

Re: change boot sequence

Post by dorothy39 »

Didn’t work, I get “specific location is not mounted” after first line.

decrepit
Level 4
Level 4
Posts: 326
Joined: Mon Dec 03, 2018 4:07 am
Location: Mandurah Western Australia

Re: change boot sequence

Post by decrepit »

That's interesting, I get the same warning, but it seems to be irrelevant, because it actually worked, and I got this, try again and look for this popping up.
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="elevator=deadline quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1366x768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

User avatar
pbear
Level 14
Level 14
Posts: 5078
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: change boot sequence

Post by pbear »

dorothy39 wrote:
Fri Feb 07, 2020 12:53 pm
Didn’t work, I get “specific location is not mounted” after first line.
Well, the instructions work, so you're doing something wrong. How about describing in detail what you did and what happened.
Time flies like an arrow. Fruit flies like a banana.
Before you post, please read how to get help.

decrepit
Level 4
Level 4
Posts: 326
Joined: Mon Dec 03, 2018 4:07 am
Location: Mandurah Western Australia

Re: change boot sequence

Post by decrepit »

pbear,
The OP is correct I had exactly the same warning following the first line exactly. But you are also correct the instructions work, if you disregard the warning, our newbie was undoubtedly phased by it and didn't press on.

Code: Select all

mike@mike-ThinkPad:~$ xed admin:///etc/default/grub

** (xed:2529): WARNING **: 23:10:55.847: The specified location is not mounted
So I don't get this, all of /etc should be mounted, it's part of /. Is this a bug in xed?

I'll try it in another editor and see.
Nup it's not just zed

Code: Select all

mike@mike-ThinkPad:~$ gedit admin:///etc/default/grub

** (gedit:3810): WARNING **: 23:18:52.033: The specified location is not mounted

User avatar
pbear
Level 14
Level 14
Posts: 5078
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: change boot sequence

Post by pbear »

I'm sorry, but "first line" is ambiguous. We need to know exactly what command was run and exactly what terminal said in response. Indeed, what we prefer is copy-and-paste from terminal, as you did in your second post. It's common, by the way, that the problem is a typo rather than the command.

Anyhoo, dorothy, you can try pressing on as decrepit suggests. Or try a different text editor. sudo nano /etc/default/grub will open the Terminal text editor, which I generally prefer for configuration files because it's easier and faster. Use arrow keys to move around, backspace to delete. When done, Ctrl-O to write-out, Enter to overwrite current file, and Ctrl-X to exit nano and return to Terminal.

If that doesn't work, you have an interesting problem which has nothing to do with the Grub menu. Let's hope not.
Time flies like an arrow. Fruit flies like a banana.
Before you post, please read how to get help.

dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

Re: change boot sequence

Post by dorothy39 »

The first line is the first line in the command sequence. xed admin:///etc/default/grub.
I tried it several times and checked the spelling carefully. If you want to see those pages of code I can do that when I get home. When I say "Newbie" I mean "Green Newbie". But I will try your suggestions

So, re: suggestion by decrepit, after I do that and get pages of "its not working" I just continue with the rest of the program?

Thank you both for responding.

decrepit
Level 4
Level 4
Posts: 326
Joined: Mon Dec 03, 2018 4:07 am
Location: Mandurah Western Australia

Re: change boot sequence

Post by decrepit »

Dorothy, that "first line" brings up a text editor with admin privileges, so you can modify the grub config file to change the boot order. If you didn't see the text editor with the grub file, then something else is wrong.

pbear is correct, it's always best to copy and paste commands rather than type. It only takes the smallest of differences and the command doesn't work.

If you are getting more than that one line warning, yes definitely copy and paste that here. I only saw the one line warning, and the text editor ready to be changed.

So do you see xed? if not try pbear's suggestion of nano, that brings the grub file up in the terminal with no error message. But you'll need to follow his guide on how to use it.

User avatar
pbear
Level 14
Level 14
Posts: 5078
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: change boot sequence

Post by pbear »

First, my bad. I've done this so many times I'm used to ignoring that error message. Also, I think of it as coming after I've done the edits, as xed's screen covers Terminal when it opens. Anyhoo, yes, that warning is normal and can be ignored. What I can't fathom is why xed never comes up for you, dorothy. I've done this more times than I can count and have never had a problem. Are you entering your password when prompted? Actually, you have to do that twice when opening xed this way, but it's two prompts so pretty obvious what you're supposed to do.

Alternatively, there's another GUI method you could try. Open File Manager. Right-click anywhere blank in the right pane (i.e., not a file); select Open as Administrator; enter password when prompted (will only be once). Click File System in the left navigation pane. You'll see a bunch of folders on the right side, bin, boot, cdrom, etc.; double-click etc > default > grub. As you've done all this as Administrator, xed will open with admin privileges and you can edit the file per Pjotr's instructions. Close xed, then the Admin session of File Manager. You can close the regular session of File Manager or not as you like, but don't leave the admin one open. It's easy to edit or delete something important by accident.

I encourage you to learn the nano method. Like anything new, it seems awkward until you do it a few times. Once you get used to it, though, it is (as I said) the easiest and fastest way to edit configuration files.
Time flies like an arrow. Fruit flies like a banana.
Before you post, please read how to get help.

dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

Re: change boot sequence

Post by dorothy39 »

Thanks to both.
I will work on this later today.
I usually read these on my ipad and set it in front of computer for reference, so I can’t copy and paste. Buy I will if I need to.

dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

Re: change boot sequence

Post by dorothy39 »

This is what I get from beginning of easy linux tips projects. A new window, password twice then this.

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

Re: change boot sequence

Post by dorothy39 »

Closed that window. Terminal says this:

dot@dot-HP-Compaq-dc7600-Convertible-Minitower:~$ xed admin:///etc/default/grub

** (xed:1671): WARNING **: 03:02:46.077: The specified location is not mounted

User avatar
pbear
Level 14
Level 14
Posts: 5078
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: change boot sequence

Post by pbear »

As mentioned, you can ignore that warning. Indeed, it's so insignificant I had forgotten it pops up. :)

Anyhoo, now you're over the first hurdle. You're able to open xed as administrator, i.e., with elevated privileges.

Did you edit the file as instructed in the tutorial? Did you run sudo update-grub afterwards? Are the Grub options now in the desired order?
Time flies like an arrow. Fruit flies like a banana.
Before you post, please read how to get help.

dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

Re: change boot sequence

Post by dorothy39 »

OK there's another window under that on second try. Need admin permission.
Don't know how to find file manager. Feeling really stupid.

dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

Re: change boot sequence

Post by dorothy39 »

GOT IT!!!
Used the first option, xed..............
Finally got it that the new window is the editor and all I have to do is change one number.
But the tut is wrong. I needed to use the number of the line showing for Win7. not go down.
Windows shows on line 4 so I finally tried GRUB_DEFAULT=4 and that worked. Only took 1 1/2 hrs.

decrepit
Level 4
Level 4
Posts: 326
Joined: Mon Dec 03, 2018 4:07 am
Location: Mandurah Western Australia

Re: change boot sequence

Post by decrepit »

Good one Dorothy, glad you sorted it. It does take a while to get used to the terminal, but you're initiated now, any further interaction with it should come easier.

User avatar
pbear
Level 14
Level 14
Posts: 5078
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: change boot sequence

Post by pbear »

dorothy39 wrote:
Sun Feb 09, 2020 2:18 pm
GOT IT!!!
Oh, I do like a happy ending. Congratulation and well done.
Time flies like an arrow. Fruit flies like a banana.
Before you post, please read how to get help.

dorothy39
Level 2
Level 2
Posts: 67
Joined: Wed Jan 08, 2020 1:30 pm

Re: change boot sequence

Post by dorothy39 »

Thank you very much, both.

Post Reply

Return to “Newbie Questions”