[SOLVED] Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - hardware too old?

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
slvstr3
Level 1
Level 1
Posts: 5
Joined: Sat Feb 15, 2020 7:20 am

[SOLVED] Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - hardware too old?

Post by slvstr3 »

After using Linux mint 19.3 on a laptop I want to switch completely and also install it on my desktop. However, these freezes would be a deal-breaker. I would greatly appreciate any advice.

Using Linux mint 19.3 Cinnamon, 64. I just installed it on an ssd. There is still a 2nd ssd with Windows 7. I bought the hardware 8 years ago.

Problems:
  • It works well for about 10 minutes and then freezes.
  • Also my second monitor on its native resolution (3840 x 2160)
    doesnt show anything and just powers off. I use it on the lower resolution of 1920x1080 - this works (and is not nice but acceptable).
Tried so far:
  • add the nomodeset in the boot option: result: no difference
inxi -Fxxxrz gives:

System:
Host: slvst-MS-7793 Kernel: 5.0.0-32-generic x86_64 bits: 64 compiler: gcc
v: 7.4.0 Desktop: Cinnamon 4.4.5 wm: muffin 4.4.1 dm: LightDM 1.26.0
Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic
Machine:
Type: Desktop Mobo: MSI model: FM2-A85XA-G65 (MS-7793) v: 1.0
serial: <filter> BIOS: American Megatrends v: 2.6 date: 02/12/2015
CPU:
Topology: Quad Core model: AMD A8-5600K APU with Radeon HD Graphics
bits: 64 type: MCP arch: Piledriver rev: 1 L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 28737
Speed: 1397 MHz min/max: 1400/3600 MHz boost: enabled Core speeds (MHz):
1: 1397 2: 1396 3: 1951 4: 1895
Graphics:
Device-1: NVIDIA GK106 [GeForce GTX 660] vendor: ASUSTeK driver: nouveau
v: kernel bus ID: 01:00.0 chip ID: 10de:11c0
Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: NVE6 v: 4.3 Mesa 19.0.8 direct render: Yes
Audio:
Device-1: AMD FCH Azalia vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus ID: 00:14.2 chip ID: 1022:780d
Device-2: NVIDIA GK106 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 01:00.1 chip ID: 10de:0e0b
Sound Server: ALSA v: k5.0.0-32-generic
Network:
Device-1: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k
v: kernel port: e000 bus ID: 02:00.0 chip ID: 168c:002e
IF: wlp2s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: down mac: <filter>
Drives:
Local Storage: total: 3.06 TiB used: 7.37 GiB (0.2%)
ID-1: /dev/sda vendor: SanDisk model: SDSSDP128G size: 117.38 GiB
speed: 6.0 Gb/s serial: <filter> scheme: MBR
ID-2: /dev/sdb vendor: Kingston model: SV300S37A240G size: 223.57 GiB
speed: 6.0 Gb/s serial: <filter> rev: UA scheme: MBR
ID-3: /dev/sdc vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB
speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC44 scheme: GPT
ID-4: /dev/sdd vendor: Seagate model: ST2000DM001-1CH164 size: 1.82 TiB
speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC24 scheme: GPT
Partition:
ID-1: / size: 29.21 GiB used: 7.28 GiB (24.9%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 71.00 GiB used: 84.2 MiB (0.1%) fs: ext4 dev: /dev/sda7
ID-3: swap-1 size: 14.93 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors:
System Temperatures: cpu: 21.0 C mobo: N/A gpu: nouveau temp: 31 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 1050
Repos:
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
Processes: 213 Uptime: 1m Memory: 31.43 GiB used: 691.3 MiB (2.1%)
Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Shell: bash
v: 4.4.20 running in: gnome-terminal inxi: 3.0.32
Last edited by slvstr3 on Sun Feb 16, 2020 4:27 am, edited 2 times in total.

deepakdeshp
Level 16
Level 16
Posts: 6876
Joined: Sun Aug 09, 2015 10:00 am

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by deepakdeshp »

My a8 and 7410 and 8 gb works very well. I don't think hardware specs is the problem in your case. Does Cinnamon live USB work? If not what about Mate live USB?
Use memtest in grub to test memory. And test disk with
https://googleweblight.com/i?u=https:// ... s&hl=en-IN
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.3 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

ajgreeny
Level 5
Level 5
Posts: 532
Joined: Mon Nov 19, 2007 3:27 pm

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by ajgreeny »

I may have missed it in your spec but what graphics driver do you use, and do you use the radeon or nvidia graphics?

slvstr3
Level 1
Level 1
Posts: 5
Joined: Sat Feb 15, 2020 7:20 am

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by slvstr3 »

ajgreeny wrote:
Sat Feb 15, 2020 8:01 am
I may have missed it in your spec but what graphics driver do you use, and do you use the radeon or nvidia graphics?
Graphics driver is this one: Device-1: NVIDIA GK106 [GeForce GTX 660]

User avatar
Pjotr
Level 21
Level 21
Posts: 14577
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by Pjotr »

Right, try this:

1. Install the latest kernel of the 5.3 series. Should be a regular update in Update Manager. Afterwards, reboot.

2. Launch Driver Manager and install the non-free closed Nvidia driver it recommends to you.
Tip: 10 things to do after installing Linux Mint 19.3 Tricia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

ajgreeny
Level 5
Level 5
Posts: 532
Joined: Mon Nov 19, 2007 3:27 pm

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by ajgreeny »

slvstr3 wrote:
Sat Feb 15, 2020 8:20 am
ajgreeny wrote:
Sat Feb 15, 2020 8:01 am
I may have missed it in your spec but what graphics driver do you use, and do you use the radeon or nvidia graphics?
Graphics driver is this one: Device-1: NVIDIA GK106 [GeForce GTX 660]
That is the card, not the driver; show us the output of lspci -k, which will show drivers.

slvstr3
Level 1
Level 1
Posts: 5
Joined: Sat Feb 15, 2020 7:20 am

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by slvstr3 »

ajgreeny wrote:
Sat Feb 15, 2020 8:29 am
slvstr3 wrote:
Sat Feb 15, 2020 8:20 am
ajgreeny wrote:
Sat Feb 15, 2020 8:01 am
I may have missed it in your spec but what graphics driver do you use, and do you use the radeon or nvidia graphics?
Graphics driver is this one: Device-1: NVIDIA GK106 [GeForce GTX 660]
That is the card, not the driver; show us the output of lspci -k, which will show drivers.
lspci -k gives:

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Complex
Subsystem: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) I/O Memory Management Unit
Subsystem: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) I/O Memory Management Unit
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Port
Kernel driver in use: pcieport
00:03.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Port
Kernel driver in use: pcieport
00:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Root Port
Kernel driver in use: pcieport
00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 03)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH USB XHCI Controller
Kernel driver in use: xhci_hcd
00:10.1 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 03)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH USB XHCI Controller
Kernel driver in use: xhci_hcd
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH SATA Controller [AHCI mode]
Kernel driver in use: ahci
Kernel modules: ahci
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH USB OHCI Controller
Kernel driver in use: ohci-pci
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH USB EHCI Controller
Kernel driver in use: ehci-pci
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH USB OHCI Controller
Kernel driver in use: ohci-pci
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 11)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH USB EHCI Controller
Kernel driver in use: ehci-pci
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 14)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH SMBus Controller
Kernel driver in use: piix4_smbus
Kernel modules: i2c_piix4, sp5100_tco
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH Azalia Controller
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH LPC Bridge
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] FCH PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB OHCI Controller (rev 11)
Subsystem: Micro-Star International Co., Ltd. [MSI] FCH USB OHCI Controller
Kernel driver in use: ohci-pci
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 3
Kernel driver in use: k10temp
Kernel modules: k10temp
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1fh) Processor Function 5
01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)
Subsystem: ASUSTeK Computer Inc. GK106 [GeForce GTX 660]
Kernel driver in use: nouveau
Kernel modules: nvidiafb, nouveau
01:00.1 Audio device: NVIDIA Corporation GK106 HDMI Audio Controller (rev a1)
Subsystem: ASUSTeK Computer Inc. GK106 HDMI Audio Controller
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
02:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
Subsystem: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express)
Kernel driver in use: ath9k
Kernel modules: ath9k
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
Kernel driver in use: r8169
Kernel modules: r8169

ajgreeny
Level 5
Level 5
Posts: 532
Joined: Mon Nov 19, 2007 3:27 pm

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by ajgreeny »

So you are using the OS nouveau driver.
Have a look in the Additional drivers utility to see what is recommended by nvidia for that card; it might be all that's needed.

slvstr3
Level 1
Level 1
Posts: 5
Joined: Sat Feb 15, 2020 7:20 am

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by slvstr3 »

deepakdeshp wrote:
Sat Feb 15, 2020 7:55 am
My a8 and 7410 and 8 gb works very well. I don't think hardware specs is the problem in your case. Does Cinnamon live USB work? If not what about Mate live USB?
Use memtest in grub to test memory. And test disk with
https://googleweblight.com/i?u=https:// ... s&hl=en-IN
Thanks.
  • memtest in grub showed no problems (is it normal for this to take 16 hours for 2 passes?). (also, Win 7 runs without problems)
  • smarttools shows no problem with disks
  • live USBs - will test later (sometimes linux mint works more than an hour before freezing)

slvstr3
Level 1
Level 1
Posts: 5
Joined: Sat Feb 15, 2020 7:20 am

Re: Linux Mint Cinnamon 19.3, 64-bit, fresh install, works fine for 10 min. then freezes - Is my hardware too old (8 yea

Post by slvstr3 »

Pjotr wrote:
Sat Feb 15, 2020 8:23 am
Right, try this:

1. Install the latest kernel of the 5.3 series. Should be a regular update in Update Manager. Afterwards, reboot.

2. Launch Driver Manager and install the non-free closed Nvidia driver it recommends to you.
ajgreeny wrote:
Sat Feb 15, 2020 6:56 pm
So you are using the OS nouveau driver.
Have a look in the Additional drivers utility to see what is recommended by nvidia for that card; it might be all that's needed.
Ok, I opened the driver manager and it indeed showed a different recommended driver than the one installed.
screenshot.png
I chose the one recommended and restarted computer. Now
  • My philips 43" monitor has the right resolution (very nice).
  • No freezes anymore


Thanks a lot!

(I was already thinking about buying a new desktop, but with LM running so smoothly, I can skip that - and so glad I wont have to suffer more Win10)

Post Reply

Return to “Hardware Support”