Dummy output no sound

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

Ubuntu is most likely aware, but their fixes will start with Focal and work their way backwards. Bionic (that Mint is based on) will be last to see a fix, although they may do it all in one shot.

In the terminal enter xed admin:///etc/default/grub and when the file opens find this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Change it so that it looks like this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"
Save the file then run sudo update-grub then reboot and test the sound

Be aware that your line may have more than just "quiet splash", so make the necessary adjustments.
jorgeva
Level 1
Level 1
Posts: 21
Joined: Tue Mar 17, 2020 9:34 pm

Re: Dummy output no sound

Post by jorgeva »

do the underlines have to be included or is that just to show me to enter a space?
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

Included. Good question! :D
jorgeva
Level 1
Level 1
Posts: 21
Joined: Tue Mar 17, 2020 9:34 pm

Re: Dummy output no sound

Post by jorgeva »

Success!!!!

I hear sound!!

I have Speakers Built In Audio, Dummy Sound is gone!

Thank you , thank you, thank you! :D :D :D :D
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

Fantastic! I've already lines up a few referrals to this fix!
jorgeva
Level 1
Level 1
Posts: 21
Joined: Tue Mar 17, 2020 9:34 pm

Re: Dummy output no sound

Post by jorgeva »

I appreciate all the time and patience you had with me.

I really like Cinnamon so far and was dreading having to leave for a different Distro.
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

It's my pleasure! I learned something new myself, so we both win! Thanks for being my guinea pig. :D
gmb43
Level 1
Level 1
Posts: 17
Joined: Sat Dec 01, 2018 12:47 pm

Re: Dummy output no sound

Post by gmb43 »

MrEen, I would like to add my thanks for your patience and persistence in coming up with a solution. Can you just explain the difference between this solution and what I did? I just backed out the update to kernel 5.3.0.42.99, so I'm now using 5.3.0.40.
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

And I have a correction to my earlier statement about Ubuntu ever fixing Bionic. It won't happen. Bionic by default uses the 4.15 kernel, where this issue doesn't exist. They're not backporting the dmic_detect config to 4.15 that causes this on 5.3.0-41 and above, so there nothing to "fix" in that scenario.

This summer will see the release of Mint 20, which will be based on Ubuntu 20.04LTS codename Focal Fossa. Focal should have all the necessary bits and pieces in place to prevent the need to "fix" anything in this regard.

If, for some reason there's still an issue, the fix will be slightly different as the default kernel will be 5.4 where the dmic_detect parameter has already been deprecated. That's when the change to options snd-intel-dspcfg dsp_driver=1 will come into play.

SeanNZ: If you ever return, I believe this command might fix your issue:

Code: Select all

sudo tee /etc/modprobe.d/alsa-fix.conf <<<'options snd-hda-intel dmic_detect=0'
Finish with a reboot.
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

gmb43 wrote:
Wed Mar 18, 2020 9:49 pm
MrEen, I would like to add my thanks for your patience and persistence in coming up with a solution. Can you just explain the difference between this solution and what I did? I just backed out the update to kernel 5.3.0.42.99, so I'm now using 5.3.0.40.
Certainly. As of kernel 5.3.0-41, there a new config (dmic_detect) that forces the use of the new audio driver. The Bionic version of Ubuntu that Mint 19.x is based on doesn't have the support for the new driver. As it uses kernel 4.15, it will never have the support. The fixes (2 different approaches to the achieve the same result) force the use of the old driver instead.

One thing you haven't noticed yet is that your internal microphone doesn't work. That's one of the things the new driver fixes. Come Mint 20 this summer, all should be good.

Here's what gave it away for me. From the dmesg output there was this line:

Code: Select all

[ 4.841313] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, aborting probe
That stopped the "legacy" snd-hda-intel driver from loading. That's the driver most of us have been using for many years. The new sof-audio-pci driver is what everyone will be on eventually, but it's quite a change that needs a number of other updates done as well (firmware, topology and config files) that the Bionic version of Ubuntu will never see.
D5B7
Level 1
Level 1
Posts: 4
Joined: Wed Mar 18, 2020 7:13 am

Re: Dummy output no sound

Post by D5B7 »

Wow, MrEen, super brain you have !
I followed your procedure indicated in the beginning of this post, modifying the grub.

It works perfectly now. Sound is back !
Thank you very much for this help, much appreciated.
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

You're quite welcome D5B7. Although I can't claim to have a super brain! In the act of trying to help others, I had already known this issue was coming. I had trouble getting the syntax correct due to the way the developers tend to talk in the bug reports that I had read. If you read comments #1 and #4 in this bug report it kind of shows what I mean. In #1, he's talking about using the method you used of altering grub, but in #4 that person shows the syntax for the simpler method I showed in my previous post. Figuring out when the #1 method became deprecated was a little tricky, but I'm pretty sure that happens in kernel 5.4 or later.

To put things simply, this brand new issue is fixed by something that is already outdated. When Mint 20 comes out, the #4 post is the correct format if there are still issues getting the sound card detected, but hopefully won't be necessary.
BubbySoup
Level 1
Level 1
Posts: 1
Joined: Sat Mar 21, 2020 9:10 am

Re: Dummy output no sound

Post by BubbySoup »

MrEen wrote:
Wed Mar 18, 2020 10:01 pm
And I have a correction to my earlier statement about Ubuntu ever fixing Bionic. It won't happen. Bionic by default uses the 4.15 kernel, where this issue doesn't exist. They're not backporting the dmic_detect config to 4.15 that causes this on 5.3.0-41 and above, so there nothing to "fix" in that scenario.

This summer will see the release of Mint 20, which will be based on Ubuntu 20.04LTS codename Focal Fossa. Focal should have all the necessary bits and pieces in place to prevent the need to "fix" anything in this regard.

If, for some reason there's still an issue, the fix will be slightly different as the default kernel will be 5.4 where the dmic_detect parameter has already been deprecated. That's when the change to options snd-intel-dspcfg dsp_driver=1 will come into play.

SeanNZ: If you ever return, I believe this command might fix your issue:

Code: Select all

sudo tee /etc/modprobe.d/alsa-fix.conf <<<'options snd-hda-intel dmic_detect=0'
Finish with a reboot.
Just registered here to say big thank you - this fixed my issue as well :D
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

I'm glad it helped you, BubbySoup. :D
User avatar
GratePotato
Level 1
Level 1
Posts: 4
Joined: Tue Mar 24, 2020 12:47 am

Re: Dummy output no sound

Post by GratePotato »

Wow, I was having issues also with Suspend, I don't know why, it was freezing my pc when I was suspending my laptop, also kernel 5.3.0-42-generic,
applied the grub trick, both sound is back and suspend is gone. wow you guys rock
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

Hi GratePotato, and welcome to the forum.

I'm glad that worked for you but I must say I'm quite surprised it also fixed a suspend issue! I might need to remember that to see if helps some others.

Thanks for posting! :D
User avatar
meleneemil
Level 1
Level 1
Posts: 7
Joined: Fri Mar 27, 2020 6:19 am
Location: Geneva

Re: Dummy output no sound

Post by meleneemil »

MrEen wrote:
Wed Mar 18, 2020 4:38 pm
Ubuntu is most likely aware, but their fixes will start with Focal and work their way backwards. Bionic (that Mint is based on) will be last to see a fix, although they may do it all in one shot.

In the terminal enter xed admin:///etc/default/grub and when the file opens find this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Change it so that it looks like this:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash snd_hda_intel.dmic_detect=0"
Save the file then run sudo update-grub then reboot and test the sound

Be aware that your line may have more than just "quiet splash", so make the necessary adjustments.
This worked for me perfectly as well, after identifying the Kernel update as the issue.
Machine is X1 Carbon 7th, clean Linux Mint 19.3.

thanks for the support!
X1C7 - 19.3
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

You're welcome meleneemil, and welcome to the forum.

It was another X1 Carbon 7th user I was trying to help a few months ago that is the reason I knew this issue was coming. Nice machine you have there! :D
User avatar
meleneemil
Level 1
Level 1
Posts: 7
Joined: Fri Mar 27, 2020 6:19 am
Location: Geneva

Re: Dummy output no sound

Post by meleneemil »

MrEen wrote:
Wed Mar 18, 2020 10:06 pm
One thing you haven't noticed yet is that your internal microphone doesn't work. That's one of the things the new driver fixes. Come Mint 20 this summer, all should be good.

Here's what gave it away for me. From the dmesg output there was this line:

Code: Select all

[ 4.841313] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, aborting probe
That stopped the "legacy" snd-hda-intel driver from loading. That's the driver most of us have been using for many years. The new sof-audio-pci driver is what everyone will be on eventually, but it's quite a change that needs a number of other updates done as well (firmware, topology and config files) that the Bionic version of Ubuntu will never see.
Back on this now;
1) The Grub argument that was added, simply disables the detection of the mic?
2) Does this mean that with this sound output fix, we won't have the input working until the summer, when the sof-audio-pci rolls out?

(yes, I would prefer to be able to have both output and input working, and reloading alsa modules doesn't help)

thank you for helping me understand

EDIT: Applied the fix on viewtopic.php?p=1709728#p1709728 and now Mic is recognised, but still not working. I tried pavucontrol to make it work, but now the output has the issue of being only 0% or 100%...

EDIT2: Tried also this solution found online, but it breaks sound, and even ends up with a system not able to shutdown.

EDIT3: Tried again only adding the

Code: Select all

options snd-hda-intel model=laptop-amic
On board mic not working, on board sound is only at 0 or 100%, but at least with external devices on the audiojack, they seem to work well, both output and input (tested with arecord and aplay as suggested)
I could pick up that thread for debugging the mic with blacklisting the intel snd.
X1C7 - 19.3
User avatar
MrEen
Level 22
Level 22
Posts: 15253
Joined: Mon Jun 12, 2017 8:39 pm

Re: Dummy output no sound

Post by MrEen »

Simply put, your Internal Mic is a digital array microphone, and it will not work with Mint at all until Mint 20 comes out.

The grub edit simply allows/forces the use of the legacy snd-hda-intel driver so that everything else will work, including input jacks on the computer.

Mint doesn't have the necessary alsa libraries, topology files, firmware files, etc. to run the sof-pci driver yet, which is why people are getting the Dummy Output.

Only bleeding edge distros are already configured for the new driver (Arch based and Fedora based distros) but Ubuntu should be there when 20.04 comes out soon that Mint 20 will be based on.

I have a couple of threads where we went through over 10 pages trying to get the internal mic working before I finally came to understand what was involved, and realized it's just not doable at this time. The newest kernel is ready for it, which is why the grub change was necessary. In the future, snd-hda-intel will be unsupported and the sof-pci driver will be what most people (all?) will be using.
Post Reply

Return to “Newbie Questions”