Emerald Theme Shadow Color Mismatch <Solved via workaround>

Forum rules
Before you post please read how to get help
Post Reply
zaileion
Level 4
Level 4
Posts: 294
Joined: Sun Jan 25, 2015 6:01 pm

Emerald Theme Shadow Color Mismatch <Solved via workaround>

Post by zaileion »

I installed Emerald and use COmpiz. Hands down best ever! IMO...

Anyway, the shadow color when editing themes shows up wrong color. I dunno if its an Emerald thing, an Ubuntu things, or a Ming thing...

It only happens with some custom colours.

I have attached pics. It makes it so much easier to explain...

Notice the purple colour check in the blue circle... That is the colour the window shadow should be... But... you will notice the blue circled shadows are red...

Any suggestions?

Well... I was going to upload a picture but aparently an 800Kb file is too large and scaling to down any further would render it useless so here is a link to the pic on Google Drive.

https://drive.google.com/file/d/1ee6FlV ... sp=sharing
Last edited by zaileion on Tue Jun 16, 2020 7:41 am, edited 1 time in total.
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Emerald Theme Shadow Color Mismatch

Post by gm10 »

You say it's only with specific colours but you didn't specify which ones. I tried with a general purple and it works just fine, so it's hard to comment:

Image

This is with Compiz Reloaded (rather than Ubuntu's Compiz fork) and Emerald compiled from source, frame engine is vrunner. If you want, attach your theme and I'll give it a try on my system.
zaileion
Level 4
Level 4
Posts: 294
Joined: Sun Jan 25, 2015 6:01 pm

Re: Emerald Theme Shadow Color Mismatch

Post by zaileion »

So this color is red #AB00FF but it's supposed to be purple... Any color in this realm comes thru red tho. in fact most of the custom colors come through wrong. The default colors come through fine, its the custom colors that are wrong. it seems the color codes are displaying ncorrectly.
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Emerald Theme Shadow Color Mismatch

Post by gm10 »

zaileion wrote:
Wed Feb 12, 2020 2:32 pm
So this color is red #AB00FF but it's supposed to be purple... Any color in this realm comes thru red tho. in fact most of the custom colors come through wrong. The default colors come through fine, its the custom colors that are wrong. it seems the color codes are displaying ncorrectly.
Can confirm. Haven't looked at emerald's code but seems like an integer overflow with the FF colour code. If you use FE instead it seems to work correctly.
zaileion
Level 4
Level 4
Posts: 294
Joined: Sun Jan 25, 2015 6:01 pm

Re: Emerald Theme Shadow Color Mismatch

Post by zaileion »

gm10 wrote:
Thu Feb 13, 2020 10:00 am
zaileion wrote:
Wed Feb 12, 2020 2:32 pm
So this color is red #AB00FF but it's supposed to be purple... Any color in this realm comes thru red tho. in fact most of the custom colors come through wrong. The default colors come through fine, its the custom colors that are wrong. it seems the color codes are displaying ncorrectly.
Can confirm. Haven't looked at emerald's code but seems like an integer overflow with the FF colour code. If you use FE instead it seems to work correctly.
Hey that worked! I just put FE at the end of the color code and it worked! Awesome! Thank you!
Post Reply

Return to “Compiz, Conky, Docks, & Widgets”