Evolution & Claws email - error message

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
wpshooter
Level 6
Level 6
Posts: 1070
Joined: Sun May 22, 2011 8:06 am

Evolution & Claws email - error message

Post by wpshooter »

Does anyone know the cause of this error message being generated when I try to receive emails from within Evolution ?

Error performing TLS handshake: Internal error in memory allocation.

The SEND function works fine.

I have checked the Evolution configuration settings, port, etc., etc. and they are all the same as they have always been.

Both receive and send function were working fine this morning, now for the past 3 to 4 hours can not receive anything.

Have attached a screenshot of the error.

Have contacted AOL/Verizon and they have been ZERO help in resolving this. I suspect that this error is being caused by something that they have changed on their mail server. But in case I am wrong, is there any way to report this problem to the developers of Evolution ?

Thanks.
Attachments
Screenshot - error on receiving emails.png
Mint 20 mate 64 bit.
SERVICE > competition
geoffreycompnovice
Level 1
Level 1
Posts: 5
Joined: Thu Apr 30, 2020 9:49 am

Re: Evolution email - error message

Post by geoffreycompnovice »

I am hoping someone can help. I know very little about how Linux Mint works, but I have the same problem with Evolution. It started last night and I am assuming that it has something to do with updates shown in attached photo. I am unable to retrieve email from active accounts and get the error message stated in this thread. For security purposes, I do not have all passwords saved in login keyring, so for two accounts I must enter password manually when opening Evolution for first time in a given session. The option to enter the password box no longer appears before I get the error message for those two accounts. The two accounts with saved passwords also give the error message.

As stated, I feel it must have something to do with the updates made on 4/29/20 as prior to the updates it worked normally. I wonder if there is some way to remove those updates to fix the problem, but I have no idea how to go about it.

If many people are having this problem, perhaps a new update will appear to fix the problem???

Any advice will be appreciated!
20.04.29 Updates.jpg
wpshooter
Level 6
Level 6
Posts: 1070
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

geoffreycompnovice:

I private messaged & emailed you regarding this issue.

Thanks.
Mint 20 mate 64 bit.
SERVICE > competition
LinuxStuff
Level 1
Level 1
Posts: 8
Joined: Thu Apr 30, 2020 1:42 pm

Re: Evolution email - error message

Post by LinuxStuff »

I'm having the same problem with Evolution. I believe this has to do with the certs, in Linux keys. Let me know if you find any answers. I haven't run any updates and I think cert. at the ISP may have expired or at least the certs in Linux Seahorse are outdated. Not sure how to update them. I forced the keys to be retrieved again and that didn't work. Gmail works no problem. ATT and Yahoo mail have problems. Hope this helps solve this. Let me know if you need more info...
donnstewart
Level 1
Level 1
Posts: 5
Joined: Thu Apr 30, 2020 2:41 pm

Re: Evolution email - error message

Post by donnstewart »

Same problem here. Just started today. It is specific to Evolution, and my Verizon account. I suspect Verizon. By the way, my linux flavor is Ubuntu, not Mint, but when I googled this error this forum thread seemed most relevant. I cannot view my verizon mail certificates in Evolution/Edit/Preferences/Certificates, but the certificates for my other mail I can view.
wpshooter
Level 6
Level 6
Posts: 1070
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

donnstewart wrote:
Thu Apr 30, 2020 2:47 pm
Same problem here. Just started today. It is specific to Evolution, and my Verizon account. I suspect Verizon. By the way, my linux flavor is Ubuntu, not Mint, but when I googled this error this forum thread seemed most relevant. I cannot view my verizon mail certificates in Evolution/Edit/Preferences/Certificates, but the certificates for my other mail I can view.
I have my deep suspicions that you are correct in this being a certificate problem. Sounds sort of like the certificate that AOL has for/from Evolution has expired and then nobody at either AOL or Evolution are smart enough to realize this and so far I have found it all but impossible to get either one of them to get in touch with the other. Seems like they think all of this is going to happen automatically !!!

I notice that when I go into the Seahorse / password thingy, that I have a listing for the sending function but if memory serves me correctly, there is also supposed to be a listing for the receiving function and since this problem started there is now no receive listing present. Believe that is because of an expired certificate. I just spent 1/2 hour talking to a front line person at AOL about this all to no avail. Good luck to us.
Mint 20 mate 64 bit.
SERVICE > competition
Galaxie
Level 1
Level 1
Posts: 3
Joined: Thu Apr 30, 2020 5:06 pm

Re: Evolution email - error message

Post by Galaxie »

Same problem with AT&T. When I click Send/Receive I get "Could not connect to inbound.att.net: Connection timed out". I can send mail, just can't receive. I hope Evolution can get this figured out soon.
wpshooter
Level 6
Level 6
Posts: 1070
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

Galaxie wrote:
Thu Apr 30, 2020 5:12 pm
Same problem with AT&T. When I click Send/Receive I get "Could not connect to inbound.att.net: Connection timed out". I can send mail, just can't receive. I hope Evolution can get this figured out soon.
How do we even know that they are aware of it ? It is practically impossible to get in touch with the people that write this and other Linux based software !!!
Mint 20 mate 64 bit.
SERVICE > competition
User avatar
Amii_Leigh
Level 5
Level 5
Posts: 700
Joined: Fri Mar 25, 2016 10:58 pm
Location: Somewhere in the middle of nowhere, Missouri

Evolution email memory issue

Post by Amii_Leigh »

Since the last kernel update, I've been getting this message every time I check my email, unless I restart my computer: Error performing TLS handshake: Internal error in memory allocation.
My current system:

Code: Select all

inxi -Fxz
System:    Host: Basically Kernel: 4.15.0-99-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Hewlett-Packard product: HP Compaq 8200 Elite CMT PC
           Mobo: Hewlett-Packard model: 1494
           Bios: Hewlett-Packard v: J01 v02.15 date: 11/10/2011
CPU:       Quad core Intel Core i5-2400 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 24743
           clock speeds: max: 3400 MHz 1: 2662 MHz 2: 2789 MHz 3: 2658 MHz
           4: 2696 MHz
Graphics:  Card: NVIDIA GP107 [GeForce GTX 1050] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 1050/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GP107GL High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-3 Creative Labs EMU10k1 [Sound Blaster Live! Series]
           driver: snd_emu10k1 port: d000 bus-ID: 06:01.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-99-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection (Lewisville)
           driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eno1 state: down mac: <filter>
           Card-2: Ralink RT5370 Wireless Adapter
           driver: rt2800usb v: 2.3.0 usb-ID: 001-004
           IF: wlx000ce7014af0 state: N/A mac: N/A
Drives:    HDD Total Size: 1820.4GB (10.6% used)
           ID-1: /dev/sda model: ST3500418AS size: 500.1GB
           ID-2: /dev/sdb model: Hitachi_HDS72105 size: 500.1GB
           ID-3: /dev/sdc model: ST3500312CS size: 500.1GB
           ID-4: USB /dev/sdd model: Storage_Device size: 320.1GB
Partition: ID-1: / size: 451G used: 130G (31%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 8.47GB used: 0.14GB (2%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 45.0C mobo: N/A gpu: 0.0:40C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 252 Uptime: 16:16 Memory: 4509.0/7935.2MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
amii@Basically ~ $ 
If anyone has any constructive ideas on how to fix this error would be appreciated. Since I cannot retrieve my email, but I can get my email with my browser just fine. The point is, I'd rather use my email program to do that.
Last edited by xenopeek on Fri May 01, 2020 6:17 am, edited 2 times in total.
Reason: looks to be same error in different email client; merged here to find common cause
नमस्ते = Namaste
I honor the place in you in which the entire universe dwells.
I honor the place in you in which is of love, of truth, of light, and of peace.
When you are in that place in you, and I am in that place in me, we are one.
User avatar
AndyMH
Level 12
Level 12
Posts: 4229
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Evolution email memory issue

Post by AndyMH »

Seems to be dependent on your email service provider. I'm not having problems (do have problems from time to time with google calendar which appear and then go away). You could try timeshifting back to the previous kernel, or boot to the earlier kernel but suspect it won't fix the problem.

Note - see you are running LM18.3. Evolution was one of the primary reasons I upgraded to LM19.x - for a later less buggy version. Think LM18.3 is running evolution 3.18, LM19 is 3.28.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
xenopeek
Level 24
Level 24
Posts: 24769
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

I can't find any posts with this exact error message elsewhere either. I did find something that kinda sounds similar: https://www.mail-archive.com/debian-bug ... 35889.html. Suggestion is to try starting Evolution from the terminal with this command:
export G_TLS_GNUTLS_PRIORITY="NORMAL:%COMPAT:+VERS-TLS1.0" ; evolution

I don't know how this interacts with your current Evolution install but you could also install the latest version of Evolution from Flathub: https://flathub.org/apps/details/org.gnome.Evolution. IIRC Linux Mint 18.3 has Flatpak support so the commands noted there to install it should work.
Image
donnstewart
Level 1
Level 1
Posts: 5
Joined: Thu Apr 30, 2020 2:41 pm

Re: Evolution email - error message

Post by donnstewart »

Note - see you are running LM18.3. Evolution was one of the primary reasons I upgraded to LM19.x - for a later less buggy version. Think LM18.3 is running evolution 3.18, LM19 is 3.28.
I am running Evolution 3.28.5 (in Ubuntu) but I still get the error "Error performing TLS handshake: Internal error in memory allocation". But this only with my Verizon/AOL account. I have another POP account that works fine using TLS on a dedicated port. So it is something specific between Evolution and Verizon/AOL in my case. By the way, I can send email through my Verizon account, using their smtp server, with TLS on a dedicated port. It is only the receiving connection that fails.
User avatar
Amii_Leigh
Level 5
Level 5
Posts: 700
Joined: Fri Mar 25, 2016 10:58 pm
Location: Somewhere in the middle of nowhere, Missouri

Re: Evolution email - error message

Post by Amii_Leigh »

Do I have to uninstall the version of Evolution I have now? Or can I install over it?
नमस्ते = Namaste
I honor the place in you in which the entire universe dwells.
I honor the place in you in which is of love, of truth, of light, and of peace.
When you are in that place in you, and I am in that place in me, we are one.
wpshooter
Level 6
Level 6
Posts: 1070
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

what you eventually could do is :
at first make a " reserve copy " of your evolution data !
reinstall Evolution :
after you desactivated all the evolution related packages in Synaptic ... reboot ... reinstall via programmanager

or ... do a double check with Mozilla Thunderbird ?

I did all of the above, it did not help/change anything, the problem was still there after
re-installing Evolution.

Thunderbird, works fine. No problem there, other than the fact that I just don't like thunderbird.

Thanks.
Last edited by wpshooter on Fri May 01, 2020 8:52 am, edited 1 time in total.
Mint 20 mate 64 bit.
SERVICE > competition
User avatar
xenopeek
Level 24
Level 24
Posts: 24769
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

donnstewart wrote:
Fri May 01, 2020 8:00 am
I am running Evolution 3.28.5 (in Ubuntu) but I still get the error "Error performing TLS handshake: Internal error in memory allocation". But this only with my Verizon/AOL account. I have another POP account that works fine using TLS on a dedicated port. So it is something specific between Evolution and Verizon/AOL in my case.
Does starting Evolution from terminal with this command help or make no difference?
export G_TLS_GNUTLS_PRIORITY="NORMAL:%COMPAT:+VERS-TLS1.0" ; evolution
Image
wpshooter
Level 6
Level 6
Posts: 1070
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

xenopeek wrote:
Fri May 01, 2020 8:29 am
donnstewart wrote:
Fri May 01, 2020 8:00 am
I am running Evolution 3.28.5 (in Ubuntu) but I still get the error "Error performing TLS handshake: Internal error in memory allocation". But this only with my Verizon/AOL account. I have another POP account that works fine using TLS on a dedicated port. So it is something specific between Evolution and Verizon/AOL in my case.
Does starting Evolution from terminal with this command help or make no difference?
export G_TLS_GNUTLS_PRIORITY="NORMAL:%COMPAT:+VERS-TLS1.0" ; evolution
Give me a second and I will try it. Thanks.
Mint 20 mate 64 bit.
SERVICE > competition
wpshooter
Level 6
Level 6
Posts: 1070
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

Tried that command, after opening the receive email function generates the exact same error message.

Any other suggestions ? I still think that this is something that needs to be revolved by getting the
developers of Evolution to talk directly to the technical people (not just some front line telephone person)
at AOL. So far my efforts to get that to happen have been met with a constant response of we can not
do that.
Mint 20 mate 64 bit.
SERVICE > competition
User avatar
xenopeek
Level 24
Level 24
Posts: 24769
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Evolution email - error message

Post by xenopeek »

wpshooter wrote:
Fri May 01, 2020 8:59 am
Any other suggestions ?
Did you try the flatpak version?
Image
wpshooter
Level 6
Level 6
Posts: 1070
Joined: Sun May 22, 2011 8:06 am

Re: Evolution email - error message

Post by wpshooter »

xenopeek wrote:
Fri May 01, 2020 9:07 am
wpshooter wrote:
Fri May 01, 2020 8:59 am
Any other suggestions ?
Did you try the flatpak version?
I have heard of flatpak but that is about it.

How would I do that ?

Thanks.
Mint 20 mate 64 bit.
SERVICE > competition
User avatar
Amii_Leigh
Level 5
Level 5
Posts: 700
Joined: Fri Mar 25, 2016 10:58 pm
Location: Somewhere in the middle of nowhere, Missouri

Re: Evolution email - error message

Post by Amii_Leigh »

I did try using the export G_TLS_GNUTLS_PRIORITY="NORMAL:%COMPAT:+VERS-TLS1.0" ; evolution command, and it worked once.

I'm getting error messages:

Code: Select all

(evolution:21783): Gtk-WARNING **: Failed to register client: GDBus.Error:org.gnome.SessionManager.AlreadyRegistered: Unable to register client

(evolution:21783): e-data-server-WARNING **: e_module_load_all_in_directory: Error opening directory '/usr/lib/evolution-data-server/credential-modules': No such file or directory

(evolution:21783): camel-WARNING **: Failed to initialize NSS SQL database in sql:/etc/pki/nssdb: NSS error -8126
नमस्ते = Namaste
I honor the place in you in which the entire universe dwells.
I honor the place in you in which is of love, of truth, of light, and of peace.
When you are in that place in you, and I am in that place in me, we are one.
Post Reply

Return to “Software & Applications”