Unable to 'Open as Administrator' in Caja (installed on Cinnamon) SOLVED

Forum rules
Before you post please read how to get help
Post Reply
norm.h
Level 5
Level 5
Posts: 601
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Unable to 'Open as Administrator' in Caja (installed on Cinnamon) SOLVED

Post by norm.h »

Trying to change an /etc file title, I was advised to right-click and 'Open as Administrator', but that option is not available.
I overcame the issue by writing a new file with the correct title, but is there a way to put the 'Open as Administrator' option into Caja that I installed on Linux Mint 19.3 Cinnamon edition?

I came across this https://forum.manjaro.org/t/mate-caja-h ... tion/55070 which doesn't work here, but does in viewtopic.php?p=1765559#p1765559 which basically says that the option is removed from Caja, although it is 18 months old.
Last edited by norm.h on Fri Feb 21, 2020 11:05 am, edited 2 times in total.
User avatar
xenopeek
Level 24
Level 24
Posts: 24844
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to 'Open as Administrator' in Caja.

Post by xenopeek »

What did you right-click? You should right-click an empty spot inside the directory. You can also find the Open as Administrator action in Caja's File menu (the leftmost menu in its menu bar).

If you still don't see it, please share your Linux Mint version.

And be sure of what you're doing! You should not normally ever have to change the name of file in system directories.
Image
User avatar
JOPETA
Level 16
Level 16
Posts: 6999
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Unable to 'Open as Administrator' in Caja.

Post by JOPETA »

I'm not a good reference because I don't have an untouched Mate desktop in both my LM 18 and LM 19 .1 as they are multi-desktop, but observe the same in LM 18. This option wont be shown in r-click menu unless you select or point to something (folder or file) in LM 18 (caja 1.14.2) neither the option in Archive/File>..,even if you select something. I don't mind about.

LM 19.1 with mate/caja 1.20 does not have this problem in my case.

(Edited)
Last edited by JOPETA on Sat Feb 22, 2020 2:47 pm, edited 6 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
User avatar
Schultz
Level 7
Level 7
Posts: 1993
Joined: Thu Feb 25, 2016 8:57 pm

Re: Unable to 'Open as Administrator' in Caja.

Post by Schultz »

xenopeek wrote:
What did you right-click? You should right-click an empty spot inside the directory.
I don't get any option right clicking an empty spot. In Mate you need to right click on the file / folder.

EDIT
I'm on Mate 1.16.2. Maybe the empty spot way works in newer versions of Mate?
User avatar
all41
Level 16
Level 16
Posts: 6344
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Unable to 'Open as Administrator' in Caja.

Post by all41 »

Open as administrator in Caja is a function of Pluma file editor, now replaced by xed.
You can add Pluma as an additional editor and regain the 'Edit as Administrator' context in the right-click menu

Code: Select all

apt install pluma
or do it from Synaptic or Software Manager
For me it is a must have
Light travels faster than sound.
That's why some people appear smart until you hear what they are saying.
User avatar
xenopeek
Level 24
Level 24
Posts: 24844
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to 'Open as Administrator' in Caja.

Post by xenopeek »

OP wants to rename a file in /etc, not edit it. Open as Administrator is an action on the directory itself, to open Caja root window on the current directory.

I don't have old versions here but I think this option has always been there:
Image
Image
User avatar
leadwtZ
Level 3
Level 3
Posts: 133
Joined: Fri Aug 29, 2014 1:42 pm
Location: Universe

Re: Unable to 'Open as Administrator' in Caja.

Post by leadwtZ »

Just passing thru with nothing better to do!

I have Mate 1.22.2 so Caja is 1.22.2-2 tricia. (LM 19.3)

I get 'Open as Administrator' under File as xenopeek has shown & by clicking an empty space & by clicking on a folder so perhaps your old version is just not up to it?

'xed' is installed as is 'caja-admin' which seems to provide the 'administrator' options. More than saying that will see me drowning in the deep waters of coding. :D

i use a stand alone file manager myself (Double Commander) and never touch Caja.

Farewell.
Celeron CPU G1610@2.60GHz x 2
GeForce 8400 GS/PCle/SSE2
Linux MInt 19.3 - Mate 1.22.2
Reg. Linux user: 467766 Claws-Mail & Pale Moon user.
norm.h
Level 5
Level 5
Posts: 601
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Unable to 'Open as Administrator' in Caja.

Post by norm.h »

xenopeek wrote:
Thu Feb 20, 2020 4:36 pm
What did you right-click? You should right-click an empty spot inside the directory. You can also find the Open as Administrator action in Caja's File menu (the leftmost menu in its menu bar).
If you still don't see it, please share your Linux Mint version.
This is really weird..............
I ran Nemo from the CLI, and got the 'Open as Administrator' option.
As I said in the OP, I had written another file with the correct title yesterday, so I was able to just delete the one with the bad title.

Mint version 19.3
I don't know if this is relevant, but I installed 19.3 Cinnamon from a Magazine Cover DVD, and changed the DE to Mate.

From Synaptic....

Caja is 1.22.2-2+tricia
Mate desktop is 1.22.2-1+tricia

I've tried all the instructions you good folk have suggested, but I still don't get any option anywhere to 'Open as Administrator'.
I was using gedit, so removed it and installed xed, which didn't work, so removed that and installed pluma, which doesn't work either.
User avatar
xenopeek
Level 24
Level 24
Posts: 24844
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to 'Open as Administrator' in Caja (installed on Cinnamon)

Post by xenopeek »

Rather pertinent information I'd say :) Not that I have a solution for this but it would have been helpful if from the start you'd made clear you're not running Linux Mint MATE but Linux Mint Cinnamon with MATE cobbled on to it.

Hopefully somebody else can suggest what package, file or configuration would need to be added to get this functionality.
Image
norm.h
Level 5
Level 5
Posts: 601
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Unable to 'Open as Administrator' in Caja (installed on Cinnamon)

Post by norm.h »

Yeah, my bad, sorry! ........... :oops:

At least I know that if I ever have to do such a thing again, I can open Nemo to do it..
I see that the topic title and my OP have been amended accordingly - so thanks for that :D
User avatar
Schultz
Level 7
Level 7
Posts: 1993
Joined: Thu Feb 25, 2016 8:57 pm

Re: Unable to 'Open as Administrator' in Caja (installed on Cinnamon)

Post by Schultz »

Okay, this explains it. Open Synaptic and do a search for "caja." The following below is what I have installed. Install whatever you're missing from the list below (you can/should probably ignore caja-wallpaper) and I'd bet "Open as administrator" will show up (maybe after a reboot). Also, a lot/some people have ran into problems having two desktops installed, just an FYI.

caja
caja-common
caja-extensions-common
caja-gksu
caja-open-terminal
caja-wallpaper
libcaja-extension1
User avatar
xenopeek
Level 24
Level 24
Posts: 24844
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Unable to 'Open as Administrator' in Caja (installed on Cinnamon)

Post by xenopeek »

Schultz wrote:
Fri Feb 21, 2020 10:01 am
caja-gksu
That's probably it! Thanks Schultz.
Image
norm.h
Level 5
Level 5
Posts: 601
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Unable to 'Open as Administrator' in Caja (installed on Cinnamon)

Post by norm.h »

Thanks for your help, but this is interesting.................

caja-gksu is the one item that's not listed - see screenshot, but.....
I installed the ones that were missing [caja-extensions-common and caja-open-terminal] and hey presto! I can 'Open as Administrator'
Screenshot at 2020-02-21 14-42-09.png
Will mark as solved, but as an aside..................
Schultz wrote:
Fri Feb 21, 2020 10:01 am
....... Also, a lot/some people have ran into problems having two desktops installed, just an FYI....
I uninstalled the Cinnamon Desktop after setting up Mate [see screenshots].
Is this sufficient to avoid problems?
Screenshot at 2020-02-21 14-23-37.png
Attachments
Screenshot at 2020-02-21 14-23-07.png
User avatar
Schultz
Level 7
Level 7
Posts: 1993
Joined: Thu Feb 25, 2016 8:57 pm

Re: Unable to 'Open as Administrator' in Caja (installed on Cinnamon) SOLVED

Post by Schultz »

norm.h wrote:
I uninstalled the Cinnamon Desktop after setting up Mate [see screenshots].
Is this sufficient to avoid problems?
I wouldn't have advised that, since Cinnamon was the original install. Only time will tell.
norm.h
Level 5
Level 5
Posts: 601
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: Unable to 'Open as Administrator' in Caja (installed on Cinnamon) SOLVED

Post by norm.h »

I have bitten the bullet and burned a DVD for Mint 19.3 Mate, and installed.
Of course, 'Open As Administrator' is there!
Should have done that in the first place instead of faffing around with Cover DVDs. :oops:

We, or rather I, live and learn.
Celcius1
Level 1
Level 1
Posts: 7
Joined: Mon May 18, 2020 8:30 am

Re: Unable to 'Open as Administrator' in Caja (installed on Cinnamon) SOLVED

Post by Celcius1 »

I think this problem is being caused by the fact that the gksu facility has been removed from the Ubuntu repository found this web article referring to the removal https://www.maketecheasier.com/gksu-alt ... tu-bionic/ If its available after a fresh install, then the Mint maintainers must be adding it manually, but if your like me and done an upgrade from Mint 18.3 the upgrade is based on the repositories, and therefore will end up being removed, to be honest those maintaining the MATE desktop need to come up with a replacement FAST! as not everyone is capable of doing a fresh install to maintain functionality, they have to do an upgrade.

So until they update the functions in the MATE desktop to not use gksu those that do an upgrade will loose this ability.
Post Reply

Return to “MATE”