Linux Mint 19.3 se cuelga (Kernel 5.3.0-53)

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
cagimenez
Level 1
Level 1
Posts: 3
Joined: Fri May 29, 2020 10:59 pm

Linux Mint 19.3 se cuelga (Kernel 5.3.0-53)

Post by cagimenez »

Buenas noches, gracias por leer mi consulta, espero puedan darme una mano.

Ante la respuesta de JOPETA, me surgió una duda, a que se refiere con "equipos de cierta edad" y los problemas con el kernel 5.3? Les cuento que tengo cuelgues también de mi Linux Mint Tricia y no entiendo por qué pasa esto. Con la versión Mint anterior esto no me pasaba, instalé esta versión nueva y no responde bien.
Espero puedan ayudarme o al menos orientarme.
Gracias, saludos

Les comparto la info de mi sistema:

Code: Select all

System:    Host: joakux Kernel: 5.3.0-53-generic x86_64 bits: 64 compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 
           Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop Mobo: Intel model: DH61BE v: AAG14062-206 serial: <filter> UEFI: Intel 
           v: BEH6110H.86A.0120.2013.1112.1412 date: 11/12/2013 
CPU:       Topology: Quad Core model: Intel Core i5-2400 bits: 64 type: MCP arch: Sandy Bridge rev: 7 
           L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24741 
           Speed: 1596 MHz min/max: 1600/3400 MHz Core speeds (MHz): 1: 1596 2: 1596 3: 1596 4: 1596 
Graphics:  Device-1: NVIDIA GT218 [GeForce 210] vendor: Gigabyte driver: nvidia v: 340.108 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 1680x1050~60Hz 
           OpenGL: renderer: GeForce 210/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Device-2: NVIDIA High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.3.0-53-generic 
Network:   Device-1: Intel 82579V Gigabit Network driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0 
           IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.93 TiB used: 1.52 TiB (78.8%) 
           ID-1: /dev/sda vendor: Western Digital model: WD1002FAEX-00Z3A0 size: 931.51 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-00WN4A0 size: 931.51 GiB 
           ID-3: /dev/sdc vendor: Kingston model: SA400S37120G size: 111.79 GiB 
Partition: ID-1: / size: 37.30 GiB used: 13.01 GiB (34.9%) fs: ext4 dev: /dev/sdc5 
           ID-2: /home size: 68.05 GiB used: 11.69 GiB (17.2%) fs: ext4 dev: /dev/sdc7 
           ID-3: swap-1 size: 3.81 GiB used: 768 KiB (0.0%) fs: swap dev: /dev/sdc6 
Sensors:   System Temperatures: cpu: 36.0 C mobo: N/A gpu: nvidia temp: 41 C 
           Fan Speeds (RPM): N/A 
Repos:     No active apt repos in: /etc/apt/sources.list 
           No active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
           Active apt repos in: /etc/apt/sources.list.d/cybermax-dexter-sdl2-backport-bionic.list 
           1: deb http://ppa.launchpad.net/cybermax-dexter/sdl2-backport/ubuntu bionic main
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
           1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/jitsi-stable.list 
           1: deb https://download.jitsi.org stable/
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
           2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ bionic partner
           No active apt repos in: /etc/apt/sources.list.d/plexmediaserver.list 
           Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
           1: deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt repos in: /etc/apt/sources.list.d/spotify.list 
           1: deb http://repository.spotify.com stable non-free
           Active apt repos in: /etc/apt/sources.list.d/stebbins-handbrake-releases-bionic.list 
           1: deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu bionic main
           Active apt repos in: /etc/apt/sources.list.d/teamviewer.list 
           1: deb http://linux.teamviewer.com/deb stable main
Info:      Processes: 223 Uptime: 14h 35m Memory: 7.74 GiB used: 1.49 GiB (19.3%) Init: systemd runlevel: 5 
           Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20 inxi: 3.0.32 
Last edited by JCSenar on Mon Jun 08, 2020 9:06 am, edited 1 time in total.
Reason: Título corregido
User avatar
tomeu
Level 6
Level 6
Posts: 1343
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Linux Mint 19.3 se cuelga

Post by tomeu »

Si antes funcionaba bien y los problemas pueden ser debidos a una actualización reciente, teniendo un PC de 2013, mira de probar cómo funciona volviendo al kernel anterior (el LTS = 4.15).

Del modo explicado aquí
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
JOPETA
Level 16
Level 16
Posts: 6901
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Linux Mint 19.3 se cuelga

Post by JOPETA »

cagimenez wrote:
Fri May 29, 2020 11:06 pm
Ante la respuesta de JOPETA, me surgió una duda, a que se refiere con "equipos de cierta edad" y los problemas con el kernel 5.3? Les cuento que tengo cuelgues también de mi Linux Mint Tricia y no entiendo por qué pasa esto. Con la versión Mint anterior esto no me pasaba, instalé esta versión nueva y no responde bien.
Por alusiones ( :D ), los kernels con soporte a corto plazo tienen como objetivo fundamental incorporar el nuevo hardware desarrollado en el último año y dar soluciones a problemas existentes conocidos con otro hardware que aún no tiene la cobertura adecuada por Linux. Sin embargo desatienden en cierta forma el hardware mas antiguo o carente de problemas con lo que la aparición de regresiones (parches a problemas conocidos) son mas frecuentes que en kernels con soporte a largo plazo.

En concreto el kernel instalado, el 5.3.0-53, tiene muchos problemas (bugs) que aconsejan su desintalación y volver al anterior 5.3.0-51 (si este funcionaba bien claro) como se comenta en este hilo.

El kernel 5.3 distribuido por Ubuntu, en general no sólo no ha logrado resolver los problemas existentes con equipos relativamente nuevos como los Ryzen de AMD además, a deferencia del anterior 5.0, ha creado muchos otros problemas con cierto hardware como gráficas Nvidia e incluso procesadores intel. A poco que busque en los foros como este o los de Ubuntu verás múltiples ejemplos.

Tampoco es la primera vez que LM X.3 sufre estos efectos colaterales de los plazos de Ubuntu. El kernel de corto plazo último (5.3) debería haber mejorado desde que sale con este kernel Ubuntu 19.10 en octubre hasta que lo incorpora al HWE de Ubuntu 18.04.04 en febrero quizás por estar mas pendiente del kernel de la nueva edición (Ubuntu 20.04 con el 5.4) recién sacada del horno y en su política el upgrade&&dist-upgrade es la solución a casi todo.

Si tu equipo es reciente y sobre todo del último último año, por lo comentado, debes probar con los nuevos kernels, pero si tu equipo es de dos años o mas el downgrade al kernel 4.15 con soporte a largo plazo te pondría en el buen camino.

Si tienes un equipo de mas de dos años (en tu caso puede que 9) que vienen funcionando perfectamente no tienes necesidad de cambiar ni de edición ni de kernel si ambos tienen soporte otros 2 o tres años mas. Tampoco va a ser lo mismo instalar la última edición punto (en el caso de LM 19.2 o LM 19.3) cuando sale, que incorporan además de novedades de software mas o menos atractivas un kernel de corto plazo pero testado lo suficiente durante la fase beta , pasados nos meses del lanzamiento .

La experiencia que se tiene con el Live de la edición X.3 a estas alturas de la película puede cambiar en cuestión de días o nada mas instalar con las primeras actualizaciones tras la instalación de LM 19.3 ya que se han superado con creces los seis meses de soporte el kernel de corto plazo (5.0) incorporado a la ISO y el salto al 5.3 es casi obligado por las políticas de actualizaciones aplicadas por defecto.

Para eso se ha incorporado Timeshif, pero en estas ediciones con estas políticas de actualizaciones es un vuelta a empezar ya que no puedes quedarte con un kernel sin soporte. Debes hacer algo más: patada a seguir con un nuevo kernel (el 5.4 sería lo razonable de tener un equipo muy nuevo) o volver al de la edición de Ubuntu en que se basa Mint, el 4.15 de soporte a largo plazo (en el caso de equipos ya maduritos). :roll:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
cagimenez
Level 1
Level 1
Posts: 3
Joined: Fri May 29, 2020 10:59 pm

Re: Linux Mint 19.3 se cuelga

Post by cagimenez »

tomeu wrote:
Sat May 30, 2020 1:27 am
Si antes funcionaba bien y los problemas pueden ser debidos a una actualización reciente, teniendo un PC de 2013, mira de probar cómo funciona volviendo al kernel anterior (el LTS = 4.15).

Del modo explicado aquí
Gracias!!
Seguiré tu consejo, saludos.
cagimenez
Level 1
Level 1
Posts: 3
Joined: Fri May 29, 2020 10:59 pm

Re: Linux Mint 19.3 se cuelga [SOLUCIONADO]

Post by cagimenez »

JOPETA wrote:
Sat May 30, 2020 6:23 am
cagimenez wrote:
Fri May 29, 2020 11:06 pm
Ante la respuesta de JOPETA, me surgió una duda, a que se refiere con "equipos de cierta edad" y los problemas con el kernel 5.3? Les cuento que tengo cuelgues también de mi Linux Mint Tricia y no entiendo por qué pasa esto. Con la versión Mint anterior esto no me pasaba, instalé esta versión nueva y no responde bien.
Por alusiones ( :D ), los kernels con soporte a corto plazo tienen como objetivo fundamental incorporar el nuevo hardware desarrollado en el último año y dar soluciones a problemas existentes conocidos con otro hardware que aún no tiene la cobertura adecuada por Linux. Sin embargo desatienden en cierta forma el hardware mas antiguo o carente de problemas con lo que la aparición de regresiones (parches a problemas conocidos) son mas frecuentes que en kernels con soporte a largo plazo.

En concreto el kernel instalado, el 5.3.0-53, tiene muchos problemas (bugs) que aconsejan su desintalación y volver al anterior 5.3.0-51 (si este funcionaba bien claro) como se comenta en este hilo.

El kernel 5.3 distribuido por Ubuntu, en general no sólo no ha logrado resolver los problemas existentes con equipos relativamente nuevos como los Ryzen de AMD además, a deferencia del anterior 5.0, ha creado muchos otros problemas con cierto hardware como gráficas Nvidia e incluso procesadores intel. A poco que busque en los foros como este o los de Ubuntu verás múltiples ejemplos.

Tampoco es la primera vez que LM X.3 sufre estos efectos colaterales de los plazos de Ubuntu. El kernel de corto plazo último (5.3) debería haber mejorado desde que sale con este kernel Ubuntu 19.10 en octubre hasta que lo incorpora al HWE de Ubuntu 18.04.04 en febrero quizás por estar mas pendiente del kernel de la nueva edición (Ubuntu 20.04 con el 5.4) recién sacada del horno y en su política el upgrade&&dist-upgrade es la solución a casi todo.

Si tu equipo es reciente y sobre todo del último último año, por lo comentado, debes probar con los nuevos kernels, pero si tu equipo es de dos años o mas el downgrade al kernel 4.15 con soporte a largo plazo te pondría en el buen camino.

Si tienes un equipo de mas de dos años (en tu caso puede que 9) que vienen funcionando perfectamente no tienes necesidad de cambiar ni de edición ni de kernel si ambos tienen soporte otros 2 o tres años mas. Tampoco va a ser lo mismo instalar la última edición punto (en el caso de LM 19.2 o LM 19.3) cuando sale, que incorporan además de novedades de software mas o menos atractivas un kernel de corto plazo pero testado lo suficiente durante la fase beta , pasados nos meses del lanzamiento .

La experiencia que se tiene con el Live de la edición X.3 a estas alturas de la película puede cambiar en cuestión de días o nada mas instalar con las primeras actualizaciones tras la instalación de LM 19.3 ya que se han superado con creces los seis meses de soporte el kernel de corto plazo (5.0) incorporado a la ISO y el salto al 5.3 es casi obligado por las políticas de actualizaciones aplicadas por defecto.

Para eso se ha incorporado Timeshif, pero en estas ediciones con estas políticas de actualizaciones es un vuelta a empezar ya que no puedes quedarte con un kernel sin soporte. Debes hacer algo más: patada a seguir con un nuevo kernel (el 5.4 sería lo razonable de tener un equipo muy nuevo) o volver al de la edición de Ubuntu en que se basa Mint, el 4.15 de soporte a largo plazo (en el caso de equipos ya maduritos). :roll:
JOPETA, muchas gracias por tomarte el tiempo de explicarme todo. Volveré al kernel 4.15, será lo mejor.
Saludos
Post Reply

Return to “Español (Spanish)”