Oracle VirtualBox black screen with blinking cursor on boot

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
Netherprovinc3
Level 4
Level 4
Posts: 347
Joined: Mon Feb 04, 2019 9:29 pm

Oracle VirtualBox black screen with blinking cursor on boot

Post by Netherprovinc3 »

Virtualbox 6.0.22 r137980 (Qt5.9.5)
Host OS: Linux Mint Cinnamon 19.1
Guest OS: Linux Mint Mate 19.3

I have been using the guest machine just fine, even a few days ago. However, just now I added the shared folder back (I have turned it on and off regularly). I set it as auto mount, read only, and I did not specify a mount point (I think this is how I have always done it).

Instead of booting, it just stays on a black screen, with a blinking cursor in the upper left.

I am trying to figure out what went wrong. There could have been an update that caused this.
Also, I can't exit (hot key + F1, F2, etc don't do anything, selecting ACPI shutdown from the menu doesn't do anything).

Edit: To get me out of there here is what I did. From the menu, I "paused" and then I chose "close," and "save machine state."

Edit2: per reply 1 (user RIH)
Last edited by Netherprovinc3 on Sun Jun 28, 2020 8:28 pm, edited 2 times in total.
Linux Mint 19.1 Cinnamon unless otherwise noted.
RIH
Level 5
Level 5
Posts: 738
Joined: Sat Aug 22, 2015 3:47 am

Re: Oracle VirtualBox black screen with blinking cursor on boot

Post by RIH »

Netherprovinc3 wrote:
Sun Jun 28, 2020 6:18 pm
and I did not specify a location (I think this is how I have always done it).
I am a little puzzled as to what you mean by this.
I cannot see how you can add a shared folder without specifying exactly where it is..

When confronted, like you, with a completely dead guest I tend to select
Power Off the machine
rather than either of the other two options..
Netherprovinc3
Level 4
Level 4
Posts: 347
Joined: Mon Feb 04, 2019 9:29 pm

Re: Oracle VirtualBox black screen with blinking cursor on boot

Post by Netherprovinc3 »

RIH wrote:
Sun Jun 28, 2020 8:10 pm
Netherprovinc3 wrote:
Sun Jun 28, 2020 6:18 pm
and I did not specify a location (I think this is how I have always done it).
I am a little puzzled as to what you mean by this.
I cannot see how you can add a shared folder without specifying exactly where it is..
I meant that I did not specify a mount point. I'll fix the OP.
RIH wrote:
Sun Jun 28, 2020 8:10 pm
When confronted, like you, with a completely dead guest I tend to select
Power Off the machine
rather than either of the other two options..
ok. that's useful here.
Linux Mint 19.1 Cinnamon unless otherwise noted.
RIH
Level 5
Level 5
Posts: 738
Joined: Sat Aug 22, 2015 3:47 am

Re: Oracle VirtualBox black screen with blinking cursor on boot

Post by RIH »

OK Thanks.
That is the way I would have set up the Shared Folder as well.

I can only suggest that you start up the guest again.
I believe that it will take you back to the blinking cursor.
Now shut down VirtualBox using Power Off the Machine.

Now try a re-boot & see what errors it gives you.. if any!!!
User avatar
Pierre
Level 20
Level 20
Posts: 10719
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Oracle VirtualBox black screen with blinking cursor on boot

Post by Pierre »

the Shared Folder .. should work, if you can set it up properly,
& you don't have to disable it, so regularly, either .. there is no harm, in letting keep running.

did you set up, any Saved State ? your back-up ? that's saved me, on several occasions.
:mrgreen:
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
llr51
Level 1
Level 1
Posts: 34
Joined: Thu Jan 30, 2020 8:28 pm

Re: Oracle VirtualBox black screen with blinking cursor on boot

Post by llr51 »

see if it is a display problem by getting into a console - it takes a few seconds for the console to appear.
right-ctrl+insert+f3 (f2 or f4) if it give you a login prompt then a library or symbolic link is missing.

I had a missing symbolic link on one of my virtual machines that left a black screen on reboot.
Netherprovinc3
Level 4
Level 4
Posts: 347
Joined: Mon Feb 04, 2019 9:29 pm

Re: Oracle VirtualBox black screen with blinking cursor on boot

Post by Netherprovinc3 »

Pierre wrote:
Mon Jun 29, 2020 2:34 am
the Shared Folder .. should work, if you can set it up properly,
& you don't have to disable it, so regularly, either .. there is no harm, in letting keep running.
I used the virtual machine (kept offline) to open files that I don't totally trust. I would (1) move the file to the shared folder; (2) boot VM; (3) move file to the VM (4) unshare the folder; (5) open the file.
Pierre wrote:
Mon Jun 29, 2020 2:34 am
did you set up, any Saved State ? your back-up ? that's saved me, on several occasions.
:mrgreen:
I do have a backup of the VM. But, I would like to review the files on the VM. There might be a few files there that I would like to salvage. Try booting to a live linux CD on the virtual machine to check out the files?
llr51 wrote:
Mon Jun 29, 2020 1:52 pm
see if it is a display problem by getting into a console - it takes a few seconds for the console to appear.
right-ctrl+insert+f3 (f2 or f4) if it give you a login prompt then a library or symbolic link is missing.
Those keys do not have any affect.
Linux Mint 19.1 Cinnamon unless otherwise noted.
Post Reply

Return to “Virtualization”