Qualcomm QCA6174 Dropping connection.

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
marcosamaraljr
Level 1
Level 1
Posts: 8
Joined: Sun Jun 28, 2020 2:03 am

Qualcomm QCA6174 Dropping connection.

Post by marcosamaraljr »

Hello Guys,

I'm facing a issue with my Wi-Fi card QCA6174, which is dropping my connection randomly, but, I noticed that if I try to check my connection speed(speedtest.net/pt), its instantly, So I think this is related some how with the "high use".

But it does not happen when I route internet from my phone

Why? I've searched some theories, and some people think that this is related to Ipv6, and my phone internet does not provide Ipv6. (Just guessing).

I've searched for this problem and it seems to be a firmware problem, but it only happen in linux systems (I didn't test it, but I read a lot about it).
I found some Topics in here regarding similar issues, but I couldn't find an answer that really fixed it.

I'm gonna let some information below that maybe will make things more easy.

Code: Select all

$ uname -a 
 Linux mintPC 5.4.0-39-generic #43~18.04.1-Ubuntu  x86_64 GNU/LINUX 

Code: Select all

~$ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device 9d1a (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-LM (rev 21)
01:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)

Code: Select all

$ dmesg
[ 4113.553447] wlp1s0: deauthenticating from 2a:21:86:95:85:eb by local choice (Reason: 3=DEAUTH_LEAVING)
[ 4113.585230] wlp1s0: authenticate with c8:5d:38:0d:8d:9c
[ 4113.626564] wlp1s0: send auth to c8:5d:38:0d:8d:9c (try 1/3)
[ 4113.627882] wlp1s0: send auth to c8:5d:38:0d:8d:9c (try 2/3)
[ 4113.629153] wlp1s0: send auth to c8:5d:38:0d:8d:9c (try 3/3)
[ 4113.630372] wlp1s0: authentication with c8:5d:38:0d:8d:9c timed out
[ 4118.617158] wlp1s0: authenticate with c8:5d:38:0d:8d:9c
[ 4118.658043] wlp1s0: send auth to c8:5d:38:0d:8d:9c (try 1/3)
[ 4118.660854] wlp1s0: authenticated
[ 4118.665674] wlp1s0: associate with c8:5d:38:0d:8d:9c (try 1/3)
[ 4118.667793] wlp1s0: RX AssocResp from c8:5d:38:0d:8d:9c (capab=0x11 status=0 aid=1)
[ 4118.670421] wlp1s0: associated
[ 4118.670552] ath: EEPROM regdomain: 0x804c
[ 4118.670553] ath: EEPROM indicates we should expect a country code
[ 4118.670554] ath: doing EEPROM country->regdmn map search
[ 4118.670555] ath: country maps to regdmn code: 0x3b
[ 4118.670556] ath: Country alpha2 being used: BR
[ 4118.670557] ath: Regpair used: 0x3b
[ 4118.670558] ath: regdomain 0x804c dynamically updated by country element
[ 4118.690762] wlp1s0: Limiting TX power to 30 (30 - 0) dBm as advertised by c8:5d:38:0d:8d:9c
[ 4122.261390] pcieport 0000:00:1c.0: AER: Corrected error received: 0000:00:1c.0
[ 4122.261415] pcieport 0000:00:1c.0: AER: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
[ 4122.261429] pcieport 0000:00:1c.0: AER:   device [8086:9d14] error status/mask=00001000/00002000
[ 4122.261439] pcieport 0000:00:1c.0: AER:    [12] Timeout 
This last message keeps repeating.

Please let me know if you need more details.

I also want to say that, I already tried to download and replace the firmware from the repository:
https://github.com/kvalo/ath10k-firmwar ... 174/hw3.0/

Thank you in advance!!

Ps: I'm from Brazil, its a little hard for me to explain this stuff in English, I'm sorry if it is confusing.

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

Post results of:

Code: Select all

 lspci -nnk | grep -iA3 net 

Code: Select all

 iwconfig 

marcosamaraljr
Level 1
Level 1
Posts: 8
Joined: Sun Jun 28, 2020 2:03 am

Re: Qualcomm QCA6174 Dropping connection.

Post by marcosamaraljr »

Hi,

Code: Select all

$ lspci -nnk | grep -iA3 net
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection I219-LM [8086:156f] (rev 21)
	Subsystem: Dell Ethernet Connection I219-LM [1028:06de]
	Kernel driver in use: e1000e
	Kernel modules: e1000e
01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
	Subsystem: Dell QCA6174 802.11ac Wireless Network Adapter [1028:0310]
	Kernel driver in use: ath10k_pci
	Kernel modules: ath10k_pci
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)

Code: Select all

$ iwconfig
enp0s31f6  no wireless extensions.

wlp1s0    IEEE 802.11  ESSID:"Marquinhos 5G"  
          Mode:Managed  Frequency:5.66 GHz  Access Point: C8:5D:38:0D:8D:9C   
          Bit Rate=6 Mb/s   Tx-Power=24 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=52/70  Signal level=-58 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:21   Missed beacon:0

lo        no wireless extensions.

virbr0    no wireless extensions.

virbr0-nic  no wireless extensions.


Thanks for helping me!

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

Try turning power management off, #2.1 here:
https://easylinuxtipsproject.blogspot.c ... html#ID2.1

marcosamaraljr
Level 1
Level 1
Posts: 8
Joined: Sun Jun 28, 2020 2:03 am

Re: Qualcomm QCA6174 Dropping connection.

Post by marcosamaraljr »

I did it before, didn't worked.

I did it again, but still facing the same problem :/

I also tried to disable Ipv6, on my laptop and on my router, but still the same.

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

Not sure if it will help, but you can try reloading the driver:

Code: Select all

 sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci 

marcosamaraljr
Level 1
Level 1
Posts: 8
Joined: Sun Jun 28, 2020 2:03 am

Re: Qualcomm QCA6174 Dropping connection.

Post by marcosamaraljr »

Just did it, still dropping :/

Just to clarify, when I mean "drop", I can't ping anyone, neither my router, or google, but I'm still connected to the wifi.

When I get dropped, if I run $ arp command, it wait too long until bring me an answer, sometimes it works, sometimes not.

normal

Code: Select all

$ arp
Address                  HWtype  HWaddress           Flags Mask            Iface
_gateway                 ether   c8:5d:38:0d:8d:9a   C                     wlp1s0
dropped
PS: Sometimes it works but very slowly.

Code: Select all

$ arp
Address                  HWtype  HWaddress           Flags Mask            Iface
_gateway                         (incomplete)                              wlp1s0
Thanks for helping!

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

How old is your machine? Just wondering if it could be a kernel issue. The 4.15 kernel is best for older machines pre 2018.

marcosamaraljr
Level 1
Level 1
Posts: 8
Joined: Sun Jun 28, 2020 2:03 am

Re: Qualcomm QCA6174 Dropping connection.

Post by marcosamaraljr »

Hi,

My machine is a DELL Latitude E5470, so I think is kind of "old". I can try this kernel you told me.

But I have a Question, New Kernels shouldn't have a better performance? I mean, By logic they must solve more issues then the old ones, right?

I'm don't know a lot about kernel, I'm sorry :s

Thank you!

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

The newer kernels are generally for newer hardware. I'm not sure if the 4.15 kernel will solve your problem, but maybe.

marcosamaraljr
Level 1
Level 1
Posts: 8
Joined: Sun Jun 28, 2020 2:03 am

Re: Qualcomm QCA6174 Dropping connection.

Post by marcosamaraljr »

Report:

I installed Kernel 4.15.0-108

I made some tests, but still the same result, :/

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

Just to be sure, what does this say:

Code: Select all

 uname -r 

DisturbedDragon
Level 3
Level 3
Posts: 156
Joined: Mon Oct 29, 2012 6:29 pm
Location: Texas

Re: Qualcomm QCA6174 Dropping connection.

Post by DisturbedDragon »

I have the same wireless controller on a new Lenovo 14w (Mint 19.3 Cinnamon). Using the current 5.4.0-39 kernel is the best it has ever performed but that's not saying much. It's just a bad controller or has bad drivers. No longer drops connection for me but still has a very slow connection. Tried turning off power management and rebuilding driver as well but it's still just bad. Took a micro wifi adapter and plugged into a USB port for now. Only solution I have found unfortunately.

Code: Select all

wlp1s0    IEEE 802.11  ESSID:"DisturbedDragon"  
          Mode:Managed  Frequency:2.422 GHz  Access Point: 84:16:F9:AC:A2:4F   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:42   Missed beacon:0

Code: Select all

01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
	Subsystem: Lenovo QCA6174 802.11ac Wireless Network Adapter [17aa:0827]
	Kernel driver in use: ath10k_pci
	Kernel modules: ath10k_pci
04:00.0 SD Host controller [0805]: O2 Micro, Inc. Device [1217:8620] (rev 01)

Code: Select all

System:
  Host: Mint-Lenovo14w Kernel: 5.4.0-39-generic x86_64 bits: 64 
  compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 wm: muffin dm: LightDM 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 81MQ000JUS v: Lenovo 14w 
  serial: <filter> Chassis: type: 10 v: Lenovo 14w serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0K13476 WIN serial: <filter> 
  UEFI: LENOVO v: ANCN24WW(V1.04) date: 05/07/2019 
Battery:
  ID-1: BAT1 charge: 44.8 Wh condition: 54.0/57.0 Wh (95%) volts: 12.4/11.5 
  model: 0x53 0x4D 0x50 0x32 0x30 0x31 0x PABAS0241231 serial: <filter> 
  status: Discharging 
CPU:
  Topology: Dual Core model: AMD A6-9220C RADEON R5 5 COMPUTE CORES 2C+3G 
  bits: 64 type: MCP arch: Excavator L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 7186 
  Speed: 1311 MHz min/max: 1200/1800 MHz Core speeds (MHz): 1: 1292 2: 1493 
Graphics:
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo 
  driver: amdgpu v: kernel bus ID: 00:01.0 chip ID: 1002:98e4 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD STONEY (DRM 3.35.0 5.4.0-39-generic LLVM 9.0.0) 
  v: 4.5 Mesa 19.2.8 direct render: Yes 
Audio:
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 chip ID: 1002:15b3 
  Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:09.2 chip ID: 1022:157a 
  Sound Server: ALSA v: k5.4.0-39-generic 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel port: 3100 bus ID: 01:00.0 
  chip ID: 168c:003e 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Atheros type: USB driver: btusb bus ID: 1-1.2:3 
  chip ID: 0cf3:e300 
Drives:
  Local Storage: total: 58.24 GiB used: 12.60 GiB (21.6%) 
  ID-1: /dev/mmcblk1 model: DA4064 size: 58.24 GiB serial: <filter> 
Partition:
  ID-1: / size: 11.20 GiB used: 9.84 GiB (87.9%) fs: ext4 
  dev: /dev/mmcblk1p3 
  ID-2: /home size: 45.58 GiB used: 2.75 GiB (6.0%) fs: ext4 
  dev: /dev/mmcblk1p2 
Sensors:
  System Temperatures: cpu: 40.1 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 192 Uptime: 12m Memory: 3.72 GiB used: 1.14 GiB (30.6%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.5.0 alt: 7 Shell: bash 
  v: 4.4.20 running in: gnome-terminal inxi: 3.0.32 
AMD Ryzen 9 3950X 16C/32T | MSI x470 Gaming Pro | 1TB Crucial P1 NVMe | 1TB Samsung 960 Pro NVMe | 32GB DDR4 3200 | Nvidia RTX2080 OC | Linux Mint 20.0 Cinnamon

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

DisturbedDragon,

Did you ever try the 4.15 kernel? Just wondering if that was any better or not.

DisturbedDragon
Level 3
Level 3
Posts: 156
Joined: Mon Oct 29, 2012 6:29 pm
Location: Texas

Re: Qualcomm QCA6174 Dropping connection.

Post by DisturbedDragon »

Either the wifi or touchpad on my device did not work on 4x kernel. Honestly don't remember which it was. You can give it a try though. Won't hurt anything.
AMD Ryzen 9 3950X 16C/32T | MSI x470 Gaming Pro | 1TB Crucial P1 NVMe | 1TB Samsung 960 Pro NVMe | 32GB DDR4 3200 | Nvidia RTX2080 OC | Linux Mint 20.0 Cinnamon

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

DisturbedDragon wrote:
Tue Jun 30, 2020 12:25 pm
Either the wifi or touchpad on my device did not work on 4x kernel. Honestly don't remember which it was. You can give it a try though. Won't hurt anything.
Well, your machine is newer than the OP's, so 5.4 is your best choice.

marcosamaraljr
Level 1
Level 1
Posts: 8
Joined: Sun Jun 28, 2020 2:03 am

Re: Qualcomm QCA6174 Dropping connection.

Post by marcosamaraljr »

sleeper12 wrote:
Tue Jun 30, 2020 12:12 pm
Just to be sure, what does this say:

Code: Select all

 uname -r 

Code: Select all

$ uname -r
4.15.0-108-generic

sleeper12
Level 11
Level 11
Posts: 3582
Joined: Thu May 25, 2017 3:22 pm

Re: Qualcomm QCA6174 Dropping connection.

Post by sleeper12 »

Ok, you are using the 4.15 kernel for sure. Since that didn't help, maybe it's a firmware issue. If so, someone else will need to address that.

DisturbedDragon
Level 3
Level 3
Posts: 156
Joined: Mon Oct 29, 2012 6:29 pm
Location: Texas

Re: Qualcomm QCA6174 Dropping connection.

Post by DisturbedDragon »

Firmware was first released in 2013 and last updated in 2018. Required kernel is 4.0

https://wireless.wiki.kernel.org/en/use ... k/firmware

Maybe someone else here has a suggestion on how to get more performance out of this adapter. I do know this wireless adapter sucked under Winwoes and sucks under Linux.

EDIT: This is the same laptop with super cheap Edimax nano USB wifi adapter. Huge difference with the Realtek chip in it.

Code: Select all

Bus 002 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

Code: Select all

wlx74da380d21aa  IEEE 802.11  ESSID:"DisturbedDragon"  
          Mode:Managed  Frequency:2.422 GHz  Access Point: 84:16:F9:AC:A2:4F   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=63/70  Signal level=-47 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:15   Missed beacon:0
AMD Ryzen 9 3950X 16C/32T | MSI x470 Gaming Pro | 1TB Crucial P1 NVMe | 1TB Samsung 960 Pro NVMe | 32GB DDR4 3200 | Nvidia RTX2080 OC | Linux Mint 20.0 Cinnamon

marcosamaraljr
Level 1
Level 1
Posts: 8
Joined: Sun Jun 28, 2020 2:03 am

Re: Qualcomm QCA6174 Dropping connection.

Post by marcosamaraljr »

Should I try anything else? I'm desperate to solve this issue :/

Post Reply

Return to “Wireless”