Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

AndyMH wrote:
Mon Jun 29, 2020 7:32 am
I always do a clean install on a major version change. I have a separate /home partition which makes life easier. Only had one problem with old configs - evolution and that was easy to fix.
Hi Andy, further to this I have two SSD on my main Linux machine. The main drive is installed with Linux Mint Mate 19.3 and the second one has Windows 10 as a VM. Now if I did a clean install of LM 20 on to the SSD with Win 10 on (do not have any real use for that there now), would this be ok and not interfere with the LM 19.3 install. In the BIOS the SSD with 19.3 is set up as the first boot drive. Am I right in thinking that if I installed LM 20 on that second SSD and then set that drive as the first boot drive in the bios I could then play around with LM20 without interfering with my other, 19.3, LM install?
Last edited by Moem on Tue Jun 30, 2020 6:01 pm, edited 1 time in total.
Reason: This topic was created from (parts of) two threads that have been merged together. Sorry for any confusion.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

After coming across this comment from Reddit.
The reason this happened is because grub was written to the MBR of the IDE drive. This happened because that IDE drive was the primary boot device of your system. Therefore, installing grub on the MBR of your ssd would not have worked, because the ssd would never have been booted from, and mint would not have been usable. It doesn't make sense to install grub anywhere else but the current primary boot device.
I assume that this would happen if I installed LM20 to that second SSD that it would automatically put the grub on to the primary SSD (With LM19.3 on) and interfere with the boot process of the system because of the different Ubuntu types. Can someone please confirm that my thinking is correct.

One of the the things that excites me about LM20 is Warpinator. I have a second LM PC and the idea of transferring files from one machine to another on fly will be a big plus for me. I currently have shared folders on all three of my machines, one is Windows 10 on but it is a bit of a pain sharing. Will Warpinator enable me to share between LM machine and Win10 machine?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
Moem
Level 20
Level 20
Posts: 11415
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Linux Mint 20 “Ulyana” Cinnamon released!

Post by Moem »

muffybean wrote:
Tue Jun 30, 2020 5:47 am
Will Warpinator enable me to share between LM machine and Win10 machine?
No, it's a Linux program. It will not run on a Windows machine.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
User avatar
AndyMH
Level 12
Level 12
Posts: 4216
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Linux Mint 20 “Ulyana” Cinnamon released!

Post by AndyMH »

muffybean wrote:
Tue Jun 30, 2020 5:47 am
After coming across this comment from Reddit.
The reason this happened is because grub was written to the MBR of the IDE drive. This happened because that IDE drive was the primary boot device of your system. Therefore, installing grub on the MBR of your ssd would not have worked, because the ssd would never have been booted from, and mint would not have been usable. It doesn't make sense to install grub anywhere else but the current primary boot device.
I assume that this would happen if I installed LM20 to that second SSD that it would automatically put the grub on to the primary SSD (With LM19.3 on) and interfere with the boot process of the system because of the different Ubuntu types. Can someone please confirm that my thinking is correct.
I disagree with what you found. Assume you are booting LM19.x from your main drive, say sda and want to have a play with LM20 on a second drive, say sdb, before commiting to LM20. In this case, there is a lot of sense in having grub installed to the SSD you install LM20 into so that booting to your main OS is un-affected.

Problem is - if booting UEFI, there is a bug (may be fixed in LM20) where irrespective of where you tell the installer to put grub, it will also put a copy on the EFI partition in sda. Easy fix, boot the install media, run gparted and switch OFF the boot & esp flags on the EFI partition on sda. Do the installation to sdb and when finished turn the flags back ON on the EFI partition on sda.

This is one area where installing in legacy mode is simpler.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

Hi Andy I boot via bios on both my Linux machines as they are older type. So coming back to what you say
run gparted and switch OFF the boot & esp flags on the EFI partition on sda.


Where is that option available for me to do that? I am hoping I can get my head round this by this evening as I would love to go ahead with the clean install on to that second SSD. Just to clarify, I have two SSD, one with LM19.3 on SDA1 (256gb SSD ) and the second SDB1 (128Gb SSD) with Windows 10 VM installed. As I said I am happy to dump Win10 off this drive, however, should I do anything first on LM 19.3 on SDA with referencing the Win10 VM on in LM19.3?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
AndyMH
Level 12
Level 12
Posts: 4216
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Linux Mint 20 “Ulyana” Cinnamon released!

Post by AndyMH »

With legacy, an awful lot simpler.

Just to confirm - check your BIOS settings and run gparted and check sda, if you have a msdos partition table (view > device information) and you don't have a small (<500MB) partition formatted fat32 with the flags esp & boot, then you are legacy = good.

To install LM20 on sdb in legacy:
  • If you want to keep your win10 VM, copy it somewhere else.
  • Boot LM19.3 as normal, run gparted, select sdb (your win10 VM SSD) and delete the existing partitions (easiest way is device > create partition table and select msdos).
  • Create one or two (if you want a separate /home partition) ext4 partitions on sdb, if two partitions, sdb1 = / needs to be around 30GB and the rest for /home. Personally I wouldn't bother with a separate /home partition if you are just trying out LM20 as a pre-cursor to installing it as your main OS.
  • Boot your LM20 usb stick and run the installer, select the 'something else' option.
  • At the next screen point the installer at sdb1 and tell it to use it for / (and then same again for sdb2 and tell it to use it for /home if you want a /home partition).
  • Important - at the bottom of the screen tell the installer to use sdb for the bootloader (grub).
  • Reboot and use the fn key to get into the BIOS boot order (F12 on my thinkpads, F11 on my desktop, yours may be different). Select sdb (might show as HDD1). Does LM20 boot okay?
  • If okay, reboot and let the system boot into LM19.3 as normal. Open up a terminal and sudo update-grub. Grub will find LM20. Next time you boot you will get the choice of LM19.3 or LM20, but LM19.3 will be top of the list and the default.
What you are wanting to do is similar to what I've done - main OS, LM19.0 is on an mSATA SSD (sdc) and when I installed it I put grub on sdc, installed LM20 on sda (another SSD), sdc = HDD2 is set as the first boot device in BIOS.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

Just to confirm - check your BIOS settings and run gparted and check sda, if you have a msdos partition table (view > device information) and you don't have a small (<500MB) partition formatted fat32 with the flags esp & boot, then you are legacy = good.
Hi Andy, yep it is legacy as the there is just the one ext4 partition there, no small FAT32 partition at all.

As I said I am not that bothered about Win10 VM being there but will copy it somewhere else in case I want to try something at a later date.

Thanks for the precise instructions and will get to work on it later on this evening. Will update you when I have got it all up front and running.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Clean install of LM20 on second SSD

Post by muffybean »

To install LM20 on sdb in legacy:
If you want to keep your win10 VM, copy it somewhere else.
Boot LM19.3 as normal, run gparted, select sdb (your win10 VM SSD) and delete the existing partitions (easiest way is device > create partition table and select msdos).
Create one or two (if you want a separate /home partition) ext4 partitions on sdb, if two partitions, sdb1 = / needs to be around 30GB and the rest for /home. Personally I wouldn't bother with a separate /home partition if you are just trying out LM20 as a pre-cursor to installing it as your main OS.
Boot your LM20 usb stick and run the installer, select the 'something else' option.
At the next screen point the installer at sdb1 and tell it to use it for / (and then same again for sdb2 and tell it to use it for /home if you want a /home partition).
Important - at the bottom of the screen tell the installer to use sdb for the bootloader (grub).
Further to my posting at viewtopic.php?f=143&t=322958&start=40 Andy I got as far as this and came across this and not sure where to go from there.
Root-file.png
Can you please advise. TIA

Update from this, from your advice I had missed the bit about
Create one or two (if you want a separate /home partition) ext4 partitions on sdb, if two partitions, sdb1 = / needs to be around 30GB and the rest for /home. Personally I wouldn't bother with a separate /home partition if you are just trying out LM20 as a pre-cursor to installing it as your main OS.
So I went back to gparted in 19.3 and created a single ext4 primary partition on sdb1. I then booted from my LM20 USB and tried again but got the same error,
No root file system is defined Please correct this from the partitioning menu
Where do I do this in LM20 install?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

Important - at the bottom of the screen tell the installer to use sdb for the bootloader (grub).
Not sure what to do from here Andy and I have posted a new topic at viewtopic.php?f=46&t=323348 as I needed to show you a capture which I cannot do in this section.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
deepakdeshp
Level 17
Level 17
Posts: 7941
Joined: Sun Aug 09, 2015 10:00 am

Re: Clean install of LM20 on second SSD

Post by deepakdeshp »

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB
User avatar
zcot
Level 5
Level 5
Posts: 999
Joined: Wed Oct 19, 2016 6:08 pm

Re: Clean install of LM20 on second SSD

Post by zcot »

No root file system is defined.

That means you have to define where you want the root of the file system to be located.

For example you can double-click a line for a particular partition on a drive such as sdb and tell it to use ext4 and tell it to use / at this location. "/" means the root of the file system -the very lowest base point.

But you don't have any partitions on that drive anyway, only free space so it's not useful like that, just letting you know.
User avatar
AndyMH
Level 12
Level 12
Posts: 4216
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Clean install of LM20 on second SSD

Post by AndyMH »

So I went back to gparted in 19.3 and created a single ext4 primary partition on sdb1
zcot has covered most of it, in the screen you posted, either double click on sdb1 or click on sdb1 and click on the change button and tell the installer to use it for / and format it.

Don't forget - at the bottom of the screen select sdb as the location for the bootloader.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
Moem
Level 20
Level 20
Posts: 11415
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by Moem »

Moderator's note:
This thread originally started in this Announcement topic: viewtopic.php?f=143&t=322958
The posts about Muffybean's installation questions, and the helpful answers they received, have been added to Muffybean's other thread about the same questions.
Sorry if that confuses anyone.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
User avatar
AndyMH
Level 12
Level 12
Posts: 4216
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by AndyMH »

I did wonder if you would step in giving we were drifting way off topic :)
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 3 x Thinkpad T430 Cinnamon 19.0, i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
User avatar
Moem
Level 20
Level 20
Posts: 11415
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by Moem »

If you see that kind of thing happening, a heads up is always appreciated. The 'report' button is the easiest way since it reaches all the mods.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

Moem wrote:
Tue Jun 30, 2020 6:07 pm
Moderator's note:
This thread originally started in this Announcement topic: viewtopic.php?f=143&t=322958
The posts about Muffybean's installation questions, and the helpful answers they received, have been added to Muffybean's other thread about the same questions.
Sorry if that confuses anyone.
This is what I thought Moem and that is why I started this topic here. Thank you for understanding. :wink:
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

If okay, reboot and let the system boot into LM19.3 as normal. Open up a terminal and sudo update-grub. Grub will find LM20. Next time you boot you will get the choice of LM19.3 or LM20, but LM19.3 will be top of the list and the default.
Hi Andy after a couple of glitches of my own making, which I sorted OK, LM20 is successfully installed on sdb with LM19.3 on sda. The default boot being 19.3 after updating the grub in 19.3.

I have been absent from my machines for a while due the lurgy; I am in the vulnerable group due to cancerous growths in my spine and a shadow on my left lung. So most of the time I spent in my garden on a project as a result of acquiring some additional land to my property. As result I am a bit rusty on Linux but have picked up on some things straight away.

Reason for this explanation is that I can't quite remember how to reduce the distro choice time, Currently 10 secs but want to cut this down to 5 secs; think it is in the grub.cfg? Is it the set timeout=10? If I edit that to 5 would that be correct? Also, do I do this in terminal?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
arvy
Level 6
Level 6
Posts: 1086
Joined: Sat Mar 26, 2016 11:22 am

Re: Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by arvy »

If LM 19.3 is your current Grub controller, you'll need to edit the "timeout=10" setting at the tail end of /etc/grub.d/40_custom which overrides the default GRUB_TIMEOUT setting in etc/default/grub. If LM 20 becomes the Grub controller at some later time, its default GRUB_TIMEOUT setting prevails most of the time. In either case, you'd run sudo update-grub in the terminal after making the change.
System: Asus ROG Maximus XI Code mobo, Intel i9-9900K CPU, Nvidia GTX1080 GPU, 32 GB DDR4-3600 RAM, Sumsung Pro 2x512GB NVMe & 3x1TB SSD, Multiboot
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

Thought this was done in terminal from what I remember about this. Can't do the way you suggest.
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
User avatar
muffybean
Level 5
Level 5
Posts: 556
Joined: Thu Oct 17, 2019 8:22 am
Location: Pembrokeshire-Wales

Re: Clean install of LM20 on second SSD, was: Linux Mint 20 “Ulyana” Cinnamon released!

Post by muffybean »

Having got my clean install of LM20 up front and running, what files do I need from my 19.3 install on the other sda to copy to my LM20 version on sdb? I am referring to things like Thunderbird settings, ksnip and other software that I have installed in LM19.3?
Running Linux Mint MATE on 2 desktops + Linux Mint Xfce on Netbook + Cinnamon VM on 3rd Desktop
Post Reply

Return to “Installation & Boot”