Mint v19.3 audio popping

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: Mint v19.3 audio popping

Post by gm10 »

Flexan wrote:
Wed Dec 25, 2019 10:17 pm
wonder if something in the update is causing this.
The reason is a changed power management default setting in the snd_hda_intel driver in kernel 5.0, maybe we didn't state that clearly enough above. You can go back to kernel 4.15, or apply the fix I posted above.
User avatar
Neke
Level 1
Level 1
Posts: 7
Joined: Tue Nov 12, 2019 8:30 pm
Location: UK

Re: Mint v19.3 audio popping

Post by Neke »

gm10 wrote:
Fri Dec 20, 2019 8:49 am
dev0 wrote:
Fri Dec 20, 2019 8:35 am
I have the same issue after upgrade to 19.3.
Any solution found?
Your options are to go back to the 4.15 kernel series or to disable power management for Intel's HDA driver:

Code: Select all

sudo tee /etc/modprobe.d/snd-hda-intel.conf <<<'options snd-hda-intel power_save=0'
(takes effect on reboot)
Thanks gm10. Just updated Mint 19.2 to 19.3 and the kernel to v.5. Found the same speaker popping problem. Solved using your power management disable ploy. :D
System: Packard-Bell ixtreme M3720 Intel Core2 Quad Q8300 2.5GHz
4GB DDR2 PC2-6400
NVIDIA GeForce 7100/NVIDIA nForce 630i
------------------------------------------------
OS: Linux Mint 19.3 MATE
able2c
Level 1
Level 1
Posts: 3
Joined: Wed May 11, 2016 4:50 pm

Re: Mint v19.3 audio popping

Post by able2c »

JoeBingo wrote:
Thu Dec 19, 2019 4:56 pm
I guess it depends on hardware, but the solution at this link fixed my popping problem and there is also a link in the solution to a youtube video for further explanation and is worth a watch ... https://superuser.com/questions/1493096 ... ew-seconds
Thank you so much for this fix!
This "little" bug killed my sound bar.
jazz.h
Level 4
Level 4
Posts: 318
Joined: Sat Jun 18, 2011 7:13 am

Re: Mint v19.3 audio popping

Post by jazz.h »

I have also this problem in my AMD Ryzen configuration. The fix is still the same :D
Thx
bugeyedalien
Level 1
Level 1
Posts: 35
Joined: Wed Oct 30, 2013 7:51 pm
Location: South of Oslo.

Re: Mint v19.3 audio popping

Post by bugeyedalien »

hmm Im using Nvidia HDMI audio ?? :-( Linux Mint 19.3 .. Kernel 4.15.88 ?? :-/
User avatar
MrEen
Level 21
Level 21
Posts: 13355
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

bugeyedalien wrote:
Sun Feb 23, 2020 5:28 pm
hmm Im using Nvidia HDMI audio ?? :-( Linux Mint 19.3 .. Kernel 4.15.88 ?? :-/
If running cat /sys/module/snd_hda_intel/parameters/power_save in the terminal returns with 1, then you want to run the command. Otherwise, it's a different issue for you. And Nvidia HTML audio still uses the snd-hda-intel driver.
jalin
Level 1
Level 1
Posts: 44
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

Hi there, first post :) ... disabling power mgmt for Intel HDA driver doesn't help for me in particular. My issue is the popping noise (EXTREME through my plugged in speakers) occurs only on startup, after bios, before login, right around when the big green M is in the centre of screen

I've had similar issues in windows before, but this is the most extreme version I've ever come across. I'm dual booted with Win 10, on a dell XPS 13 9730 running Mint 19.3

Plz help! Of course I can switch off speakers around bootup and reboot, but if I forget I lose some hearing. I need audio dead *before* login

Cheers, any help much appreciated
arnie
Level 1
Level 1
Posts: 4
Joined: Sun Aug 23, 2015 11:41 am

Re: Mint v19.3 audio popping

Post by arnie »

This fix worked for me.
If there are any Mint devs looking in could this not be added as an option in the System Settings power management module.
User avatar
MrEen
Level 21
Level 21
Posts: 13355
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Hi arnie,

This is something that is set upstream at Ubuntu, who have flip-flopped on this issue somewhat recently. One of the reasons for the current setting is that Laptops can see considerable power savings with it set this way. Because of that, I doubt anyone is going to change it, but I could be wrong.
jalin
Level 1
Level 1
Posts: 44
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

I hope and pray for a solution to this... it looks like this has been an issue going back many years. I am deafened by a simple reboot if I forget to turn off my speakers before rebooting. None of the the fixes I've found online work

Big sustained buzz/boom (~3 seconds) on shutdown and multiple short booms on bootup
User avatar
MrEen
Level 21
Level 21
Posts: 13355
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Hi jalin,

This is just a stab in the dark, but give it a shot and see if it helps at all:

Code: Select all

sudo tee /etc/modprobe.d/blacklist-snd-hda-intel.conf <<<'blacklist snd-hda-intel'
Now when you reboot, there won't be any sound. Running this should get your sound back, but hopefully the noise before login will be gone:

Code: Select all

sudo modprobe snd-hda-intel
This won't stop the noise on shutting down. I'm trying to come up with a better way of handling all of this.

Let me know if:

A. This stopped the noise before login
B. There hopefully wasn't a big noise with the modprobe command (but do be prepared for it!)

If that works, I'll figure out something for the shutdown noise.

Also, please run this and post the URL it'll give when finished when choosing the upload option:

Code: Select all

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
jalin
Level 1
Level 1
Posts: 44
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

MrEen, thank you!

Correct, the first code snippet stopped the startup booms from occurring. The shutdown boom happened as expected.

Upon running the second code snippet, the startup booms happened (3 in short succession) and playback came back as normal. Interestingly, the booms happened even though my builtin laptop speakers were enabled (the booms came from my plugin system, and then the music I had running in the background started playing from laptop). I have the tweeters unplugged so just the woofer is making the noise now

Here's the data you requested, thanks again!
http://alsa-project.org/db/?f=0edffd8a6 ... b11b4a3f2f

On side note, I'm hoping there is a breakthrough on the audio side with linux. Whenever I need to do any pro audio type work I dual boot into windoze. A stable and robust DAW for linux would be a game changer
User avatar
MrEen
Level 21
Level 21
Posts: 13355
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Okay, I'd like you try another experiment. Run this then reboot:

Code: Select all

sudo tee /etc/modprobe.d/alsa-fix.conf <<<'options snd-intel-dspcfg dsp_driver=1'
Then see if the sudo modprobe command still has the 3 booms. If that stops the booms when running modprobe, it should also fix the shutdown booms, but you won't know until after all of that is tried. i.e. the reboot after running this command will still boom.

If it booms or not, I'd like to see the output of bash alsa-info.sh again afterwards. You don't need the wget part of the line after having already run that.
jalin
Level 1
Level 1
Posts: 44
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

No dice on that one. Shutdown boom still occurs. Startup booms don't upon startup, but do after modprobe command

http://alsa-project.org/db/?f=e5e983626 ... 58900c557b

thanks again
User avatar
MrEen
Level 21
Level 21
Posts: 13355
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

I only see 2 things slightly unusual:

1. You have two power_save entries in /etc/modprobe.d/*:

Code: Select all

snd_hda_intel: power_save=0 power_save_controller=N
snd_intel_dspcfg: dsp_driver=1
snd_hda_intel: power_save=0
I'd suggest removing the one that includes the power_save_controller.

2. I'm not used to seeing this in the lsmod output:

Code: Select all

ac97_bus
It might be entirely appropriate here, but usually I believe it's usually used separately from snd-hda-intel. Just to be safe, check your BIOS for audio settings. Some people can switch between AC97 and HDAudio in their BIOS, and it almost seems like you have both enabled.

Also, as the dspcfg parameter made no real change, you can remove that with this:

Code: Select all

sudo rm /etc/modprobe.d/alsa-fix.conf
jalin
Level 1
Level 1
Posts: 44
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

I'm a noob -- is there a particular conf file in /etc/modprobe.d where you'd like me to remove snd_hda_intel: power_save=0 power_save_controller=N ?

There doesn't seem to be any audio settings in my system's BIOS

dspcfg parameter removed, thank you
User avatar
MrEen
Level 21
Level 21
Posts: 13355
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

You can see which file you put it in (probably alsa-base.conf) with this command:

Code: Select all

grep snd-hda-intel /etc/modprobe.d/*
jalin
Level 1
Level 1
Posts: 44
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

MrEen, snd-hda-intel is blacklisted... grep returned:

Code: Select all

/etc/modprobe.d/alsa-base.conf:options snd-hda-intel power_save=0 power_save_controller=N
/etc/modprobe.d/blacklist-snd-hda-intel.conf:blacklist snd-hda-intel
/etc/modprobe.d/snd-hda-intel.conf:options snd-hda-intel power_save=0
thoughts?
User avatar
MrEen
Level 21
Level 21
Posts: 13355
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint v19.3 audio popping

Post by MrEen »

Yes, that's what we did here, to prevent the pops on startup.

You can remove it for testing with this:

Code: Select all

sudo rm /etc/modprobe.d/blacklist-snd-hda-intel.conf
Then use this to edit out the last line of alsa-base.conf:

Code: Select all

xed admin:///etc/modprobe.d/alsa-base.conf
This is this line I'm referring to:

Code: Select all

options snd-hda-intel power_save=0 power_save_controller=N
Either put a # in front of the line, or remove it completely, your choice. Then reboot and see what happens.
jalin
Level 1
Level 1
Posts: 44
Joined: Thu Mar 05, 2020 8:57 pm

Re: Mint v19.3 audio popping

Post by jalin »

Did the commands as above. My sound settings were showing 'Dummy Audio' (no outputs detected) when I rebooted. No shutdown boom at that time

On startup I got the 3 booms. Now outputs detected in sound settings. Rebooted again and shutdown boom back as well.
Post Reply

Return to “Sound, Multimedia, & Codecs”