[Solved] Linux Mint 20 Wifi Disconnects

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
GamerTechUniverse
Level 1
Level 1
Posts: 6
Joined: Tue Jun 30, 2020 7:51 pm

[Solved] Linux Mint 20 Wifi Disconnects

Post by GamerTechUniverse »

When I use my Linux Mint system, a few minutes later, it disconnects from the internet and can't connect. I tried typing the command

Code: Select all

sudo service network-manager
, but that doesn't work for me. If you want to see my system specifications, here it is:

System: Kernel: 5.4.0-39-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.6
wm: muffin dm: LightDM Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
Machine: Type: Laptop System: Microsoft product: Surface 3 v: B30D1SW1C4G1X1 serial: <filter>
Chassis: type: 9 v: 1 serial: <filter>
Mobo: Microsoft model: Surface 3 v: 00 serial: <filter> UEFI: American Megatrends
v: 1.51116.238 date: 03/09/2015
CPU: Topology: Quad Core model: Intel Atom x7-Z8700 bits: 64 type: MCP arch: Airmont rev: 3
L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12800
Speed: 743 MHz min/max: 480/2400 MHz Core speeds (MHz): 1: 780 2: 769 3: 697 4: 953
Graphics: Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics
vendor: Microsoft driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b0
Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1280~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (CHV) v: 4.6 Mesa 20.0.4 compat-v: 3.0
direct render: Yes
Audio: Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit
vendor: Microsoft driver: intel_atomisp2_pm v: kernel bus ID: 00:03.0
chip ID: 8086:22b8
Sound Server: ALSA v: k5.4.0-39-generic
Network: Device-1: Marvell 88W8897 [AVASTAR] 802.11ac Wireless driver: mwifiex_pcie v: 1.0
port: f000 bus ID: 01:00.0 chip ID: 11ab:2b38
IF: wlp1s0 state: up mac: <filter>
Device-2: Marvell Bluetooth and Wireless LAN Composite Device type: USB driver: btusb
bus ID: 1-4:3 chip ID: 1286:204c
Drives: Local Storage: total: 58.24 GiB used: 35.38 GiB (60.8%)
ID-1: /dev/mmcblk0 model: CWBC3R size: 58.24 GiB serial: <filter>
Partition: ID-1: / size: 19.11 GiB used: 13.64 GiB (71.4%) fs: ext4 dev: /dev/mmcblk0p5
Sensors: System Temperatures: cpu: 54.0 C mobo: N/A
Fan Speeds (RPM): N/A

Info: Processes: 230 Uptime: 2m Memory: 1.86 GiB used: 854.3 MiB (44.8%) Init: systemd v: 245
runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client inxi: 3.0.38


It has become a pain, I better finish this post before it disconnects.
Last edited by GamerTechUniverse on Thu Jul 02, 2020 7:14 pm, edited 2 times in total.

sleeper12
Level 11
Level 11
Posts: 3566
Joined: Thu May 25, 2017 3:22 pm

Re: Linux Mint 20 Wifi Disconnects

Post by sleeper12 »

Post result of:

Code: Select all

 iwconfig 

GamerTechUniverse
Level 1
Level 1
Posts: 6
Joined: Tue Jun 30, 2020 7:51 pm

Re: Linux Mint 20 Wifi Disconnects

Post by GamerTechUniverse »

I am a noob who switched from windows a month ago, but what does

Code: Select all

iwconfig
do?

GamerTechUniverse
Level 1
Level 1
Posts: 6
Joined: Tue Jun 30, 2020 7:51 pm

Re: Linux Mint 20 Wifi Disconnects

Post by GamerTechUniverse »

So far, the wifi hasn't disconnected, I will let everyone know if that changes. So thank you, for now.

GamerTechUniverse
Level 1
Level 1
Posts: 6
Joined: Tue Jun 30, 2020 7:51 pm

Re: Linux Mint 20 Wifi Disconnects

Post by GamerTechUniverse »

Well I was very wrong, it disconnected, and I couldn't connect back to the wifi, so I had to restart the computer, let me know if there is any commands that will fix this.

GamerTechUniverse
Level 1
Level 1
Posts: 6
Joined: Tue Jun 30, 2020 7:51 pm

Re: Linux Mint 20 Wifi Disconnects

Post by GamerTechUniverse »

here is the output of

Code: Select all

iwconfig

Code: Select all

lo        
no wireless extensions.

wlp1s0    IEEE 802.11  ESSID:"TP-Link_2119_5G"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: B0:4E:26:AA:21:18   
          Bit Rate=702 Mb/s   Tx-Power=5 dBm   
          Retry short limit:9   RTS thr=2347 B   Fragment thr=2346 B   
          Power Management:on
          Link Quality=70/70  Signal level=-39 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sleeper12
Level 11
Level 11
Posts: 3566
Joined: Thu May 25, 2017 3:22 pm

Re: Linux Mint 20 Wifi Disconnects

Post by sleeper12 »

Turn power management off & see if that helps, # 2.1 here:
https://easylinuxtipsproject.blogspot.c ... html#ID2.1

GamerTechUniverse
Level 1
Level 1
Posts: 6
Joined: Tue Jun 30, 2020 7:51 pm

Re: Linux Mint 20 Wifi Disconnects

Post by GamerTechUniverse »

I have disabled the power management, hope that helps,

Code: Select all

wlp1s0    IEEE 802.11  ESSID:"TP-Link_2119_5G"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: B0:4E:26:AA:21:18   
          Bit Rate=702 Mb/s   Tx-Power=5 dBm   
          Retry short limit:9   RTS thr=2347 B   Fragment thr=2346 B   
          Power Management:off
          Link Quality=70/70  Signal level=-37 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.
. Anyway, thanks for the help.

Edit: it works, no disconnects
Last edited by GamerTechUniverse on Wed Jul 01, 2020 9:16 pm, edited 1 time in total.

sleeper12
Level 11
Level 11
Posts: 3566
Joined: Thu May 25, 2017 3:22 pm

Re: Linux Mint 20 Wifi Disconnects

Post by sleeper12 »

GamerTechUniverse wrote:
Wed Jul 01, 2020 8:47 pm
I have disabled the power management, hope that helps,

Code: Select all

wlp1s0    IEEE 802.11  ESSID:"TP-Link_2119_5G"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: B0:4E:26:AA:21:18   
          Bit Rate=702 Mb/s   Tx-Power=5 dBm   
          Retry short limit:9   RTS thr=2347 B   Fragment thr=2346 B   
          Power Management:off
          Link Quality=70/70  Signal level=-37 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.
. Anyway, thanks for the help.
Let us know either way. If not, you can also try # 2.2 on that same page.

Post Reply

Return to “Wireless”