[SOLVED] Nvidia drivers not loading (Mint 20)

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
SickenChalad
Level 1
Level 1
Posts: 2
Joined: Thu Jul 09, 2020 9:12 pm

[SOLVED] Nvidia drivers not loading (Mint 20)

Post by SickenChalad »

I'm a new linux/mint user and would greatly appreciate any assistance. Thanks in advance for your time!

I just setup Mint 20 (dual booting alongside Win10 - Lenovo P1). Everything works great except that my external HDMI monitor isn't recognized. When I open the Driver Manager, 3 drivers are shown:
  • nvidia-driver-440 (recommended) <- Selected && installed/restarted
  • xserver-xorg-video-nouveau (open-source)
  • nvidia-driver-435
When I try to open the Nvidia X Server settings, an empty window with Help (displays "No help available") and Quit buttons. This is the only Nvidia app that shows up when I search in the menu.

Also, if I try switching to the nouveau drivers, nothing seems to change, but when I go to the Driver Manager, no nvidia driver alternatives are shown. Entering the following in the terminal makes the 3 choices reappear: 'ubuntu-drivers devices ' -> ' sudo ubuntu-drivers autoinstall'

Any thoughts on how I can get the second display working?

Other (hopefully) helpful details:

Code: Select all

$ ubuntu-drivers devices

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==

modalias : pci:v000010DEd00001FB9sv000017AAsd0000229Fbc03sc00i00

vendor : NVIDIA Corporation

model : TU117GLM [Quadro T1000 Mobile]

driver : nvidia-driver-440 - distro non-free recommended

driver : nvidia-driver-435 - distro non-free

driver : xserver-xorg-video-nouveau - distro free builtin
==================================

Code: Select all

$ sudo nvidia-settings

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:5547): GLib-GObject-CRITICAL **: 17:19:29.166: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

** Message: 17:19:29.168: PRIME: No offloading required. Abort

** Message: 17:19:29.168: PRIME: is it supported? no
Last edited by SickenChalad on Sun Jul 12, 2020 6:29 pm, edited 1 time in total.
sneakykitty
Level 1
Level 1
Posts: 6
Joined: Sat Jul 11, 2020 4:10 am

Re: Nvidia drivers not loading (Mint 20)

Post by sneakykitty »

Hi,

I'm having the same issue (albeit Mint 19.3), with those exact 3 drivers listed as being available. Yet running nvidia-settings returns 'driver not loaded'.
From what I've read on other forums, post your nvidia log to help:

Code: Select all

sudo nvidia-bug-report.sh
(The .gz file will be made where you ran the script)

Mine returned the attached file.
Secure boot is disabled - which is what many forum posts suggest checking.

Additional info:
Operating system:

Code: Select all

lsb_release -a
Linux Mint 19.3 Tricia

Kernal version:

Code: Select all

uname -r

5.4.0-40-generic

Thanks mint users for your help!
Attachments
nvidia-bug-report.log.gz
(148.09 KiB) Downloaded 15 times
User avatar
roblm
Level 13
Level 13
Posts: 4511
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia drivers not loading (Mint 20)

Post by roblm »

SickenChalad,
You have not posted any useful info for anyone to help you. At the minimum, use the command inxi -Fxz.

Also, post the output of these commands:

Code: Select all

lspci -nnk | grep -EA3 "3D|VGA"   			
ls /lib/modprobe.d/		
dpkg -l | grep -i nvidia
mokutil --sb-state
Use this command to upload the Xorg.0.log file to terminal.com pastebin:
cat /var/log/Xorg.0.log | nc termbin.com 9999

Post the URL address that displays in the Terminal window.
sneakykitty
Level 1
Level 1
Posts: 6
Joined: Sat Jul 11, 2020 4:10 am

Re: Nvidia drivers not loading (Mint 20)

Post by sneakykitty »

Hijacking the thread...

Code: Select all

System:    Host: leaf Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 7.5.0 
           Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x 
           serial: <root required> UEFI: American Megatrends v: 1201 date: 09/09/2019 
CPU:       Topology: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 
           L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 182064 
           Speed: 2790 MHz min/max: 2200/3800 MHz Core speeds (MHz): 1: 2795 2: 1860 3: 2195 4: 2162 
           5: 2794 6: 1863 7: 1863 8: 2196 9: 2195 10: 2195 11: 2127 12: 2147 13: 1862 14: 2221 
           15: 2196 16: 2196 17: 2163 18: 2194 19: 2048 20: 2189 21: 2070 22: 2100 23: 2275 24: 2195 
Graphics:  Device-1: NVIDIA vendor: Micro-Star MSI driver: N/A bus ID: 08:00.0 
           Display: x11 server: X.Org 1.20.8 driver: nouveau,vesa unloaded: modesetting 
           resolution: 1024x768~N/A 
           OpenGL: renderer: llvmpipe (LLVM 9.0 128 bits) v: 3.3 Mesa 19.2.8 direct render: Yes 
Audio:     Device-1: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 08:00.1 
           Device-2: AMD vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 0a:00.4 
           Sound Server: ALSA v: k5.4.0-40-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK 
           driver: r8169 v: kernel port: f000 bus ID: 04:00.0 
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: 04:d9:f5:d5:7d:e4 
Drives:    Local Storage: total: 465.76 GiB used: 128.60 GiB (27.6%) 
           ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP600 size: 465.76 GiB 
Partition: ID-1: / size: 456.96 GiB used: 128.59 GiB (28.1%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 65.8 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 483 Uptime: 1h 49m Memory: 62.78 GiB used: 5.04 GiB (8.0%) Init: systemd 
           runlevel: 5 Compilers: gcc: 6.5.0 Shell: bash v: 4.4.20 inxi: 3.0.32 

Code: Select all

08:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1e81] (rev a1)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:c724]
	Kernel modules: nvidiafb, nouveau
08:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:10f8] (rev a1)

Code: Select all

aliases.conf                                   fbdev-blacklist.conf
blacklist_linux-hwe_5.0.0-32-generic.conf      nvidia-graphics-drivers.conf
blacklist_linux-hwe-5.4_5.4.0-40-generic.conf  systemd.conf

Code: Select all

ii  libnvidia-cfg1-440:amd64                   440.100-0ubuntu0.18.04.1                         amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-435                       435.21-0ubuntu0.18.04.2                          all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-440                       440.100-0ubuntu0.18.04.1                         all          Shared files used by the NVIDIA libraries
rc  libnvidia-compute-430:amd64                430.50-0ubuntu0.18.04.2                          amd64        NVIDIA libcompute package
rc  libnvidia-compute-435:amd64                435.21-0ubuntu0.18.04.2                          amd64        NVIDIA libcompute package
ii  libnvidia-compute-440:amd64                440.100-0ubuntu0.18.04.1                         amd64        NVIDIA libcompute package
ii  libnvidia-decode-440:amd64                 440.100-0ubuntu0.18.04.1                         amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-440:amd64                 440.100-0ubuntu0.18.04.1                         amd64        NVENC Video Encoding runtime library
ii  libnvidia-extra-440:amd64                  440.100-0ubuntu0.18.04.1                         amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-440:amd64                   440.100-0ubuntu0.18.04.1                         amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-440:amd64                     440.100-0ubuntu0.18.04.1                         amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-440:amd64                   440.100-0ubuntu0.18.04.1                         amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
rc  nvidia-compute-utils-435                   435.21-0ubuntu0.18.04.2                          amd64        NVIDIA compute utilities
ii  nvidia-compute-utils-440                   440.100-0ubuntu0.18.04.1                         amd64        NVIDIA compute utilities
rc  nvidia-dkms-435                            435.21-0ubuntu0.18.04.2                          amd64        NVIDIA DKMS package
ii  nvidia-dkms-440                            440.100-0ubuntu0.18.04.1                         amd64        NVIDIA DKMS package
ii  nvidia-driver-440                          440.100-0ubuntu0.18.04.1                         amd64        NVIDIA driver metapackage
rc  nvidia-kernel-common-435                   435.21-0ubuntu0.18.04.2                          amd64        Shared files used with the kernel module
ii  nvidia-kernel-common-440                   440.100-0ubuntu0.18.04.1                         amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-440                   440.100-0ubuntu0.18.04.1                         amd64        NVIDIA kernel source package
ii  nvidia-prime                               0.8.8.2                                          all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                            440.44-0ubuntu0.18.04.1                          amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-440                           440.100-0ubuntu0.18.04.1                         amd64        NVIDIA driver support binaries
ii  xserver-xorg-video-nvidia-440              440.100-0ubuntu0.18.04.1                         amd64        NVIDIA binary Xorg driver

Code: Select all

SecureBoot disabled
https://termbin.com/qfj8
User avatar
roblm
Level 13
Level 13
Posts: 4511
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia drivers not loading (Mint 20)

Post by roblm »

sneakykitty,
It appears that the Nvidia kernel modules failed to build. Use this command to remove the Nvidia driver: apt purge *nvidia*

After rebooting, use this command to re-install the driver: apt install nvidia-driver-440

Copy the installation log in the Terminal window and save it to a file. Reboot and post the contents of that file.
sneakykitty
Level 1
Level 1
Posts: 6
Joined: Sat Jul 11, 2020 4:10 am

Re: Nvidia drivers not loading (Mint 20)

Post by sneakykitty »

Thankyou for looking into this Roblm.

Code: Select all

>>sudo apt install nvidia-driver-440
[sudo]>>password for mint:  
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  screen-resolution-extra
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  libnvidia-cfg1-440 libnvidia-common-440 libnvidia-compute-440
  libnvidia-decode-440 libnvidia-encode-440 libnvidia-extra-440
  libnvidia-fbc1-440 libnvidia-gl-440 libnvidia-ifr1-440
  nvidia-compute-utils-440 nvidia-dkms-440 nvidia-kernel-common-440
  nvidia-kernel-source-440 nvidia-utils-440 xserver-xorg-video-nvidia-440
Recommended packages:
  nvidia-settings nvidia-prime libnvidia-compute-440:i386
  libnvidia-decode-440:i386 libnvidia-encode-440:i386 libnvidia-ifr1-440:i386
  libnvidia-fbc1-440:i386 libnvidia-gl-440:i386
The following NEW packages will be installed
  libnvidia-cfg1-440 libnvidia-common-440 libnvidia-compute-440
  libnvidia-decode-440 libnvidia-encode-440 libnvidia-extra-440
  libnvidia-fbc1-440 libnvidia-gl-440 libnvidia-ifr1-440
  nvidia-compute-utils-440 nvidia-dkms-440 nvidia-driver-440
  nvidia-kernel-common-440 nvidia-kernel-source-440 nvidia-utils-440
  xserver-xorg-video-nvidia-440
0 to upgrade, 16 to newly install, 0 to remove and 0 not to upgrade.
Need to get 19.1 kB/101 MB of archives.
After this operation, 367 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main amd64 nvidia-kernel-common-440 amd64 440.100-0ubuntu0.18.04.1 [19.1 kB]
Fetched 19.1 kB in 0s (171 kB/s)                    
Selecting previously unselected package libnvidia-cfg1-440:amd64.
(Reading database ... 327373 files and directories currently installed.)
Preparing to unpack .../00-libnvidia-cfg1-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libnvidia-cfg1-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package libnvidia-common-440.
Preparing to unpack .../01-libnvidia-common-440_440.100-0ubuntu0.18.04.1_all.deb ...
Unpacking libnvidia-common-440 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package libnvidia-compute-440:amd64.
Preparing to unpack .../02-libnvidia-compute-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libnvidia-compute-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package libnvidia-decode-440:amd64.
Preparing to unpack .../03-libnvidia-decode-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libnvidia-decode-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package libnvidia-encode-440:amd64.
Preparing to unpack .../04-libnvidia-encode-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libnvidia-encode-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package libnvidia-extra-440:amd64.
Preparing to unpack .../05-libnvidia-extra-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libnvidia-extra-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package libnvidia-fbc1-440:amd64.
Preparing to unpack .../06-libnvidia-fbc1-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libnvidia-fbc1-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Progress: [ 27%] [##################..................................................] 
Preparing to unpack .../07-libnvidia-gl-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libnvidia-gl-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package libnvidia-ifr1-440:amd64.....................................................................................................] 
Preparing to unpack .../08-libnvidia-ifr1-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libnvidia-ifr1-440:amd64 (440.100-0ubuntu0.18.04.1) .........................................................] 
Selecting previously unselected package nvidia-compute-utils-440...............................................................................................................] 
Preparing to unpack .../09-nvidia-compute-utils-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking nvidia-compute-utils-440 (440.100-0ubuntu0.18.04.1) .............................................................................................................................] 
Selecting previously unselected package nvidia-kernel-source-440............................................................................................................................] 
Preparing to unpack .../10-nvidia-kernel-source-440_440.100-0ubuntu0.18.04.1_amd64.deb ........................................................................................................] 
Unpacking nvidia-kernel-source-440 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package nvidia-kernel-common-440.
Preparing to unpack .../11-nvidia-kernel-common-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking nvidia-kernel-common-440 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package nvidia-dkms-440.
Preparing to unpack .../12-nvidia-dkms-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking nvidia-dkms-440 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package nvidia-utils-440.
Preparing to unpack .../13-nvidia-utils-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking nvidia-utils-440 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package xserver-xorg-video-nvidia-440.
Preparing to unpack .../14-xserver-xorg-video-nvidia-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking xserver-xorg-video-nvidia-440 (440.100-0ubuntu0.18.04.1) ...
Selecting previously unselected package nvidia-driver-440.
Preparing to unpack .../15-nvidia-driver-440_440.100-0ubuntu0.18.04.1_amd64.deb ...
Unpacking nvidia-driver-440 (440.100-0ubuntu0.18.04.1) ...
Setting up libnvidia-common-440 (440.100-0ubuntu0.18.04.1) ...
Setting up libnvidia-fbc1-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Setting up libnvidia-compute-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Setting up nvidia-utils-440 (440.100-0ubuntu0.18.04.1) ...
Setting up nvidia-kernel-common-440 (440.100-0ubuntu0.18.04.1) ...
update-initramfs: deferring update (trigger activated)
Setting up libnvidia-cfg1-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Setting up libnvidia-decode-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Setting up nvidia-compute-utils-440 (440.100-0ubuntu0.18.04.1) ...
Warning: The home dir /nonexistent you specified can't be accessed: No such file or directory
Adding system user `nvidia-persistenced' (UID 122) ...
Adding new group `nvidia-persistenced' (GID 129) ...
Adding new user `nvidia-persistenced' (UID 122) with group `nvidia-persistenced' ...
Not creating home directory `/nonexistent'.
Setting up libnvidia-extra-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Setting up libnvidia-encode-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Setting up nvidia-kernel-source-440 (440.100-0ubuntu0.18.04.1) ...
Setting up xserver-xorg-video-nvidia-440 (440.100-0ubuntu0.18.04.1) ...
Setting up libnvidia-gl-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Setting up nvidia-dkms-440 (440.100-0ubuntu0.18.04.1) ...
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
Loading new nvidia-440.100 DKMS files...
Building for 5.4.0-40-generic
Building for architecture x86_64
Building initial module for 5.4.0-40-generic
Error! Bad return status for module build on kernel: 5.4.0-40-generic (x86_64)
Consult /var/lib/dkms/nvidia/440.100/build/make.log for more information.
Setting up libnvidia-ifr1-440:amd64 (440.100-0ubuntu0.18.04.1) ...
Setting up nvidia-driver-440 (440.100-0ubuntu0.18.04.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for initramfs-tools (0.130ubuntu3.9) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-40-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8125a-3.fw for module r8169
This catches my eye:

Code: Select all

Building initial module for 5.4.0-40-generic
Error! Bad return status for module build on kernel: 5.4.0-40-generic (x86_64)
User avatar
roblm
Level 13
Level 13
Posts: 4511
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia drivers not loading (Mint 20)

Post by roblm »

I just tested installing the 440.100 driver for Mint Cinnamon 20 and it worked, both with the default 5.4.0-26 kernel and the 5.4.0-40 kernel.

These lines are from your inxi output:
System: Host: leaf Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 7.5.0

Info: Processes: 483 Uptime: 1h 49m Memory: 62.78 GiB used: 5.04 GiB (8.0%) Init: systemd
runlevel: 5 Compilers: gcc: 6.5.0 Shell: bash v: 4.4.20 inxi: 3.0.32
The gcc versions should usually be identical, with some exceptions.

Here is mine:
System: Kernel: 5.4.0-26-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.6

Info: Processes: 207 Uptime: 14m Memory: 7.79 GiB used: 775.6 MiB (9.7%) Init: systemd runlevel: 5 Compilers: gcc: 9.3.0
Shell: bash v: 5.0.16 inxi: 3.0.38
The default version of gcc is 9.3. I checked this on a second installation on another system. On your system, gcc 7.5 was used to build the kernel and gcc 6.5 is the installed version. Some package you installed must be the reason for the version difference. The default gcc version for Mint 19.3 is 7.4.

Did you upgrade from Mint 19.3 or do a new installation?
sneakykitty
Level 1
Level 1
Posts: 6
Joined: Sat Jul 11, 2020 4:10 am

Re: Nvidia drivers not loading (Mint 20)

Post by sneakykitty »

Ah, gcc!

I did a reinstall of 'build-essential' earlier today thinking that would magically fix any compiler issues.

Should I go ahead and purge *gcc* then install gcc 7.4? Or, do you think installing mint 20 would be a good idea, with gcc 9.3?

Edit: Looking at the gcc, I recall fiddling about with it months ago - I'll get back to you later tonight/tomorrow! :) Thanks for spotting the gcc as being the culprit!
User avatar
roblm
Level 13
Level 13
Posts: 4511
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia drivers not loading (Mint 20)

Post by roblm »

What I was supposed to say is, did you upgrade from Mint 19.2, not 19.3.

sneakykitty wrote: Should I go ahead and purge *gcc* then install gcc 7.4?
I don’t know if that will work. You may have to open the Synaptic package manager and force the installation of version 7.4. Be sure to create a Timeshift restore point first, unless you can go back to an earlier time with an older restore point.
sneakykitty
Level 1
Level 1
Posts: 6
Joined: Sat Jul 11, 2020 4:10 am

Re: Nvidia drivers not loading (Mint 20)

Post by sneakykitty »

Sorry - I'd forgotten to answer that part entirely - yes I'd upgraded from 19.2 rather han done a fresh install.

I'll create a time shift and look into the gcc! :)
sneakykitty
Level 1
Level 1
Posts: 6
Joined: Sat Jul 11, 2020 4:10 am

Re: Nvidia drivers not loading (Mint 20)

Post by sneakykitty »

Success!

Thankyou so much for your time.

To fix gcc:
When running:

Code: Select all

ls /usr/bin/gcc*
, my gcc installations were listed (such as gcc-7, and gcc-6), but not '/usr/bin/gcc'.
I created a symbollic link in that directory pointing from gcc to gcc-7.

Code: Select all

ln -s gcc-7 gcc
(I also purged gcc-6, reinstalled gcc and build-essential - although that may not have been necessary).

I then re-installed nvidia 440.

Let's hope the creator of this thread also has swimming fix; I'll keep an eye out and try to help out if I'm able.

I hope you have a nice night roblm - it's very kind of you to help. (A vfx artist can now continue to do her work!) :D
SickenChalad
Level 1
Level 1
Posts: 2
Joined: Thu Jul 09, 2020 9:12 pm

Re: Nvidia drivers not loading (Mint 20)

Post by SickenChalad »

roblm - thanks for your reply and apologies for the delay in my response. I solved the issue last night by turning Secure Boot off in the UEFI menu. I appreciate your time!
Post Reply

Return to “Graphics Cards & Monitors”