Brightness not working after switching to Nvidia driver

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

I recently switched to Nvidia driver, which works fine except that I am not getting any brightness option. Earlier when I used the open-source driver, I used to get the brightness option if I clicked the battery icon, as I am running mint on a laptop. Please help me get brightness option back. I am running the latest Linux Mint Ulyana.

My laptop specs:
Sony vaio VPCCW1BGN
Intel core 2 duo CPU
Nvidia Geforce G210M GPU
4GB ddr3 ram
deepakdeshp
Level 18
Level 18
Posts: 8390
Joined: Sun Aug 09, 2015 10:00 am

Re: Brightness not working after switching to Nvidia driver

Post by deepakdeshp »

Paste output of

Code: Select all

 inxi -Fxz
Somebody else may chip in for a solution.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

The Output:


System:
Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana
base: Ubuntu 20.04 focal
Machine:
Type: Laptop System: Sony product: VPCCW1BGN v: C602CZ9P serial: <filter>
Mobo: Sony model: VAIO serial: <filter> BIOS: American Megatrends
v: R0190Y5 date: 09/22/2009
Battery:
ID-1: BAT0 charge: 39.2 Wh condition: 39.2/48.8 Wh (80%) model: Sony Corp.
status: Full
CPU:
Topology: Dual Core model: Intel Core2 Duo P8700 bits: 64 type: MCP
arch: Penryn rev: A L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10108
Speed: 1559 MHz min/max: 800/2534 MHz Core speeds (MHz): 1: 2144 2: 2153
Graphics:
Device-1: NVIDIA GT218M [GeForce G210M] vendor: Sony driver: nvidia
v: 340.108 bus ID: 01:00.0
Display: x11 server: X.Org 1.20.8 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1366x768~60Hz
OpenGL: renderer: GeForce G210M/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108
direct render: Yes
Audio:
Device-1: Intel 82801I HD Audio vendor: Sony driver: snd_hda_intel
v: kernel bus ID: 00:1b.0
Device-2: NVIDIA High Definition Audio vendor: Sony driver: snd_hda_intel
v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k5.4.0-42-generic
Network:
Device-1: Marvell 88E8057 PCI-E Gigabit Ethernet vendor: Sony driver: sky2
v: 1.30 port: c000 bus ID: 02:00.0
IF: enp2s0 state: down mac: <filter>
Device-2: Intel WiFi Link 5100 driver: iwlwifi v: kernel port: c000
bus ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Drives:
Local Storage: total: 298.09 GiB used: 43.28 GiB (14.5%)
ID-1: /dev/sda vendor: Seagate model: ST9320325ASG size: 298.09 GiB
Partition:
ID-1: / size: 291.92 GiB used: 21.64 GiB (7.4%) fs: ext4 dev: /dev/sda5
Sensors:
System Temperatures: cpu: 76.0 C mobo: 76.0 C gpu: nvidia temp: 92 C
Fan Speeds (RPM): N/A
Info:
Processes: 198 Uptime: 45m Memory: 3.81 GiB used: 1.72 GiB (45.1%)
Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17
inxi: 3.0.38
deepakdeshp
Level 18
Level 18
Posts: 8390
Joined: Sun Aug 09, 2015 10:00 am

Re: Brightness not working after switching to Nvidia driver

Post by deepakdeshp »

If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

It seems a bit risky, is it safe?
deepakdeshp
Level 18
Level 18
Posts: 8390
Joined: Sun Aug 09, 2015 10:00 am

Re: Brightness not working after switching to Nvidia driver

Post by deepakdeshp »

Many have done it and nobody reported any problem.
Backup your system to be safe.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB
User avatar
SMG
Level 7
Level 7
Posts: 1836
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Brightness not working after switching to Nvidia driver

Post by SMG »

The 340 driver you are using is the one Nvidia recommends to use for that card. I'm not sure how trying a different driver will affect your system.

Are you sure that was the only change made when the brightness/battery icon disappeared? If you go to Power Management from the menu, is Brightness available there?

(By the way - your system and Nvidia card are running hot. Wow!)
Last edited by SMG on Wed Aug 19, 2020 9:04 pm, edited 1 time in total.
LM20.0 Cinnamon
deepakdeshp
Level 18
Level 18
Posts: 8390
Joined: Sun Aug 09, 2015 10:00 am

Re: Brightness not working after switching to Nvidia driver

Post by deepakdeshp »

Clean the fan blow up the lint accumulated, so that your system cools properly.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 20 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

Yeah, I have double checked no brightness option in power management too. By the way I am able to control brightness with

Code: Select all

xbacklight -set 65
command which increases/decreases according to the number specified.


I had recently changed the thermal paste of my cpu and gpu, not sure why the temperature is too high :?
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

There is this script called lumos which basically gives a gui for xbacklight. What I have done is that I have pasted that script in /bin directory and made a desktop config file that allowed it to execute from there which would give me options in gui for brightness like 10, 50, 100 etc. Is there any way to get a shortcut of this to the panel, I mean the notification panel near to the battery, wifi symbol etc?
User avatar
SMG
Level 7
Level 7
Posts: 1836
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Brightness not working after switching to Nvidia driver

Post by SMG »

Spectrum75 wrote:
Thu Aug 20, 2020 2:50 am
Yeah, I have double checked no brightness option in power management too.
That Nvidia driver was last updated in December 2019 and I don't believe it will be further updated. That may be why the brightness option in LM20 is not displaying?
Spectrum75 wrote:
Thu Aug 20, 2020 3:32 am
There is this script called lumos which basically gives a gui for xbacklight. What I have done is that I have pasted that script in /bin directory and made a desktop config file that allowed it to execute from there which would give me options in gui for brightness like 10, 50, 100 etc. Is there any way to get a shortcut of this to the panel, I mean the notification panel near to the battery, wifi symbol etc?
I do not have enough experience with the panel coding to know how to put it there.

I recall reading a different thread where a desktop user had the brightness applet missing and they found one they were able to install. I see a Brightness and gamma applet available when I did a search, but I don't recall if that was the one that person used (and I am unable to locate that thread right now).

Edited to add: Here is the thread Power Manager Brightness Applet where is it.
LM20.0 Cinnamon
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

I could not understand anything mentioned there, as I am new to linux :(
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

When I right-clicked on the panel and clicked applets, there I found a brightness applet which I installed and now I have brightness control on the panel (the same area near to the battery icon) :D

EDIT: for some reason whenever I change the brightness it comes back to the original, which I have set in lumos :(
User avatar
SMG
Level 7
Level 7
Posts: 1836
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Brightness not working after switching to Nvidia driver

Post by SMG »

Spectrum75 wrote:
Sat Aug 22, 2020 8:14 am
When I right-clicked on the panel and clicked applets, there I found a brightness applet which I installed and now I have brightness control on the panel (the same area near to the battery icon) :D
Maybe it was there all along and just not visible. If it has both the brightness and the battery, then it is the standard applet which is part of the Cinnamon install.
Spectrum75 wrote:
Sat Aug 22, 2020 8:14 am
EDIT: for some reason whenever I change the brightness it comes back to the original, which I have set in lumos :(
It is possible that lumos is overriding what is in the applet. You may need to remove the code you installed for lumos/backlight for the brightness applet to work properly.
LM20.0 Cinnamon
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

I tried removing lumos, but it still doesn't work. Seems like lumos only puts a layer of screen fliter with the given brightness value :(
User avatar
SMG
Level 7
Level 7
Posts: 1836
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Brightness not working after switching to Nvidia driver

Post by SMG »

You removed lumos, but do you still have this controlling brightness?
Spectrum75 wrote:
Thu Aug 20, 2020 2:50 am
Yeah, I have double checked no brightness option in power management too. By the way I am able to control brightness with

Code: Select all

xbacklight -set 65
command which increases/decreases according to the number specified.
LM20.0 Cinnamon
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

Yes, thats the only thing that helps me to control the brightness now.
User avatar
Spectrum75
Level 2
Level 2
Posts: 50
Joined: Tue Aug 11, 2020 3:40 am

Re: Brightness not working after switching to Nvidia driver

Post by Spectrum75 »

I tried removing xbacklight, but then too that applet isn't able to control brightness
User avatar
SMG
Level 7
Level 7
Posts: 1836
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Brightness not working after switching to Nvidia driver

Post by SMG »

Spectrum75 wrote:
Sat Aug 22, 2020 10:06 am
I tried removing xbacklight, but then too that applet isn't able to control brightness
Is that applet the one which also has power management?
LM20.0 Cinnamon
User avatar
roblm
Level 13
Level 13
Posts: 4539
Joined: Sun Feb 24, 2013 2:41 pm

Re: Brightness not working after switching to Nvidia driver

Post by roblm »

Use this command and post the output: ls /sys/class/backlight/*/*
Post Reply

Return to “Graphics Cards & Monitors”