Disable the touchpad

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
AndrewPayton
Level 1
Level 1
Posts: 1
Joined: Mon Aug 24, 2020 1:44 am

Disable the touchpad

Post by AndrewPayton »

I can't type without the pointer misdirecting my typing all over the place, and the touchpad makes it worse by moving it around by my wrist brushing over it, any ideas how to fix this?

Thanks
User avatar
AZgl1500
Level 14
Level 14
Posts: 5331
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Disable the touchpad

Post by AZgl1500 »

open the menu and type the word "touchpad" and press <enter>

it will show up long before you type it all, when Touchpad shows up, press <enterL>

the click on Touchpad, and the button to Disable.

I'm sure you already know, you need a USB mouse :lol:

OR,
you can configure the Touchpad to be Disabled While Typing.

your choice.
Linux Mint 19.3 Cinnamon
User avatar
Lord Boltar
Level 5
Level 5
Posts: 767
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Disable the touchpad

Post by Lord Boltar »

Run the following command in a terminal:

Code: Select all

xinput list
You will get an output that looks something like this:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ Laptop_Integrated_Webcam_1.3M id=10 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
↳ Dell WMI hotkeys id=13 [slave keyboard (3)]

It displays all the input devices connected. Note that they all have an id=. Since 12 is the id for my touchpad, running the following command will disable it until you reboot. NOTE - Your number may be different also this will only temporarily disable the touchpad

Code: Select all

xinput --disable 12
It will be disabled until you reboot or you can run

Code: Select all

xinput --enable 12
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing
User avatar
BG405
Level 8
Level 8
Posts: 2382
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Disable the touchpad

Post by BG405 »

Another option might be to set "Disable the touchpad when a mouse is plugged in". Plus some laptops have a key combination for this, usually Fn plus one of the function keys.

Further to that, if you are using a mouse, maybe add a trackpad indicator to your panel?
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Two ROMS don't make a WRITE ...
Lady Fitzgerald
Level 5
Level 5
Posts: 900
Joined: Tue Jan 07, 2020 3:12 pm
Location: AZ, SSA (Squabbling States of America)

Re: Disable the touchpad

Post by Lady Fitzgerald »

I found AZgl1500's solution to work best. It's baked into Linux Mint Cinnamon so it will work with all computers. In addition to fully disabling or disabling while typing (I wasn't impressed with that option when I tried it), you can also set it to disable the stupid touchpad when a mouse is present (this can either be a wired mouse or the dongle for wireless mince).

I'm using that last option. As long as the wireless mouse dongle (specifically, a Logitech Unifying Receiver) is plugged in, the idiot touchpad is disabled. If I remove the dongle, the misbegotten touchpad is enabled. Plugging the dongle back in disables the moronic touchpad again.


Did I ever mention that I do not like touchpads?
Jeannie

Linux Mint Cinnamon 19.3 Cinnamon 64 bit
System 76 Serval WS (serw11) 17" Laptop
User avatar
BG405
Level 8
Level 8
Posts: 2382
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Disable the touchpad

Post by BG405 »

He didn't mention that, unless the post was edited before I saw it .. what I do do though, is disable tapping. I have a clickable touchpad on this machine & it's the first machine I've had with a useable one.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Two ROMS don't make a WRITE ...
User avatar
Mick-Cork
Level 4
Level 4
Posts: 318
Joined: Sun Mar 23, 2014 10:10 pm
Location: West Cork & London

Re: Disable the touchpad

Post by Mick-Cork »

I guess it varies from machine to machine, but I found turning off 'Tap to click' and disabling touchpad while typing works well for me (Dell Latitude).
Prior to that it was driving me nuts (especially the tap to click). Now I don't even think about it as there never seems to be any random effects. The touchpad doesn't react to the bottom of my hand or the base of my thumb should either slide over the touchpad whilst doing something else.

If you're using a mouse it probably makes sense to completely disable the touchpad, but I'd also suggest trying the above as well just to see if you get a better result.
User avatar
AZgl1500
Level 14
Level 14
Posts: 5331
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Disable the touchpad

Post by AZgl1500 »

Lady Fitzgerald wrote:
Mon Aug 24, 2020 3:08 pm
I found AZgl1500's solution to work best. It's baked into Linux Mint Cinnamon so it will work with all computers. In addition to fully disabling or disabling while typing (I wasn't impressed with that option when I tried it), you can also set it to disable the stupid touchpad when a mouse is present (this can either be a wired mouse or the dongle for wireless mince).

I'm using that last option. As long as the wireless mouse dongle (specifically, a Logitech Unifying Receiver) is plugged in, the idiot touchpad is disabled. If I remove the dongle, the misbegotten touchpad is enabled. Plugging the dongle back in disables the moronic touchpad again.


Did I ever mention that I do not like touchpads?
I just figured that once you got to the TouchPad options, that you would set it up for the way you want to use it.

I use a LogiTech M510 mouse, and if I pull the Dongle out, the touchpad becomes active again.
Personal Preference, but once you had access to the menu, you can see all of the options.

. I figured out that you don't like Touch Pads real quick :)
I hate them, and my thumb keeps touching it when I type, and the mouse jumps to WTH and gone, destroying the story, because I am a touch typist and not watching the screen while I type.

.
Linux Mint 19.3 Cinnamon
User avatar
AZgl1500
Level 14
Level 14
Posts: 5331
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Disable the touchpad

Post by AZgl1500 »

BG405 wrote:
Mon Aug 24, 2020 4:42 pm
He didn't mention that, unless the post was edited before I saw it .. what I do do though, is disable tapping. I have a clickable touchpad on this machine & it's the first machine I've had with a useable one.
I quite often edit before I leave that thread,

but I think that this was in my original post

OR,
you can configure the Touchpad to be Disabled While Typing.

your choice.
Linux Mint 19.3 Cinnamon
Hoser Rob
Level 16
Level 16
Posts: 6842
Joined: Sat Dec 15, 2012 8:57 am

Re: Disable the touchpad

Post by Hoser Rob »

Disabling the touchpad when the keyboard is being used is the simplest way, it's always worked for me ... actually it's one of the first things I do after a fresh install. If it doesn't work I'd suspect a problem with the touchpad driver. That happened once with me but I suspect it'd be rare.
User avatar
BG405
Level 8
Level 8
Posts: 2382
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Disable the touchpad

Post by BG405 »

AZgl1500 wrote:
Tue Aug 25, 2020 2:30 am
OR,
you can configure the Touchpad to be Disabled While Typing.

your choice.
I was referring to the bit ablut having the trackpad disabled when a mouse is plugged in. ;) (there's no edit note below the post).
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Two ROMS don't make a WRITE ...
Post Reply

Return to “Newbie Questions”