Installing Displaylink gives error on LM20

Quick to answer questions about finding your way around Linux Mint as a new user.
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
larlar
Level 1
Level 1
Posts: 9
Joined: Fri Apr 24, 2020 5:26 pm

Installing Displaylink gives error on LM20

Post by larlar »

Hi,

I'm trying to install Displaylink with LM 20 but I get an error. I downloaded the latest driver for Ubuntu.

I give the command: sudo ./displaylink-driver-5.3.1.34.run
And the response I get is this:

Verifying archive integrity... 100% All good.
Uncompressing DisplayLink Linux Driver 5.3.1.34 100%
DisplayLink Linux Software 5.3.1.34 install script called:
Distribution discovered: Linux Mint 20

Installing

[ Installing EVDI ]
[[ Installing EVDI DKMS module ]]
Error! DKMS tree already contains: evdi-1.7.0
You cannot add the same module/version combo more than once.
EVDI DKMS module already installed.
[[ Installing module configuration files ]]
[[ Installing EVDI library ]]
cc -I../module -std=gnu99 -fPIC -c -o evdi_lib.o evdi_lib.c
In file included from evdi_lib.c:5:
/usr/lib/gcc/x86_64-linux-gnu/9/include/stdint.h:9:16: fatal error: stdint.h: No such file or directory
9 | # include_next <stdint.h>
| ^~~~~~~~~~
compilation terminated.
make: *** [<builtin>: evdi_lib.o] Error 1
ERROR: Failed to build evdi/5.3.1.34 library.

It ends with an error.

Any suggestions anyone?

Thanks!!
User avatar
Kadaitcha Man
Level 16
Level 16
Posts: 6102
Joined: Mon Aug 27, 2012 10:17 pm

Re: Installing Displaylink gives error on LM20

Post by Kadaitcha Man »

larlar wrote:
Sat Jul 04, 2020 10:03 am
I give the command: sudo ./displaylink-driver-5.3.1.34.run
And the response I get is this:

Code: Select all

Error! DKMS tree already contains: evdi-1.7.0
You cannot add the same module/version combo more than once.
Any suggestions anyone?
https://displaylink.org/forum/index.php ... cec1866726

You might have better luck there. I can't offer more advice because you haven't provided the link to the download page or to what instructions you were following. On the surface of it, it looks like a problem with the installation script. If that's true, there's really nothing anyone here can do.
[*] All kadaitcha men are liars
larlar
Level 1
Level 1
Posts: 9
Joined: Fri Apr 24, 2020 5:26 pm

Re: Installing Displaylink gives error on LM20

Post by larlar »

I followed the instructions on the Displaylink homepage, I could have been more clear on that one...

I saw that a lot of people running LM had been successful in installing it so I thought I would try this forum. I will do a second attempt on the Displaylink forum.

Since I'm new to Linux it's not obvious if I'm doing something wrong. I followed the instructions but it did not work. Is it my fault or the installer...

Thank you for taking the time to respond!
Adrien
Level 1
Level 1
Posts: 2
Joined: Tue Jul 07, 2020 6:14 am

Re: Installing Displaylink gives error on LM20

Post by Adrien »

Hi,
I have a new computer for my work and they bought me Dock Station D6000. When connecting it by following the same method as posted. I got exactly the same error :

[ Installing EVDI ]
[[ Installing EVDI DKMS module ]]
Error! DKMS tree already contains: evdi-1.7.0
You cannot add the same module/version combo more than once.
EVDI DKMS module already installed.

I first tried with DKMS installed, then a second try without anything installed (purge of DKMS package), etc. I tried all combinations but there is still this error.

I am not familiar with Ubuntu and I can't see what is the problem.

Thanks,
User avatar
Kadaitcha Man
Level 16
Level 16
Posts: 6102
Joined: Mon Aug 27, 2012 10:17 pm

Re: Installing Displaylink gives error on LM20

Post by Kadaitcha Man »

larlar wrote:
Sun Jul 05, 2020 11:47 am
Since I'm new to Linux it's not obvious if I'm doing something wrong.
The version number for your download supports Ubuntu 20.04, which is likely not going to work unless you have Linux Mint 20. If you have LM 19.x, you need Ubuntu 19.04, 18.04, 16.04 | Release: 5.2 08 Jul 2019.
[*] All kadaitcha men are liars
Adrien
Level 1
Level 1
Posts: 2
Joined: Tue Jul 07, 2020 6:14 am

Re: Installing Displaylink gives error on LM20

Post by Adrien »

I have the same error but versions seems good, here is all the install message:

sudo ./displaylink-driver-5.3.1.34.run

Verifying archive integrity... 100% All good.
Uncompressing DisplayLink Linux Driver 5.3.1.34 100%
DisplayLink Linux Software 5.3.1.34 install script called:
Distribution discovered: Ubuntu 20.04 LTS

Installing

[ Installing EVDI ]
[[ Installing EVDI DKMS module ]]
Error! DKMS tree already contains: evdi-1.7.0
You cannot add the same module/version combo more than once.
EVDI DKMS module already installed.
[[ Installing module configuration files ]]
[[ Installing EVDI library ]]
cc -I../module -std=gnu99 -fPIC -c -o evdi_lib.o evdi_lib.c
cc evdi_lib.o -shared -Wl,-soname,libevdi.so.0 -o libevdi.so.1.7.0 -lc -lgcc
cp libevdi.so.1.7.0 libevdi.so
[ Installing x64-ubuntu-1604/DisplayLinkManager ]
[ Installing libraries ]
[ Installing firmware packages ]
[ Installing licence file ]
[ Adding udev rule for DisplayLink DL-3xxx/4xxx/5xxx/6xxx devices ]
[ Adding upstart and powermanager sctripts ]

Please read the FAQ
http://support.displaylink.com/knowledg ... ing-ubuntu

Installation complete!

Please reboot your computer if intending to use Xorg.

###############################################################

My release is :

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04 LTS
Release: 20.04
Codename: focal

##############################################################

Even if it says that the installation is complete. Keyboard and mouse are working but not monitors and display.

Maybe a link with Xorg ?

Thanks for the time you take yo reply,

Adrien
yodes
Level 1
Level 1
Posts: 1
Joined: Sun Aug 30, 2020 10:24 pm

Re: Installing Displaylink gives error on LM20

Post by yodes »

Hello,

I had this same error and was able to resolve it by first running: sudo apt-get install libc6-dev

Hope this helps!
foghoud
Level 1
Level 1
Posts: 1
Joined: Mon Sep 14, 2020 11:47 am

Re: Installing Displaylink gives error on LM20

Post by foghoud »

Yodes, thanks for post, I tried your fix when seeing the same DisplayLink driver installation problem and it worked.
Big :D
Post Reply

Return to “Beginner Questions”