[SOLVED] Dual Boot system boots straight into Windows 10

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
bigal
Level 4
Level 4
Posts: 337
Joined: Mon Aug 03, 2009 3:26 am
Location: Pembrokeshire, South West Wales

Re: Dual Boot system boots straight into Windows 10

Post by bigal »

I’m sorry if I was unclear. What I meant was just open a terminal and type the command. Anyway, the output you have listed is what I was asking for so one way or another you got there. Well done.

The entry ‘GRUB_DEFAULT=0’ is the boot order. Changing the ‘0’ to ‘1’ should put the second OS, Mint, as the one the M/C boots into by default.

From a terminal after the $ type

Code: Select all

sudo xed /etc/default/grub
After entering you password make the change then save the file and exit.

Next, again from the $ prompt run

Code: Select all

sudo update-grub
That will update all the hidden workings of GRUB with the change you have made.

By the way, you are correct in stating that the ‘GRUB_TIMEOUT=10’ is the number of seconds GRUB is desplayed before booting the default option. I have mine set to 15 as it gives a little longer to read all the options. Personal preference here. As I said before hashing out the ‘GRUB_TIMEOUT_STYLE=hidden’ line sdhould cause GRUB to appear ever time.

Whenever you make changes to GRUB you must always run

Code: Select all

sudo update-grub
after to make the changes take effect.

If you are happy with the outcome of this – or any post you have started – please edit your initial entry and ad SOLVED to the heading.

Cheers

bigal
Lots of Minty machines but there again I like lamb and I do live in Wales!
Kurogane
Level 1
Level 1
Posts: 17
Joined: Sun Sep 13, 2020 8:56 am
Location: Russia, Moscow

Re: Dual Boot system boots straight into Windows 10

Post by Kurogane »

bigal wrote:
Mon Sep 14, 2020 4:31 pm
The entry ‘GRUB_DEFAULT=0’ is the boot order. Changing the ‘0’ to ‘1’ should put the second OS, Mint, as the one the M/C boots into by default.

From a terminal after the $ type

Code: Select all

sudo xed /etc/default/grub
After entering you password make the change then save the file and exit.

Next, again from the $ prompt run

Code: Select all

sudo update-grub
That will update all the hidden workings of GRUB with the change you have made.

If you are happy with the outcome of this – or any post you have started – please edit your initial entry and ad SOLVED to the heading.

Cheers

bigal
Thanks for your advice, but this doesn't fix the issue, I booted into W10 on restart as always. I'm sure I did update the grub after, so this shouldn't be the problem, though I will try this again tomorrow, as it is too late now.

Also, after searching the Internet, there seem to be a lot of threads similar to mine, especially on this forum. The thing is, I mentioned that I use a Lenovo AIO PC and it has InsydeH20 BIOS (not sure which revision that is, though). It seems that the issue is this exact BIOS limitations, so there might be no solution for my problem. The model of the AIO is Lenovo S20-00. I already tried to get some help on Lenovo forum back in the day, but had no luck, though this was related to another issue. I'm not sure where to search and where to get help on this, that model is not very popular in costumer market in my opinion, and most of the businesses buying those in bulk, usually won't be scratching their heads around dual booting Mint on it :D

It seems related to InsydeH20 BIOS, with no way to make it work on Lenovo, as far as I know. On this forum I found some HP laptop threads with the same BIOS utility and the solution there was to press esc on restart, which would allow to enter boot manager settings. The esc on start won't show any debug options for my PC.
I also found some Acer cases, and there the option was to add supervisor password, which would unlock advanced options, such as adding UEFI file as trusted for executing, which is probably the solution mr_raider suggested. No luck for me there too, as adding admin password in my bios settings didn't unlock any new option

With all that being said, I'm still open for suggestions, and willing to experiment, though, if there is nothing else to do, all I can do is, to thank everyone for putting effort. 8)
bigal
Level 4
Level 4
Posts: 337
Joined: Mon Aug 03, 2009 3:26 am
Location: Pembrokeshire, South West Wales

Re: Dual Boot system boots straight into Windows 10

Post by bigal »

Hi Kurogane,

I’m sorry that none of my ideas worked for you. There is nothing else I can suggest I’m afraid. BIOS settings are way above my league, not helped by your machine being UEFI.

I wish you luck and hope that you can get where you want to be.

bigal
Lots of Minty machines but there again I like lamb and I do live in Wales!
pbear
Level 14
Level 14
Posts: 5441
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Dual Boot system boots straight into Windows 10

Post by pbear »

Kurogane wrote:
Mon Sep 14, 2020 6:59 pm
... I'm still open for suggestions, and willing to experiment ...
Ahem, I told you Grub wasn't going to solve the problem. Did you ever try the bcdedit solution?

Alternatively, there's the trick I mentioned earlier. On my HP with Insyde UEFI, I had success with this workaround from Unix & Linux. Basically, you leave Windows in first position in NVRAM, but deactivate it. These commands should do it on your system:

Code: Select all

sudo efibootmgr --bootnum 0000 --inactive
sudo efibootmgr --bootorder 0000,0001,2001,2002,2003
Note: To reverse this at some future date, run sudo efibootmgr --bootnum 0000 --active. Alternatively, at a Windows Command Prompt (or in Power Shell), run bcdboot C:\Windows (which reinstalls the boot loader, restoring its NVRAM entry).

A third option would be to create a rEFInd USB flash drive and boot from that. Other options are discussed in that thread, as well.
Kurogane
Level 1
Level 1
Posts: 17
Joined: Sun Sep 13, 2020 8:56 am
Location: Russia, Moscow

Re: Dual Boot system boots straight into Windows 10

Post by Kurogane »

pbear wrote:
Tue Sep 15, 2020 11:10 am
Ahem, I told you Grub wasn't going to solve the problem. Did you ever try the bcdedit solution?
Yes, I did! I posted the results earlier, but I guess, it wasn't relevant to further work on the issue. bcdedit shows grubx64.efi as path, but the PC still restarts into W10.
Kurogane wrote:
Mon Sep 14, 2020 6:06 am
pbear wrote:
Sun Sep 13, 2020 10:20 pm
Try changing boot order with efibootmgr. If that doesn't stick, the Windows way to do this is bcdedit. At a command prompt:

Code: Select all

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
So, I tried this command, restarted the PC, and still booted into W10. I've ran it again, just to make sure, here's the output, it seems the change is intact, it just doesn't work:

Code: Select all

Диспетчер загрузки Windows                                                                                              
--------------------                                                                                                    
идентификатор           {bootmgr}                                                                                       
device                  partition=\Device\HarddiskVolume2                                                               
path                    \EFI\ubuntu\grubx64.efi                                                                         
description             Windows Boot Manager                                                                            
locale                  ru-RU                                                                                          
inherit                 {globalsettings}                                                                                
default                 {current}                                                                                       
resumeobject            {9edca4b1-d4e1-11ea-9d40-b2cbe5551ded}                                                          
displayorder            {current}                                                                                       
toolsdisplayorder       {memdiag}                                                                                       
timeout                 30  
pbear wrote:
Tue Sep 15, 2020 11:10 am
Alternatively, there's the trick I mentioned earlier. On my HP with Insyde UEFI, I had success with this workaround from Unix & Linux. Basically, you leave Windows in first position in NVRAM, but deactivate it. These commands should do it on your system:

Code: Select all

sudo efibootmgr --bootnum 0000 --inactive
sudo efibootmgr --bootorder 0000,0001,2001,2002,2003
Note: To reverse this at some future date, run sudo efibootmgr --bootnum 0000 --active. Alternatively, at a Windows Command Prompt (or in Power Shell), run bcdboot C:\Windows (which reinstalls the boot loader, restoring its NVRAM entry).

A third option would be to create a rEFInd USB flash drive and boot from that. Other options are discussed in that thread, as well.
Thanks, I will try these methods and post on the result.
pbear
Level 14
Level 14
Posts: 5441
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Dual Boot system boots straight into Windows 10

Post by pbear »

Kurogane wrote:
Tue Sep 15, 2020 5:37 pm
Yes, I did! I posted the results earlier, but I guess, it wasn't relevant to further work on the issue.
The way I read your post, you had deferred bcdedit and tried something else. Anyhoo, as you did try it, time to escalate to inactivating the Windows boot loader while leaving it nominally in first position. That's what I do on my obstreperous HP. If it doesn't work, a rEFInd-installed flash drive almost certainly will. We know it will work because you were able to boot a live session from USB (right?).
User avatar
Pierre
Level 20
Level 20
Posts: 10731
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Dual Boot system boots straight into Windows 10

Post by Pierre »

it would seem that the Dual_Boot scenario for my HP G6 Pavilion,
is no more, after an win-10 update, last year.
:roll:

thus I've having to press the F9 key, on start-up, to get the Linux Boot Menu,
& where there is still an option, to boot into either system.

if that F9 is not pressed, then the HP machine will boot straight into the Windows System.

so, is there such an key function on that AIO machine :?:
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
mr_raider
Level 7
Level 7
Posts: 1876
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: Dual Boot system boots straight into Windows 10

Post by mr_raider »

Kurogane wrote:
Mon Sep 14, 2020 8:38 am
mr_raider wrote:
Mon Sep 14, 2020 6:35 am
Go to your BIOS and turn secure boot back on. See if you can add shimx64.efi as a trusted bootloader.
Sorry, could you explain further if I need to do all of this in BIOS settings? I tried turning on secure boot, it boots me right into W10 again, but I booted Mint using boot menu, it started to lag though, so I disabled secure boot. Everything I have in BIOS on secure boot:
https://pasteboard.co/Jr2nGi9.jpg
bigal wrote:
Mon Sep 14, 2020 7:21 am
The GRUB menu should appear if you press and hold Shift during the time when Grub should be loading. Use this if you boot using BIOS. If your system boots using UEFI, press Esc. Don’t worry if you are unsure when GRUB is actually loading. Boot into Mint in whatever way you can then make changes as detailed below.

For a permanent change you'll need to edit your /etc/default/grub file. To do this go to a Mint terminal and type sudo xed /etc/default/grub. (xed is the default text editor in Mint 20) Once there look for the line GRUB_HIDDEN_TIMEOUT=0 and place a hash (#) at the start of the line. If you want the GRUB menu to display for, lets say 10 seconds don’t put the hash there but change the 0 (zero) to 10.

To change the boot order go to /etc/default/grub and look for the line GRUB_DEFAULT=0 and change it to GRUB_DEFAULT=n where n is the number of the OS you want to have first in the list. NOTE that the numbering starts from 0 (zero).

Once you have made all the changes suggested above run sudo update-grub then reboot. Hopefully the GRUB menu will appear and the Mint OS will be the default.
Hi! So I opened the grub file as you mentioned, and I have some questions on the steps you provided. Firstly, I only have GRUB_TIMEOUT_STYLE=hidden and GRUB_TIMEOUT=10, in my file, and if I'm not mistaken, that settings refer to how long GRUB will stay before automatically choosing an option? When I use boot menu, GRUB starts and the timer counts if I don't press any button, so should I really change those settings now? I don't really mind that timer, but should I change it to see if I can get GRUB to boot by default?

So, I also have the GRUB_DEFAULT=0 line. How can I figure what number should I put there? Are the numbers from efibootmgr related to those for grub file? Otherwise, please elaborate where to get the correct numbers, I have no idea :(
The short version is that although your BIOS can boot non Windows OSes, it refuses to honor the boot priority set by efibootmgr. The only solution, if possible is to manually set a new boot order in BIOS. Whether you can do this, and how it can be done is dependent on how your BIOS is configured by Lenovo.

This is a Lenovo specific BIOS problem. I suggest you take it to Lenovo forums or boards.

If that does not work, we can try to install refind within Linux.

https://www.rodsbooks.com/refind/installing.html
Image
Kurogane
Level 1
Level 1
Posts: 17
Joined: Sun Sep 13, 2020 8:56 am
Location: Russia, Moscow

Re: Dual Boot system boots straight into Windows 10

Post by Kurogane »

pbear wrote:
Tue Sep 15, 2020 11:10 am
Alternatively, there's the trick I mentioned earlier. On my HP with Insyde UEFI, I had success with this workaround from Unix & Linux. Basically, you leave Windows in first position in NVRAM, but deactivate it. These commands should do it on your system:

Code: Select all

sudo efibootmgr --bootnum 0000 --inactive
sudo efibootmgr --bootorder 0000,0001,2001,2002,2003
Note: To reverse this at some future date, run sudo efibootmgr --bootnum 0000 --active. Alternatively, at a Windows Command Prompt (or in Power Shell), run bcdboot C:\Windows (which reinstalls the boot loader, restoring its NVRAM entry).

A third option would be to create a rEFInd USB flash drive and boot from that. Other options are discussed in that thread, as well.
Thank you, pbear! The method that worked for me is creating a rEFInd drive and giving it boot priority in BIOS. There is no visible delay whatsoever, so I might go with this solution for the moment. Didn't went far from just entering boot menu at every startup, but rEFInd seems like a powerful tool, and I wonder if I could get it to somehow boot Mint by default instead of giving me options, though that may go against the purpose of the program and may be a bit out of scope of this thread. Still, the result is there, and I can maybe optimize it by checking out the FAQ later. Thanks a lot!

On the other hand, I tried making Windows Boot Manager inactive in the efibootmgr, but I still booted into Windows that way, and after restarting into Mint once again, all the changes in the efibootmgr are overwritten. I wonder if the fact that I have few more Windows Boot Managers listed in the order affects that - I have Windows Boot Manager also as entry 0003 and 0004. The thing that surprised me, is the fact, that when I did the changes to the boot order, W10 booted a LOT faster than usual, it was really noticeable. I tried to get such boot speed again when I first tried the efibootmgr method but I failed, and trying once again today my Windows booted a lot faster. Unrelated to the actual thread, I wonder what could cause such thing, and if it's possible to make Windows always behave like that :D

Pierre wrote:
Tue Sep 15, 2020 11:21 pm
it would seem that the Dual_Boot scenario for my HP G6 Pavilion,
is no more, after an win-10 update, last year.
:roll:

thus I've having to press the F9 key, on start-up, to get the Linux Boot Menu,
& where there is still an option, to boot into either system.

if that F9 is not pressed, then the HP machine will boot straight into the Windows System.

so, is there such an key function on that AIO machine :?:
Hi! Yes, that is the method I was using all this time since installing Mint on my computer. I enter boot menu by pressing F11 on every startup and from there I can either load Grub or Windows. In the beginning, I was using Windows more, so that was ok. Now, I use Mint more and more as the primary system, and I was wondering if I can automate the boot process a bit.
mr_raider wrote:
Wed Sep 16, 2020 7:33 am
The short version is that although your BIOS can boot non Windows OSes, it refuses to honor the boot priority set by efibootmgr. The only solution, if possible is to manually set a new boot order in BIOS. Whether you can do this, and how it can be done is dependent on how your BIOS is configured by Lenovo.

This is a Lenovo specific BIOS problem. I suggest you take it to Lenovo forums or boards.

If that does not work, we can try to install refind within Linux.

https://www.rodsbooks.com/refind/installing.html
Yes, I understand. I've already posted on Lenovo forum, and I might get some help on unlocking advanced BIOS options, I think if it is possible to unlock boot manager options on my machine, like choosing the trusted exec method mentioned in Acer laptop thread, that would be the best solution. Also, by installing rEFInd in Linux, do you mean the flash drive method? Or actually installing it on the PC? If we were to install it on the hard drive, could we make it boot by default with the current BIOS limitations, if I can't make Mint boot by default, for example? That's the idea that came to my mind, when I wondered about the rEFInd install.

Once again, thank you guys for your help! I will mark the topic as solved 8)

UPDATE: I was able to edit rEFInd config, so now I have it automatically booting up GRUB, and otherwise, I can always press the number on keyboard matching Windows Boot Manager when rEFInd loads up for it to boot Windows. Everything is working as it should when booting from rEFInd USB. Thanks again pbear
pbear
Level 14
Level 14
Posts: 5441
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: [SOLVED] Dual Boot system boots straight into Windows 10

Post by pbear »

Glad you got it working and found the config file. To answer the question about installing rEFInd to the internal drive, I don't think it will work. I'd expect that to be trapped by the same problem which keeps Grub from working, i.e., that Windows will trump both in NVRAM. By the way, I don't know what size flash drive you used, but if large, you can put another partition on it and use for something else, Timeshift backups, for example.

The real solution will be figuring out how to get into the Lenovo firmware settings. Failing that, if you remove the superfluous Windows entries from NVRAM with bcdedit, I bet you could get the Unix & Linux solution to work.
mr_raider
Level 7
Level 7
Posts: 1876
Joined: Sun Jun 20, 2010 9:50 am
Location: Montreal, QC

Re: [SOLVED] Dual Boot system boots straight into Windows 10

Post by mr_raider »

It may work to install refind directly within Mint. Install Rod smith's PPA and just sudo apt install the program.

Refind has several bootloaders, including a fallback bootloader that simulates the .efi file from a USB key. That seems to be the only non windows device you can boot successfully.

OTOH if you have a working solution, leave it as is.

Note to self: stay away from newer Lenovo laptops.
Image
bendipa
Level 2
Level 2
Posts: 98
Joined: Sat Jan 04, 2020 8:02 pm

Re: [SOLVED] Dual Boot system boots straight into Windows 10

Post by bendipa »

The problem you've had dual booting with Linux (always booting into W10 regardless of UEFI configuration) is a common issue with certain machines. Some manufacturers, eg Acer and HP have their own unique ways of how to configure UEFI for dual booting. With Acer you have to set a Supervisor password on your BIOS before it will let you boot to a system other than Windows. Some HP laptops cause similar issues, but so far I haven't come across a solution that seems to work in their case. There may well be one, but I don't own an HP so can't try things out.

I have a Dell PC, and although I never had an issue dual booting Win 7 with Linux, I did start to have one once I upgraded to Win 10. It just booted straight to it. Using efibootmgr worked temporarily in so far as the grub menu appeared and I could choose either system. As long as I kept choosing Linux a reboot would always give me a grub menu. But if I chose Win 10 I would boot to it, but from then on the Dell would always boot straight to it - no grub. Furthermore, once that happened, if I brought up the UEFI menu as an alternative means of booting, the Linux choice was now missing. The only way to restore grub at the time was to boot to Live Mint (on my USB) and apply the efibootmgr device order, but again as soon as I chose Win 10 from grub it was back to square one.

I then discovered 2 different ways of resolving the problem for good. The first was to use the bcdedit command in Win10, but I used bcdedit /set {bootmgr} path "\EFI\ubuntu\shimx64.efi" (you can omit quotes). I was using Ubuntu at the time so you need to ensure that path is correct to find shimx64. That took me straight to grub menu every time. If I brought up the UEFI menu instead it still showed just Windows as a choice, but that still took me to grub menu on selection, and I could boot to either system without the Win10 issue recurring.

The second method was to revert bcdedit back to its default path - '\EFI\Microsoft\Boot\bootmgfw.efi'. The issue then returned. What I did then was to change UEFI mode to Legacy mode (CFM). When I rebooted I got a disk error as it's formatted to GPT so Windows could no longer read it in Legacy. I then entered UEFI and changed back to UEFI mode (and saved). This time I got a grub menu. I then had to boot Linux at least a couple of times in succession. Once I did that, even if I chose Win 10 afterwards it no longer booted automatically to it. And UEFI boot menu always shows Windows and Linux separately. I could now boot to either from there also without a recurrence of the previous issue.
Computer: Dell Vostro 470
Systems: Linux Mint 19.3, Ubuntu 18.04, Windows 10 (1909), Windows 7 Pro
Kurogane
Level 1
Level 1
Posts: 17
Joined: Sun Sep 13, 2020 8:56 am
Location: Russia, Moscow

Re: [SOLVED] Dual Boot system boots straight into Windows 10

Post by Kurogane »

pbear wrote:
Wed Sep 16, 2020 12:10 pm
Glad you got it working and found the config file. To answer the question about installing rEFInd to the internal drive, I don't think it will work. I'd expect that to be trapped by the same problem which keeps Grub from working, i.e., that Windows will trump both in NVRAM. By the way, I don't know what size flash drive you used, but if large, you can put another partition on it and use for something else, Timeshift backups, for example.

The real solution will be figuring out how to get into the Lenovo firmware settings. Failing that, if you remove the superfluous Windows entries from NVRAM with bcdedit, I bet you could get the Unix & Linux solution to work.
Yes, this is exactly the thought that came to my mind, about rEFInd not booting just like Grub. I used to have bootable Mint image on the USB. It's not high capacity, so I don't think something else would fit there, though would be good to make it also contain Mint image just in case, I'll try to do this later.

And, could you, by any chance, provide me some info or a link on removing Windows boot entry? Will I be able to boot it from rEFInd if I do it? Not a big issue, if Windows won't boot as a result, need to learn how to fix that as well. I never had issues with Windows boot record for all these years of using a PC :lol:, I'm kinda curious, honestly.
mr_raider wrote:
Wed Sep 16, 2020 1:01 pm
It may work to install refind directly within Mint. Install Rod smith's PPA and just sudo apt install the program.

Refind has several bootloaders, including a fallback bootloader that simulates the .efi file from a USB key. That seems to be the only non windows device you can boot successfully.

OTOH if you have a working solution, leave it as is.

Note to self: stay away from newer Lenovo laptops.
Yes, I want to install rEFInd on disk at some point later to try, I just been very busy, and didn't do anything with my PC. I'm waiting for an answer on Lenovo forum as well, so I'll see what's up there as well. By the way, my computer is not from recent Lenovos, I suppose. It is probably released around 2014, at least that's the year I got it. Judging by the other post I saw here, should rather stay away from most laptops. As far as I can tell, I never heard about issues on ASUS and MSI devices :roll:
bendipa wrote:
Wed Sep 16, 2020 1:23 pm
The problem you've had dual booting with Linux (always booting into W10 regardless of UEFI configuration) is a common issue with certain machines. Some manufacturers, eg Acer and HP have their own unique ways of how to configure UEFI for dual booting. With Acer you have to set a Supervisor password on your BIOS before it will let you boot to a system other than Windows. Some HP laptops cause similar issues, but so far I haven't come across a solution that seems to work in their case. There may well be one, but I don't own an HP so can't try things out.

I have a Dell PC, and although I never had an issue dual booting Win 7 with Linux, I did start to have one once I upgraded to Win 10. It just booted straight to it. Using efibootmgr worked temporarily in so far as the grub menu appeared and I could choose either system. As long as I kept choosing Linux a reboot would always give me a grub menu. But if I chose Win 10 I would boot to it, but from then on the Dell would always boot straight to it - no grub. Furthermore, once that happened, if I brought up the UEFI menu as an alternative means of booting, the Linux choice was now missing. The only way to restore grub at the time was to boot to Live Mint (on my USB) and apply the efibootmgr device order, but again as soon as I chose Win 10 from grub it was back to square one.

I then discovered 2 different ways of resolving the problem for good. The first was to use the bcdedit command in Win10, but I used bcdedit /set {bootmgr} path "\EFI\ubuntu\shimx64.efi" (you can omit quotes). I was using Ubuntu at the time so you need to ensure that path is correct to find shimx64. That took me straight to grub menu every time. If I brought up the UEFI menu instead it still showed just Windows as a choice, but that still took me to grub menu on selection, and I could boot to either system without the Win10 issue recurring.

The second method was to revert bcdedit back to its default path - '\EFI\Microsoft\Boot\bootmgfw.efi'. The issue then returned. What I did then was to change UEFI mode to Legacy mode (CFM). When I rebooted I got a disk error as it's formatted to GPT so Windows could no longer read it in Legacy. I then entered UEFI and changed back to UEFI mode (and saved). This time I got a grub menu. I then had to boot Linux at least a couple of times in succession. Once I did that, even if I chose Win 10 afterwards it no longer booted automatically to it. And UEFI boot menu always shows Windows and Linux separately. I could now boot to either from there also without a recurrence of the previous issue.
Yes, I already found that posts on this forum about Acer and HP laptops, none of the provided solutions work for Lenovo, though. I used the bcdedit solution you provided as it is pretty easy to do, but it didn't change anything, though using shimx64.efi instead of grubx64.efi made sense to me at first, because I've read about its relation to Secure Boot etc. The other option you mentioned, could you elaborate more? You just switched to Legacy in BIOS, couldn't boot the OS, then switched back and it worked?
pbear
Level 14
Level 14
Posts: 5441
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: [SOLVED] Dual Boot system boots straight into Windows 10

Post by pbear »

A few thoughts, foregoing the quote function.

1. Generally speaking, you can't have two bootable things on the same USB drive. The firmware has no way to sort out the conflict.

2. I meant removing the superfluous entries with bcdedit, the expectation being that only one of the Windows entries is hard coded. Sounds like you already know how it works. For more info, see here and here.

3. If you mangle the Windows boot loader, the simple fix is to reinstall it. At a Command Prompt, run bcdboot C:\Windows. This reinstalls the boot loader from a backup copy stored at \Windows\System32\Config\BCD-Template. Reference.

Considering we're on a Mint forum, that's probably as much Windows support as I should do. :)
Post Reply

Return to “Installation & Boot”