Linux mint not shutting down with NVidia GeForce GTX1070

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
KingTChoka
Level 1
Level 1
Posts: 6
Joined: Mon Sep 14, 2020 5:36 pm

Linux mint not shutting down with NVidia GeForce GTX1070

Post by KingTChoka »

I have GeForce GTX 1070 installed with my windows 10, and when I've dual booted with Linux Mint 20, and I'm unable to shut down my machine (from linux). I've tried switching driver's to all the different editions, but they all produce the same error. When I click shut off, I'm stuck at this 'end kernel panic' error.
Photo details --> https://drive.google.com/drive/folders/ ... sp=sharing
Any advice?
Thanks!
Last edited by KingTChoka on Tue Sep 15, 2020 9:57 am, edited 1 time in total.
tinca
Level 5
Level 5
Posts: 580
Joined: Sun Jan 11, 2009 9:23 am
Location: England U.K.

Re: Linx mint not shutting down with NVidia GeForce GTX1070

Post by tinca »

HI,
I have a GTX 1070 and my drive manager is running the Nvidia-Driver-440 Recommended. This runs OK

best regards Keith
KingTChoka
Level 1
Level 1
Posts: 6
Joined: Mon Sep 14, 2020 5:36 pm

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by KingTChoka »

@tinca I tried using the nvidia-driver-440-server as one of my options but it still causes the crash in the second photo. Perhaps you have a different 440 driver? If so, do you know how I can get the specific version you have?

Thanks
tinca
Level 5
Level 5
Posts: 580
Joined: Sun Jan 11, 2009 9:23 am
Location: England U.K.

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by tinca »

Post by KingTChoka ,

I am running Cinnamon 20, and from my Menu I simply go to Control panel/System setting and at the bottom of the screen is Driver Manager. When I open Driver Manager it updates Cache. The top of the list is Nvidia-Driver-440 recommended. It is not the server one that shows at the bottom of your list. Make sure that when you open the drive manager and put in your password it refreshes the cache.
User avatar
SMG
Level 5
Level 5
Posts: 860
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by SMG »

Can you please give us information about your install by entering this command in a terminal:

Code: Select all

inxi -Fxxxrz
Enclose the results between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply. This will let us know how Mint sees your hardware.
LM20.0 Cinnamon
KingTChoka
Level 1
Level 1
Posts: 6
Joined: Mon Sep 14, 2020 5:36 pm

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by KingTChoka »

Code: Select all

System:    Kernel: 5.4.0-47-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7 wm: muffin 4.6.3 
           dm: LightDM 1.30.0 Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Desktop System: Alienware product: Alienware Aurora R6 v: 1.0.19 serial: <filter> Chassis: type: 3 
           serial: <filter> 
           Mobo: Alienware model: 07HV66 v: A00 serial: <filter> UEFI: Alienware v: 1.0.19 date: 02/11/2019 
CPU:       Topology: Quad Core model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 67200 
           Speed: 853 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 900 2: 900 3: 901 4: 900 5: 900 6: 901 7: 900 8: 900 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5912 
           Device-2: NVIDIA GP104 [GeForce GTX 1070] vendor: Dell driver: nvidia v: 450.66 bus ID: 01:00.0 chip ID: 10de:1b81 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:a2f0 
           Device-2: NVIDIA GP104 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f0 
           Sound Server: ALSA v: k5.4.0-47-generic 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 bus ID: 03:00.0 chip ID: 8086:3165 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell driver: alx v: kernel port: d000 
           bus ID: 04:00.0 chip ID: 1969:e0a1 
           IF: enp4s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.94 TiB used: 10.77 GiB (0.5%) 
           ID-1: /dev/sda vendor: Toshiba model: DT01ACA200 size: 1.82 TiB speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> 
           rev: AC70 scheme: GPT 
           ID-2: /dev/sdb vendor: SanDisk model: X400 M.2 2280 128GB size: 119.24 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 0012 scheme: GPT 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 bus ID: 00:17.0 chip ID: 8086.2822 
           rev: N/A 
Partition: ID-1: / size: 335.15 GiB used: 10.76 GiB (3.2%) fs: ext4 dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 32 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-focal.list 
           1: deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://muug.ca/mirror/linuxmint/packages ulyana main upstream import backport
           2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:      Processes: 261 Uptime: 1m Memory: 15.54 GiB used: 1.16 GiB (7.4%) Init: systemd v: 245 runlevel: 5 Compilers: 
           gcc: 9.3.0 alt: 9 Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 
I even ran

Code: Select all

 sudo apt install nvidia-driver-440 
but no updates to the drivers, as even the software manager you can see that 'nvidia-driver-440' points to version 450 which is what I currently have and that doesn't work :'(
User avatar
SMG
Level 5
Level 5
Posts: 860
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by SMG »

The 450.66 driver is the one recommended for your card and it does appear that it is installed properly.

Graphics:
Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5912
Device-2: NVIDIA GP104 [GeForce GTX 1070] vendor: Dell driver: nvidia v: 450.66 bus ID: 01:00.0 chip ID: 10de:1b81
Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 direct render: Yes

There are a lot of items mentioned in the error message, so I wouldn't assume the Nvidia card is the problem. Is there a specific reason you think the Nvidia card is the problem?
LM20.0 Cinnamon
User avatar
SMG
Level 5
Level 5
Posts: 860
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by SMG »

This older Dell thread Kernel Panic comfirmed indicates, "This kernel panic also happens on the R7 as well, it's to do with the designware modules not being loaded."

The last post mentions a fix, but I don't know if that fix still applies with the kernel you have. I'm also not sure if the people who posted in that thread were dual-booting or not.
LM20.0 Cinnamon
User avatar
SMG
Level 5
Level 5
Posts: 860
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by SMG »

Here's a Reddit link Dell Aurora R6, Linux Mint and Shutdown Issues which mentions what I think is the same fix as the one in the prior link I posted. This person was dual booting and it was an earlier Mint version.

Here's a link from this forum Dell Aurora R6 dual boot How-To and issues I ran into. about the same shutdown problem, but a subsequent post indicates the issue is still around and the fix may no longer work. That last post indicated using a different kernel worked for them.

So it appears that many people with the Alienware Aurora hardware have the issue and it is not related to Nvidia, but with as many posts as I found, I'm sure someone has found a way to address it.
LM20.0 Cinnamon
KingTChoka
Level 1
Level 1
Posts: 6
Joined: Mon Sep 14, 2020 5:36 pm

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by KingTChoka »

@SMG Thank you so much for providing those links 🙏 ! I'll be sure to take a deeper dive and see if I can find a solution and mark this as solved 🤞
tinca
Level 5
Level 5
Posts: 580
Joined: Sun Jan 11, 2009 9:23 am
Location: England U.K.

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by tinca »

KingTChoka,

for what it is worth, mine shows

Code: Select all

System:
  Kernel: 5.4.0-472009090909-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 wm: muffin 4.6.3 dm: LightDM 1.30.0 
  Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop Mobo: Gigabyte model: Z97X-UD5H-BK v: x.x serial: <filter> 
  BIOS: American Megatrends v: F7 date: 04/21/2015 
CPU:
  Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 63857 
  Speed: 4390 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 4390 2: 4390 
  3: 4390 4: 4390 5: 4391 6: 4390 7: 4394 8: 4392 
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: eVga.com. driver: nvidia 
  v: 440.100 bus ID: 01:00.0 chip ID: 10de:1b81 
  Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1280x720~60Hz 
  OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
  direct render: Yes 
as you can see, I have a 1070 GPU and installed is the 440 driver. I can see that your first item under Graphics is your built in graphics on your CPU. My listing does not show my CPU graphics. I do remember when I first put the GPU in I did have some trouble with graphics and somewhere in my motherboard BIOS I disabled the onboard CPU graphics, and then everything has been working OK. Don't know if any of this is relevant to you

Best regards Keith
User avatar
SMG
Level 5
Level 5
Posts: 860
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux mint not shutting down with NVidia GeForce GTX1070

Post by SMG »

Today I was able to find a link with a current Ubuntu release.
This person found there were only problems on shutdown, but not upon reboot with an Alienware R7.
Kernel panic Ubuntu 20.04
No solution noted and the person filed a bug report.
LM20.0 Cinnamon
Post Reply

Return to “Hardware Support”