<SOLVED> Disable "check your video drives" *notification*

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
mallard
Level 1
Level 1
Posts: 6
Joined: Thu Oct 01, 2020 5:35 am

<SOLVED> Disable "check your video drives" *notification*

Post by mallard »

Hi,

I'm running Mint Cinnamon in a configuration where 3D acceleration simply isn't available (I don't think the details of exactly what configuration that is are relevant). I'm fine with that, software-rendered desktop performance is perfectly acceptable and I don't intend to run anything 3D.

Unfortunately, this means I get an obnoxious "Check your video drivers" notification every time I log in. It's annoying and serves no purpose. How do I disable it?
Last edited by mallard on Sat Oct 03, 2020 1:15 pm, edited 1 time in total.
Hoser Rob
Level 16
Level 16
Posts: 6938
Joined: Sat Dec 15, 2012 8:57 am

Re: Disable "check your video drives" *notification*

Post by Hoser Rob »

mallard wrote:
Thu Oct 01, 2020 5:40 am
... I don't intend to run anything 3D....
Cinnamon does, it need 3D hardware accelerated video just by itself. And ALL video playback involves "3D". The best cure is a clean reinstall o9f the Xfce or Mate version.

Also please paste the etxt output of inxi -Fxz run in the terminal.
mallard
Level 1
Level 1
Posts: 6
Joined: Thu Oct 01, 2020 5:35 am

Re: Disable "check your video drives" *notification*

Post by mallard »

Hoser Rob wrote:
Thu Oct 01, 2020 8:57 am
Cinnamon does, it need 3D hardware accelerated video just by itself. And ALL video playback involves "3D". The best cure is a clean reinstall o9f the Xfce or Mate version.
As previously stated, I am 100% happy with the performance of the desktop (including video playback, which works fine, not that I intend to use it much) in software mode.
Hoser Rob wrote:
Thu Oct 01, 2020 8:57 am
Also please paste the etxt output of inxi -Fxz run in the terminal.
Why do you need my system specs in order to tell me how to disable a warning message? I am not interested in "fixing" the issue it's warning me about. That's just not possible in my situation.

If you must know, the installation in a VM on a server that doesn't have a GPU worthy of being called that and is accessed over a remote connection. Even if there were some tiny benefit in using the server's "GPU" (According to what documentation there is, it likely wouldn't even be capable of supporting Cinnamon's hardware mode even if it were run directly on the hardware. Server "GPU"s simply aren't designed to be used for anything except basic system configuration.), it wouldn't be noticeable over the network anyway.
User avatar
SMG
Level 9
Level 9
Posts: 2884
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Disable "check your video drives" *notification*

Post by SMG »

I'm only aware of that notification coming up when the video drivers have not been installed properly. Therefore, the way to get rid of the notification is to have them installed properly. If you provide your system information as requested we may be able to help you do that.
LM20.1 Cinnamon
mallard
Level 1
Level 1
Posts: 6
Joined: Thu Oct 01, 2020 5:35 am

Re: Disable "check your video drives" *notification*

Post by mallard »

SMG wrote:
Thu Oct 01, 2020 10:08 am
I'm only aware of that notification coming up when the video drivers have not been installed properly.
The message appears whenever hardware 3D is not available, of course that includes situations where the drivers are not installed (properly), but also includes situations like mine where there are no such drivers to install*. It appeared before I'd even installed anything at all (except Mint itself) on the new VM.

* Technically, yes, since the VM is running under VirtualBox there are drivers that can enable 3D under a different configuration. VirtualBox does not support 3D acceleration for "headless" VMs like mine and certainly can't do any such thing when the host's hardware doesn't include a capable GPU.
User avatar
SMG
Level 9
Level 9
Posts: 2884
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Disable "check your video drives" *notification*

Post by SMG »

mallard wrote:
Fri Oct 02, 2020 5:27 am
It appeared before I'd even installed anything at all (except Mint itself) on the new VM.
Mint installs graphics device and display drivers as part of the installation. It is not a separate step in the installation process to install graphics drivers. There may be additional steps needed to get the most appropriate graphics drivers installed after the installation is complete, but the base graphics are supplied by the kernel during installation.

Without seeing your data which is information the rules of the forum ask posters to provide (see section 5 of READ: How To Get Help!) I do not know why you might be getting the message. I also do not know what you mean by the host not having a "capable gpu". Your definition of what is capable and Mint's might well be different.
LM20.1 Cinnamon
mallard
Level 1
Level 1
Posts: 6
Joined: Thu Oct 01, 2020 5:35 am

Re: Disable "check your video drives" *notification*

Post by mallard »

SMG wrote:
Fri Oct 02, 2020 9:44 am
Mint installs graphics device and display drivers as part of the installation. It is not a separate step in the installation process to install graphics drivers. There may be additional steps needed to get the most appropriate graphics drivers installed after the installation is complete, but the base graphics are supplied by the kernel during installation.
I know. Working drivers are installed. Nothing went wrong during installation. These drivers do not support 3D acceleration in this configuration, hence the warning. There is no way to change that fact that is compatible with my use-case for the system.
SMG wrote:
Fri Oct 02, 2020 9:44 am
Without seeing your data which is information the rules of the forum ask posters to provide (see section 5 of READ: How To Get Help!) I do not know why you might be getting the message. I also do not know what you mean by the host not having a "capable gpu". Your definition of what is capable and Mint's might well be different.
The only specs you need to be aware of are the specs of the VM. The host's hardware is irrelevant, since VMs do not have direct access to host hardware. The VM is a standard VirtualBox (6.1.14) VM running in "headless" mode. VirtualBox does not support 3D acceleration in "headless" VMs. So "my definition" of what's capable isn't even relevant. I could install the latest RX 5300 in the server and it wouldn't change the VM's specs one iota. I've attached the specs from inxi; note that the only "real" device shown in the CPU (and even then what you see is limited since the VM is only configured to use two cores/threads on what a Google search will tell you is a 6 core/12 thread physical CPU). Running a similarly-configured VM on any reasonably modern PC will give you the exact same output with the exception of the CPU ID.

Since you seem to have a morbid fascination with irrelevant facts, the host's "GPU" (which the VM has no access to) is an ATI (AMD) ES1000. That's a server chip that's closest consumer relatives were a range of budget graphics cards from the early 2000s (of course the server is much newer than that). Again, it's irrelevant, since even if it were capable of providing 3D acceleration to the VM, VirtualBox only supports 3D acceleration when the VM is run on a local graphical desktop, something that isn't (and won't be) even installed on the host.

Now can we please stop trying to "fix" the non-problem of 3D acceleration not being possible and answer the question of how to disable the annoying warning? Personally, I think it's a bit of an omission that Cinnamon has no way to allow/disallow notifications per-application, nor a way to identify the "owner" of a particular notification...
Attachments
inxi.txt
(1.97 KiB) Downloaded 9 times
User avatar
SMG
Level 9
Level 9
Posts: 2884
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Disable "check your video drives" *notification*

Post by SMG »

Thank you for providing the information. I did a little investigation and I now have a better understanding of your issue. You posted in the Graphic Cards & Monitors section of the forum and I was approaching the issue from that frame of mind. My investigation leads me to believe you have a Virtualization question.

There is a separate section of the forum for Virtualization. And it appears others have questions related to your (although it seems from the reverse direction).

One thread is Video drivers issue on Linux Mint 20 VM in vmware workstation and another one just posted today Cinnamon in VirtualBox: No Video Acceleration.

I also found this link What are differences between VBoxVGA, VMSVGA and VBoxSVGA in VirtualBox? which leads me to believe that perhaps you wanted the None setting, but most of what I know about VirtualBox I learned this morning. So I thank you for expanding my knowledge on virtualization and I apologize for misunderstanding the underlying context of your question and frustrating both of us in the process.

Hopefully those links will provide help. If not maybe you can request a moderator to move this thread to Virtualization (or create a new thread there which doesn't have my posts cluttering it) as those with virtualization experience will be more likely to see it. Not everyone follows all the categories on the forum.
LM20.1 Cinnamon
mallard
Level 1
Level 1
Posts: 6
Joined: Thu Oct 01, 2020 5:35 am

Re: Disable "check your video drives" *notification*

Post by mallard »

The issue I'm trying to resolve is not specific to virtualisation, nor specific to my configuration.

Having looked at the Cinnamon's code, I've discovered that the warning is displayed in the following circumstances:

* Software rendering is being used.
* The environment variable CINNAMON_2D is not set.
* The system was not started with the "boot=casper" or "boot=live" kernel parameters.

(Line 479 and following in /usr/share/cinnamon/js/ui/main.js)

The easiest way to disable the warning is therefore to set the CINNAMON_2D environment variable. Since I want this to apply to all users of the system, I've done this by adding the line 'CINNAMON_2D="true"' to /etc/environment. There are probably other ways to set this, but this works for me. The actual value of the variable doesn't seem to have any meaning, it just needs to be set to something.

After a reboot, I've confirmed that this has disabled the warning.
Post Reply

Return to “Graphics Cards & Monitors”