aggiornare linux mint dalla ver 19.3 alla 20

Italian Forum
Post Reply
Marcolino
Level 1
Level 1
Posts: 9
Joined: Sun Oct 04, 2020 12:40 pm

aggiornare linux mint dalla ver 19.3 alla 20

Post by Marcolino »

Ciao a tutti
Vorrei aggiornare la mia versione di linux Mint dalla versione 19.3 all'ultima, la 20.
La versione 19.3 è perfettamente configurata e aggiornata con tutti i programmi che mi servono.
ho visto la procedura per l'aggiornamento ma non funziona...
ho lanciato dal terminale i seguenti comandi in successione :
apt install mintupgrade
mintupgrade check
mintupgrade dowload
mintupgrade upgrade
ma alla fine mi avvisa con questo :
!! ERROR: The following 3rd party repositories were detected. Disable them and refresh your APT cache.

- Folder Color (LP-PPA-costales-folder-color) - ppa.launchpad.net
- FreeCAD Stable Releases (LP-PPA-freecad-maintainers-freecad-stable) - ppa.launchpad.net
- Gambas Daily Builds (LP-PPA-gambas-team-gambas-daily) - ppa.launchpad.net
- Launchpad PPA for Grub Customizer (LP-PPA-danielrichter2007-grub-customizer) - ppa.launchpad.net
- Oracle Corporation (Oracle Corporation) - download.virtualbox.org
- Oracle Java (LP-PPA-linuxuprising-java) - ppa.launchpad.net

Cosa significa ? Sbaglio qualcosa ?
Mi aiutate ?
Paolo_C
Level 2
Level 2
Posts: 74
Joined: Sat Feb 10, 2018 11:20 am

Re: aggiornare linux mint dalla ver 19.3 alla 20

Post by Paolo_C »

Salve,
personalmente ti consiglierei di aspettare la 20.1 prima di aggiornare la 19.3. Per quanto mi riguarda la 20 mi ha dato alcuni intoppi.
Comunque la guida per l'aggiornamento se lo vuoi fare è la seguente:
https://linuxmint-user-guide.readthedoc ... nt-20.html
dopo se hai qualche problema con la configurazione della stampante vedi qua al paragrafo "USB Printer Support":
https://blog.linuxmint.com/?p=3969
In bocca al lupo.
Marcolino
Level 1
Level 1
Posts: 9
Joined: Sun Oct 04, 2020 12:40 pm

Re: aggiornare linux mint dalla ver 19.3 alla 20

Post by Marcolino »

Ciao
Ho seguito la procedura che mi hai detto, ma alla fine mi viene restituito l'errore che ho detto nel precedente post.

!! ERROR: The following 3rd party repositories were detected. Disable them and refresh your APT cache.
- Folder Color (LP-PPA-costales-folder-color) - ppa.launchpad.net
- FreeCAD Stable Releases (LP-PPA-freecad-maintainers-freecad-stable) - ppa.launchpad.net
- Gambas Daily Builds (LP-PPA-gambas-team-gambas-daily) - ppa.launchpad.net
- Launchpad PPA for Grub Customizer (LP-PPA-danielrichter2007-grub-customizer) - ppa.launchpad.net
- Oracle Corporation (Oracle Corporation) - download.virtualbox.org
- Oracle Java (LP-PPA-linuxuprising-java) - ppa.launchpad.net

Posso attendere tranquillamente la versione 20.1
Quando uscirà ufficialmente ?
La versione 20 sta dando problemi ?
Paolo_C
Level 2
Level 2
Posts: 74
Joined: Sat Feb 10, 2018 11:20 am

Re: aggiornare linux mint dalla ver 19.3 alla 20

Post by Paolo_C »

!! ERROR: The following 3rd party repositories were detected. Disable them and refresh your APT cache.
- Folder Color (LP-PPA-costales-folder-color) - ppa.launchpad.net
- FreeCAD Stable Releases (LP-PPA-freecad-maintainers-freecad-stable) - ppa.launchpad.net
- Gambas Daily Builds (LP-PPA-gambas-team-gambas-daily) - ppa.launchpad.net
- Launchpad PPA for Grub Customizer (LP-PPA-danielrichter2007-grub-customizer) - ppa.launchpad.net
- Oracle Corporation (Oracle Corporation) - download.virtualbox.org
- Oracle Java (LP-PPA-linuxuprising-java) - ppa.launchpad.net
Il messaggio di errore ti indica che devi disabilitare i ppa e i repository di terze parti che hai aggiunto, ma di conseguenza devi anche disinstallare i relativi pacchetti che hai installati.
Ma prima di farlo ricordati di fare un backup della partizione con TIMESHIFT.
La disinstallazione dei pacchetti suddetti si rende necessaria perché sono stati creati per la versione 19.3, quindi una volta aggiornato alla 20 dovrai reinstallare quelli idonei per essa.
Ciao.
desperados
Level 3
Level 3
Posts: 176
Joined: Wed Apr 13, 2016 1:57 am

Re: aggiornare linux mint dalla ver 19.3 alla 20

Post by desperados »

non serve necessariamente disinstallare i pacchetti credo, dipende se sono compatibili o meno con la versione successiva, improbabile ma non impossibile
in ogni caso mi pare che lo stesso team di Mint consigli di reinstallare
Post Reply

Return to “Italiano (Italian)”