Re devenir propriétaire de mes fichiers

French Forum

Moderator: Laurent85

Post Reply
Benou
Level 1
Level 1
Posts: 30
Joined: Sat Oct 10, 2015 7:46 am

Re devenir propriétaire de mes fichiers

Post by Benou »

Bonjour,

Je post à nouveau sur le même sujet, car je crois que mon post précédent était trop confus.

J'ai voulu installer la version 20 de LM, mais cela n'a pas fonctionné.
J'ai donc restauré une ancienne version via Timeshift, et mis à jour la version 19.3.
Tout fonctionne correctement, sauf que je ne suis plus propriétaire de mes fichiers, ni de mon disque de données.
Je n'arrive même pas à télécharger un fichier, car j'obtiens un message m'indiquant que je n'ai pas les permissions nécessaires.

Quelqu'un pourrait il m'aider?

Merci

Guy
franck35
Level 2
Level 2
Posts: 69
Joined: Thu Jan 09, 2020 6:16 am

Re: Re devenir propriétaire de mes fichiers

Post by franck35 »

Pareil que idem :

Code: Select all

cat /etc/fstab
Desktop Dell Optiflex 790_LMDE 4 Cinnamon-64 bit
CPU : Intel© Core™ i5-2400 CPU @ 3.10GHz × 4_8 Go de RAM_SSD 240 Go (LM) + DD 750 Go (Data)
franck35
Level 2
Level 2
Posts: 69
Joined: Thu Jan 09, 2020 6:16 am

Re: Re devenir propriétaire de mes fichiers

Post by franck35 »

Et après

Code: Select all

lsblk -fi
Desktop Dell Optiflex 790_LMDE 4 Cinnamon-64 bit
CPU : Intel© Core™ i5-2400 CPU @ 3.10GHz × 4_8 Go de RAM_SSD 240 Go (LM) + DD 750 Go (Data)
franck35
Level 2
Level 2
Posts: 69
Joined: Thu Jan 09, 2020 6:16 am

Re: Re devenir propriétaire de mes fichiers

Post by franck35 »

J'ai oublié

Code: Select all

id
Et, peut-être, avec tout çà, Ricardo va te donner la solution.
Desktop Dell Optiflex 790_LMDE 4 Cinnamon-64 bit
CPU : Intel© Core™ i5-2400 CPU @ 3.10GHz × 4_8 Go de RAM_SSD 240 Go (LM) + DD 750 Go (Data)
Benou
Level 1
Level 1
Posts: 30
Joined: Sat Oct 10, 2015 7:46 am

Re: Re devenir propriétaire de mes fichiers

Post by Benou »

Voila ce que retourne

Code: Select all

guy@Guy-LinuxMint:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb4 during installation
UUID=235f2de3-d215-4d66-abae-b9e6d51c2039 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sdb1 during installation
UUID=C435-93E5  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
/dev/disk/by-uuid/55AF-2F64 /mnt/55AF-2F64 auto nosuid,nodev,nofail,x-gvfs-show 0 0
guy@Guy-LinuxMint:~$ 
Puis

Code: Select all

guy@Guy-LinuxMint:~$ lsblk -fi
NAME   FSTYPE LABEL       UUID                                 MOUNTPOINT
sda                                                            
`-sda1 vfat   POUIC-POUIC 55AF-2F64                            /mnt/55AF-2F64
sdb                                                            
|-sdb1 vfat               C435-93E5                            /boot/efi
|-sdb2 ext4               b01601d7-4e36-4aee-9023-b9fb56f86f63 
|-sdb3 swap               35667f9b-5b66-4afc-ac1b-8c1b82cf704e 
`-sdb4 ext4               235f2de3-d215-4d66-abae-b9e6d51c2039 /
sr0                                                            
guy@Guy-LinuxMint:~$ 
Et enfin

Code: Select all

guy@Guy-LinuxMint:~$ id
uid=1000(guy) gid=1000(guy) groupes=1000(guy),4(adm),6(disk),24(cdrom),27(sudo),30(dip),46(plugdev),112(lpadmin),127(sambashare)
guy@Guy-LinuxMint:~$ 
Voilà, et merci d'avance

Guy
franck35
Level 2
Level 2
Posts: 69
Joined: Thu Jan 09, 2020 6:16 am

Re: Re devenir propriétaire de mes fichiers

Post by franck35 »

Bonjour,

Je ne suis pas sur, mais remplaces dans ton fichier fstab :

Code: Select all

/dev/disk/by-uuid/55AF-2F64 /mnt/55AF-2F64 auto nosuid,nodev,nofail,x-gvfs-show 0 0
Par

Code: Select all

UUID=55AF-2F64 /mnt/55AF-2F64 vfat utf8,umask=007,gid=46,uid=1000 0 2
Si çà ne va pas, tu pourras toujours remettre l'ancienne ligne.
J'ai essayé d'adapter la commande de Ricardo à ton cas. Mais bon, je ne suis pas un spécialiste. Loin de là .....

Pour ne pas supprimer la ligne existante, tu mets un # devant. Comme çà, au cas où la nouvelle commande ne donne rien, tu n'auras qu'à la supprimer ainsi que le # pour revenir au fichier original.
Desktop Dell Optiflex 790_LMDE 4 Cinnamon-64 bit
CPU : Intel© Core™ i5-2400 CPU @ 3.10GHz × 4_8 Go de RAM_SSD 240 Go (LM) + DD 750 Go (Data)
Benou
Level 1
Level 1
Posts: 30
Joined: Sat Oct 10, 2015 7:46 am

[Resolu] : Re devenir propriétaire de mes fichiers

Post by Benou »

Bonjour,

J'ai trouvé ce qui n'allait pas.
J'avais modifié les propriétés de montage de mon disque, afin de le monter automatiquement au démarrage. Cela fonctionnait, mais cela ne me rendait plus propriétaire de mes fichiers.
J'ai donc remis les options de montage antérieurs. Je suis donc de nouveau obligé d'ouvrir le disque pour qu'il se monte (je n'arrive pas à comprendre pourquoi il faut faire cela), mais quand mon disque est monté, je suis désormais proprio de ce qui s'y trouve.

Donc, je ne comprend pas très bien ce qui s'est passé, mais au moins, c'est résolu.

A bientôt
Guy
franck35
Level 2
Level 2
Posts: 69
Joined: Thu Jan 09, 2020 6:16 am

Re: Re devenir propriétaire de mes fichiers

Post by franck35 »

Bonjour,

Tu n'as pas essayé de modifier ton fichier fstab ?
Dans mon cas, après modification du fstab, le disque est monté au démarrage et je suis le propriétaire des dossiers/fichiers.
Desktop Dell Optiflex 790_LMDE 4 Cinnamon-64 bit
CPU : Intel© Core™ i5-2400 CPU @ 3.10GHz × 4_8 Go de RAM_SSD 240 Go (LM) + DD 750 Go (Data)
Post Reply

Return to “Français (French)”