Linux Mint 20 Reboots instead of Shutdown

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
ChrisAJ
Level 4
Level 4
Posts: 204
Joined: Sun Sep 11, 2011 1:51 pm

Linux Mint 20 Reboots instead of Shutdown

Post by ChrisAJ »

Hello again and happy new year. Over Christmas I decided that Linux Mint 17 on my Acer Aspire 5 could do with updating. I duly installed Mint 20 Cinnamon and fresh installations of my favourite software etc. My problem is that it will not shutdown. Instead it reboots. I have tried "shutdown" in the terminal, changing the grub.config to acpi=force from quiet splash and back again and Alt + PrtScn + REISUO all to no avail.

I suspect it may have something to do with the bios and need to know what I have to do to make this right as holding down the power button is not really a viable option.

Many thanks, Chris :? :? :?
User avatar
SMG
Level 11
Level 11
Posts: 3689
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux Mint 20 Reboots instead of Shutdown

Post by SMG »

Please give us information about your install by entering this command in a terminal:

Code: Select all

inxi -Fxxxrz
Click </> from the mini toolbar above the textbox where you type your reply and then place your cursor between the code markers and paste the results of the command between the code markers [code]Results[/code]. This will let us know how Mint sees your hardware.
LM20.1 Cinnamon
ChrisAJ
Level 4
Level 4
Posts: 204
Joined: Sun Sep 11, 2011 1:51 pm

Re: Linux Mint 20 Reboots instead of Shutdown

Post by ChrisAJ »

Code: Select all

chris@acer:~$ inxi -Fxxxrz
System:
  Kernel: 5.4.0-58-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 wm: muffin 4.6.3 dm: LightDM 1.30.0 
  Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: Acer product: Aspire V5-571 v: V2.11 serial: <filter> 
  Mobo: Acer model: Aspire V5-571 v: V2.11 serial: <filter> 
  UEFI [Legacy]: Phoenix v: 2.11 date: 11/05/2012 
Battery:
  ID-1: BAT0 charge: 32.6 Wh condition: 32.6/32.6 Wh (100%) volts: 16.3/14.8 
  model: SANYO AL12A32 type: Li-ion serial: <filter> status: Full 
CPU:
  Topology: Dual Core model: Intel Core i3-2365M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11174 
  Speed: 798 MHz min/max: 800/1400 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0116 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) 
  v: 3.3 Mesa 20.0.8 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.4.0-58-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000 
  bus ID: 02:00.2 chip ID: 10ec:8168 
  IF: enp2s0f2 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Lite-On 
  driver: ath9k v: kernel port: 2000 bus ID: 03:00.0 chip ID: 168c:0034 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 698.64 GiB used: 66.42 GiB (9.5%) 
  ID-1: /dev/sda vendor: Western Digital model: WD7500BPVT-00HXZT3 
  size: 698.64 GiB speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1A01 scheme: MBR 
Partition:
  ID-1: / size: 686.18 GiB used: 66.42 GiB (9.7%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: 30.0 C 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
  1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/google-earth-pro.list 
  1: deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main
  Active apt repos in: /etc/apt/sources.list.d/nordvpn.list 
  1: deb https://repo.nordvpn.com//deb/nordvpn/debian stable main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
  Active apt repos in: /etc/apt/sources.list.d/teamviewer.list 
  1: deb https://linux.teamviewer.com/deb stable main
Info:
  Processes: 239 Uptime: 5m Memory: 7.57 GiB used: 1.16 GiB (15.3%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 
chris@acer:~$ 
vimes666
Level 4
Level 4
Posts: 402
Joined: Tue Jan 19, 2016 6:08 pm

Re: Linux Mint 20 Reboots instead of Shutdown

Post by vimes666 »

Have you tried disabling 'Wake-on-lan' in the BIOS?
If you think the issue is solved, edit your original post and add the word solved to the title.
ChrisAJ
Level 4
Level 4
Posts: 204
Joined: Sun Sep 11, 2011 1:51 pm

Re: Linux Mint 20 Reboots instead of Shutdown

Post by ChrisAJ »

Just checked and it's disabled.
vimes666
Level 4
Level 4
Posts: 402
Joined: Tue Jan 19, 2016 6:08 pm

Re: Linux Mint 20 Reboots instead of Shutdown

Post by vimes666 »

Does it also happen if you disable wifi prior to shutdown?
If you think the issue is solved, edit your original post and add the word solved to the title.
ChrisAJ
Level 4
Level 4
Posts: 204
Joined: Sun Sep 11, 2011 1:51 pm

Re: Linux Mint 20 Reboots instead of Shutdown

Post by ChrisAJ »

Yes it does
User avatar
Welcome
Level 5
Level 5
Posts: 946
Joined: Wed Aug 19, 2020 11:38 am

Re: Linux Mint 20 Reboots instead of Shutdown

Post by Welcome »

A long time ago, I had a similar problem. My simple solution was to enter grub on the reboot, enter the command mode, and type in "halt" followed by return.

I helped someone else recently with the same problem, and in their case, the grub/halt method was the only solution that worked.

Until you find a better solution, try the grub/halt method. It's much better than using the power button.
3 steps to find an answer: (1) Search forum with unique key words. (2) Search with Google and add site:linuxmint.com to your unique key word query. (3) Search with Google and add either Linux Mint or Ubuntu to your unique key word query.
vimes666
Level 4
Level 4
Posts: 402
Joined: Tue Jan 19, 2016 6:08 pm

Re: Linux Mint 20 Reboots instead of Shutdown

Post by vimes666 »

Well the next is disabling USB3 support in the bios. Not really a solution but it worked for others.
If you think the issue is solved, edit your original post and add the word solved to the title.
User avatar
SMG
Level 11
Level 11
Posts: 3689
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux Mint 20 Reboots instead of Shutdown

Post by SMG »

If you want to check the logs to get an idea of why the computer is rebooting, the following will give you the prior boot log information.

Code: Select all

journalctl -b -1 | tee >(gzip --stdout > journalctl_$USER.gz)
This command will write the prior boot log to the file journalctl_(yourname).gz and to your screen. The file will be located in your /home/login_name directory.

When looking at shutdown issues, I usually look for the line with "Playing logout sound" and then start checking the lines after that. Maybe something in the log will give an indication of what is happening so it might be easier to find a fix.
LM20.1 Cinnamon
ChrisAJ
Level 4
Level 4
Posts: 204
Joined: Sun Sep 11, 2011 1:51 pm

Re: Linux Mint 20 Reboots instead of Shutdown

Post by ChrisAJ »

Welcome wrote:
Mon Jan 04, 2021 12:14 pm
A long time ago, I had a similar problem. My simple solution was to enter grub on the reboot, enter the command mode, and type in "halt" followed by return.

I helped someone else recently with the same problem, and in their case, the grub/halt method was the only solution that worked.

Until you find a better solution, try the grub/halt method. It's much better than using the power button.
How do I get into this?
User avatar
Welcome
Level 5
Level 5
Posts: 946
Joined: Wed Aug 19, 2020 11:38 am

Re: Linux Mint 20 Reboots instead of Shutdown

Post by Welcome »

The official way:
- Reboot.
- Press and hold the Shift key to show the boot menu.
- In the boot menu, press the letter 'c' to enter the command mode.
- Type 'halt' and press the Enter key.

The problem that a lot of people have is that they can't seem to get into grub. Sometimes pressing the Esc key works, sometimes pressing the space bar works, and sometimes the Shift key works. But, it's hard to get into it.

This would make it a little easier to get to the grub menu, but you'd see it each time the computer was booted. Maybe a good solution overall.
smurphos wrote:
Mon May 11, 2020 12:57 am
...
If you want to set grub to show automatically on every boot then run this command to open the relevant config file in a terminal based text editor with elevated privileges

Code: Select all

sudoedit /etc/default/grub
Change these lines

Code: Select all

GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
to

Code: Select all

GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
Then Ctrl-X, Y, Enter to save.
Then in the terminal run

Code: Select all

sudo update-grub

Enjoy! :D
3 steps to find an answer: (1) Search forum with unique key words. (2) Search with Google and add site:linuxmint.com to your unique key word query. (3) Search with Google and add either Linux Mint or Ubuntu to your unique key word query.
User avatar
SMG
Level 11
Level 11
Posts: 3689
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux Mint 20 Reboots instead of Shutdown

Post by SMG »

Welcome wrote:
Mon Jan 04, 2021 4:44 pm
The problem that a lot of people have is that they can't seem to get into grub. Sometimes pressing the Esc key works, sometimes pressing the space bar works, and sometimes the Shift key works. But, it's hard to get into it.
I've read that the key to press depends on whether it is EFI or legacy boot.

-- Hold the shift key during boot to enter grub for non-EUFI/Legacy boot.
-- Hold the escape key during boot to enter grub when have EUFI boot.

However, the OP of this thread has an EFI bootable computer set to legacy boot so I do know if that changes the advice of which key to press.
LM20.1 Cinnamon
Post Reply

Return to “Installation & Boot”