Forticlient / Fortigate VPN Internal DNS resolution issues.

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 1
Joined: Tue Jan 12, 2021 3:44 pm

Forticlient / Fortigate VPN Internal DNS resolution issues.

Post by otakugenx »

I am posting this in case anyone else runs into this issue. And perhaps I solved it wrong, but it was what worked.

It seems that if you are using Forticlient to connect to a VPN and have systemd-resolved installed (it is by default) resolution does not change over to the right DNS servers. This does not effect external connections through the VPN, but does prohibit internal only resolution like connecting to a desktop.

To test this after you connect to your VPN open a terminal and try a nslookup on an external name, like Google. It will respond fine coming from now try an internal only name, Assuming your companies DNS servers do not allow internal machine names to be resolved on the internet it will fail with a Server: and another line *** No answer.

Now if you check your Network settings you will see the proper VPN DNS servers listed in there. However it seems that they are not being queried.

To fix this I followed the instructions on this page: ... -in-ubuntu
sudo systemctl disable systemd-resolved
sudo systemctl stop systemd-resolved

Edit /etc/NetworkManager/NetworkManager.conf and add dns=default under [main]
rm /etc/resolv.conf
Then restart Network Manager
sudo systemctl restart NetworkManager

Now test again as before. You will notice Server: is now showing the DNS server it is querying. You should also now be able to lookup internal only names.
Post Reply

Return to “Other networking topics”