[SOLVED] Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Questions about hardware, drivers and peripherals
Forum rules
Before you post please read how to get help
User avatar
SMG
Level 22
Level 22
Posts: 15829
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by SMG »

KenoKokoro wrote:
Thu Nov 11, 2021 5:47 am
Yes yes! I am actually just waiting for the updates to be rolled out, so I can try them out to post back that hopefully things are fixed. In the meantime I just use a dongle for it, but I am hoping to get the updates soon.
That firmware update I mentioned is already rolled out. I copied the info from the changelog in Update Manager when I received the update on my computer.

Which kernel are you currently using? Are you using an Ubuntu kernel or a mainline kernel? That might be a factor in receiving that update.

There is a 5.13 kernel now available in Update Manager and there is also a 5.14-oem kernel available through the command line, so newer kernels are available since your original post.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
KenoKokoro
Level 1
Level 1
Posts: 14
Joined: Sun Sep 12, 2021 4:11 pm

Re: Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by KenoKokoro »

Thanks for your update.

I actually just installed the 5.15.2 kernel from `tuxivader/lts-mainline` ppa, just to see if things will work. With this kernel the bluetooth is working, so the whole issue was missing kernel support for the device.

I am hoping to have more time over the weekend, since the machine seems stable with 5.15.2 as well, but I wanna install the 5.14-oem kernel once I have the time. I am assuming if the changes from 5.15 are there, things should be fine.

But anyways, I am guessing we can close this post, since the actual issue was missing kernel support.

Thanks for you help again. Much appreciated!
User avatar
SMG
Level 22
Level 22
Posts: 15829
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by SMG »

KenoKokoro wrote:
Mon Nov 15, 2021 3:58 am
I am hoping to have more time over the weekend, since the machine seems stable with 5.15.2 as well, but I wanna install the 5.14-oem kernel once I have the time. I am assuming if the changes from 5.15 are there, things should be fine.
I am not aware of drivers being backported to older kernels, but sometimes (as I mentioned above) firmware updates are made which add the new drivers. Getting the updated firmware can address the issue for someone using an older kernel.
KenoKokoro wrote:
Mon Nov 15, 2021 3:58 am
But anyways, I am guessing we can close this post, since the actual issue was missing kernel support.
As the topic creator, you are the one to do that. Go to your first post in this topic, click the pencil icon to modify the title. However, I'd suggest waiting until you get a chance to see if the 5.14-oem does work before marking the topic [SOLVED].
Image
A woman typing on a laptop with LM20.3 Cinnamon.
KenoKokoro
Level 1
Level 1
Posts: 14
Joined: Sun Sep 12, 2021 4:11 pm

Re: Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by KenoKokoro »

Just an update on this one.

I installed `linux-image-oem-20.04c` which is `5.13.0-1021-oem` and `linux-image-oem-20.04d` which is `5.14.0-1010-oem`, but the bluetooth still doesn't work properly on this oem kernels.

I am constantly updating the `5.15` kernel, and now I am at `5.15.7` and the bluetooth is working fine there, but I am getting random freezes sometimes, which I can't really find out why are happening, since I didn't have them in `5.14` or `5.13` kernels that I tried before. But that is another topic.

I will double check when I have updates on the 5.14-oem and 5.13-oem when/if this issue is resolved. Rest of the things that I currently have like firmware seems like they are up to date, so I don't know, I guess I will just keep `5.15` then.
EnlightenedBacon
Level 1
Level 1
Posts: 22
Joined: Thu Jul 22, 2021 10:37 am

Re: Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by EnlightenedBacon »

Just FYI I commented on this in a similar thread, but I have a Zephyrus and running Mint 20.2. I found Kernel 5.15.9 makes everything work and I haven't noticed any issues or instability. 5.14 was very problematic. Also I dual boot and found that if Fastboot is enabled in Windows, it breaks Wifi in Linux seemingly randomly.
KenoKokoro
Level 1
Level 1
Posts: 14
Joined: Sun Sep 12, 2021 4:11 pm

Re: Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by KenoKokoro »

I was waiting if something is gonna change here, but I will just mark this as SOLVED, since as it seems the 5.15 are the solution to this issue.
I have the latest updates to the oem kernels (5.13 and 5.14), and none of them fixes the bluetooth issue
User avatar
SMG
Level 22
Level 22
Posts: 15829
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by SMG »

KenoKokoro wrote:
Wed Jan 05, 2022 4:34 am
I was waiting if something is gonna change here, but I will just mark this as SOLVED, since as it seems the 5.15 are the solution to this issue.
I have the latest updates to the oem kernels (5.13 and 5.14), and none of them fixes the bluetooth issue
So it seems the linux-firmware updates have not helped? There was just another one which came through for me yesterday. Linux-firmware 1.187.23 mentions
* linux-firmware: update frimware for mediatek bluetooth chip (MT7921) (LP: #1954300)
as one of the two changes. However, looking at an email chain on that particular bug patch I see it marked as "invalid" for the oem kernels, so maybe the change was only added to the non-oem kernels.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
EnlightenedBacon
Level 1
Level 1
Posts: 22
Joined: Thu Jul 22, 2021 10:37 am

Re: [SOLVED] Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by EnlightenedBacon »

Just as an update, Kernel 5.15 mostly fixed the issue, but I find it still randomly just stops working. Sometimes disabling and reenabling wifi works, other times need to hard reset the laptop.

I'm hoping 5.16 fixes things, as there are some Mediatek updates there, but can't try until Nvidia drivers work with it properly.
EnlightenedBacon
Level 1
Level 1
Posts: 22
Joined: Thu Jul 22, 2021 10:37 am

Re: [SOLVED] Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by EnlightenedBacon »

FYI Kernel 5.16.2 does NOT fix things. In fact I found Wifi entirely non functional using it.

Damn Mediatek!

Edit:
Ended up giving up and replaced the Mediatek with an Intel AX200. No regrets.

ReEdit:
Regrets... The AX200 is more stable, but once I booted and the adaptor just didn't show up at all in Windows or Linux. Needed to do a hard reset (hold power button down for 60 seconds with power disconnected) to get it to appear again.

It appears the problem with ASUS wifi is more serious than just the Mediatek adaptor. Hopefully a future BIOS update can resolve it.
TRNSL8OR
Level 1
Level 1
Posts: 19
Joined: Tue Mar 15, 2022 12:11 pm

Re: [SOLVED] Linux Mint 20.2 not showing any bluetooth devices on Asus Zephyrus M16

Post by TRNSL8OR »

You are not the only one with this issue from the update. I have the Asus Vivobook X513/514 and my bluetooth has always been working until i updated my drivers or did the updates. No dongle for me though, I don't need any more accessories.
I prefer the internal options.
Post Reply

Return to “Hardware Support”