Can't get the grub menu to show during boot

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
Post Reply
axellieb
Level 1
Level 1
Posts: 10
Joined: Sat Nov 25, 2023 6:39 am

Can't get the grub menu to show during boot

Post by axellieb »

Fresh Mint 21.2 Cinnamon 5.8.4 install on a late 2010 Macbook Air (Core Duo 2/nvidia graphics). I have not messed with the graphics driver. It's nouveau as it comes standard with the fresh installation.

Everything's good, except I can't get a grub menu at boot despite my best effort to edit the grub file accordingly. See below. What am I doing wrong?
I've also tried replacing the quiet splash with loglevel=3, no good. This does reveal the entire boot process, line by line, but no grub menu. Have also tried with the resolution commented out, makes no difference. (Of course, I "sudo update-grub" every time I make a change.)

Code: Select all

RUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
linux-rox
Level 10
Level 10
Posts: 3291
Joined: Sun Jul 19, 2020 9:17 pm

Re: Can't get the grub menu to show during boot

Post by linux-rox »

Open /boot/grub/grub.cfg. Find the section corresponding to this:

Code: Select all

terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=30
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=6
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=6
  fi
fi
### END /etc/grub.d/00_header ###
What does your file say? As you probably can guess, the system I'm quoting has the timeout set to 6 in /etc/default/grub.
axellieb
Level 1
Level 1
Posts: 10
Joined: Sat Nov 25, 2023 6:39 am

Re: Can't get the grub menu to show during boot

Post by axellieb »

linux-rox wrote: Sun Nov 26, 2023 9:48 pm Open /boot/grub/grub.cfg. Find the section corresponding to this:

Code: Select all

terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=30
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=6
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=6
  fi
fi
### END /etc/grub.d/00_header ###
What does your file say? As you probably can guess, the system I'm quoting has the timeout set to 6 in /etc/default/grub.
Hi there. It says:

Code: Select all

terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=30
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=5
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=5
  fi
fi
### END /etc/grub.d/00_header ###
linux-rox
Level 10
Level 10
Posts: 3291
Joined: Sun Jul 19, 2020 9:17 pm

Re: Can't get the grub menu to show during boot

Post by linux-rox »

Well, the bad news is I don't see anything wrong either. :?

Reviewing notes, there was a Grub bug years ago solved by removing the # in front of GRUB_TERMINAL=console.
Not optimistic, but easy to try. Run update-grub, of course. If doesn't help, revert the change.

If nothing else works, consider switching to rEFInd as boot manager. You can use on a trial basis first, to see whether you like it.
Reddog1
Level 7
Level 7
Posts: 1821
Joined: Wed Jun 01, 2011 2:12 pm

Re: Can't get the grub menu to show during boot

Post by Reddog1 »

One of the (many) things about rEFInd, is it nests all the installed kernels under the Mint boot logo on its boot screen. You have the ability to always get to, and boot from, any kernel that is installed on your Mint system. Grub is by-passed in its boot manager capacity.

You can also unnest the kernels by editing the refind.conf file, so that each kernel has its own Mint logo. That's how I do it.

My opinion is that grub is a not very good boot manager, and I just won't use it on multi-boot linux systems. I've never had a problem with it on single-boot or multi-booting with systems other than linux. Actually, that isn't quite true, because grub doesn't recognize apple APFS, so it is always in 'single-boot--hidden' mode when booting on a modern apple with macOS.

And the fact that an Apple keyboard will not bring up the grub menu is a real problem, one that only affects apple hardware.

If you want to give rEFInd a try, it is in the Mint Software Manager, and I recommend that is what you use for your install. It also makes uninstalling simpler should you decide that you don't want to use it.

Also, RTFM, it's quite extensive.

https://www.rodsbooks.com/refind/

If you do decide to use rEFInd, disable the grub VERSION updates in the Update Manager. If you aren't using grub you don't want the headache that a grub version update will cause. Fixable, but still a pain.

But I'm still stymied by your problem. I have several Apple computers running linux, and I've never seen this. My 'normal' grub is, for all 'practical' purposes, exactly like yours.
axellieb
Level 1
Level 1
Posts: 10
Joined: Sat Nov 25, 2023 6:39 am

Re: Can't get the grub menu to show during boot

Post by axellieb »

linux-rox wrote: Sun Nov 26, 2023 11:47 pm Well, the bad news is I don't see anything wrong either. :?

Reviewing notes, there was a Grub bug years ago solved by removing the # in front of GRUB_TERMINAL=console.
Not optimistic, but easy to try. Run update-grub, of course. If doesn't help, revert the change.

If nothing else works, consider switching to rEFInd as boot manager. You can use on a trial basis first, to see whether you like it.
Yeah, that was going to be my next step but I only have one OS on this machine so it seems overkill. But yeah, I guess I'll try that. Thanks.
axellieb
Level 1
Level 1
Posts: 10
Joined: Sat Nov 25, 2023 6:39 am

Re: Can't get the grub menu to show during boot

Post by axellieb »

Reddog1 wrote: Mon Nov 27, 2023 2:21 am One of the (many) things about rEFInd, is it nests all the installed kernels under the Mint boot logo on its boot screen. You have the ability to always get to, and boot from, any kernel that is installed on your Mint system. Grub is by-passed in its boot manager capacity.

You can also unnest the kernels by editing the refind.conf file, so that each kernel has its own Mint logo. That's how I do it.

My opinion is that grub is a not very good boot manager, and I just won't use it on multi-boot linux systems. I've never had a problem with it on single-boot or multi-booting with systems other than linux. Actually, that isn't quite true, because grub doesn't recognize apple APFS, so it is always in 'single-boot--hidden' mode when booting on a modern apple with macOS.

And the fact that an Apple keyboard will not bring up the grub menu is a real problem, one that only affects apple hardware.

If you want to give rEFInd a try, it is in the Mint Software Manager, and I recommend that is what you use for your install. It also makes uninstalling simpler should you decide that you don't want to use it.

Also, RTFM, it's quite extensive.

https://www.rodsbooks.com/refind/

If you do decide to use rEFInd, disable the grub VERSION updates in the Update Manager. If you aren't using grub you don't want the headache that a grub version update will cause. Fixable, but still a pain.

But I'm still stymied by your problem. I have several Apple computers running linux, and I've never seen this. My 'normal' grub is, for all 'practical' purposes, exactly like yours.
Thank you for your comments. I'll try rEFInd. I've had it on this machine before, but that was when I had Windows and the MacOs on it as well. Now it's only LM, didn't think I'd need rEFInd. Anyway, thanks, will try in a day or two when I have the time. Will report back here.
xinu
Level 3
Level 3
Posts: 143
Joined: Fri Apr 24, 2015 1:39 am

Re: Can't get the grub menu to show during boot

Post by xinu »

Hi,

I've written sth about it in the Dutch forum department ('Installatieavonturen: UEFI vs legacy boot', exemplary bios snapshot inc.).

On my Dell (with Windows!), the dual boot and grub installation (of Mint cinnamon 21.2 Edge) came down to this:

1) Mint installation from boot disk -> in bios: legacy mode.
2) After Mint installation, in bios: Select UEFI.
3) 'Add Boot Option'.
4) In EFI Boot Selection, File System FSO: select 'EFI', next 'ubuntu', next 'grubx64.efi', give the latter a name (preferably without spaces).
5) Put the named grubx64.efi on top of Windows (or your platform) in the UEFI list.
6) Save & Exit & Restart & Mint will probably still load without grub as is.
7) In Mint open terminal: sudo update-grub.
8 ) Restart, the full grub menu should show.

Even on another PC, even on a Mac, the procedure could be similar.
For those with a Dell with Windows, the procedure will probably be the same.
Last edited by xinu on Tue Nov 28, 2023 3:19 am, edited 1 time in total.
axellieb
Level 1
Level 1
Posts: 10
Joined: Sat Nov 25, 2023 6:39 am

Re: Can't get the grub menu to show during boot

Post by axellieb »

xinu wrote: Mon Nov 27, 2023 7:13 am Hi,

I've written sth about it in the Dutch forum department ('Installatieavonturen: UEFI vs legacy boot', exemplary bios snapshot inc.).

On my Dell (with Windows!), the dual boot and grub installation (of Mint cinnamon 21.2 Edge) came down to this:

1) Mint installation from boot disk -> in bios: legacy mode.
2) After Mint installation, in bios: Select UEFI.
3) 'Add Boot Option'.
4) In EFI Boot Selection, File System FSO: select 'EFI', next 'ubuntu', next 'grubx64.efi', give the latter a name (preferably without spaces).
5) Put the named grubx64.efi on top of Windows (or your platform) in the UEFI list.
6) Save & Exit & Restart & Mint will probably still load without grub as is.
7) In Mint open terminal: sudo update-grub.
8) Restart, the full grub menu should show.

Even on another PC, even on a Mac, the procedure could be similar.
For those with a Dell with Windows, the procedure will probably be the same.
Thanks but I'm not sure I understand how this relates to my case. In the first place, mine is a Macbook Air which doesn't have a BIOS. It's UEFI out of the box. And, I only have one OS on this machine, which is Linux Mint.
User avatar
JerryF
Level 16
Level 16
Posts: 6511
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Can't get the grub menu to show during boot

Post by JerryF »

Does your setup have auto login for a user account?

My spouse's computer does, and that setting somehow disables the grub menu from showing, even though I've changed the timeout (and like you, sudo update-grub).
linux-rox
Level 10
Level 10
Posts: 3291
Joined: Sun Jul 19, 2020 9:17 pm

Re: Can't get the grub menu to show during boot

Post by linux-rox »

I'm all for trying anything-and-everything when trouble shooting a mysterious problem, but will mention autologin doesn't generally disable display of the Grub menu. I use it on all my systems, and also always force display of Grub (which I think should be the default).
xinu
Level 3
Level 3
Posts: 143
Joined: Fri Apr 24, 2015 1:39 am

Re: Can't get the grub menu to show during boot

Post by xinu »

axellieb wrote: Mon Nov 27, 2023 6:42 pm
xinu wrote: Mon Nov 27, 2023 7:13 am Hi,

I've written sth about it in the Dutch forum department ('Installatieavonturen: UEFI vs legacy boot', exemplary bios snapshot inc.).

On my Dell (with Windows!), the dual boot and grub installation (of Mint cinnamon 21.2 Edge) came down to this:

Even on another PC, even on a Mac, the procedure could be similar.
For those with a Dell with Windows, the procedure will probably be the same.
Thanks but I'm not sure I understand how this relates to my case. In the first place, mine is a Macbook Air which doesn't have a BIOS. It's UEFI out of the box. And, I only have one OS on this machine, which is Linux Mint.
I'm sorry but I have to admit I'm not so much into Mac.
I just thought that, maybe, doing something with the /boot/efi/EFI/ubuntu/grubx64.efi file could also lead to a grub load solution on Mac.
On (this newest powerful) system of mine, with bios and Windows, the grub menu only started to appear after, additionally, doing a 'sudo update-grub' in Mint.
You will have done that too by now possibly, without result.
Another 'travel'-Asusnetbook of mine with only (l)ubuntu has a totally different bios. It's a modest celeron to the newest standards, has 4 Gb ram, 2 cores, but handles most things quite rapidly anyway. Except video conversions ;-) (due to the somewhat lower hardware towards modern high video conversion demands). The light weight, the long battery life makes it practical. Its bios doesn't really show a clear difference UEFI-legacy. As I remember I just put the linux boot usb stick on top of anything else and installed (l)ubuntu as only system. It updates fluently to recent linux-images. If and when I want to see a grub, I push the Shift key whenst booting.
Forget about it ;-)
Last edited by xinu on Tue Nov 28, 2023 1:17 pm, edited 4 times in total.
linux-rox
Level 10
Level 10
Posts: 3291
Joined: Sun Jul 19, 2020 9:17 pm

Re: Can't get the grub menu to show during boot

Post by linux-rox »

xinu wrote: Tue Nov 28, 2023 3:47 am I just thought that, maybe ...
For future reference, your solution relates specifically to that particular Dell firmware. And which boot loader you registered is incidental. The important thing was figuring out you needed to authorize the boot loader manually. This problem doesn't come up often - and the names usually aren't the same - but if someone was able to boot from USB but the installed system won't boot, firmware authorization is worth checking. Able to boot but some other problem (e.g., Grub menu not displaying) isn't going to be a firmware authorization issue.
xinu
Level 3
Level 3
Posts: 143
Joined: Fri Apr 24, 2015 1:39 am

Re: Can't get the grub menu to show during boot

Post by xinu »

linux-rox wrote: Tue Nov 28, 2023 11:43 am
xinu wrote: Tue Nov 28, 2023 3:47 am I just thought that, maybe ...
For future reference, your solution relates specifically to that particular Dell firmware. And which boot loader you registered is incidental. The important thing was figuring out you needed to authorize the boot loader manually. This problem doesn't come up often - and the names usually aren't the same - but if someone was able to boot from USB but the installed system won't boot, firmware authorization is worth checking. Able to boot but some other problem (e.g., Grub menu not displaying) isn't going to be a firmware authorization issue.
Okay, no problem, so "Dells" could apply that in case of issues.
Sure the original Mac user/poster will find (a simple system specific) solution in the end.

Once Things Work as Desired: *Boogie Time* ;-P
Reddog1
Level 7
Level 7
Posts: 1821
Joined: Wed Jun 01, 2011 2:12 pm

Re: Can't get the grub menu to show during boot

Post by Reddog1 »

I rarely use 'auto-login', but I have a couple of VM's that are auto-login, and grub menu still shows.

Apple firmware cannot be accessed by the user (walled-garden stuff), just for the record.

I wonder if there might be some obscure bug in grub??? Maybe somebody smarter than me can solve this.

As I said, I've never had a problem unhiding it, but it's been a thorn in my side that ubuntu developers hide grub, just to save a few boot-seconds, without regard to those of us that install linux on apple hardware. And, in the case of borked gpu drivers (common with older apples), it is a serious issue.

I filed a 'bug' report about hiding grub on apples that appears to have gone nowhere.

One solution is to install a debian-based distro (Mint LMDE), because debian doesn't hide grub. On apple hardware, it also solves some other problems, such as installing proprietary drivers along with the intial installation, so that apple wifi works from the get-go.
Post Reply

Return to “Installation & Boot”