Mint 21.1 refuses to Boot after installation on PC with 2 x Drives. [SOLVED]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
Studiohead
Level 2
Level 2
Posts: 99
Joined: Fri Jun 11, 2021 5:55 am

Mint 21.1 refuses to Boot after installation on PC with 2 x Drives. [SOLVED]

Post by Studiohead »

I have a Dell Optiplex desktop with a 250GB SSD drive and a 500GB HHD drive.

I installed Mint 21.2 on the SSD drive and used Gparted to delete the existing partitions on the HDD drive and added new timeshift and data partitions. I followed instructions given on this thread: viewtopic.php?p=2397911#p2397911

I hoped I'd have a setup with the op system on the fast SSD drive with the slow HDD drive used for storage.

:( It refused to boot.

Prior to the new installation Disks and Gparted showed that the HHD drive was using /dev/sda and the SSD drive was using /dev/sdb but when I installed Mint on the SSD drive the Mint installer states that the SSD drive was using /dev/sdc

I’m wondering if this is creating some sort of boot problem.

After installing Mint on the SSD drive I updated the grub menu via the terminal command: sudo update-grub but when I booted the PC it just brought up a black screen with a blinking cursor in the top left corner.

I’ve now installed Mint on the HDD drive and I used Gparted to delete and create new partitions on the SSD drive. So I’m using the slow HHD drive for the op system and the fast SSD drive for storage - the wrong way round!

Any suggestions?
Last edited by Studiohead on Wed Dec 27, 2023 5:08 am, edited 1 time in total.
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

Yes. Get into computer Setup in oder to set Boot options accodingly the way/mode you want to boot/install:
-if BIOS Legacy, disable UEFI boot and enable Legacy OptionsROM if needed or

-if UEFI, disable Legacy and be sure Secure boot is disabled at the moment.
Then install as indicated on the other thread but, first, post back inxi -M; sudo parted -l to be sure the way you are booting/installing and SSD/HDD partitioning as your are going to install with Something else option.
Arrieritos semos y en el camino nos encontraremos.
Studiohead
Level 2
Level 2
Posts: 99
Joined: Fri Jun 11, 2021 5:55 am

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Studiohead »

Thanks,

Sorry, I’d forgotten about BIOS Legacy and UEFI.

The efibootmgr command says that: ‘EFI variables are not supported’

I understand that this means I’m booting in Legacy.

Here is the data from the inxi -M; sudo parted -l command:

Code: Select all

Machine:
  Type: Desktop System: Dell product: OptiPlex 3010 v: 01
	serial: <superuser required>
  Mobo: Dell model: 042P49 v: A02 serial: <superuser required> BIOS: Dell
	v: A11 date: 09/16/2013


I don’t plan to use the ‘something else’ method. I intend to select the ‘erase everything’ option and then install Mint on the SSD drive. I then intend to use Gparted on the SSD drive to delete the existing partitions on the HHD drive and then create the desired new partitions so that the drive can be used for storage (this was the advice given in the above mentioned thread).

Could you give me tips on how to create the correct boot order?

In the past I’ve always set up the bootable media by pressing the boot key on startup and then selecting the usb device from the list. Is there a different method of booting into the bootable media which enables either BIOS Legacy or UEFI installations?
Last edited by Studiohead on Mon Nov 27, 2023 2:43 pm, edited 1 time in total.
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

You didn't post back codes second part (sudo parted -l). :(

A per inxi you are booting (Linux Mint Live?) on BIOS Legacy mode, in the same way as per sudo efibootmgr. I'm not sure computer boot mode is set to Legacy only (i.e. UEFI disable), as it will depend on firmware. In most cases ([BIOS]:Dell v: A11... means it is so, and you will see UEFI[Legacy]:.... when booting media on BIOS mode and also UEFI boot options are enabled on computer Setup ([UEFI] in case of booting on UEFI mode).

It is important because installing LM 21.X with Erase all and install will install on both BIOS and Legacy mode by default (it will format SSD with GPT partitioning scheme and create bios_grub partition on first 1MB , an UEFI partition and will create a / root partition). Once installed you will boot on UEFI or BIOS mode depending on Boot options (on boot order priorities if both modes are enabled).

In theory if UEFI is disabled (so booting on Legacy mode only) you will be able to boot on BIOS legacy but once again it will depend on firmware you can boot on BIOS mode from GPT disk (from bios_grub).

It's been commented on previous thread some old firmware would have problem with such installation and it is worth installing on BIOS mode (if it is what you want) as per AndyMH's tutorial (formatting SSD and creating an Ext.4 partition previously with Gparted and then install with Something Else option...).

In other hand on computer's boot menu (if booting on Legacy only) you wont get an UEFI boot option for Linux Mint USB but take into account LM 21.1 Live can (will try) to install on both UEFI and Legacy mode never mind you boot Linux Mint installation media on BIOS legacy mode. Installing on BIOS mode with Something else.. option you will receive a warning about EFI partition is needed you can ignore.
Last edited by Jo-con-Ël on Mon Nov 27, 2023 4:11 pm, edited 4 times in total.
Arrieritos semos y en el camino nos encontraremos.
Studiohead
Level 2
Level 2
Posts: 99
Joined: Fri Jun 11, 2021 5:55 am

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Studiohead »

here is the data from the sudo parted -l command [sorry!]

Code: Select all

Model: ATA ST500DM002-1BD14 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End 	Size	File system  Name              	Flags
 1  	1049kB  2097kB  1049kB                                 	bios_grub
 2  	2097kB  540MB   538MB   fat32    	EFI System Partition  boot, esp
 3  	540MB   500GB   500GB   ext4


Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End 	Size	Type 	File system  Flags
 1  	1049kB  62.9GB  62.9GB  primary  ext4
 2  	62.9GB  240GB   177GB   primary  ext4

I don’t want to install using the ‘something else’ method. The correspondents in the above mentioned thread urged me not to use that method.

As I stated I installed Mint on the SSD drive and then formatted the HDD drive partitions. It worked but when I tried to restart the PC it refused to boot.

I’m out of my depth with this sort of thing.

If I use the same method that I’ve previously used and then disable UEFI will it boot then?
Last edited by Studiohead on Mon Nov 27, 2023 2:43 pm, edited 1 time in total.
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

Only one more question about Mint 21.1 installer you need to know. Not only it will try to install on both UEFI and BIOS legacy mode, if it finds an already existent EFI partition (now on HDD) it will place efi loader there w/o any advise.

As per parted -l you have installed on HDD using Erease and Install option. If you want now install LM 21.X on SSD with the same Erease and install option I have told you what will happend...
Last edited by Jo-con-Ël on Mon Nov 27, 2023 2:53 pm, edited 1 time in total.
Arrieritos semos y en el camino nos encontraremos.
Studiohead
Level 2
Level 2
Posts: 99
Joined: Fri Jun 11, 2021 5:55 am

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Studiohead »

I’m really very confused about all of this.

If I use the installation method outlined above - installing the op system on the SSD drive and then formatting storage partitions on the HHD drive - how do I get it to boot?

Where am I going wrong?

Is it the installation media that I’ve used?

Is it something that I have to do after the installation?
bendipa
Level 5
Level 5
Posts: 566
Joined: Sat Jan 04, 2020 8:02 pm
Location: NW London. UK

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by bendipa »

Studiohead wrote: Mon Nov 27, 2023 1:46 pm here is the data from the sudo parted -l command [sorry!]

Code: Select all

Model: ATA ST500DM002-1BD14 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End 	Size	File system  Name              	Flags
 1  	1049kB  2097kB  1049kB                                 	bios_grub
 2  	2097kB  540MB   538MB   fat32    	EFI System Partition  boot, esp
 3  	540MB   500GB   500GB   ext4


Model: ATA KINGSTON SA400S3 (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End 	Size	Type 	File system  Flags
 1  	1049kB  62.9GB  62.9GB  primary  ext4
 2  	62.9GB  240GB   177GB   primary  ext4

I don’t want to install using the ‘something else’ method. The correspondents in the above mentioned thread urged me not to use that method.

As I stated I installed Mint on the SSD drive and then formatted the HDD drive partitions. It worked but when I tried to restart the PC it refused to boot.

I’m out of my depth with this sort of thing.

If I use the same method that I’ve previously used and then disable UEFI will it boot then?
It refused to boot.

There's one problem staring you right in the face. You have two boot partitions. How is your PC going to know which boot partition to use? Personally I would always run my computer in UEFI mode if the motherboard is a UEFI one, which yours most likely is. So the ESP is the one that your PC should automatically refer to in UEFI mode.

So delete sda1, go into UEFI/BIOS (F2 button) and set PC to UEFI mode. You'll probably have to boot to your USB installer (Live Mint) if you get a boot error, as grub may still need to be reconfigured, but it's a relatively straightforward process to do that from there. On the other hand you could be lucky as an ESP exists (sda2) and may be already correctly configured for your PC to run as UEFI.
Computer: Dell Vostro 470
Systems: Linux Mint 21.2 Xfce (Victoria), Manjaro 23.1 Xfce (Vulcan), Windows 10 (22H2) Pro.
Studiohead
Level 2
Level 2
Posts: 99
Joined: Fri Jun 11, 2021 5:55 am

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Studiohead »

The boot key that I’ve used on this PC is F12 on this PC not F2. Is F2 for UEFI/BIOS?

I don’t understand what you mean when you say I have 2 x boot partitions, do you mean one on the SDD and one on the HDD?

Are you advising me to boot into the live image of Mint on the usb stick and then delete sda1 and then install Mint?

I’m getting more and more confused with all of this!
bendipa
Level 5
Level 5
Posts: 566
Joined: Sat Jan 04, 2020 8:02 pm
Location: NW London. UK

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by bendipa »

F12 is the key for your boot selection. All Dells use F2 key to access the UEFI/BIOs, and it's only from there that you can change the boot order for your systems (if you have multi-booting), and a number of other things besides. I should know. I have a Dell. As you've only got one system, ie Mint you don't have to worry about changing the boot order. So you can continue to use F12, eg to choose your USB Live Mint.

I don’t understand what you mean when you say I have 2 x boot partitio MBR booting with a GPTns,

If you look at your 3rd post where you list the parted command output, there are 2 partitions, sda1 and sda2. Both of these are where your PC is supposed to start a boot from. sda1 is for Legacy mode booting (using MBR system), and sda2 is for UEFI (EFI) booting. sda is a GPT disk, which in short indicates you are meant to use UEFI, although Linux can use a GPT disk using an MBR boot-up (unlike Windows). So there is a dilemma. Which boot-up method should your PC use?

As you have a GPT disk, I was advising you to switch your computer from Legacy BIOS to UEFI mode. You do that using the F2 key, Then once in UEFI go to the Boot tab, where you should see a choice for Legacy BIOS (sometimes called CSM) and UEFI. Choose UEFI then save settings on Exit. You should then press the F12 button on reboot to access your Live Mint, where you should run gparted and delete the sda1 partition, so as not to confuse your PC how it should boot. At this point you can only boot through UEFI.

There may be a further problem on reboot in that your ESP (sda2) may not be correctly configured, which would result in a boot error on rebooting. If that's the case, boot back into Live Mint from F12, and the ESP can be re-configured from there. Alternatively, you can do a few manual checks from Live Mint on your system before you reboot to ensure that sda2 is correctly configured in the first place rather than chancing on a straight reboot and hoping for the best. If on reboot you get a grub terminal prompt (grub bash), that's okay because you can boot to Mint from there, as long as the rest of your Mint system is undamaged.
Computer: Dell Vostro 470
Systems: Linux Mint 21.2 Xfce (Victoria), Manjaro 23.1 Xfce (Vulcan), Windows 10 (22H2) Pro.
Studiohead
Level 2
Level 2
Posts: 99
Joined: Fri Jun 11, 2021 5:55 am

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Studiohead »

I might have confused matters here by leading people to believe that the data that I’ve uploaded here is from the system that failed to boot. I tried to install Mint on the SSD and use the HDD for storage but, as I said, it failed to boot. I then installed Mint on the HDD and used the SSD for storage. This system boots and the data that I’ve uploaded here is from that system.

In other words it’s not a question of forcing a system that fails to boot to spark into life. It’s a question of how to do a fresh installation of Mint in which the op system will be installed on the fast SSD and the slower HDD will be used for storage.

I tried to do this before but it failed to boot and that’s the problem.

There are presently 3 x partitions on sda [500gb HDD]

1 Unknown 1mb
2 EFI 538mb
3 Filesystem 500gb

On sdb [240gb SSD] there are two partitions, which I created.

1 timeshift 63gb
2 data 177gb

When I installed the system that refused to boot I discovered that the 250gb SSD drive was listed as sdc and yet I’d examined the drives and partitions in Disks and Gparted before the installation and the same drive was listed there as sdb. For some reason sdb in Disks/Gparted changes to sdc in the Mint installer.

Have you any idea why that should happen? Could it be significant?

I’m thinking that I should boot into a live image of Mint and then use Gparted to delete all of the partitions on the 2 x drives and then use the Mint installer to do a fresh installation on the SSD and then use Gparted on the SSD to format the storage partitions on the HHD.

Would that be a good idea?

Should I boot into F2 beforehand and switch from Legacy BIOS to UEFI?
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

You don't considere installing with Something else... an option BUT it is the solution when the problem is firmware can not manage Linux Mint 21.X hybrid install/boot .


First decide the mode you want to boot/install as indicated on my first post from the beginning. Then boot Linux Mint Live USB in such mode and run Gparted to format and create partitions as desired on both disks.

- Choose HDD on Gparted menu. If dedicate for storage and backups you can click on Device>Create new partititon table> Choose GPT partitioning and create partitions you want.

-Choose SSD (never mind if if it is mapped as sdb or sdc) on Gparted menu Device>Create new partititon table.
-If going to install on BIOS mode MBR/msdos partioning. Then create partition you want but you only need a primary Ext-4 partition for root (do not create an EFI partition in any case).

-if going to install on UEFI mode choose GPT partitioning. Then create partition you will need. Minimum one 500MB FAT 32 partition to use as EFI partition and one Ext.4 partition for root (no dot create a bios-grub partition in any case).
When done run Mint installer clicking on desktop icon. As I said choose Something else... option. On Mint installer GUI:
-In case of BIOS installation select Ext 4 partition on SSD and click on Change button downside. Complete pop-up window accordingly (use as ext. 4, mount point / (root) and check to format.

-In case of UEFI also select Fat 32 partition> Click on Change button> use as EFI partition.

Confirm boot loader will be place on SSD disk on both cases and proceeed with installation. Ignore warnings about BIOS boot partition (in case of UEFI installation) or BIOS bios is needed (in case of BIOS installation) and click on Continue.

After installing remove Linux MInt USB and on restarting get into computer/BIOS Setup.
In case of BIOS Legacy place SSD first on boot order priorty

In case of UEFI installation in many Dell computers you will need to create a new boot option for ubuntu pointing to SSD>EFI partition>ubuntu folder>shim64.efi file.

in both cases save changes and exit to restart. :wink:
Arrieritos semos y en el camino nos encontraremos.
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

You don't considere installing with Something else... an option BUT it is the solution when the problem is firmware can not manage Linux Mint 21.X hybrid install/boot .

First decide the mode you want to boot/install as indicated on my first post from the beginning.

Then boot Linux Mint Live USB in such mode and run Disks or Gparted to format and create partitions as desired on both disks.

- Choose HDD on Gparted menu. If dedicate for storage and backups you can click on Device>Create partititon table> Choose GPT partitioning and then create partitions you want.

-Choose SSD (never mind if if it is mapped as sdb or sdc) on Gparted menu. Click on Device>Create partititon table.
-If going to install on BIOS mode MBR/msdos partioning. Then create partition you want but you only need a primary Ext-4 partition for root (do not create an EFI partition in any case).

-if going to install on UEFI mode choose GPT partitioning. Then create partition you will need. Minimum one 500MB FAT 32 partition to use as EFI partition and one Ext.4 partition for root (no dot create a bios-grub partition in any case).
When done run Mint installer clicking on desktop icon. As I said choose Something else... option. On Mint installer GUI:
-In case of BIOS installation select Ext 4 partition on SSD and click on Change button downside. Complete pop-up window accordingly (use as ext. 4, mount point / (root) and check to format.

-In case of UEFI also select Fat 32 partition> Click on Change button> use as EFI partition.

Confirm boot loader will be place on SSD disk on both cases and proceeed with installation. Ignore warnings about BIOS boot partition (in case of UEFI installation) or BIOS bios is needed (in case of BIOS installation) and click on Continue.

After installing remove Linux MInt USB and on restarting get into computer/BIOS Setup.
In case of BIOS Legacy place SSD first on boot order priorty

In case of UEFI installation in many Dell computers you will need to create a new boot option for ubuntu pointing to SSD>EFI partition>ubuntu folder>shim64.efi file.

in both cases save changes and exit to restart. :wink:
Arrieritos semos y en el camino nos encontraremos.
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

You don't considere installing with Something else... an option BUT it is the solution when the problem is firmware can not manage Linux Mint 21.X hybrid install/boot .

First decide the mode you want to boot/install as indicated on my first post from the beginning.

Then boot Linux Mint Live USB in such mode and run Disks or Gparted to format and create partitions as desired on both disks.

- Choose HDD on Gparted menu. If dedicate for storage and backups you can click on Device>Create partititon table> Choose GPT partitioning and then create partitions you want.

-Choose SSD (never mind if if it is mapped as sdb or sdc) on Gparted menu. Click on Device>Create partititon table.
-If going to install on BIOS mode MBR/msdos partioning. Then create partition you want but you only need a primary Ext-4 partition for root (do not create an EFI partition in any case).

-if going to install on UEFI mode choose GPT partitioning. Then create partition you will need. Minimum one 500MB FAT 32 partition to use as EFI partition and one Ext.4 partition for root (no dot create a bios-grub partition in any case).
When done run Mint installer clicking on desktop icon. As I said choose Something else... option. On Mint installer GUI:
-In case of BIOS installation select Ext 4 partition on SSD and click on Change button downside. Complete pop-up window accordingly (use as ext. 4, mount point / (root) and check to format.

-In case of UEFI also select Fat 32 partition> Click on Change button> use as EFI partition.

Confirm boot loader will be place on SSD disk on both cases and proceeed with installation.

Ignore warnings about BIOS boot partition (in case of UEFI installation) or BIOS bios is needed (in case of BIOS installation) and click on Continue.
After installing remove Linux MInt USB and on restarting get into computer/BIOS Setup.
In case of BIOS Legacy place SSD first on boot order priorty

In case of UEFI installation if there is no ubuntu option on Boot Order, in many Dell computers you need to create a new boot option for ubuntu pointing to SSD>EFI partition>ubuntu folder>shim64.efi file.

in both cases save changes and exit to restart. :wink:
Arrieritos semos y en el camino nos encontraremos.
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

You don't considere installing with Something else... an option BUT it is the solution when the problem is firmware can not manage Linux Mint 21.X hybrid install/boot .

First decide the mode you want to boot/install as indicated on my first post from the beginning.
Jo-con-Ël wrote: Mon Nov 27, 2023 7:17 am Get into computer Setup in oder to set Boot options accodingly the way/mode you want to boot/install:
-if BIOS Legacy, disable UEFI boot and enable Legacy OptionsROM if needed or

-if UEFI, disable Legacy and be sure Secure boot is disabled at the moment.
Then boot Linux Mint Live USB in such mode and run Disks or Gparted to format and create partitions as desired on both disks. With Gparted (Menu>Administration>Gparted)

- Choose HDD on Gparted menu. If dedicate for storage and backups you can click on Device>Create partition table
Screenshot from 2023-11-29 17-45-28.png
Choose gpt partitioning
Screenshot from 2023-11-29 17-51-13.png
Then create partitions you want.
-Choose SSD (never mind if if it is mapped as sdb or sdc) on Gparted menu. Click on Device>Create partition table:
-If going to install on BIOS mode choose msdos partioning. Then create partition you want but you only need a primary Ext-4 partition for root (do not create an EFI partition in any case).

-if going to install on UEFI mode choose gpt partitioning. Then create partition you will need. Minimum one 500MB FAT 32 partition to use as EFI partition and one Ext.4 partition for root (no dot create a bios-grub partition in any case).
When done run Mint installer clicking on desktop icon. As I said choose Something else... option. On Mint installer GUI:
-In case of BIOS installation only select Ext 4 partition on SSD and click on Change button downside. Complete pop-up window accordingly (use as ext. 4, mount point / (root) and check to format.

-In case of UEFI also select Fat 32 partition> Click on Change button> use as EFI partition.

Confirm boot loader will be place on SSD disk on both cases and proceeed with installation.

Ignore warnings about it is needed a BIOS boot partition (in case of UEFI installation) or EFI partition (in case of BIOS installation) and click on Continue.
After installing remove Linux MInt USB and on restarting get into computer/BIOS Setup.
In case of BIOS Legacy place SSD first on boot order priorty

In case of UEFI installation if there is no ubuntu option on Boot Order, in many Dell computers you need to create a new boot option for ubuntu pointing to SSD>EFI partition>ubuntu folder>shim64.efi file.

in both cases save changes and exit to restart. :wink:
Last edited by Jo-con-Ël on Wed Nov 29, 2023 12:58 pm, edited 2 times in total.
Arrieritos semos y en el camino nos encontraremos.
Studiohead
Level 2
Level 2
Posts: 99
Joined: Fri Jun 11, 2021 5:55 am

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Studiohead »

Thanks,

I think that the ‘something else’ method sounds like the best idea. I also think that I should use a BIOS Legacy installation method.

I’ll explain the method that I intend to use, please correct any errors that I’ve made.

Boot via F2 to enter computer setup and then disable UEFI and enable Legacy optionsROM

Boot via F12 into live image of Mint on usb stick.

Use Gparted to create partitions.

On HDD

device/create partition table/gpt

On SSD

device/create partition table/MBR/MSdos

Do not create an EFI partition

Click install and select ‘something else’

Ignore EFI warning and proceed with installation

After installation is complete restart and boot into F2 to enter BIOS/Setup and place SSD first in order of priority.

The questions that I have are: -

I just want to use the HDD for storage, should I just create one partition and should I create it like this?

Type = primary
Location = beginning
Size = all remaining
Mount point /home

Should it be Ext4 or gpt?

On SSD do I need a root and a storage partition and should I create them like this?

ROOT PARTITION

Size = 1024MB
Type = Primary
Location = Beginning
Ext 4
Mount Point /

STORAGE PARTITION

Type = Logical
Location = Beginning
Size = all remaining space
Ext4
Mount point /home

Do I select BIOS mode MBR/msdos partioning?

If I were to use the other method - using the Mint installer to install the op system on SSD and then using Gparted to format partitions on the HDD - would it work if I were to disable UEFI beforehand and then enter computer BIOS/setup afterwards in order to to set the SSD as ‘primary’?
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

(duplicated)
Last edited by Jo-con-Ël on Thu Nov 30, 2023 1:45 am, edited 1 time in total.
Arrieritos semos y en el camino nos encontraremos.
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

Notice I'm proposing/recommending to format disks first with gparted (see image I have attached recently on previous post) and also create partition with such tool before. When creating partitions with gparted (or Disks) you can not define mount points only sizes partition type (if MBR/msdos partitioning it could be primary or logical but first you need to create an extended partition) and filesystem.

Then, on installing with Something else option, you can "Change" those partitions already created. Change pop-up window is quite different to pop-up window when creating a new partitions on allocated space with Mint installer GUI. It looks like you are talking about last ones. On change pop-up windos you can change partition size but do not do it, not the place (at beguining,..) or type if disk is GPT. Just define use as and mount point fields and check to format.

Yes, you can remove and create partitions when installing with Something else option even create an new partition table but only on HDD (it will be GPT by default). If installing on BIOS mode you will need to format SSD firt with Gparted or Disk as it need to be msdos partitioning scheme.
Studiohead wrote: Wed Nov 29, 2023 4:50 am The questions that I have are: -

I just want to use the HDD for storage, should I just create one partition and should I create it like this?

Type = primary
Location = beginning
Size = all remaining
Mount point /home

Should it be Ext4 or gpt?


gpt is not a filesystem type but recommended partitioning scheme for storage drive (HDD). As I said you can create partitions you want on HDD when installing with Something else option and, yes, you can create only one partition you can use as Ext.4 moint point /home. Notice you will need to decide if mount this one on /home or the other one on SSD not both.
Studiohead wrote: Wed Nov 29, 2023 4:50 am On SSD do I need a root and a storage partition and should I create them like this?

ROOT PARTITION

Size = 1024MB
Type = Primary
Location = Beginning
Ext 4
Mount Point /

STORAGE PARTITION

Type = Logical
Location = Beginning
Size = all remaining space
Ext4
Mount point /home

Do I select BIOS mode MBR/msdos partioning?
If going to install on BIOS legacy mode, yes, format SSD with msdos partititoning scheme previouly with gparted. Yes, you can create root and /home partition on SSD but not together with the other one on HDD. Asign mount point /home only to one of them. I doesn't need to be logical I could be primary as the other Ext. 4 partition for root.
Studiohead wrote: Wed Nov 29, 2023 4:50 am If I were to use the other method - using the Mint installer to install the op system on SSD and then using Gparted to format partitions on the HDD - would it work if I were to disable UEFI beforehand and then enter computer BIOS/setup afterwards in order to to set the SSD as ‘primary’?
If you mean intalling with Erease all and Install on SSD (again) it will install on both BIOS and EFI mode and most probably will reproduce the problem when trying to boot on BIOS mode....but you can boot on UEFI (only) mode and, in case of problem, do as indicated on another thread and remove bios-grub partition.
Last edited by Jo-con-Ël on Wed Nov 29, 2023 3:53 pm, edited 1 time in total.
Arrieritos semos y en el camino nos encontraremos.
Studiohead
Level 2
Level 2
Posts: 99
Joined: Fri Jun 11, 2021 5:55 am

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Studiohead »

This is getting more and more confusing!

As I don’t really know what I’m doing I’m thinking that it might be an idea to take things one step at a time.

Step 1 would be to install Mint on the SSD creating a split load setup.

Step 2 would be to use Gparted to delete the Mint partitions on the HDD.

Step 3 would be to see if I can get Mint on the SSD to boot by entering computer setup and setting SSD as primary.

Step 4 (if I can get the SSD to boot) would be to use Gparted on the SSD to format the HDD so that it can be used for storage.

Does that make sense? Or is there something else I would have to do?
User avatar
Jo-con-Ël
Level 10
Level 10
Posts: 3417
Joined: Sun Jun 20, 2021 12:41 pm
Location: donde habita el olvido

Re: Mint 21.1 refuses to Boot after installation on PC with 2 x Drives.

Post by Jo-con-Ël »

Up to you. I'm leaving. Good luck. :wink:
Arrieritos semos y en el camino nos encontraremos.
Post Reply

Return to “Installation & Boot”