No WIFI

Questions about Wi-Fi and other network devices, file sharing, firewalls, connection sharing etc
Forum rules
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

No WIFI

Post by alicebtoklas »

Hi forum,
Since 2 days I can't use the wifi anymore. A notification says I'm connected but any software needing to use internet keeps hanging without finding it.
Problem appeared 2 days ago approx. with Mint 19 Tricia. Today I made a fresh install, Linux Mint 21.2. The problem persists.
Other machines in the house connect to the WIFI without problem.
Cable connection works OK.
Please help me!
Alice
Last edited by alicebtoklas on Sun Dec 03, 2023 7:10 am, edited 2 times in total.
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
User avatar
JerryF
Level 16
Level 16
Posts: 6511
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: No WIFI

Post by JerryF »

Following posted forum rules:

Please open the System Reports app and click the System Information tab on the left. Your computer's information should come up in the right pane. Click the Copy button and then paste the results into a reply window here so we can see how Linux Mint views your hardware. No need to use code tags because System Information copy already inserts the tags when you paste.
---OR---
Please post the results of this command using Terminal:

Code: Select all

inxi -Fdrxxz
Highlight and copy the results of the command from the Terminal (Shift+Ctrl+C). Click the </> button from the mini toolbar above the text box where you type your reply. Code tags [code][/code] will be inserted. Place your cursor between the code tags and paste the results of the command between the tags. Example: [code]copied results[/code].
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

Re: No WIFI

Post by alicebtoklas »

Thanks a lot.

Code: Select all

System:
  Kernel: 5.15.0-89-generic x86_64 bits: 64 compiler: gcc v: 11.4.0 Desktop: Cinnamon 5.8.4
    tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.2 Victoria base: Ubuntu 22.04 jammy
Machine:
  Type: Laptop System: LENOVO product: 20F5S23G2M v: ThinkPad X260 serial: <superuser required>
    Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20F5S23G2M v: SDK0J40705 WIN serial: <superuser required> UEFI: LENOVO
    v: R02ET46W (1.19 ) date: 03/15/2016
Battery:
  ID-1: BAT0 charge: 17.2 Wh (99.4%) condition: 17.3/23.2 Wh (74.4%) volts: 12.3 min: 11.1
    model: SANYO 45N1773 serial: <filter> status: Not charging
  ID-2: BAT1 charge: 30.4 Wh (54.5%) condition: 55.8/71.3 Wh (78.3%) volts: 10.8 min: 10.8
    model: SANYO 45N1777 serial: <filter> status: Discharging
CPU:
  Info: dual core model: Intel Core i5-6300U bits: 64 type: MT MCP arch: Skylake rev: 3 cache:
    L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 800 min/max: 400/3000 cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 19999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 v: kernel ports:
    active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1916
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-8:12
    chip-ID: 04f2:b52c
  Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: modesetting unloaded: fbdev,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 model: Chi Mei Innolux res: 1920x1080 dpi: 177 diag: 317mm (12.5")
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 23.0.4-0ubuntu1~22.04.1
    direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:9d70
  Sound Server-1: ALSA v: k5.15.0-89-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:156f
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: speed: 2.5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 8086:24f3
  IF: wlp4s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:2
    chip-ID: 8087:0a2b
  Report: hciconfig ID: hci0 rfk-id: 3 state: up address: <filter> bt-v: 2.1 lmp-v: 4.2
    sub-v: 100
Drives:
  Local Storage: total: 238.47 GiB used: 16.27 GiB (6.8%)
  ID-1: /dev/sda vendor: Micron model: MTFDDAK256MAY-1AH12ABHA size: 238.47 GiB speed: 6.0 Gb/s
    serial: <filter>
Partition:
  ID-1: / size: 233.18 GiB used: 16.26 GiB (7.0%) fs: ext4 dev: /dev/sda5
  ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat dev: /dev/sda1
Swap:
  ID-1: swap-1 type: file size: 2 GiB used: 2.5 MiB (0.1%) priority: -2 file: /swapfile
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002
  Device-1: 1-7:2 info: Intel Bluetooth wireless interface type: Bluetooth driver: btusb
    rev: 2.0 speed: 12 Mb/s chip-ID: 8087:0a2b
  Device-2: 1-8:12 info: Chicony Integrated Camera type: Video driver: uvcvideo rev: 2.0
    speed: 480 Mb/s chip-ID: 04f2:b52c
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s chip-ID: 1d6b:0003
Sensors:
  System Temperatures: cpu: 51.0 C pch: 49.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 3051
Repos:
  Packages: apt: 2103
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb http: //packages.linuxmint.com victoria main upstream import backport
    2: deb http: //archive.ubuntu.com/ubuntu jammy main restricted universe multiverse
    3: deb http: //archive.ubuntu.com/ubuntu jammy-updates main restricted universe multiverse
    4: deb http: //archive.ubuntu.com/ubuntu jammy-backports main restricted universe multiverse
    5: deb http: //security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Info:
  Processes: 231 Uptime: 11h 21m Memory: 7.62 GiB used: 3.92 GiB (51.5%) Init: systemd v: 249
  runlevel: 5 Compilers: gcc: 11.4.0 alt: 11/12 Client: Unknown python3.10 client inxi: 3.3.13
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
sleeper12
Level 21
Level 21
Posts: 14130
Joined: Thu May 25, 2017 3:22 pm

Re: No WIFI

Post by sleeper12 »

Post also:

Code: Select all

rfkill list ; iwconfig ; mokutil --sb-state
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

Re: No WIFI

Post by alicebtoklas »

Code: Select all

0: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
4: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
lo        no wireless extensions.

enp0s31f6  no wireless extensions.

wlp4s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          
SecureBoot disabled
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
JeremyB
Level 21
Level 21
Posts: 13651
Joined: Fri Feb 21, 2014 8:17 am

Re: No WIFI

Post by JeremyB »

In terminal

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Reboot, then do

Code: Select all

rfkill unblock all
Does it work then?
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

Re: No WIFI

Post by alicebtoklas »

No it still does not work!
I did everything suggested above.
Any other idea?
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
JeremyB
Level 21
Level 21
Posts: 13651
Joined: Fri Feb 21, 2014 8:17 am

Re: No WIFI

Post by JeremyB »

What results from terminal for

Code: Select all

rfkill list; dmesg|grep iwl
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

Re: No WIFI

Post by alicebtoklas »

Code: Select all

0: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
[    5.650245] iwlwifi 0000:04:00.0: loaded firmware version 36.ca7b901d.0 8000C-36.ucode op_mode iwlmvm
[    5.754327] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x204
[    5.841980] iwlwifi 0000:04:00.0: base HW address: 44:85:00:c3:c0:c1
[    5.932509] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    6.202171] iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
JeremyB
Level 21
Level 21
Posts: 13651
Joined: Fri Feb 21, 2014 8:17 am

Re: No WIFI

Post by JeremyB »

Try the FN keyboard combo for turning wifi on and off
User avatar
stevengarland
Level 5
Level 5
Posts: 806
Joined: Tue Mar 05, 2019 4:04 pm
Location: Michigan

Re: No WIFI

Post by stevengarland »

I would try moving up to at least a 6.2 kernel. Sometimes a simple fix.
Keep It Simple Sweetheart
sleeper12
Level 21
Level 21
Posts: 14130
Joined: Thu May 25, 2017 3:22 pm

Re: No WIFI

Post by sleeper12 »

You can also try:

Code: Select all

 rfkill unblock wifi 
Reddog1
Level 7
Level 7
Posts: 1822
Joined: Wed Jun 01, 2011 2:12 pm

Re: No WIFI

Post by Reddog1 »

Try the FN keyboard combo for turning wifi on and off
I thought the keyboard combo was a hard block. Am I wrong?
JeremyB
Level 21
Level 21
Posts: 13651
Joined: Fri Feb 21, 2014 8:17 am

Re: No WIFI

Post by JeremyB »

Reddog1 wrote: Thu Nov 30, 2023 10:00 pm
Try the FN keyboard combo for turning wifi on and off
I thought the keyboard combo was a hard block. Am I wrong?
Depends on what machine. Some Dell and Asus use the keyboard combo as hard block
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

Re: No WIFI

Post by alicebtoklas »

I tried

Code: Select all

 rfkill unblock wifi 
It didn't work.
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
sleeper12
Level 21
Level 21
Posts: 14130
Joined: Thu May 25, 2017 3:22 pm

Re: No WIFI

Post by sleeper12 »

Try it with sudo:

Code: Select all

sudo rfkill unblock wifi 
Or:

Code: Select all

sudo rfkill unblock all
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

Re: No WIFI

Post by alicebtoklas »

The thing is that wifi seems to be on.
This notification shows:
Image
Only the softwares do not connect to it.

By the way, I think I found the FN keyboard combo for turning wifi on and off, but nothing happens when I press it.

Thanks,
Attachments
Capture d’écran du 2023-12-01 18-10-55.png
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

Re: No WIFI

Post by alicebtoklas »

I tried

Code: Select all

sudo rfkill unblock wifi 
and

Code: Select all

sudo rfkill unblock all
It doesn't work
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
sleeper12
Level 21
Level 21
Posts: 14130
Joined: Thu May 25, 2017 3:22 pm

Re: No WIFI

Post by sleeper12 »

Does it work if you turn wifi off, run command, then turn back on?
alicebtoklas
Level 1
Level 1
Posts: 20
Joined: Sat Nov 24, 2012 6:31 pm

Re: No WIFI

Post by alicebtoklas »

I just realized the problem comes from my WIFI extender (tp-link). Some machines in the house are connected to the extender and some are connected directly to the wifi network, that's why I thought the problem was linked only to my computer. Sorry and thank you all for your time!!
Alice
Linux Mint 21.2 Vanessa Cinnamon on Lenovo Thinkpad
Post Reply

Return to “Networking”