Printing no longer works over IPP

Forum rules
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
Post Reply
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Printing no longer works over IPP

Post by warriorofthelight »

Hey there,

has there been something changed recently with IPP/Airprint? My Brother MFC J4540 worked fine until a few days(?) ago with Mint 20.3. Now I can't print anything any more. The printer still shows up, but doesn't respond to print requests. When I delete it it will immediatly show up again on the network, so I think everything is fine, except there is no printing... I just tried printing on the same LAN with my iPhone on this printer. Works as usual, so the printer is not the problem. I highly suspect some recent update has gone wrong...

Anybody knows something about that?
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

I tried installing the proprietary driver from Brother in the meantime, and after some tinkering the printer works. But no luck with Airprint/IPP. Can't understand what is happening here. IPP worked fine with it since I got the printer months ago, always on 20.3. And it still works when I print from the iPhone. Only if I try to print from Mint on one of the two printer icons (there are 2 for some reason), no luck. Also no test print possible.

The only difference I see between the proprietary and the ipp printer icons is the connection: proprietary uses socket://.... and ipp uses either ipp:// oder dns...://

What should be the protocol for the connection? I tried all available, none worked. And using ip address doesn't work for ipp.
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

Still nobody?

In the meantime I tried it with a notebook that runs Mint 21.3 and here the printer works fine over IPP. So the printer is certainly not the issue, but i have no clue what the problem on my 20.3 could be? I tried several times to remove the printer, reinstall it (to make sure the connection setting is correct): no luck.
User avatar
AndyMH
Level 21
Level 21
Posts: 14105
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Printing no longer works over IPP

Post by AndyMH »

warriorofthelight wrote: Fri Feb 02, 2024 6:40 am Only if I try to print from Mint on one of the two printer icons (there are 2 for some reason)
One is a manually added entry, e.g. you changed the printer name, the other is automatically "discovered" each time you boot. Has the IP address of the printer changed recently? Other than that no ideas.
Thinkcentre M720Q - LM21.3 cinnamon, 4 x T430 - LM21.3 cinnamon, Homebrew desktop i5-8400+GTX1080 Cinnamon 19.0
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

AndyMH wrote: Wed Feb 07, 2024 7:27 pm
warriorofthelight wrote: Fri Feb 02, 2024 6:40 am Only if I try to print from Mint on one of the two printer icons (there are 2 for some reason)
One is a manually added entry, e.g. you changed the printer name, the other is automatically "discovered" each time you boot. Has the IP address of the printer changed recently? Other than that no ideas.
No, nothing changed. And even if it has... on my notebook running 21.3 it instantly discovered the printer and could print fine. That's what IPP is for. Removing and adding the printer on my 20.3 pc works fine as well, but printing itself doesn't work. No errors, just no printing happens. I'm completely at a loss. I would go to 21.3 gladly, but there are other problems with that version for me (OpenCl...).
User avatar
AndyMH
Level 21
Level 21
Posts: 14105
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Printing no longer works over IPP

Post by AndyMH »

While I'm running LM21.3, it had little to offer me and a few downsides, I would have been better off sticking with LM20.3.
Thinkcentre M720Q - LM21.3 cinnamon, 4 x T430 - LM21.3 cinnamon, Homebrew desktop i5-8400+GTX1080 Cinnamon 19.0
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

AndyMH wrote: Thu Feb 08, 2024 7:06 am While I'm running LM21.3, it had little to offer me and a few downsides, I would have been better off sticking with LM20.3.
Honestly, that was my impression too. No advantages, but more issues - not the dev teams fault, but still.
Laugh2
Level 4
Level 4
Posts: 276
Joined: Fri Aug 16, 2013 4:01 am

Re: Printing no longer works over IPP

Post by Laugh2 »

We've had similar issues with LM21.x MATE. We have a Brother MFC-4540DW over wifi from our router with a Desktop (LM21.3 Virginia), a laptop (LM21 Vanessa), and a laptop (recent Macbook Pro from my wife's work). Printing was OK from the desktop on LM20.3 using DNS-SD but the laptop (LM21) would print OK for a day or two then stop printing even though no the configuration had been changed (by humans, at least). This has been going on ever since LM21 was put on the laptop a number of months ago. :(

Then a week or two ago I installed LM21.3 onto the desktop (which had been running LM20.3) and hey-presto the printing problems immediately began with the desktop, which under LM20.3 had been printing reliably every time. :(

So today I spent a few hours dredging the internet, repeatedly uninstalling and reinstalling, repeatedly trying something different ... but nothing seemed to work. Until I finally I did the following:
  • 1) changed one computer of the two computers from DNS-SD to IPP
    2) shut the printer down in between
    3) deleted all but one instance of that printer on any computer
... immediately both computers could print. :D

My current working hypothesis is that if multiple computers use the same protocol e.g. DNS-SD, then somewhere something gets confused and nothing prints although everything appears to be OK. It might be that the printer is getting confused? (Or maybe it is coincidence that the printer was shut down at the same time as one computer was changed from DNS-SD to IPP?)

Time will tell if this solution is stable and our problem is solved. Maybe it works in your context?
BillyLinux
Level 4
Level 4
Posts: 359
Joined: Wed Sep 07, 2022 6:09 am
Location: Wiltshire

Re: Printing no longer works over IPP

Post by BillyLinux »

Building on Laugh2 hypothesis my understanding is this:-
When a physical printer is accessed by more than one device, regardless of the network being utilised it "should" cleanse itself after it has completed the clients requests in such a way that any subsequent client from any source should also receive a satisfactory outcome.

In other words if I print from say an iphone to a printer and subsequently print from a linux device or vice-versa then I should receive 2 good outcomes. It should be exactly the same if 3 devices are used. Stating the obvious perhaps. But just imagine a scenario where for whatever reason, a print request is not fully cleansed afterwards. Could that cause a blockage and prevent further printing? In theory, no, because as far as I am aware at the start of a printing request is a little thing that cleanses the printer, just in case the last use did not cleanse it.

Back in the days when printers were attached via ethernet parts, there also used to be similar problems. An old trick which could never be explained was to detach the ethernet lead for 5 minutes or so and then reinsert. (we always asked the rookie apprentices to point the cable into a bucket to empty out the invisible ones and zeroes :) )

The "server" part of the printing resides on the device - not the printer or the router. But comms and handshaking are so important. If two devices are constantly trying to communicate (cleanse) is it any wonder you get blockages? I'm sure this is why switching everything off and switching things on in a particular order will sometimes work.
I am just one of the volunteers for a UK charity https://abilitynet.org.uk/
who provides free IT support to older people and disabled people of any age, anywhere in the UK.
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

Laugh2 wrote: Sun Feb 11, 2024 3:42 am We've had similar issues with LM21.x MATE. We have a Brother MFC-4540DW over wifi from our router with a Desktop (LM21.3 Virginia), a laptop (LM21 Vanessa), and a laptop (recent Macbook Pro from my wife's work). Printing was OK from the desktop on LM20.3 using DNS-SD but the laptop (LM21) would print OK for a day or two then stop printing even though no the configuration had been changed (by humans, at least). This has been going on ever since LM21 was put on the laptop a number of months ago. :(

Then a week or two ago I installed LM21.3 onto the desktop (which had been running LM20.3) and hey-presto the printing problems immediately began with the desktop, which under LM20.3 had been printing reliably every time. :(

So today I spent a few hours dredging the internet, repeatedly uninstalling and reinstalling, repeatedly trying something different ... but nothing seemed to work. Until I finally I did the following:
  • 1) changed one computer of the two computers from DNS-SD to IPP
    2) shut the printer down in between
    3) deleted all but one instance of that printer on any computer
... immediately both computers could print. :D

My current working hypothesis is that if multiple computers use the same protocol e.g. DNS-SD, then somewhere something gets confused and nothing prints although everything appears to be OK. It might be that the printer is getting confused? (Or maybe it is coincidence that the printer was shut down at the same time as one computer was changed from DNS-SD to IPP?)

Time will tell if this solution is stable and our problem is solved. Maybe it works in your context?
Thanks, I will check into this. My situation is not the same though, I only have 1 PC on my LAN that uses the printer. Later I only checked with my iPhone if the printer was the problem... which it wasn't. And then to get more hints I also tried the notebook running 21.3 - which in my case was the one that could print... but anyway. If there is something going on under the hood, it might show up in different symptoms on different setups. So it definitely is worth a try. At the moment I use the proprietary Brother driver, which lets me print. But I really want to go back to IPP, just felt so much better :)
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

BillyLinux wrote: Sun Feb 11, 2024 5:21 am Building on Laugh2 hypothesis my understanding is this:-
When a physical printer is accessed by more than one device, regardless of the network being utilised it "should" cleanse itself after it has completed the clients requests in such a way that any subsequent client from any source should also receive a satisfactory outcome.

In other words if I print from say an iphone to a printer and subsequently print from a linux device or vice-versa then I should receive 2 good outcomes. It should be exactly the same if 3 devices are used. Stating the obvious perhaps. But just imagine a scenario where for whatever reason, a print request is not fully cleansed afterwards. Could that cause a blockage and prevent further printing? In theory, no, because as far as I am aware at the start of a printing request is a little thing that cleanses the printer, just in case the last use did not cleanse it.

Back in the days when printers were attached via ethernet parts, there also used to be similar problems. An old trick which could never be explained was to detach the ethernet lead for 5 minutes or so and then reinsert. (we always asked the rookie apprentices to point the cable into a bucket to empty out the invisible ones and zeroes :) )

The "server" part of the printing resides on the device - not the printer or the router. But comms and handshaking are so important. If two devices are constantly trying to communicate (cleanse) is it any wonder you get blockages? I'm sure this is why switching everything off and switching things on in a particular order will sometimes work.
Not sure about this. I will try some stuff that Laugh2 suggested, most of which I already did (changing protocol, reinstalling printer...), but it's good to hear other people have similar issues and could solve them. In my case, only 1 PC was ever attached to my LAN, and there were no issues with the printer with Mint 20.3 since I bought it. Connected it, switched it on, and printed. No issues what so ever - until a few weeks ago, for mysterious reasons. Still 20.3, nothing that I know of changed, but no more printing - well I explained it all in detail before. So no other device there that could interfere, I never use my iPhone to print (except this once to test it, and once when I first installed the printer to check if it works). And when I brought my notebook (which is usually not connected to this network) it did work - so no, the "two devices theory" doesn't seem to apply here. But anyway, thanks for your thoughts. I will try some more, there has to be a solution.

Also, I did test out my hypothesis about a failed recent update of ipp and switched back to an older version of my system via Timeshift. Didn't change anything, so I guess that's not the reason (or it was an earlier update... ).
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

Laugh2 wrote: Sun Feb 11, 2024 3:42 am We've had similar issues with LM21.x MATE. We have a Brother MFC-4540DW
I just realize you have the same printer as me. I don't think that this is a coincidence...
Laugh2
Level 4
Level 4
Posts: 276
Joined: Fri Aug 16, 2013 4:01 am

Re: Printing no longer works over IPP

Post by Laugh2 »

Two days later and printing is still working from all 3 computers (using LM21.x and one Macbook, Brother MFC-4540DW). Maybe I've found a stable, successful configuration (at least for my configuration)? Time will tell. :D
Last edited by Laugh2 on Wed Feb 14, 2024 2:24 am, edited 1 time in total.
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

Laugh2 wrote: Tue Feb 13, 2024 3:09 am Two days later and printing is still working from all 3 computers (using LM21.x and one Macbook). Maybe I've found a stable, successful configuration (at least for my configuration)? Time will tell. :D
No luck here. Maybe I need to switch to 21.3 on my PC as well, as it works on the Notebook. But then I have other issues that I really have no desire to deal with... puh. Sometimes Linux does make it hard to be loved, honestly. I thought the whole printing pita was finally solved by IPP, but no. Still going strong.
User avatar
warriorofthelight
Level 3
Level 3
Posts: 114
Joined: Wed Jan 20, 2016 6:04 am

Re: Printing no longer works over IPP

Post by warriorofthelight »

Switched to 21.3 on my desktop pc and now printing works as it always did. Of course now I'm stuck with the AMD OpenCL problem I discussed several times here on other threads... :?
Laugh2
Level 4
Level 4
Posts: 276
Joined: Fri Aug 16, 2013 4:01 am

Re: Printing no longer works over IPP

Post by Laugh2 »

After working reliably for a week or so printing from the laptop (LM21) stopped, even though the computer was still receiving error messages from the printer regarding ink and paper levels - but the print job didn't succeed. Everything appeared OK and worked - just the print job didn't succeed.

So now I'm trying ipp everywhere.
Laugh2
Level 4
Level 4
Posts: 276
Joined: Fri Aug 16, 2013 4:01 am

Re: Printing no longer works over IPP

Post by Laugh2 »

After updating the LM21 laptop to LM21.3 the printer connections have remained stable. Assuming that printing remains stable now, then I would recommend anyone with the problems described should update asap.
Post Reply

Return to “Printers & Scanners”