[SOLVED] Mintupdate Broken?

Quick to answer questions about finding your way around Linux Mint as a new user.
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions use the other forums in the support section.
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
Post Reply
featherlessbiped
Level 1
Level 1
Posts: 45
Joined: Sat Jan 06, 2024 11:57 am

[SOLVED] Mintupdate Broken?

Post by featherlessbiped »

Starting mintupdate from terminal:

Code: Select all

person@computer:~$ mintupdate
person@computer:~$ /usr/lib/linuxmint/mintUpdate/mintUpdate.py:1379: DeprecationWarning: Gdk.threads_init is deprecated
  Gdk.threads_init()
/usr/lib/linuxmint/mintUpdate/mintUpdate.py:1764: DeprecationWarning: Gdk.threads_enter is deprecated
  Gdk.threads_enter()
/usr/lib/linuxmint/mintUpdate/mintUpdate.py:803: DeprecationWarning: Gdk.threads_leave is deprecated
  Gdk.threads_leave()
Flatpak: done generating updates
person@computer:~$ 
On clicking "Install Updates" and then "Continue" to the flatpaks dialog:

Code: Select all

person@computer:~$ 'GdkWaylandWindow' object has no attribute 'get_xid'
... at this point it just sits waiting for this to happen and does not return to the "accepting input" mode. The mintupdate tray icon has a red center with an exclamation mark, and on mousing over it displays this text: "Could not install the security updates". You can also see this at the bottom of the following screencap:
https://files.catbox.moe/f4jtvu.png

Note that I am trying to install a security update, Brave browser from the official Brave repo which I added according to the directions on their site, and then a bunch of flatpaks.

Here are my sources:

Code: Select all

person@computer:~$ cat /etc/apt/sources.list.d/official-package-repositories.list 
# Do not edit this file manually, use Software Sources instead.

deb http://packages.linuxmint.com virginia main upstream import backport #id:linuxmint_main

deb http://archive.ubuntu.com/ubuntu jammy main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu jammy-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu jammy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Here is everything in /etc/apt/sources.list.d

Code: Select all

person@computer:~$ cd /etc/apt/sources.list.d/
person@computer:/etc/apt/sources.list.d$ ls
brave-browser-release.list  official-package-repositories.list
Here is the brave source list:

Code: Select all

person@computer:/etc/apt/sources.list.d$ cat brave-browser-release.list 
deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] https://brave-browser-apt-release.s3.brave.com/ stable main
Last edited by featherlessbiped on Sun Apr 14, 2024 6:35 am, edited 1 time in total.
mikeflan
Level 17
Level 17
Posts: 7308
Joined: Sun Apr 26, 2020 9:28 am
Location: Houston, TX

Re: Mintupdate Broken?

Post by mikeflan »

Please type this in a terminal:

Code: Select all

inxi -Fxxxrzc0 --usb
Post the output to this forum in "Code" tags. The button that inserts these Code tags is marked </>, which is in the mini toolbar above the edit box where you type your reply.
viewtopic.php?f=42&t=364929
featherlessbiped
Level 1
Level 1
Posts: 45
Joined: Sat Jan 06, 2024 11:57 am

Re: Mintupdate Broken?

Post by featherlessbiped »

Code: Select all

System:
  Kernel: 6.5.0-27-generic x86_64 bits: 64 compiler: N/A
    Desktop: Cinnamon 6.0.4 tk: GTK 3.24.33 wm: muffin vt: 8 dm: LightDM 1.30.0
    Distro: Linux Mint 21.3 Virginia base: Ubuntu 22.04 jammy
Machine:
  Type: Laptop System: Notebook product: L140AU v: N/A
    serial: <superuser required> Chassis: No Enclosure type: 10
    serial: <superuser required>
  Mobo: Notebook model: L140AU serial: <superuser required> UEFI: INSYDE
    v: 1.07.06 date: 06/08/2023
Battery:
  ID-1: BAT0 charge: 60.1 Wh (83.1%) condition: 72.3/73.9 Wh (97.8%)
    volts: 8.2 min: 7.7 model: Notebook BAT type: Li-ion serial: <filter>
    status: Discharging
CPU:
  Info: 10-core (2-mt/8-st) model: 13th Gen Intel Core i7-1355U bits: 64
    type: MST AMCP smt: enabled arch: N/A rev: 3 cache: L1: 928 KiB L2: 6.5 MiB
    L3: 12 MiB
  Speed (MHz): avg: 408 high: 497 min/max: 400/5000:3700 cores: 1: 400
    2: 400 3: 400 4: 400 5: 497 6: 400 7: 400 8: 400 9: 400 10: 400 11: 400
    12: 400 bogomips: 62668
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel vendor: CLEVO/KAPOK driver: i915 v: kernel ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:a7a1 class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.1
    driver: X: loaded: modesetting unloaded: fbdev,vesa gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics res: 1920x1080 dpi: 158
    size: 309x174mm (12.2x6.9") diag: 355mm (14") modes: 1920x1080
  OpenGL: renderer: Mesa Intel Graphics (RPL-U)
    v: 4.6 Mesa 23.2.1-1ubuntu3.1~22.04.2 direct render: Yes
Audio:
  Device-1: Intel vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:51ca class-ID: 0403
  Sound Server-1: ALSA v: k6.5.0-27-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 00:14.3
    chip-ID: 8086:51f1 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:2 chip-ID: 8087:0026 class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter>
    bt-v: 3.0 lmp-v: 5.2 sub-v: 356b hci-v: 5.2 rev: 356b
Drives:
  Local Storage: total: 7.28 TiB used: 332.43 GiB (4.5%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 990 PRO 4TB size: 3.64 TiB
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 0B2QJXG7
    temp: 32.9 C scheme: GPT
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 990 PRO 4TB size: 3.64 TiB
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 0B2QJXG7
    temp: 29.9 C scheme: GPT
Partition:
  ID-1: / size: 3.54 TiB used: 231.43 GiB (6.4%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 998 MiB used: 6.1 MiB (0.6%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: partition size: 40 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-10:2 info: Intel AX201 Bluetooth type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0026 class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Repos:
  Packages: 3521 apt: 3488 flatpak: 33
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb http://packages.linuxmint.com virginia main upstream import backport
    2: deb http://archive.ubuntu.com/ubuntu jammy main restricted universe multiverse
    3: deb http://archive.ubuntu.com/ubuntu jammy-updates main restricted universe multiverse
    4: deb http://archive.ubuntu.com/ubuntu jammy-backports main restricted universe multiverse
    5: deb http://security.ubuntu.com/ubuntu/ jammy-security main restricted universe multiverse
Info:
  Processes: 337 Uptime: 1h 29m wakeups: 7871 Memory: 38.88 GiB
  used: 2.65 GiB (6.8%) Init: systemd v: 249 runlevel: 5 Compilers:
  gcc: 11.4.0 alt: 11/12 Shell: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.13
I removed the official Brave repo and installed a flatpak instead, using these commands prior to running inxi as above.

Code: Select all

 sudo apt remove brave-browser brave-keyring
sudo rm /etc/apt/sources.list.d/brave-browser-*.list
User avatar
Pjotr
Level 24
Level 24
Posts: 20290
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland) 🇳🇱 🇮🇱
Contact:

Re: Mintupdate Broken?

Post by Pjotr »

Try this:

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
Tip: 10 things to do after installing Linux Mint 21.3 Virginia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
featherlessbiped
Level 1
Level 1
Posts: 45
Joined: Sat Jan 06, 2024 11:57 am

Re: Mintupdate Broken?

Post by featherlessbiped »

Pjotr wrote: Sun Apr 14, 2024 4:22 am Try this:

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
That did it, thanks.
Post Reply

Return to “Beginner Questions”