[Solucionado] Instalar multifuncional HP Ink Advantage 1515

Foro de soporte para usuarias de habla hispana

Moderator: Wibol

Forum rules
Topics in this forum are automatically closed 6 months after creation.
Locked
advericdemegrez
Level 2
Level 2
Posts: 55
Joined: Fri Nov 02, 2018 11:28 pm

[Solucionado] Instalar multifuncional HP Ink Advantage 1515

Post by advericdemegrez »

Hola.

Mi sistema:
Linux Mint 21.3 Virginia de 64 bits
Núcleo Linux 5.15.0-102-generic x86_64
MATE 1.26.0
Memoria: 8GB
Procesador: Intel® Core™ i5-4460 CPU @ 3.20GHz × 4
Grafica: NVIDIA GeForce GTX 1650/PCIe/SSE2

Estoy tratando de instalar este escaner, la impresora ya no sirve pero el escaner me es muy util este momento, ya se probo en un equipo con windows y ademas el programa de escanear documentos que viene en linux mint me permitio escanear un par de documentos sin drivers ni nada pero ahora ya no reconoce el escaner, probe con varias herramientas que usan SANE y tampoco lo reconocen, me descargue los drivers oficiales mas recientes "hplip-3.23.12.run" del 2023-11-30 de aqui:

https://support.hp.com/uy-es/drivers/hp ... el/5285090

Al final te manda a una pagina de un proyecto de Source Forge, me los descargue a pesar de la mala pinta que tenian y estoy siguiendo este tutorial en youtube:

https://www.youtube.com/watch?v=j4cfwwq3G9k

Mientras esta instalando me sale primero esta advertencia:

Code: Select all

error: linuxmint-21.3 version is not supported, so all dependencies may not be installed. However trying to install using linuxmint-21.1 version packages.
Dice mas o menos que Linux min 21.3 no es soportado y que tal vez no todas las dependencias van a ser instaladas, etc... supongo que sera ese el problema pero les escribo para ver si hay solucion, en fin continua con la instalacion y me dice que estas dependencias no han podido ser instaladas y que tendre que instalarlas manualmente,:

Code: Select all

warning: Missing REQUIRED dependency: libtool (libtool - Library building support services)
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libusb (libusb - USB library)
warning: Missing REQUIRED dependency: python3-devel (Python devel - Python development files)
warning: Missing REQUIRED dependency: libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing REQUIRED dependency: libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency: python3-pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))
warning: This installer cannot install 'python3-pyqt4' for your distro/OS and/or version.
Trate de hacerlo con el comando sudo apt-get install "nombre de la dependencia" una por una y con todas al tiempo (y tambien con synaptic) pero el resultado es el mismo:

Code: Select all

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete libcrypto
Se que debe ser por la version de Linux Mint, pero me gustaria saber si hay alguna solucion a esto.

Gracias!

Actualización

Recibí ayuda del soporte de HPLIP aqui:
https://answers.launchpad.net/hplip
Alguien me sugirio que siguiera estas instrucciones:
https://developers.hp.com/hp-linux-imag ... /linuxmint
Todo parece ir bien hasta el paso 4 primero me devuelve este mensaje:

Code: Select all

configure: error: cannot find net-snmp support (or --disable-network-build)
Y despues en el paso 5 me dice esto:

Code: Select all

make: *** No se especificó ningún objetivo y no se encontró ningún makefile.  Alto.
He verificado la carpeta, hay un par de archivos Makefile uno es "Makefile.am" y el otro es "Makefile.in" ya he instalado varios programas de forma "manual" sin problemas, instalando las dependencias, compilando etc. ¿Sera diferente con este programa? ¿habra que indicar el archivo especifico makefil.am o .in? les pregunto porque de verdad me urge trabajar con el escaner y creo que de pronto la solucion pueda ser sencilla.

Solución

En el soporte de HPLIP me recomendaron instalar hplip-gui yo lo instale desde el gestor de software, les va instalar tambien Hplip y ahora funciona perfecto, gracias tambien a Wibol pór su ayuda se apreecia mucho.
Last edited by advericdemegrez on Tue Apr 23, 2024 10:56 am, edited 1 time in total.
advericdemegrez
Level 2
Level 2
Posts: 55
Joined: Fri Nov 02, 2018 11:28 pm

Re: Instalar multifuncional HP Ink Advantage 1515

Post by advericdemegrez »

Actualización

Recibí ayuda del soporte de HPLIP aqui:
https://answers.launchpad.net/hplip
Alguien me sugirio que siguiera estas instrucciones:
https://developers.hp.com/hp-linux-imag ... /linuxmint
Todo parece ir bien hasta el paso 4 primero me devuelve este mensaje:

Code: Select all

configure: error: cannot find net-snmp support (or --disable-network-build)
Y despues en el paso 5 me dice esto:

Code: Select all

make: *** No se especificó ningún objetivo y no se encontró ningún makefile.  Alto.
He verificado la carpeta, hay un par de archivos Makefile uno es "Makefile.am" y el otro es "Makefile.in" ya he instalado varios programas de forma "manual" sin problemas, instalando las dependencias, compilando etc. ¿Sera diferente con este programa? ¿habra que indicar el archivo especifico makefil.am o .in? les pregunto porque de verdad me urge trabajar con el escaner y creo que de pronto la solucion pueda ser sencilla.
User avatar
Wibol
Level 6
Level 6
Posts: 1406
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Instalar multifuncional HP Ink Advantage 1515

Post by Wibol »

Prueba a instalar el paquete 'snmp' desde el repositorio:

Code: Select all

apt install snmp
O como sugiere el mensaje de error (si no vas a usar el escáner conectado a la LAN, sino a un equipo), sustituye --enable-network-build por --disable-network-build en el comando original para que quede así:

Code: Select all

./configure --with-hpppddir=/usr/share/ppd/HP --prefix=/usr --enable-udev-acl-rules --enable-qt4 --disable-libusb01_build --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --disable-udev_sysfs_rules --disable-policykit --enable-cups-drv-install --enable-hpcups-install --disable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build
El tutorial Compartir escáner USB con la red local te puede ayudar en caso de verte obligado a conectarlo a un equipo por USB.

Respecto al punto 5 no puedo decirte nada. Nunca compilé.
Image

No olvides:
  • Leer la Guía de publicación antes de hacer una consulta.
  • Añadir [SOLUCIONADO] al título del primer mensaje de tu consulta cuando así lo consideres.
advericdemegrez
Level 2
Level 2
Posts: 55
Joined: Fri Nov 02, 2018 11:28 pm

Re: [Solucionado] Instalar multifuncional HP Ink Advantage 1515

Post by advericdemegrez »

Solución

En el soporte de HPLIP me recomendaron instalar hplip-gui yo lo instale desde el gestor de software, les va instalar tambien Hplip y ahora funciona perfecto, gracias tambien a Wibol por su ayuda se aprecia mucho.
Locked

Return to “Español - Spanish”