outdated xdg-desktop-portal-gtk on mint 21.2

Suggestions and feedback for Linux Mint and the forums
Forum rules
Do not post support questions here. Before you post read: Where to post ideas & feature requests
User avatar
SMG
Level 25
Level 25
Posts: 33019
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: outdated xdg-desktop-portal-gtk on mint 21.2

Post by SMG »

MikeNovember wrote: Sun Jun 09, 2024 6:42 amIt is a nonsense to stay stuck for five years with Ubuntu flatpak frameworks and its portals:
What is nonsense is for you to quote me with your complaints about how Linux Mint is developed. I am not a Linux Mint developer and have no say so at all in its development.

You deleting your prior post to make the same exact post with the addition of quoting me wastes your time and mine. I am a Linux Mint user who does not even use flatpaks. I will not volunteer my time to address your specific questions about how you think you know better than the developers of what is needed for this to work properly on Linux Mint.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
User avatar
MikeNovember
Level 7
Level 7
Posts: 1932
Joined: Fri Feb 28, 2020 7:37 am
Location: Nice, Paris, France

Re: outdated xdg-desktop-portal-gtk on mint 21.2

Post by MikeNovember »

SMG wrote: Sun Jun 09, 2024 8:34 am You deleting your prior post to make the same exact post with the addition of quoting me wastes your time and mine. I am a Linux Mint user who does not even use flatpaks. I will not volunteer my time to address your specific questions about how you think you know better than the developers of what is needed for this to work properly on Linux Mint.
Hi,

1) Sorry for deleting the post, I had wrongly doubled it instead of correcting it.

2) We are in the suggestions and feedback sub-forum; this sub-forum is supposed to be read by Linux Mint developers, not only by users.

3) I quoted you because you wrote (or quote):
In order for Linux Mint to be able to work with the newer version of xdg-desktop-portal, the Linux Mint package of xdg-desktop-portal-xapp must be updated.
But I have tested that flatpak apps can work without "xdg-desktop-portal-xapp" being installed, in Linux Mint 21.3 Mate, like flatpaks work in Linux Mint 20.x Cinnamon, Mate or XFCE without using "xdg-desktop-portal-xapp" (not available) but "xdg-desktop-portal-gtk".

So, to benefit of new functionalities, only recent versions of "xdg-desktop-portal" and "xdg-desktop-portal-gtk" are needed. Of course, to build them, some libraries are needed that are not part of Linux Mint 21.3 / Jammy, and building them might request a newer operating system, with static linking, in order needed libraries are included in the compiled "xdg-desktop-portal" and "xdg-desktop-portal-gtk".

Note that it is not just a question of having new functionalities: between "xdg-desktop-portal" 1.14.1 and 1.18.4 there are a lot of bugs and crashes fixes, including a memory seg fault that could be a security weakness; and between "xdg-desktop-portal-gtk" 1.14.0 and 1.15.1 there are bugs and crashes fixes, including a use after free that could be a security weakness.

It is the same thing for flatpak component itself, 1.12.7 for Jammy while latest stable version is 1.14.8; between these two versions, there are bugs, crashes and security fixes.

This shows that Ubuntu does NOT maintain flatpak framework and its components, even when security is involved.


We are in a paradoxical situation where Linux Mint team discourages the use of snaps (and I understand why), while snapd is maintained by Ubuntu, and encourages the use of flatpaks while flatpak framework and its component are not maintained by Ubuntu, and not more maintained by Linux Mint team.

Regards,

MN
_____________________________
Linux Mint 21.3 Mate host with Ubuntu Pro enabled, VMware Workstation Player with Windows 10 Pro guest, ASUS G74SX (i7-2670QM, 16 GB RAM, GTX560M with 3GB RAM, 1TB SSD).
User avatar
SMG
Level 25
Level 25
Posts: 33019
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: outdated xdg-desktop-portal-gtk on mint 21.2

Post by SMG »

MikeNovember wrote: Sun Jun 09, 2024 9:11 am...this sub-forum is supposed to be read by Linux Mint developers, not only by users.
I am not aware of that as a requirement for Linux Mint developers. In fact, the Forum rules for this forum say, "Do not post support questions here. Before you post read: Where to post ideas & feature requests"

If you go to that topic, it indicates to post on GitHub if you want the attention of developers. You can post in the respective repository of the software with which your suggestion applies or you can post on Linux Mint Discussions.
MikeNovember wrote: Sun Jun 09, 2024 9:11 am I quoted you because you wrote (or quote):
In order for Linux Mint to be able to work with the newer version of xdg-desktop-portal, the Linux Mint package of xdg-desktop-portal-xapp must be updated.
But I have tested that flatpak apps can work without "xdg-desktop-portal-xapp" being installed, in Linux Mint 21.3 Mate, like flatpaks work in Linux Mint 20.x Cinnamon, Mate or XFCE without using "xdg-desktop-portal-xapp" (not available) but "xdg-desktop-portal-gtk".
If you know better than the developer what is needed, then you should be posting on GitHub and not quoting me as I relay information I was given. I have already provided the link to the bug report and I don't see where anyone posted saying any of the software commits which fix the issue are not needed.
Image
A woman typing on a laptop with LM20.3 Cinnamon.
Post Reply

Return to “Suggestions & Feedback”