Mounting takes 121 seconds on fast SSD (var-lib-lxcfs.mount @2min 1.076s)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Mounting takes 121 seconds on fast SSD (var-lib-lxcfs.mount @2min 1.076s)

Post by FeliksWR »

Linux mint usually booted very quickly.
But one day, it got slower.

Btw, I am dual-booting w/ Windows.
Also, both Os es boot from SSD.

Code: Select all

$ sudo systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @2min 9.143s
└─multi-user.target @2min 9.143s
  └─lxc.service @2min 9.114s +28ms
    └─lxc-net.service @2min 8.875s +186ms
      └─network-online.target @2min 8.822s
        └─NetworkManager-wait-online.service @2min 2.275s +6.545s
          └─NetworkManager.service @2min 2.000s +272ms
            └─network-pre.target @2min 1.962s
              └─ufw.service @2min 1.361s +497ms
                └─local-fs.target @2min 1.312s
                  └─var-lib-lxcfs.mount @2min 1.855s
                    └─local-fs-pre.target @1.300s
                      └─systemd-tmpfiles-setup-dev.service @1.242s +57ms
                        └─systemd-sysusers.service @1.211s +30ms
                          └─systemd-remount-fs.service @1.138s +47ms
                            └─systemd-journald.socket @1.124s
                              └─system.slice @1.096s
                                └─-.slice @1.096s

Code: Select all

─var-lib-lxcfs.mount @2min 1.855s
Is mounting taking too long??

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=a3c35816-327e-4132-80fa-93e36243e99f /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=823A-2BEA  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0

Code: Select all

sudo blkid
/dev/sdb3: UUID="9ba2fab2-1306-4802-905e-64c69bfda9dd" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="Data (Linux)" PARTUUID="5c853b47-84f0-4b24-87e8-4682a6d0a302"
/dev/sdb1: LABEL="Hard Disk" BLOCK_SIZE="512" UUID="FAFC6BC2FC6B7831" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="bb9f6713-e7be-48ee-8dcf-275b475717ee"
/dev/sda4: BLOCK_SIZE="512" UUID="FA74777074772E8F" TYPE="ntfs" PARTUUID="9d0733d2-1d02-4976-9fda-13761c7e7e38"
/dev/sda5: UUID="a3c35816-327e-4132-80fa-93e36243e99f" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="c7ab053e-458a-424f-a180-d13b75c3aa40"
/dev/sda3: BLOCK_SIZE="512" UUID="521C4F971C4F754F" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="8996502d-80b7-4616-803d-509a98cdc633"
/dev/sda1: UUID="823A-2BEA" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="274076b7-fca6-4bc5-8874-aa2e45f9a91d"
/dev/sdb2: PARTLABEL="Microsoft reserved partition" PARTUUID="20880966-11f3-11eb-a823-84a93e8a2c15"
/dev/sda2: PARTLABEL="Microsoft reserved partition" PARTUUID="8eaa4077-8424-4f05-a256-c11cd459396a"
Please help!
Last edited by FeliksWR on Thu Jun 20, 2024 8:36 am, edited 1 time in total.
User avatar
all41
Level 19
Level 19
Posts: 9769
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Boots too slowly

Post by all41 »

FeliksWR wrote: Mon Jun 10, 2024 9:49 am

Code: Select all

graphical.target @2min 9.143s
└─multi-user.target @2min 9.143s
  └─lxc.service @2min 9.114s +28ms
    └─lxc-net.service @2min 8.875s +186ms
      └─network-online.target @2min 8.822s
        └─NetworkManager-wait-online.service @2min 2.275s +6.545s
          └─NetworkManager.service @2min 2.000s +272ms
            └─network-pre.target @2min 1.962s
              └─ufw.service @2min 1.361s +497ms
                └─local-fs.target @2min 1.312s
                  └─var-lib-lxcfs.mount @2min 1.855s
                    └─local-fs-pre.target @1.300s
                      └─systemd-tmpfiles-setup-dev.service @1.242s +57ms
                        └─systemd-sysusers.service @1.211s +30ms
                          └─systemd-remount-fs.service @1.138s +47ms
                            └─systemd-journald.socket @1.124s
                              └─system.slice @1.096s
                                └─-.slice @1.096s
for comparison:

Code: Select all

graphical.target @2.195s
└─multi-user.target @2.195s
  └─getty.target @2.195s
    └─getty@tty1.service @2.194s
      └─system-getty.slice @2.193s
        └─setvtrgb.service @2.181s +11ms
          └─plymouth-quit-wait.service @2.045s +134ms
            └─systemd-user-sessions.service @2.037s +4ms
              └─network.target @2.032s
                └─networking.service @1.990s +40ms
                  └─network-pre.target @1.988s
                    └─ufw.service @1.469s +519ms
                      └─local-fs.target @1.462s
                        └─zfs-mount.service @1.454s +8ms
                          └─zfs-import.target @1.453s
There is exceptional 2 minute delay between local-fs.target and var-lib-lxcfs.mount.
Not sure why though
Everything in life was difficult before it became easy.
mikeflan
Level 17
Level 17
Posts: 7585
Joined: Sun Apr 26, 2020 9:28 am
Location: Houston, TX

Re: Boots too slowly

Post by mikeflan »

Please show the output of this in a terminal:

Code: Select all

inxi -Sxxx
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

Code: Select all

$ inxi -Sxxx
System:
  Host: HP-EliteDesk-800-G5-TWR Kernel: 6.5.0-1023-oem x86_64 bits: 64
    compiler: N/A Desktop: Cinnamon 6.0.4 tk: GTK 3.24.33 wm: muffin vt: 7
    dm: LightDM 1.30.0 Distro: Linux Mint 21.3 Virginia
    base: Ubuntu 22.04 jammy

Code: Select all

$ sudo inxi -Sxxx
System:
  Host: HP-EliteDesk-800-G5-TWR Kernel: 6.5.0-1023-oem x86_64 bits: 64
    compiler: N/A Desktop: Cinnamon 6.0.4 tk: GTK 3.24.33 wm: muffin
    dm: LightDM 1.30.0 Distro: Linux Mint 21.3 Virginia
    base: Ubuntu 22.04 jammy
mikeflan
Level 17
Level 17
Posts: 7585
Joined: Sun Apr 26, 2020 9:28 am
Location: Houston, TX

Re: Boots too slowly

Post by mikeflan »

That inxi looks good.
Linux mint usually booted very quickly.
But one day, it got slower.
Try Timeshift. That might fix this.
Have you done anything with containers (bottles or docker) recently?

This might be real bad advice. You might want to wait around for a while before you try this:

Startup LM and type this in a terminal:

Code: Select all

sudo systemctl stop --disable var-lib-lxcfs.mount
Then reboot.

If you ever want to undo this and you can still boot up LM, type this in a terminal:

Code: Select all

sudo systemctl start --enable var-lib-lxcfs.mount
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

Nothing with containers.

NOW I RECALL. IT WAS WINDOWS UPDATE THAT CHANGED THE BOOT ORDER

And that was BEFORE i used timeshift...
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

How to fix it??
mikeflan
Level 17
Level 17
Posts: 7585
Joined: Sun Apr 26, 2020 9:28 am
Location: Houston, TX

Re: Boots too slowly

Post by mikeflan »

How to fix it??
Sorry, but I don't know. I don't know what the windows update did. And I don't know what the boot order has to do with the time it takes to boot up.
I would type this in a terminal:

Code: Select all

sudo update-grub
Then reboot.

Beyond that, I don't know what to do for a person who doesn't have a TS snapshot to restore.
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

I tried this command.
But it changed absolutely nothing.
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

I booted into Windows to make space for time shift.
Next time, no dual-boot, only pure linux
mikeflan
Level 17
Level 17
Posts: 7585
Joined: Sun Apr 26, 2020 9:28 am
Location: Houston, TX

Re: Boots too slowly

Post by mikeflan »

I would call that a good development, but I suspect you think it is bad.
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

mikeflan wrote: Tue Jun 11, 2024 9:18 am That inxi looks good.
Linux mint usually booted very quickly.
But one day, it got slower.
Try Timeshift. That might fix this.
Have you done anything with containers (bottles or docker) recently?

This might be real bad advice. You might want to wait around for a while before you try this:

Startup LM and type this in a terminal:

Code: Select all

sudo systemctl stop --disable var-lib-lxcfs.mount
Then reboot.

If you ever want to undo this and you can still boot up LM, type this in a terminal:

Code: Select all

sudo systemctl start --enable var-lib-lxcfs.mount
This command did not work:

Code: Select all

$ sudo systemctl stop --disable var-lib-lxcfs.mount
systemctl: unrecognized option '--disable'
mikeflan
Level 17
Level 17
Posts: 7585
Joined: Sun Apr 26, 2020 9:28 am
Location: Houston, TX

Re: Boots too slowly

Post by mikeflan »

Try this instead:

Code: Select all

sudo systemctl stop disable var-lib-lxcfs.mount
Just removed the two '--'.
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

mikeflan wrote: Tue Jun 18, 2024 10:14 pm Try this instead:

Code: Select all

sudo systemctl stop disable var-lib-lxcfs.mount
Just removed the two '--'.
After running command, and restarting PC:

Code: Select all

$ sudo systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @2min 8.074s
└─multi-user.target @2min 8.074s
  └─lxc.service @2min 8.030s +43ms
    └─lxc-net.service @2min 7.756s +237ms
      └─network-online.target @2min 7.721s
        └─NetworkManager-wait-online.service @2min 1.338s +6.382s
          └─NetworkManager.service @2min 1.191s +138ms
            └─network-pre.target @2min 1.189s
              └─ufw.service @2min 847ms +218ms
                └─local-fs.target @2min 835ms
                  └─var-lib-lxcfs.mount @2min 1.076s
                    └─local-fs-pre.target @738ms
                      └─systemd-tmpfiles-setup-dev.service @716ms +22ms
                        └─systemd-sysusers.service @699ms +17ms
                          └─systemd-remount-fs.service @622ms +53ms
                            └─systemd-journald.socket @608ms
                              └─-.mount @577ms
                                └─-.slice @578ms
SAME OLD ISSUE!
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

Some Ubuntu/Mint dev here to help??
User avatar
all41
Level 19
Level 19
Posts: 9769
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Boots too slowly

Post by all41 »

FeliksWR wrote: Thu Jun 20, 2024 8:32 am
SAME OLD ISSUE!
You said you can boot into both Windows and Mint (which takes too long).
Are you making this choice using the grub boot-loader menu?

Yes windows update can mess with the boot loader but it usually causes a
Linux no boot situation--not a slow boot.
Everything in life was difficult before it became easy.
User avatar
PaulL
Level 6
Level 6
Posts: 1490
Joined: Mon Apr 24, 2023 10:57 am
Location: Connecticut

Re: Mounting takes 121 seconds on fast SSD (var-lib-lxcfs.mount @2min 1.076s)

Post by PaulL »

It's local-fs-pre.target that is holding things up. I suspect that it is trying to load something that is timing out. But what? My first thought was a problem with one of your Windows partitions, but they aren't even listed in fstab, so that can't be it.

When you shut down Windows, is it sleeping, or actually powering off? Is Fast Start/Fast Boot/Quick Start/Quick Boot enabled in Windows? If so, turn it off.
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Mounting takes 121 seconds on fast SSD (var-lib-lxcfs.mount @2min 1.076s)

Post by FeliksWR »

PaulL wrote: Sat Jun 22, 2024 9:46 am It's local-fs-pre.target that is holding things up. I suspect that it is trying to load something that is timing out. But what? My first thought was a problem with one of your Windows partitions, but they aren't even listed in fstab, so that can't be it.

When you shut down Windows, is it sleeping, or actually powering off? Is Fast Start/Fast Boot/Quick Start/Quick Boot enabled in Windows? If so, turn it off.
Ok, I'll see.
But, it is disabled in BIOS/UEFI settings.
Also, I seldom even boot into windows!
FeliksWR
Level 1
Level 1
Posts: 14
Joined: Tue Jun 04, 2024 3:39 am

Re: Boots too slowly

Post by FeliksWR »

all41 wrote: Thu Jun 20, 2024 11:05 pm
FeliksWR wrote: Thu Jun 20, 2024 8:32 am
SAME OLD ISSUE!
You said you can boot into both Windows and Mint (which takes too long).
Are you making this choice using the grub boot-loader menu?

Yes windows update can mess with the boot loader but it usually causes a
Linux no boot situation--not a slow boot.
It was a no boot situation, but i used some windows commands to change boot order to ubuntu first (which displays the grub menu).
Then, it became slow boot.
User avatar
PaulL
Level 6
Level 6
Posts: 1490
Joined: Mon Apr 24, 2023 10:57 am
Location: Connecticut

Re: Mounting takes 121 seconds on fast SSD (var-lib-lxcfs.mount @2min 1.076s)

Post by PaulL »

FeliksWR wrote: Fri Jul 05, 2024 2:57 am Ok, I'll see.
But, it is disabled in BIOS/UEFI settings.
Also, I seldom even boot into windows!
The BIOS/EFI setting (usually) called "Fast Boot" has to do with whether the computer does all the normal power-on tests or skips them. The Windows feature (whatever it's called in that particular version) allows Windows to quickly return to a login screen on startup. It is similar to hibernating, but it doesn't preserve and restore the active state of your machine. It just allows Windows to appear to start up faster. So even when Windows says it's powering off, it is still in a more-or-less suspended state. You can disable this feature by itself, but I understand that disabling Hibernate on Windows will also disable this feature. I've noticed a certain amount of imprecision on these forums; it's not always clear whether people are talking about the Windows feature or the firmware one.

The Windows feature has to be disabled, because it interferes with installing and running Linux Mint. The firmware feature is a matter of taste. I disable it on my computers, simply because running the POST (power-on self tests) gives me a few extra seconds to find and press the key that gets me into the BIOS/EFI. (Don't get old, okay? :D )

In any case, you could try disabling local-fs-pre.target, but I have no idea whether that would help or hurt. Take a Timeshift snapshot first, just in case. And speaking of Timeshift, I wonder whether it would help to restore to a snapshot from before the trouble began. There have been a number of kernel updates lately, as well as a firmware update (as I recall), and it might be that there is a regression in one of those LM updates that coincided with the Windows update.

At some point, you might consider re-installing LM 21.3 (back up all your data first!) or you could wait for LM 22.0 and do a fresh installation of that version.
Post Reply

Return to “Installation & Boot”