Upgrade to LMDE6 Frozen <SOLVED>

Questions about other topics and general discussion about LMDE
Forum rules
Before you post read how to get help. Topics in this forum are automatically closed 6 months after creation.
Post Reply
User avatar
bookmonger
Level 1
Level 1
Posts: 3
Joined: Mon Jun 20, 2022 5:28 am
Location: Oregon USA

Upgrade to LMDE6 Frozen <SOLVED>

Post by bookmonger »

Update: I am going with the suggestion of Karl.

I am using the Upgrade Tool LMDE6 'Faye'. 2024.01.12 The upgrade has halted. It is stuck at,
"Upgrade phase An issue was detected during the upgrade. 1,677 packages still need to be updated (0 kept, 21 deleted)."
I have already pressed the "Check again" button. What do I do now ? The upgrade tool instructions say to not close the terminal window. I am extremely hesitant at trying a restart. Is it safe to quit the tool ? Would I then try to rerun it ?

The text of the terminal is 10,469 lines long. (746KiB) It ends with,

Code: Select all

dpkg: error processing package sticky (--configure):
 installed sticky package post-installation script subprocess returned error exit status 1
Processing triggers for initramfs-tools (0.142) ...
update-initramfs: Generating /boot/initrd.img-5.10.0-29-amd64
W: No zstd in /usr/bin:/sbin:/bin, using gzip
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-5.10.0-29-amd64 with 1.
dpkg: error processing package initramfs-tools (--configure):
 installed initramfs-tools package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 linux-image-5.10.0-30-amd64
 linux-image-amd64
 sticky
 initramfs-tools
E: Sub-process /usr/bin/dpkg returned an error code (1)
Error - Return code: 100
My system:

Code: Select all

System:
  Kernel: 5.10.0-29-amd64 arch: x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: Cinnamon v: 5.6.8
    tk: GTK v: 3.24.24 wm: muffin vt: 7 dm: LightDM v: 1.26.0 Distro: LMDE 6 Faye
    base: Debian 12.1 bookworm
Machine:
  Type: Desktop Mobo: Acer model: Aspire TC-875 v: V:1.0 serial: <superuser required>
    UEFI: American Megatrends v: R01-A0 date: 05/19/2020
Last edited by bookmonger on Wed Jul 10, 2024 4:01 pm, edited 3 times in total.
User avatar
karlchen
Level 23
Level 23
Posts: 18620
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Upgrade to LMDE6 Frozen

Post by karlchen »

Hello, bookmonger.
bookmonger wrote: Wed Jul 10, 2024 6:15 am[...] The text of the terminal is 10,469 lines long. (746KiB) It ends with, [...]
The tricky thing is:
Then end of the 10469 lines does not tell what the root cause of the errrors was, which occurred.
The root cause will be further up.
Actually, the 10469 lines can all be found in the file /var/log/apt/term.log.
You would have to read the file from line #1 to the line where the upgrade process starts to fail.
Then you would have to be able to understand what precisely caused the problem.
You would have to be able to resolve the root cause.
Only then it would make sense to check again and continue.


My suggestion therefore is:
  • Give up on in-place-upgrading from LMDE 5 to LMDE 6.
  • You have certainly backed up all your important data, i.e. your complete home directory, on an external disk medium.
  • So abort the mintupgrade operation.
  • Boot your LMDE 6 live system and install from scratch.
  • Once the fresh installation has completed and the installed LMDE 6 system runs fine, restore your backed up data.
Karl
Image
The people of Alderaan have been desperately fighting back the clone warriors sent out by the unscrupulous Sith Lord Palpatine for 867 days now.
Might Just Take Your Life
Post Reply

Return to “Other Topics & Open Discussion”