HOWTO: Improve Font Rendering in LMDE

Archived topics about LMDE 1 and LMDE 2
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: HOWTO: Improve Font Rendering in LMDE

Post by gotjazz »

uhm I'm not sure if and how that can be related but since I ran this script I cannot open the appearance settings tool anymore. Trying to do so only opens a blank window with invisible (but existing) borders that - judging how long I dragged it to one side - seems to have unlimited width
Image
Sude
Level 1
Level 1
Posts: 6
Joined: Sun Sep 05, 2010 6:07 am

Re: HOWTO: Improve Font Rendering in LMDE

Post by Sude »

after running the script:
amsn didn't render contact list and the menu
conky wouldn't run
gnome-appearance-properties wouldn't run

got this fixed by doing: gconftool-2 --unset "/desktop/gnome/font_rendering/dpi"
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: HOWTO: Improve Font Rendering in LMDE

Post by gotjazz »

yup - that corrected my appearance thingy too
Image
tenfoot
Level 6
Level 6
Posts: 1072
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: HOWTO: Improve Font Rendering in LMDE

Post by tenfoot »

I copied and pasted the .sh script file and tried to saved it to File System but was informed that I did not have permission. So I went to the terminal and did a sudo -s and logged in as root. Found I still couldn't save the file.

What am I doing wrong, please?

And what should I change in the .sgh script to take into account the error people were experiencing?

Regards from New Zealand on a very windy Tueasday evening.
User avatar
tdockery97
Level 14
Level 14
Posts: 5060
Joined: Sun Jan 10, 2010 8:54 am
Location: Mt. Angel, Oregon

Re: HOWTO: Improve Font Rendering in LMDE

Post by tdockery97 »

Thanks Ikey. Everything is purty again. :D
Mint Cinnamon 20
User avatar
kmb42vt
Level 5
Level 5
Posts: 977
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: HOWTO: Improve Font Rendering in LMDE

Post by kmb42vt »

Wonderful! Thanks Ikey! My eyes were going a bit cross-eyed trying to read LMDE's "as installed" font rendering. I'll raise a glass to ya' as soon as I get the chance.

You're quite popular on Google these days you know. :D
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)
User avatar
kmb42vt
Level 5
Level 5
Posts: 977
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: HOWTO: Improve Font Rendering in LMDE

Post by kmb42vt »

ikey wrote:No probs mate :) Yeah I seen Google seems to know me a lot now, makes you think back I guess.
Go back nearly two years and nobody knew who I was, just a random guy on IRC, went by the name
"jfreak" back then..
And now look where you are today although I have to believe that the freak part hasn't gone entirely missing. After all, you are a developer. :mrgreen:

Cheers and all that,

A prehistoric geek
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)
User avatar
Mike54
Level 1
Level 1
Posts: 35
Joined: Fri Jun 25, 2010 6:12 am
Location: Lafayette, Indiana U.S.A.
Contact:

Re: HOWTO: Improve Font Rendering in LMDE

Post by Mike54 »

Ikey, you're officially my newest hero for posting this fix. Now these old eyes don't have to strain so much.
RHTopics
Level 2
Level 2
Posts: 55
Joined: Fri Sep 10, 2010 2:32 pm

Re: HOWTO: Improve Font Rendering in LMDE

Post by RHTopics »

@Ikey

I believe the setting of the serif and sans serif fonts in the set_firefox_fonts function are reversed. It should look like the following code:

Code: Select all

function set_firefox_fonts()
{
   # warning, does not account for previous font entries.
   echo "Setting default Firefox fonts.."
   FFFILE="`get_firefox_profile_dir`/prefs.js"
   echo "user_pref(\"font.name.monospace.x-western\", \"DejaVu Sans Mono\");" >> $FFFILE
   echo "user_pref(\"font.name.sans-serif.x-western\", \"DejaVu Sans\");" >> $FFFILE
   echo "user_pref(\"font.name.serif.x-western\", \"DejaVu Serif\");" >> $FFFILE
   echo "user_pref(\"font.size.fixed.x-western\", 14);" >> $FFFILE
   echo "user_pref(\"font.size.variable.x-western\", 14);" >> $FFFILE
}
RHTopics
Level 2
Level 2
Posts: 55
Joined: Fri Sep 10, 2010 2:32 pm

Re: HOWTO: Improve Font Rendering in LMDE

Post by RHTopics »

@Ikey

Thank you for response and the changes you made to the script.

Just one thought though, with the serif/sans serif font inversion, web pages that once looked good before applying the inversion, may look less appealing after the inversion. That is, a well designed web page that uses the generic serif and sans serif font type rather than coding specific font types may well look like the type of web page that you were trying to improve. :wink:
User avatar
rufong
Level 2
Level 2
Posts: 58
Joined: Fri Dec 11, 2009 9:20 am
Contact:

Re: HOWTO: Improve Font Rendering in LMDE

Post by rufong »

ikey wrote: If you have errors as described below, run this command:

Code: Select all

gconftool-2 --unset "/desktop/gnome/font_rendering/dpi
gconftool-2 --unset "/desktop/gnome/font_rendering/dpi" <- should there b a quotation mark at the end?
if i'm incorrect feel free to delete this post, ;)
User avatar
newfie
Level 2
Level 2
Posts: 91
Joined: Fri Nov 20, 2009 2:47 pm

Re: HOWTO: Improve Font Rendering in LMDE

Post by newfie »

I have the appearance properties bug, but cannot fix it:

Code: Select all

michael@lmde-laptop ~ $ gconftool-2 --unset "/desktop/gnome/font_rendering/dpi
> 
What do I do? :(
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: HOWTO: Improve Font Rendering in LMDE

Post by gotjazz »

close the quotation marks and try again ;)
Image
User avatar
newfie
Level 2
Level 2
Posts: 91
Joined: Fri Nov 20, 2009 2:47 pm

Re: HOWTO: Improve Font Rendering in LMDE

Post by newfie »

Hah! How did I miss that?

Thanks :)
tenfoot
Level 6
Level 6
Posts: 1072
Joined: Sun Jun 03, 2007 4:12 am
Location: Waipapa, Bay of Islands, New Zealand

Re: HOWTO: Improve Font Rendering in LMDE

Post by tenfoot »

ikey wrote:
tenfoot wrote:I copied and pasted the .sh script file and tried to saved it to File System but was informed that I did not have permission. So I went to the terminal and did a sudo -s and logged in as root. Found I still couldn't save the file.

What am I doing wrong, please?

And what should I change in the .sgh script to take into account the error people were experiencing?

Regards from New Zealand on a very windy Tueasday evening.
Heya, ok so that file you can save to your home directory. Then follow the instructions on my first post

Ha! success is mine :lol: Thank you.
libssd
Level 4
Level 4
Posts: 289
Joined: Tue Jun 22, 2010 11:26 am

Re: HOWTO: Improve Font Rendering in LMDE

Post by libssd »

Not strictly for this thread, but very much font-related. Would this be the correct procedure for installing the "Microsoft fonts" package with LMDE?

$ sudo gedit /etc/apt/sources.list

Add contrib to last three lines:

deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian testing main contrib non-free contrib
deb http://security.debian.org/ testing/updates main contrib non-free contrib
deb http://www.debian-multimedia.org testing main non-free contrib

Save /etc/apt/sources.list, then:

$ sudo apt-get update
$ sudo apt-get install msttcorefonts

After this operation, 1,966kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Last edited by libssd on Wed Sep 22, 2010 4:50 pm, edited 1 time in total.
gotjazz
Level 4
Level 4
Posts: 381
Joined: Fri May 28, 2010 11:38 am
Location: Vienna, Austria

Re: HOWTO: Improve Font Rendering in LMDE

Post by gotjazz »

uhm that'd be 2MB
Image
User avatar
blowtorch
Level 3
Level 3
Posts: 100
Joined: Sun Sep 05, 2010 10:03 pm

Re: HOWTO: Improve Font Rendering in LMDE

Post by blowtorch »

libssd wrote:Not strictly for this thread, but very much font-related. Would this be the correct procedure for installing the "Microsoft fonts" package with LMDE?

$ sudo gedit /etc/apt/sources.list

Add contrib to last three lines:

deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian testing main contrib non-free contrib
deb http://security.debian.org/ testing/updates main contrib non-free contrib
deb http://www.debian-multimedia.org testing main non-free contrib

Save /etc/apt/sources.list, then:

$ sudo apt-get update
$ sudo apt-get install msttcorefonts

After this operation, 1,966kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Looks like you already have contrib in "ftp.debian.org" and "security.debian.org" no need to have the contrib entries twice. Also there is no such thing as contrib for the multimedia repo. The package you are looking to install is ttf-mscorefonts-installer.
Other than that you've got the right idea.
anamnesis
Level 2
Level 2
Posts: 64
Joined: Sat Sep 18, 2010 12:01 pm
Location: Cornwall, GB

Re: HOWTO: Improve Font Rendering in LMDE

Post by anamnesis »

Beautiful or at least very satisfying fonts here: LCD 1440x900@60hz
Appearance -> fonts -> details -> lcd subpixel "slight" /Resolution 96dpi. That it. No scripts, no screwing.
hth
anamnesis
anamnesis
Level 2
Level 2
Posts: 64
Joined: Sat Sep 18, 2010 12:01 pm
Location: Cornwall, GB

Re: HOWTO: Improve Font Rendering in LMDE

Post by anamnesis »

ikey wrote: If it was a simple case of "That it. No scripts, no screwing." then I wouldn't have written it
would I? :)
Tja, I'm confused, too. I installed the os on the 18. September, entered the appearance office as usual, did the changes I always do in Debian, and voila: nice fonts :P

Greets
anamnesis
Locked

Return to “LMDE Archive”