I can't access my HDD without root privilages [SOLVED]

Forum rules
Before you post please read how to get help
Post Reply
Morgan Krieg
Level 2
Level 2
Posts: 54
Joined: Mon Nov 22, 2010 12:46 pm

I can't access my HDD without root privilages [SOLVED]

Post by Morgan Krieg » Thu Mar 10, 2011 8:15 am

Hello, I have installed LXDE on Linux Mint 9 and I can't access one of my HDDs without root privileges. In Gnome it would normally mount and I would have access to all files on it without root privileges but in LXDE I needed to mount with password and then I get a "permission denied" error. When I check ownership, it writes "root", the same for every file. AFAIK it's impossible as it's a Fat32 disk and fat32 doesn't have ownership.
EDIT:
Now I can't access it on Gnome either. What's going on? Is there any way to fix it?
Last edited by Morgan Krieg on Thu Mar 10, 2011 9:25 am, edited 1 time in total.

altair4
Level 19
Level 19
Posts: 9752
Joined: Tue Feb 03, 2009 10:27 am

Re: I can't access my HDD without root privilages

Post by altair4 » Thu Mar 10, 2011 8:21 am

I'm not sure what this means:
I have installed LXDE on Linux Mint 9
If this is a dual boot boot into Gnome and post the output of the following commands:

Code: Select all

sudo blkid -c /dev/null
cat /etc/fstab
mount
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Morgan Krieg
Level 2
Level 2
Posts: 54
Joined: Mon Nov 22, 2010 12:46 pm

Re: I can't access my HDD without root privilages

Post by Morgan Krieg » Thu Mar 10, 2011 8:38 am

altair4 wrote:I'm not sure what this means:
I have installed LXDE on Linux Mint 9
I installed the LXDE metapackage and then choose LXDE in the login menu. It worked normally. The problem started when I have booted the computer today and logged in with LXDE.

Code: Select all

/dev/loop0: LABEL="My Disc" TYPE="iso9660" 
/dev/sda1: LABEL="DISK" UUID="336A-15FB" TYPE="vfat" 
/dev/sdb1: UUID="b498f196-6daf-4db8-b1c7-eedca4e061ec" TYPE="ext3" 
/dev/sdb2: UUID="a27afdea-13fa-44b3-92d2-9d149db51566" TYPE="swap" 
/dev/sdb3: UUID="127757ee-4adc-40fd-991b-5cff4c8b6578" TYPE="ext3"



# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb1 during installation
UUID=b498f196-6daf-4db8-b1c7-eedca4e061ec /               ext3    errors=remount-ro 0       1
# /home was on /dev/sdb3 during installation
UUID=127757ee-4adc-40fd-991b-5cff4c8b6578 /home           ext3    defaults        0       2
# swap was on /dev/sdb2 during installation
UUID=a27afdea-13fa-44b3-92d2-9d149db51566 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
/home/therion/inf_load.iso /media/vrom iso9660 ro,loop,auto 0 0



/dev/sdb1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sdb3 on /home type ext3 (rw)
/dev/loop0 on /media/vrom type iso9660 (ro)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/sr0 on /media/Hind type iso9660 (ro,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500)
gvfs-fuse-daemon on /home/therion/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=therion)

altair4
Level 19
Level 19
Posts: 9752
Joined: Tue Feb 03, 2009 10:27 am

Re: I can't access my HDD without root privilages

Post by altair4 » Thu Mar 10, 2011 9:05 am

I'm not sure what if any interference between the two DE's may be the cause of your dilema but you might want to auto mount the partition at boot and see if that permanently fixes your problem:

( 1) Create a permanent mount point for the partition:

Code: Select all

sudo mkdir /media/fat32
(2) Add the following line to the end of /etc/fstab:

Code: Select all

/dev/sda1 /media/fat32 vfat utf8,umask=007,uid=1000,gid=46 0 2
This will produce a mount of sda1 with you as owner.
(3) Run the following command to test for errors and mount the partition:

Code: Select all

sudo mount -a
There's no need to reboot. "mount -a" will use the new fstab entry to mount the new partition and you'll know instantly if it works or not.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Morgan Krieg
Level 2
Level 2
Posts: 54
Joined: Mon Nov 22, 2010 12:46 pm

Re: I can't access my HDD without root privilages

Post by Morgan Krieg » Thu Mar 10, 2011 9:25 am

It worked. Thanks a lot :D !

Post Reply

Return to “Others”