Loud system beep when shutting down (XFCE Daryna BETA 008)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
dberg918
Level 2
Level 2
Posts: 64
Joined: Mon Nov 05, 2007 12:54 am

Loud system beep when shutting down (XFCE Daryna BETA 008)

Postby dberg918 » Mon Nov 05, 2007 1:12 am

Hi everyone! I'm a fairly new Linux user; though I tinkered with Ubuntu Feisty when it came out earlier this year, I ended up going back to Windows XP for a while because of some troubles I had with playing media and wireless networking. Then I found Linux Mint :)

I've been using Linux Mint for a few weeks now (dual-booting with Celena-XP on my desktop), in an attempt to loosen Microsoft's grip on my computing experience.

I decided to try out the new XFCE Beta today on my laptop since I've never experienced the XFCE desktop environment before, and I think it's great! The only beef I have with it is the loud system beep that occurs when I shut down/restart. I tried muting everything in the mixer and nothing has stopped it. Is there an option here that I'm missing? I looked for a way to disable it for at least an hour without bearing any fruit. Does anybody know of a way to disable this feature, possibly in the configuration editor? Any help would be greatly appreciated.

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Mon Nov 05, 2007 6:14 am

Welcome to Mint dberg918
You get that beep in a desktop from the system speaker so I think there is nothing to do about it - it should beep, but not so loud
I'll add this to the bug list
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
dberg918
Level 2
Level 2
Posts: 64
Joined: Mon Nov 05, 2007 12:54 am

Postby dberg918 » Mon Nov 05, 2007 9:44 am

I actually figured out a way to disable it last night by diving into the configuration editor. I found an option called something like "enable user sounds," and when I unchecked it, the beeping stopped. Of course, now I can't have any system sounds, but I usually never have them anyway.

I also forgot to mention that the same loud beep occurred when backspacing in an empty text field. It made sense, but still unusually loud.

When I get home today, I'll check the editor and post where the option is.

User avatar
dberg918
Level 2
Level 2
Posts: 64
Joined: Mon Nov 05, 2007 12:54 am

Postby dberg918 » Mon Nov 05, 2007 2:51 pm

Alright, so it turns out that I didn't fix the system beep, maybe I wasn't listening for it so I didn't hear it just that one time. The option I was talking about is in the Configuration Editor under desktop>gnome>sound, and it's called "event_sounds."

It also turns out that there are two different system beeps that I hear. One occurs randomly, but for reference, a few situations where you hear it are when you are trying to scroll past the bottom or top of the menu in the configuration editor or in evince, and also when you try to close a modified openoffice word document without saving first. The other is the shutdown beep. The shutdown beep is a higher pitch, and actually much less annoying than the other. The scroll beep seems to be louder to me.

Maybe this is just my laptop, it's most likely different on each machine. My laptop is a Dell XPS M140, for reference. I'm pretty sure the system beeps wouldn't be quite as loud on my desktop, though I am in no position to test on it.

User avatar
merlwiz79
Level 8
Level 8
Posts: 2421
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Postby merlwiz79 » Mon Nov 05, 2007 3:42 pm

This is the weirdest thing, as I never get any beeps or system sounds on my desktop.
Though, I don't have a modem.
Image

Husse
Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Postby Husse » Mon Nov 05, 2007 6:34 pm

Well on my desktop it's very loud, I never thought the system speaker could produce such a loud noice
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
Kynan
Level 4
Level 4
Posts: 245
Joined: Thu Oct 04, 2007 7:39 pm
Contact:

Re: Loud system beep when shutting down (XFCE Daryna BETA 008)

Postby Kynan » Wed Jan 23, 2008 8:17 pm

Code: Select all

sudo rmmod pcspkr
or

Code: Select all

sudo modprobe -r pcspkr

should disable it until the next boot

to stop it permanently try this http://tombuntu.com/index.php/2007/07/1 ... -in-linux/

Code: Select all

sudo modprobe pcspkr

if you miss it

I feel this should be made the norm in linux those system beeps are just ugly.

uriel.oberon
Level 1
Level 1
Posts: 1
Joined: Tue Oct 20, 2009 2:59 am

Re: Loud system beep when shutting down (XFCE Daryna BETA 008)

Postby uriel.oberon » Tue Oct 20, 2009 3:06 am

menu - control center

under "Hardware" choose "Sound" - click "Sounds" tab - deselect "Play alert sound"

-- also scroll down to the "alert sounds" and set to disable

hope this helps for it seems my beeping is over with

kburger
Level 1
Level 1
Posts: 2
Joined: Wed Nov 11, 2009 11:34 pm

Re: Loud system beep when shutting down (XFCE Daryna BETA 008)

Postby kburger » Wed Nov 11, 2009 11:39 pm

This works great for me with Linux Mint 7:

First, to disable it NOW for this session:

Code: Select all

sudo modprobe -r pcspkr


Then, to disable it permanently:
add this line to the bottom of /etc/modprobe.d/blacklist.conf

Code: Select all

blacklist pcspkr


Problem solved. No more annoyingly loud internal speaker beeps.

Sonic-Boom
Level 1
Level 1
Posts: 33
Joined: Tue Nov 10, 2009 8:36 pm
Location: UK

Re: Loud system beep when shutting down (XFCE Daryna BETA 008)

Postby Sonic-Boom » Thu Nov 12, 2009 3:44 am

i can see a problem with disabling the speaker altogether. Many have their bios setup to give temparature/fan fail warnings wouldnt these be disabled aswell by blacklisting the pcspeaker in linux?

User avatar
ibm450
Level 5
Level 5
Posts: 603
Joined: Sun Jan 11, 2009 6:56 am
Location: Kwinana, Western Australia
Contact:

Re: Loud system beep when shutting down (XFCE Daryna BETA 00

Postby ibm450 » Thu Nov 12, 2009 9:46 am

kburger wrote:This works great for me with Linux Mint 7:

First, to disable it NOW for this session:

Code: Select all

sudo modprobe -r pcspkr


Then, to disable it permanently:
add this line to the bottom of /etc/modprobe.d/blacklist.conf

Code: Select all

blacklist pcspkr


Problem solved. No more annoyingly loud internal speaker beeps.


-o0o-
  • Thanks heaps - this system beep was annoying the **** out of me
Image
Asus UL50VT laptop ~ LM10 - Unity 12.04 - Win 7
Image

User avatar
ipernar
Level 2
Level 2
Posts: 90
Joined: Fri Nov 20, 2009 1:08 pm
Location: Zagreb Croatia
Contact:

Re: Loud system beep when shutting down (XFCE Daryna BETA 008)

Postby ipernar » Tue Jan 12, 2010 4:05 pm

There is very easy way + it also makes your computer booting faster. Go to 'Menu', then applications and search for "Startup applications" and then disable "Gnome login sound".

Mint will not give start up and shut down sound signals...
"Chicks come and go but you will always have your PS3. "

User avatar
ibm450
Level 5
Level 5
Posts: 603
Joined: Sun Jan 11, 2009 6:56 am
Location: Kwinana, Western Australia
Contact:

Re: Loud system beep when shutting down (XFCE Daryna BETA 008)

Postby ibm450 » Sun Jan 17, 2010 8:54 am

-o0o-
  • ok worth a try, although im not having this issue with mint8, but ill disable it :)
Image
Asus UL50VT laptop ~ LM10 - Unity 12.04 - Win 7
Image


Return to “Newbie Questions”

Who is online

Users browsing this forum: Hoser Rob, Mute Ant and 27 guests