[SOLVED] Thunar Freezing in LMDE Xfce 201108

Forum rules
Before you post please read how to get help
Post Reply
User avatar
drjster
Level 1
Level 1
Posts: 24
Joined: Tue Nov 16, 2010 10:04 am
Location: USA

[SOLVED] Thunar Freezing in LMDE Xfce 201108

Post by drjster »

Thunar is freezing randomly when I attempt to open it using my mouse. I've tried changing to icon view and changing icon themes (from Mint-x to tangerine for example) but these seemingly random freezes continue. If I access Thunar with my keyboard (an inconvenience for sure), it will NOT freeze. Any help or suggestions would be greatly appreciated.
Last edited by drjster on Sun Sep 18, 2011 9:52 am, edited 1 time in total.
User avatar
drjster
Level 1
Level 1
Posts: 24
Joined: Tue Nov 16, 2010 10:04 am
Location: USA

[SOLVED] Thunar Freezing in LMDE Xfce 201108

Post by drjster »

I misstated my issue. Let me try again: When opening Thunar for the first time after a restart, it take about 30 seconds to become responsive. The issue is described here: http://crunchbanglinux.org/forums/topic ... r-xfce-48/ and http://forums.debian.net/viewtopic.php?f=5&t=64190 Apparently, this bug has been fixed but it still happens on my machine. Thanks in advance.
Last edited by drjster on Sun Sep 18, 2011 9:53 am, edited 1 time in total.
User avatar
richyrich
Level 19
Level 19
Posts: 9051
Joined: Mon May 04, 2009 8:31 pm

Re: Thunar Freezing in LMDE Xfce 201108

Post by richyrich »

I have both Mint 9 Xfce and Mint Xfce 201108 and cannot re-produce your problem. :?
Do you have any network drives in Places in the left pane ?
User avatar
drjster
Level 1
Level 1
Posts: 24
Joined: Tue Nov 16, 2010 10:04 am
Location: USA

Re: Thunar Freezing in LMDE Xfce 201108

Post by drjster »

richyrich wrote:I have both Mint 9 Xfce and Mint Xfce 201108 and cannot re-produce your problem. :?
Do you have any network drives in Places in the left pane ?
I have no network drives nor are any being displayed. If I open Thunar as root from the command line, I get no delay at all. From what I've read and what you've alluded to, this initial delay in opening Thunar appears to be related to some sort of network delay (gvfs- packages?)
steveov
Level 1
Level 1
Posts: 1
Joined: Sat Aug 27, 2011 8:31 am

Re: Thunar Freezing in LMDE Xfce 201108

Post by steveov »

I'm seeing this same delay in the release candidate.
Berneri
Level 1
Level 1
Posts: 11
Joined: Sun Aug 28, 2011 8:07 am
Location: Potters Bar, UK

Re: Thunar Freezing in LMDE Xfce 201108

Post by Berneri »

Hi, although I'm very new to this forum, I might have an hint of a solution. In the /etc/hosts and /etc/hostname files. A while ago, I experienced the same kind of problem on Ubuntu, and the problem was solved by modifying the /etc/hosts file as follows:

Code: Select all

127.0.0.1    localhost
I think the /etc/hostname file should have

Code: Select all

localhost
That did the trick for me. Granted, here it's a different OS and a different WM, but I would still check it...
User avatar
drjster
Level 1
Level 1
Posts: 24
Joined: Tue Nov 16, 2010 10:04 am
Location: USA

[SOLVED] Thunar Freezing in LMDE Xfce 201108

Post by drjster »

I found this fix on another forum:

"Go to /usr/share/gvfs/mounts/network.mount and change the "AutoMount" value to false. Reboot."

Thunar now opens immediately each and every time (especially the first time after a restart).

The caveat for this fix is that Thunar will no longer automatically stat your network the first time you open it. I don't do network browsing so this doesn't affect me.
Post Reply

Return to “Xfce”