How to get Compiz-Fusion on Debian Xfce 201104

Forum rules
Before you post please read how to get help
User avatar
merlwiz79
Level 10
Level 10
Posts: 3476
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

How to get Compiz-Fusion on Debian Xfce 201104

Postby merlwiz79 » Mon Apr 25, 2011 1:38 am

Make sure you have 3D accelerated drivers installed.
Example: nvidia-glx or nvidia-glx-legacy-xxx nvidia-settings for Nvidia cards

Install Xfce mintDesktop:
Download and install it from the Bug fixes post. viewtopic.php?p=406365#p406365

Install compiz:
Open terminal and run:

Code: Select all

apt install compiz-core compiz-plugins compiz-fusion-plugins-main compiz-fusion-plugins-extra compizconfig-settings-manager

Download and install Emerald:(Theme packages included)
amd64 packages: http://www.4shared.com/file/REtiJFzW/em ... 64tar.html
mirror: http://ompldr.org/vOGVyZg/emerald-amd64.tar.gz
i386 packages: http://www.4shared.com/file/NE0GKNVW/em ... 86tar.html
mirror: http://ompldr.org/vOGVyaA/emerald-i386.tar.gz
Extract the package and open the emerald folder.
Now right click and open terminal.

Code: Select all

sudo dpkg -i *.deb

Load Default Config for Xfce:
Open Compizconfig Settings Manager.
Click Preferences on the lower left hand corner.
Click the Import button and select Default.profile.

Start Compiz Fusion:
Open Xfce mintDesktop and select the Compiz Fusion tab.
Click the Enable/Disable button next to the text Compiz Fusion.

Changing Themes:
Open Emerald Theme Manger to change installed themes.
More themes are located here: http://compiz-themes.org/index.php?xsor ... ntmode=103

Optional Sphere:(for better graphic cards)
Open Compizconfig Settings Manager.
Click Preferences on the lower left hand corner.
Click the Import button and select Sphere.profile.
Sphere Schreenshots:
Image
Last edited by xenopeek on Mon Mar 24, 2014 1:23 pm, edited 3 times in total.
Reason: Made thread sticky
Image

tjphilly
Level 1
Level 1
Posts: 6
Joined: Sun May 01, 2011 10:26 am

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby tjphilly » Sun May 01, 2011 10:40 am

Thanks for the tips on this and the bug fixes post as well. Everything seemed ok with the exception that compiz will not enable from the mint desktop option. (flickers a few times and still shows "disabled")I did change "enable compiz after log-in" and that didn't seem to make any difference. Any quick tip or a place to investigate as I couldn't find this problem described so far. Tks in advance (enjoy the distro - been hopping for about 7 months since taking the plunge into Linux - based on the changes with Gnome, etc, think I might try to commit to XFCE - Mint of course...)
TKS!
Troy

User avatar
merlwiz79
Level 10
Level 10
Posts: 3476
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby merlwiz79 » Sun May 01, 2011 3:28 pm

tjphilly wrote:Thanks for the tips on this and the bug fixes post as well. Everything seemed ok with the exception that compiz will not enable from the mint desktop option. (flickers a few times and still shows "disabled")I did change "enable compiz after log-in" and that didn't seem to make any difference. Any quick tip or a place to investigate as I couldn't find this problem described so far. Tks in advance (enjoy the distro - been hopping for about 7 months since taking the plunge into Linux - based on the changes with Gnome, etc, think I might try to commit to XFCE - Mint of course...)
TKS!
Troy

Do you have the drivers that are needed for 3D acceleration?
What does Compiz check say?
Image

tjphilly
Level 1
Level 1
Posts: 6
Joined: Sun May 01, 2011 10:26 am

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby tjphilly » Sun May 01, 2011 8:11 pm

I have a GeForce 8400 and the Compiz check comes out with all OK's. Thought maybe it could be a glitch as I've gotten it up and running on a couple of other distros but that was with KDE and Gnome which I guess were a bit more mainstream. I'll do some more poking around on this end as I know you handle a lot of stuff. Was hoping a member or two would have had the same problem and chime in. Thanks for the response!
TP

User avatar
merlwiz79
Level 10
Level 10
Posts: 3476
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby merlwiz79 » Mon May 02, 2011 2:54 pm

tjphilly wrote:I have a GeForce 8400 and the Compiz check comes out with all OK's. Thought maybe it could be a glitch as I've gotten it up and running on a couple of other distros but that was with KDE and Gnome which I guess were a bit more mainstream. I'll do some more poking around on this end as I know you handle a lot of stuff. Was hoping a member or two would have had the same problem and chime in. Thanks for the response!
TP

I just did a complete update today and it works for me.
Go to Menu --> Settings --> Compizconfig Settings Manager --> Window Decorator and make sure it's enabled and the command reads as:

Code: Select all

/usr/bin/emerald --replace

If i doesn't have that command then you skipped the part of importing the default config.

I have a GT 240 and I'm using the same driver you should be.(nvidia-glx version: 260.16.44)
Image

tjphilly
Level 1
Level 1
Posts: 6
Joined: Sun May 01, 2011 10:26 am

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby tjphilly » Tue May 03, 2011 10:53 pm

I have the 260.19.44 so assume that's ok. Re engaging the Windows Decorator, realized that I can't engage anything on CCSM as the check boxes seem to be disabled and if I drill down on the gui besides the box I can change options or levels, etc but the "engage plug-in" button is dead. As a newb ,I spent a lot of time installing my Nvidia driver the hard way on Suse Gnome 2 so I don't mind doing doing some homework but I haven't found many rabbit trails to chase on this one. Do you think there will be a rolling release soon whereas I can just go that route? If not, can I delete all compiz files re synaptic and retry your solution (don't know how to delete via CL).
TKS!
TP

User avatar
merlwiz79
Level 10
Level 10
Posts: 3476
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby merlwiz79 » Wed May 04, 2011 6:14 am

tjphilly wrote:I have the 260.19.44 so assume that's ok. Re engaging the Windows Decorator, realized that I can't engage anything on CCSM as the check boxes seem to be disabled and if I drill down on the gui besides the box I can change options or levels, etc but the "engage plug-in" button is dead. As a newb ,I spent a lot of time installing my Nvidia driver the hard way on Suse Gnome 2 so I don't mind doing doing some homework but I haven't found many rabbit trails to chase on this one. Do you think there will be a rolling release soon whereas I can just go that route? If not, can I delete all compiz files re synaptic and retry your solution (don't know how to delete via CL).
TKS!
TP

Open the Nvidia settings app and it should tell you if the nvidia driver isn't being used.
I guess the nvidia 260 drivers only support 8400m cards.
You'll probably need to uninstall all nvidia drivers and install the 270 drivers manually for it to work.
You could also install the experimental packages if you remember to disable the repo after.

If you can't enable plugins then maybe you don't have compiz completely installed.
Try to search for compiz in Synaptic and make sure all of the packages i listed are installed.
Image

asymmetros
Level 4
Level 4
Posts: 303
Joined: Tue Jun 01, 2010 5:34 pm
Location: athens

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby asymmetros » Wed May 04, 2011 3:22 pm

Sorry for interfering but those applying to me too:
I have the 260.19.44 so assume that's ok.

Everything seemed ok with the exception that compiz will not enable from the mint desktop option. (flickers a few times and still shows "disabled")



But if i start afterwards compiz-fusion-icon, go there and select "reload window manager", the compiz runs as a dream :!: :o .
More precisely, fusion-icon shows that compiz is been selected but it does not matter, a reload of compiz must be performed.
Sid Mint Xfce -32, Openbox, KDE, Enlightenment, Liquorix Kernel
HP Compaq Presario cq71, Intel Core 2 Duo T4400 @ 2.2 GHz, 3 GB DDR2 RAM, Nvidia Geforce G 103M

tjphilly
Level 1
Level 1
Posts: 6
Joined: Sun May 01, 2011 10:26 am

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby tjphilly » Thu May 05, 2011 12:28 am

merlwiz79 and asymmetros -- Tks much for the help. I added a few extra compiz files from Synaptic (compiz icon being one of them and reloaded win mgmt). I have compiz enabled now. Tks for the help. First time I've broken down and asked a question on any distro. A positive experience!
TP

User avatar
merlwiz79
Level 10
Level 10
Posts: 3476
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby merlwiz79 » Sat May 07, 2011 10:40 pm

tjphilly wrote:merlwiz79 and asymmetros -- Tks much for the help. I added a few extra compiz files from Synaptic (compiz icon being one of them and reloaded win mgmt). I have compiz enabled now. Tks for the help. First time I've broken down and asked a question on any distro. A positive experience!
TP

Odd that you needed more packages installed.
Is Emerald even being used?
If you install too many compiz packages it uses the window manager for Gnome.
Image

tjphilly
Level 1
Level 1
Posts: 6
Joined: Sun May 01, 2011 10:26 am

Re: How to get Compiz-Fusion on Debian Xfce 2001104

Postby tjphilly » Tue May 10, 2011 1:02 am

As the other poster suggested, I was missing the compiz icon file. I also switched the back end option from flat file to gconf config. Emerald is working as far as the themes go but I seem to only have a limited cube animation via alt-cont, down or side arrow. It was a good enough fix to get me off the tread mill at least! tks again

User avatar
vrkalak
Level 12
Level 12
Posts: 4425
Joined: Mon Jul 20, 2009 5:53 pm
Location: Santa Fe, NM, USA

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby vrkalak » Tue May 10, 2011 1:43 am

Edited Topic title: I didn't know when 2001104 was? :lol: Changed to read 201104.
Image
:: Debian-Sid (Xfce/Fluxbox) :: LinuxMint-18 (LTS) LXDE w/Openbox ::
Registered Linux User: #497031 :: My DeviantART Page

notbilly
Level 1
Level 1
Posts: 1
Joined: Fri May 15, 2009 1:59 am

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby notbilly » Wed Aug 10, 2011 4:23 am

Has anyone had any luck getting Compiz-Fusion working inside a Virtualbox? (Windows host, Debian Xfce 201104 guest) For me, Compiz Check is complaining about software rasterization -- but I do have 3D acceleration enable in Virtualbox. :?

User avatar
dyfet
Level 1
Level 1
Posts: 5
Joined: Thu Sep 08, 2011 6:14 am
Location: Cape May
Contact:

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby dyfet » Thu Sep 08, 2011 6:22 am

I had good success with compiz on xfce4 edition using the gnome/gtk compiz decorator and (gnome) metacity decorator themes, rather than using a resurrected emerald as suggested in this thread. It seems to me a native xfce4 specific dectorator for compiz is needed.
"Information in the computer age is the last genuine free market left on earth except those free markets where indigenous people are still surviving"

User avatar
Waha
Level 1
Level 1
Posts: 4
Joined: Wed Oct 05, 2011 4:43 am
Location: Oregon, USA
Contact:

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby Waha » Thu Oct 06, 2011 10:17 pm

dyfet wrote:I had good success with compiz on xfce4 edition using the gnome/gtk compiz decorator and (gnome) metacity decorator themes, rather than using a resurrected emerald as suggested in this thread. It seems to me a native xfce4 specific dectorator for compiz is needed.


As an extension of this. The gtk themer doesn't seem to read xfce's theme settings, so I had to set my window decorator in the plugin to:

Code: Select all

/usr/bin/gtk-window-decorator --metacity-theme Xfce-saltlake

Of course, replace that with your own theme's name.


And an addition. General Options->Desktop Size->Number of Desktops does not work. However you can set the Horizontal and Vertical sizes you want then enable the Desktop Wall plugin. This plugin allows you to set hotkeys for switching left/right as well as viewing the wall. More importantly, it enables XFCE Panel's Workspace Switcher plugin to switch to the clicked workspace.
.

mbalazs81
Level 2
Level 2
Posts: 61
Joined: Fri Mar 18, 2011 12:38 am

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby mbalazs81 » Sun Oct 16, 2011 6:31 am

Helo

Compiz and xfce mintdesktop was installed. When I resize a windows, log out. When I click the windows changer compiz crash. What can I do to work? edit: works
Linux Mint KDE

morrisjones
Level 1
Level 1
Posts: 1
Joined: Wed Nov 02, 2011 6:45 pm

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby morrisjones » Wed Nov 02, 2011 6:54 pm

There's one statement in this post that has me stumped: "Launch xfce mintDesktop"

I have no such program in my menu tree. The command line doesn't seem to find anything appropriate either.

I just installed Linux Mint Debian Xfce edition today (11/2/11)

Mojo

mbalazs81
Level 2
Level 2
Posts: 61
Joined: Fri Mar 18, 2011 12:38 am

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby mbalazs81 » Wed Nov 02, 2011 7:37 pm

sudo apt-get install mintdesktop
Linux Mint KDE

User avatar
wyrdoak
Level 6
Level 6
Posts: 1309
Joined: Thu May 19, 2011 1:32 pm
Location: USA

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby wyrdoak » Thu Nov 10, 2011 3:55 am

Only problem I'm still having is getting more than one workspace in compiz, the settings will not change(stays at 1) in compiz even tried a reinstall the whole system. I can get as many as a need using Xfce as the manager, I even got WINE working even better than it did in Gnome. Compiz it's the only thing that baffling me with the workspaces problem.

Only other problem is for some reason apt-get keep dunning me to autoremove my Cairo Dock Plugins. :lol: Other than those two things and a little less eye candy, it's blowing Gnome 3 out of the water in being useful and not broken.

BTW: Debian testing just changed the GDM in Xfce to GDM3. now I can see what time it is before I login. :roll:
-Dell Mini Inspiron 910 Netbook-Atom CPU-N270-1.60ghz; 16gbs mini ePCI PATA SSD
RAM- 1gbs-(LinixMint-17.1: KDE)

jjaythomas
Level 5
Level 5
Posts: 603
Joined: Sun Mar 07, 2010 12:52 pm

Re: How to get Compiz-Fusion on Debian Xfce 201104

Postby jjaythomas » Fri Nov 11, 2011 1:33 am

Don't know if same problem...

The window switcher of xfce-panel doesn't play nice with compiz. If you stay in compiz you can use the switcher (cube,wall ect), but if you go back to not using compiz it reverts to using one(1) window.
So... if you use Fusion-Icon or XFCE-Mintdesktop to set using to not using (compiz) you have to keep resetting the windows used in the xfce panel. I believe the switcher in Cario-Dock works in both? (haven't used Cario-Dock in awile). :wink:


Return to “Compiz, Conky, Docks, & Widgets”

Who is online

Users browsing this forum: No registered users and 1 guest