Stuck in initramfs after encrypting some partitions [CANCEL]

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 18
Joined: Wed Sep 21, 2011 10:49 am

Stuck in initramfs after encrypting some partitions [CANCEL]

Post by glubbar »

I dual boot Win7 and Linux Mint 12.
Recently, encrypted Win7 system partition and another NTFS partition with TrueCrypt. After looking around and stumbling upon this I think that could be the reason why I am now stuck in initramfs when booting my linux boot loader (which is located on a /boot partition) even when booting in recovery mode.
Perhaps TrueCrypt messed the naming scheme of my partitions and now the linux bootloader can't find my linux partition anymore?

Here are the most notable error messages after it seems to be successfully loading drivers:

Code: Select all

Gave up waiting for waiting for root device. Common Problems:
 -Boot args (car /proc/cmdline)
   -Check rootdelay= (did the system wait long enough?)
   -Check root= (did the system wait for the right device?)
 Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/a6f257ca-442f-43cd-b45a-64e127c48c1b does not exist. 
Dropping to a shell!

BusyBox v.1.18.4 (Ubuntu 1:1.18.4-2ubuntu2) built-in shell (ash)
Enter help for a list of built-in commands

A a total newbie, I don't know how to handle this. But I am fairly confident this could be solvable.

Here are some more info from random commands I threw in:

Code: Select all

ls -l /dev/disk/by-label
lrwxrwxrwx    1     10    System\x20Reserved -> ../../sda1
ls -l /dev/disk/by-uuid
lrwxrwxrwx    1     10     30B8ED57B8ED1BDA ->  ../../sda1
lrwxrwxrwx    1     10     6d262e5f-3fbb-4d48-9ebb-03a704848a16 -> ../../sda3
cat /proc/partitions/
cat: can't open 'proc/partitions': not a directory
cat /proc/fstab/
cat: can't open 'proc/fstab': not a directory
Should I try doing the following from a live "disk" (from USB, who still uses CD?)
try to edit the fstab on your harddisk from the livecd to match the ID's from /dev/disk/by-id or /dev/disk/by-uuid, and reboot.
I doubt my sda3 partition is where Mint is installed, and not seeing it listed worries my a little. (I don't care for data loss, that was a nearly fresh install)
I should probably add that my NTFS encrypted partition is a logical drive and is part of the same extended partition as the ones my / and /home partitions are on, could this be the origin of the issue?

Any help or hints will be greatly appreciated and used for learning!

[EDIT]: Well, turns out when I used live CD, my linux partition is recognized in Gparted as "unallocated", which baffles me because my /boot/ partition is still intact. However, as I said earlier, the /boot/ partition is outside the extended partition where / and the encrypted NTFS partition reside, so my guess is that encrypting a partition that is part of an extended one somehow corrupts the other partitions too.
I'll reinstall linux again then. Sheesh.
Level 1
Level 1
Posts: 43
Joined: Mon Feb 11, 2013 12:03 am

Re: Stuck in initramfs after encrypting some partitions [CAN

Post by thomas.raines »

This won't help you as you already reinstalled Linux Mint, but maybe my method can help others:

I'm not going to share my output with you as I really didn't have one. Just know that that was an error. What I will tell you, last night, after watching some TV, my computer locked up. I didn't think much of it, I just did a hard power off and went to bed. This morning, I woke up with the dreaded initramfs. I tired to boot into recovery mode, but that failed too. So, I booted up with my live cd, opened terminal and typed:

Code: Select all

sudo fsck /dev/sda1 -p
I got an otuput that there was some inodes that were corrupt and after a few moment, fsck was done. I ran it again, and it reported the drive was clean. Just to make positively sure I ran:

Code: Select all

sudo tune2fs -l /dev/sda1
In the output, it said the drive was clean but with errors. I did't like it, but it should be enough to get Mint to boot again.
After getting Mint to boot, I reboot into recovery to run fsck 2 more times.

Code: Select all

fsck -yfv /dev/sda1
The first time,fsck reported that there was an error reading an inode and ignored it. Then went on to fix several read and count errors.
The second time, fsck ran with no errors.


Code: Select all

tune2fs -l /dev/sda1
The output was clean. Problem solved!

Had tune2fs reported that the drive was clean but with errors again, I would have booted back into my live cd and reformatted the drive, and reinstalled Mint. Thank god this wasn't the

NOTE** If you are performing any of these steps, make sure you change /dev/sda1 to the correct partition.
Good luck all...
Post Reply

Return to “Installation & Boot”