No sub-pixel font rendering in Gnome3 or Cinnamon

Archived topics about LMDE 1
Forum rules
neon_overload
Level 1
Level 1
Posts: 22
Joined: Mon Apr 16, 2012 9:19 pm

No sub-pixel font rendering in Gnome3 or Cinnamon

Postby neon_overload » Wed Apr 18, 2012 12:53 am

Hello,

Using Cinnamon's font settings, the "RGB" font smoothing option has no effect. Fonts appear identical to when "Grayscale" is chosen. Upon close inspection, Cinnamon isn't doing any sub-pixel rendering throughout its interface.

I have tried this both in Virtualbox on my work PC under its virtual graphics driver (with an ATI integrated driver on the host), and on my home PC with the Nvidia proprietary driver. Both exhibit the same behaviour.

Switching to "None" (ie, the option where font smoothing is turned off) works correctly and disables font smoothing (looking horrible in most cases). But the other two options both appear to be doing grayscale font smoothing and there's no difference between them.

Haven't tried testing this on the main (ubuntu) edition or looking into what's causing it, sorry.

neon_overload
Level 1
Level 1
Posts: 22
Joined: Mon Apr 16, 2012 9:19 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby neon_overload » Thu Apr 19, 2012 8:29 pm

After lots of testing I can report

- Problem does not occur in a recent Debian Testing (wheezy)
- Problem does not occur in Mint 12 Lisa

- Problem occurs in both Gnome 3/gnome-shell and Gnome 3/Cinnamon
- Problem occurs using either Cinnamon settings or gnome-tweak-tool

Description: No sub-pixel font rendering. Both gnome-tweak-tool and Cinnamon settings have a "None, Grayscale, RGBA" setting. The RGBA setting has no effect in LMDE (text is grayscale smoothed) but works in Debian Testing and Mint 12 Lisa (text is subpixel smoothed).

non-portable
Level 1
Level 1
Posts: 26
Joined: Sun Mar 25, 2012 1:28 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby non-portable » Thu Apr 19, 2012 9:13 pm

That's a good lot of digging. I got as far as - the fonts look worse in my feedback on this update pack.

I can't see anything in the changelog for libfreetype6 between lmde's (2.4.8-1) and debian testing's (2.4.9-1) that would explain this (just loads of security fixes), so I guess it's not as low as libfreetype. I should probably install libfreetype6 2.4.9-1 from debian testing to check that. I'm not sure how the stack interacts in gnome to render text.

neon_overload
Level 1
Level 1
Posts: 22
Joined: Mon Apr 16, 2012 9:19 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby neon_overload » Thu Apr 19, 2012 9:45 pm

Completely forgot to mention: sub-pixel rendering works fine in MATE. It's only gnome 3 (gnome-shell/cinnamon) where it doesn't work.

Noticed a fair few differences between Debian testing and LMDE's /etc/fonts/conf.d. However, I have no idea if it's related. All the settings in there look sensible to me. Thinking it's something in gnome 3's confs.

neon_overload
Level 1
Level 1
Posts: 22
Joined: Mon Apr 16, 2012 9:19 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby neon_overload » Thu Apr 19, 2012 10:31 pm

Workaround found!

Note: workaround has side-effects.

Enable the 10-sub-pixel-rgb.conf in /etc/fonts/conf.d by simlinking it into that folder from /etc/fonts/conf.avail

Change takes effect immediately (well, after a 1 second delay) - there doesn't seem to be a need to be a need to restart any services.

The side-effect is that now, sub-pixel rendering enabled regardless of the "Grayscale" and "RGBA" settings of gnome-tweak-tool and Cinnamon's settings: setting it to grayscale does not make it grayscale but keeps the sub-pixel. So it's the opposite problem to before, but in my case a better problem. Fonts are now looking beautiful on gnome3/cinnamon!

What is the best way to pass this sort of feedback on to the mint team?
Last edited by neon_overload on Thu Apr 19, 2012 10:41 pm, edited 1 time in total.

non-portable
Level 1
Level 1
Posts: 26
Joined: Sun Mar 25, 2012 1:28 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby non-portable » Thu Apr 19, 2012 10:41 pm

Nice work around. I was just writing a post about ~/.fonts.conf - same settings - different location.

My ~/.fonts.conf has

Code: Select all

<match target="font">
  <edit mode="assign" name="rgba">
   <const>none</const>
  </edit>
 </match>


When it should say

Code: Select all

 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgba</const>
  </edit>
 </match>


I think, as per 10-sub-pixel-rgb.conf

I don't know what gnome tweak tool is doing.

Thanks for the workaround. That's great.

non-portable
Level 1
Level 1
Posts: 26
Joined: Sun Mar 25, 2012 1:28 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby non-portable » Thu Apr 19, 2012 10:52 pm

Somehow I now have working Gnome tweak tool config.

This was after setting that 2nd bit of code in .fonts.conf above (which was actually syntactically incorrect).

Monsta
Level 9
Level 9
Posts: 2938
Joined: Fri Aug 19, 2011 3:46 am

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby Monsta » Fri Apr 20, 2012 3:32 am

non-portable wrote:My ~/.fonts.conf has

Code: Select all

<match target="font">
  <edit mode="assign" name="rgba">
   <const>none</const>
  </edit>
 </match>


When it should say

Code: Select all

 <match target="font">
  <edit mode="assign" name="rgba">
   <const>rgba</const>
  </edit>
 </match>

Hmm... what exactly should change if I only apply these changes and won't mess with 10-sub-pixel-rgb.conf? :?

neon_overload
Level 1
Level 1
Posts: 22
Joined: Mon Apr 16, 2012 9:19 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby neon_overload » Fri Apr 20, 2012 3:46 am

The main difference is /etc/fonts/conf.d is system-wide, whereas ~/.fonts.conf only applies to that user.

I presume (though I haven't tried with a .fonts.conf) that they both have the same caveat - that it still doesn't make cinnamon settings or gnome-tweak-tool's setting have any effect.

Monsta
Level 9
Level 9
Posts: 2938
Joined: Fri Aug 19, 2011 3:46 am

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby Monsta » Fri Apr 20, 2012 3:53 am

Ok, I quickly found the answer to my question: next time you run a program with GUI from the terminal, it will show:

Code: Select all

Fontconfig warning: "~/.fonts.conf", line 6: invalid constant used : rgba

:D

non-portable
Level 1
Level 1
Posts: 26
Joined: Sun Mar 25, 2012 1:28 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby non-portable » Fri Apr 20, 2012 8:02 am

Yeah, that's how I found out I'd added a syntax error. It might have been useful ?!? Apparently Gnome Tweak Tool doesn't act on that file, so maybe it just gets in the way. Anyway now when I flip between different types I see a difference. Without the system wide setting.

Firefox is an odd man out.
Attachments
fr.png
fr.png (3.25 KiB) Viewed 8802 times

Monsta
Level 9
Level 9
Posts: 2938
Joined: Fri Aug 19, 2011 3:46 am

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby Monsta » Fri Apr 20, 2012 8:24 am

BTW, the system installed from 201204 RC ISO doesn't even have ~/.fonts.conf - everything is set up globally in /etc/fonts directory... go figure :)

non-portable
Level 1
Level 1
Posts: 26
Joined: Sun Mar 25, 2012 1:28 pm

Re: No sub-pixel font rendering in Gnome3 or Cinnamon

Postby non-portable » Fri Apr 20, 2012 8:31 am

Safe to delete then :)


Return to “Archive”

Who is online

Users browsing this forum: No registered users and 6 guests