No more sound

Archived topics about LMDE 1
Forum rules
User avatar
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: No more sound

Postby mockturtl » Sat Apr 28, 2012 3:06 pm

Code: Select all

lspci -v | grep -i audio
# 00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
# 01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

Removing pulseaudio worked for me:

Code: Select all

sudo aptitude remove --purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio paman pavumeter pavucontrol pulseaudio-module-x11 pulseaudio-esound-compat

sudo mv /etc/asound.conf /etc/asound.conf.bak

rm ~/.pulse-cookie
rm -r ~/.pulse/

sudo aptitude install libalsaplayer0

Level 1
Level 1
Posts: 1
Joined: Thu Jan 24, 2013 4:10 pm

Re: No more sound

Postby wwsmurf » Thu Jan 24, 2013 5:16 pm

I have an Acer Aspire 3690 of some sort.

The Volume Control reports HDA Intel, and I believe it truly is an Intel sound system.

I find that when I need the sound back, I must unmute the Master and Front, and then check headphone if it is not checked, or uncheck and check headphone, or something like that. Of course, I clicked on headphone under switches before I ever had a problem just to see what would happen, so I'm the reason they were muted in the first place, but whatever. I've tried replacing PulseAudio with ALSA, but I think that might do more harm than good.

This is just food for the imagination. The actual procedure given may be wrong, but I don't think I'm crazy.

Level 1
Level 1
Posts: 18
Joined: Fri Jul 13, 2012 9:51 am

Re: No more sound

Postby Fixitmanarizona » Thu May 30, 2013 3:23 am

Pigsy! MUCH THANKS. Your code works great. I believe all I had to do was the line to reconfigure sound, although I've heard Pulseaudio isn't all it's cracked up to be, and I don't mind using Alsa direct.
One other tip, I found a neat little sound Icon program for the sound tray called "Volti" that I really like, it's in the Ubuntu repositories or‎ :D

This was the line that I really needed! It even brings up a warning to use Alsa if you have a modern system!

sudo dpkg-reconfigure linux-sound-base

(Using Xubuntu 12.04 with a lot of changes, should probably just installed Mint XFCE LTS, suits me better!)

Level 1
Level 1
Posts: 1
Joined: Sun Oct 20, 2013 6:48 am

Re: No more sound

Postby kzac » Sun Oct 20, 2013 7:32 am

I had this same issue when loading Mint 15 (an excellent software system so far)
I am usitng a Lenovo N585 with the E1 AMD Vision chip
After some wrangling I discovered during loading, Linux Mint did not recognize my Sound Card However it could see my sound card by. Here is how you go about fixing this issue with newer laptops which include AMD Vision processors.

1) Open up the application "Terminal
2) Type in: lspci -v (to clarify that is L at the beginning) , press the enter key and you will get a long list of all your hardware, Look for your sound card (you will probably have two listed) one for HDMI and the other your sound card, both will most likely indicate "access denied"

3) Now type in to terminal: aplay -l (again that is an L not a 1) and press the enter key. You should get back something like this = device list 252 = no sound cards found

4) Close Terminal at this point

5) Go to the web site for the manufacturer of your computer (Mine was Lenovo) and look for the audio drivers for Windows 7 or 8, does it say Conexant? If it does you can use the following fix. Conexant is the driver most used on the entry level (Chinese made) laptops of 2012 and newer. The problem is most Linux distributions do not come with the Conexant drivers already loaded (due to a licensing issue with Conexant), therefore you must obtain the drivers and load them. Further, Conexant does not make drivers for Linux (I know... I know), but they have allowed Linuxant to make them, so they are available. If the manufacturers web parge does not indicated Conexant then keep digging on the web and you will find your answer. Otherwise Go on to 6 if your audio is Conexant ....

6) Go to the Linuxant web site

7) Down load the deb driver

8) unzip the package you just downloaded (its in your downloads folder)

9) Select the file (click it) and allow it to install (most likely not the way Linux experienced users would do it but it worked)

10) You will most likely get an error that the driver did not load completely .... Let it finish

11) Reboot (you may have to reboot twice if the system hangs) but wait a few minutes before rebooting a second time

12) Your system should now start with the sound working. Select the volume icon on the desktop bar. and select Sound Settings and see if your output is now your speakers.

11) Reboot your machine (may have to do this twice but give the first reboot ample time to load the driver)

12) Your Sound should be working. Select your volume icon on the desktop task bar and select sound settings, your output should now be your speakers and not dummy output. If not go back through the steps from the beginning and make sure the driver loaded and your Conexant sound card is recognized

20 Oct 2013

Return to “Archive”

Who is online

Users browsing this forum: No registered users and 2 guests